source: projects/specs/trunk/x/xl2tpd/xl2tpd-vl.spec @ 8125

Revision 8125, 14.2 KB checked in by tomop, 10 years ago (diff)

xl2tpd-1.3.3-1

Line 
1%define src_dir_name xl2tpd-%{version}
2
3Summary: Layer 2 Tunnelling Protocol Daemon (RFC 2661)
4Name: xl2tpd
5Version: 1.3.3
6Release: 1%{?_dist_release}
7# No version specified.
8License: GPL+
9Url: http://www.xelerance.com/software/xl2tpd/
10Group: System Environment/Daemons
11# https://github.com/xelerance/xl2tpd/archive/v%{version}.tar.gz
12Source0: xl2tpd-%{version}.tar.gz
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14Requires: ppp
15BuildRequires: libpcap-devel
16BuildRequires: openssl-devel
17Requires(post): /sbin/chkconfig
18Requires(preun): /sbin/chkconfig
19Requires(preun): /sbin/service
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: tomop
24
25%description
26xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
27L2TP allows you to tunnel PPP over UDP. Some ISPs use L2TP to tunnel user
28sessions from dial-in servers (modem banks, ADSL DSLAMs) to back-end PPP
29servers. Another important application is Virtual Private Networks where
30the IPsec protocol is used to secure the L2TP connection (L2TP/IPsec,
31RFC 3193). The L2TP/IPsec protocol is mainly used by Windows and
32Mac OS X clients. On Linux, xl2tpd can be used in combination with IPsec
33implementations such as Openswan.
34Example configuration files for such a setup are included in this RPM.
35
36xl2tpd works by opening a pseudo-tty for communicating with pppd.
37It runs completely in userspace.
38
39xl2tpd supports IPsec SA Reference tracking to enable overlapping internak
40NAT'ed IP's by different clients (eg all clients connecting from their
41linksys internal IP 192.168.1.101) as well as multiple clients behind
42the same NAT router.
43
44xl2tpd supports the pppol2tp kernel mode operations on 2.6.23 or higher,
45or via a patch in contrib for 2.4.x kernels.
46
47Xl2tpd is based on the 0.69 L2TP by Jeff McAdams <jeffm@iglou.com>
48It was de-facto maintained by Jacco de Leeuw <jacco2@dds.nl> in 2002 and 2003.
49
50%prep
51%setup -q -n %{src_dir_name}
52
53%build
54make DFLAGS="$RPM_OPT_FLAGS -g -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_FLOW -DDEBUG_PAYLOAD -DDEBUG_CONTROL -DDEBUG_CONTROL_XMIT -DDEBUG_FLOW_MORE -DDEBUG_MAGIC -DDEBUG_ENTROPY -DDEBUG_HIDDEN -DDEBUG_PPPD -DDEBUG_AAA -DDEBUG_FILE -DDEBUG_FLOW -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_ZLB -DDEBUG_AUTH"
55
56%install
57rm -rf %{buildroot}
58make DESTDIR=%{buildroot} PREFIX=%{_prefix} install
59install -p -D -m644 examples/xl2tpd.conf %{buildroot}%{_sysconfdir}/xl2tpd/xl2tpd.conf
60install -p -D -m644 examples/ppp-options.xl2tpd %{buildroot}%{_sysconfdir}/ppp/options.xl2tpd
61install -p -D -m600 doc/l2tp-secrets.sample %{buildroot}%{_sysconfdir}/xl2tpd/l2tp-secrets
62install -p -D -m600 examples/chapsecrets.sample %{buildroot}%{_sysconfdir}/ppp/chap-secrets.sample
63install -p -D -m755 packaging/fedora/xl2tpd.init %{buildroot}%{_initrddir}/xl2tpd
64install -p -D -m755 -d %{buildroot}%{_localstatedir}/run/xl2tpd
65
66
67%clean
68rm -rf %{buildroot}
69
70%post
71/sbin/chkconfig --add xl2tpd
72
73%preun
74if [ $1 -eq 0 ]; then
75  /sbin/service xl2tpd stop > /dev/null 2>&1
76  /sbin/chkconfig --del xl2tpd
77fi
78
79%postun
80if [ $1 -ge 1 ]; then
81  /sbin/service xl2tpd condrestart 2>&1 >/dev/null
82fi
83
84%files
85%defattr(-,root,root)
86%doc BUGS CHANGES CREDITS LICENSE README.* TODO doc/rfc2661.txt
87%doc doc/README.patents examples/chapsecrets.sample
88%{_sbindir}/xl2tpd
89%{_sbindir}/xl2tpd-control
90%{_bindir}/pfc
91%{_mandir}/*/*
92%dir %{_sysconfdir}/xl2tpd
93%config(noreplace) %{_sysconfdir}/xl2tpd/*
94%config(noreplace) %{_sysconfdir}/ppp/*
95%attr(0755,root,root)  %{_initrddir}/xl2tpd
96%dir %{_localstatedir}/run/xl2tpd
97%ghost %attr(0600,root,root) %{_localstatedir}/run/xl2tpd/l2tp-control
98
99%changelog
100* Sun Jan 05 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.3-1
101- new upstream release.
102
103* Sat Sep 29 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
104- new upstream release.
105
106* Fri Sep 16 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
107- new upstream release.
108
109* Fri Apr 22 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.8-2
110- built for Vine Linux.
111
112* Wed Feb 23 2011 Paul Wouters <paul@xelerance.com> - 1.2.8-1
113- Updated to 1.2.8
114- Add ghosting for l2tp pipe (bz#656725)
115
116* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.7-3
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
118
119* Tue Nov 30 2010 Paul Wouters <paul@xelerance.com> - 1.2.7-2
120- fix md5 of init script in sources
121
122* Tue Nov 30 2010 Paul Wouters <paul@xelerance.com> - 1.2.7-1
123- Updated to 1.2.7
124- Added more DEBUG build options to the make command
125- Minor cleanups
126
127* Sat Jan 09 2010 Paul Wouters <paul@xelerance.com> - 1.2.5-2
128- Bump for EVR
129
130* Sat Jan 09 2010 Paul Wouters <paul@xelerance.com> - 1.2.5-1
131- Upgraded to 1.2.5. (fixes interop with two Windows machines behind same NAT)
132- Fix mix space/tab in spec file
133- Added missing keyword Default-Stop
134
135* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.4-4
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
137
138* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-3
139- Bump version for tagging mistake
140
141* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-2
142-Fix initscript for https://bugzilla.redhat.com/show_bug.cgi?id=247100
143
144* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-1
145- Upgraded to 1.2.4
146- Merged spec file with upstream
147
148* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
150
151* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.2.0-1
152- Updated to new upstream release
153
154* Sat Sep  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.12-3
155- fix license tag
156
157* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.12-2
158- Autorebuild for GCC 4.3
159
160* Fri Oct 26 2007 Paul Wouters <paul@xelerance.com> 1.1.12-1
161- Upgraded to new release upstream
162- Removed l2tpd to xl2tpd migration in post
163
164* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.1.11-3
165- Rebuild for selinux ppc32 issue.
166
167* Sat Jul 28 2007 Paul Wouters <paul@xelerance.com> 1.1.11-2
168- Upgraded to 1.1.11
169- Include new split README.*
170
171* Mon Mar 19 2007 Paul Wouters <paul@xelerance.com> 1.1.09-1
172- Upgraded to 1.1.09
173
174* Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-2
175- Bump for EVR
176
177* Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-1
178- Upgraded to 1.1.08
179- This works around the ppp-2.4.2-6.4 issue of not dying on SIGTERM
180
181* Tue Feb 20 2007 Paul Wouters <paul@xelerance.com> 1.1.07-2
182- Fixed version usage in source macro
183
184* Tue Feb 20 2007 Paul Wouters <paul@xelerance.com> 1.1.07-1
185- Upgraded to 1.1.07
186- Added /var/run/xl2tpd to the spec file so this pacakge
187  owns /var/run/xl2tpd
188 
189* Thu Dec  7 2006 Paul Wouters <paul@xelerance.com> 1.1.06-5
190- Changed space/tab replacing method
191
192* Wed Dec  6 2006 Paul Wouters <paul@xelerance.com> 1.1.06-4
193- Added -p to keep original timestamps
194- Added temporary hack to change space/tab in init file.
195- Added /sbin/service dependancy
196
197* Tue Dec  5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-3
198- Added Requires(post) / Requires(preun)
199- changed init file to create /var/run/xl2tpd fixed a tab/space
200- changed control file to be within /var/run/xl2tpd/
201
202* Tue Dec  5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-2
203- Changed Mr. Karlsen's name to not be a utf8 problem
204- Fixed Obosoletes/Provides to be more specific wrt l2tpd.
205- Added dist tag which accidentally got deleted.
206
207* Mon Dec  4 2006 Paul Wouters <paul@xelerance.com> 1.1.06-1
208- Rebased spec file on Fedora Extras copy, but using xl2tpd as package name
209
210* Sun Nov 27 2005 Paul Wouters <paul@xelerance.com> 0.69.20051030
211- Pulled up sourceforget.net CVS fixes.
212- various debugging added, but debugging should not be on by default.
213- async/sync conversion routines must be ready for possibility that the read
214  will block due to routing loops.
215- refactor control socket handling.
216- move all logic about pty usage to pty.c. Try ptmx first, if it fails try
217  legacy ptys
218- rename log() to l2tp_log(), as "log" is a math function.
219- if we aren't deamonized, then log to stderr.
220- added install: and DESTDIR support.
221
222* Thu Oct 20 2005 Paul Wouters <paul@xelerance.com> 0.69-13
223- Removed suse/mandrake specifics. Comply for Fedora Extras guidelines
224
225* Tue Jun 21 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-12jdl
226- Added log() patch by Paul Wouters so that l2tpd compiles on FC4.
227
228* Sat Jun 4 2005 Jacco de Leeuw <jacco2@dds.nl>
229- l2tpd.org has been hijacked. Project moved back to SourceForge:
230  http://l2tpd.sourceforge.net
231
232* Tue May 3 2005 Jacco de Leeuw <jacco2@dds.nl>
233- Small Makefile fixes. Explicitly use gcc instead of cc.
234  Network services library was not linked on Solaris due to typo.
235
236* Thu Mar 17 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-11jdl
237- Choosing between SysV or BSD style ptys is now configurable through
238  a compile-time boolean "unix98pty".
239
240* Fri Feb 4 2005 Jacco de Leeuw <jacco2@dds.nl>
241- Added code from Roaring Penguin (rp-l2tp) to support SysV-style ptys.
242  Requires the N_HDLC kernel module.
243
244* Fri Nov 26 2004 Jacco de Leeuw <jacco2@dds.nl>
245- Updated the README.
246
247* Wed Nov 10 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl
248- Patch by Marald Klein and Roger Luethi. Fixes writing PID file.
249  (http://l2tpd.graffl.net/msg01790.html)
250  Long overdue. Rereleasing 10jdl.
251
252* Tue Nov 9 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl
253- [SECURITY FIX] Added fix from Debian because of a bss-based
254  buffer overflow.
255  (http://www.mail-archive.com/l2tpd-devel@l2tpd.org/msg01071.html)
256- Mandrake's FreeS/WAN, Openswan and Strongswan RPMS use configuration
257  directories /etc/{freeswan,openswan,strongswan}. Install our
258  configuration files to /etc/ipsec.d and create symbolic links in
259  those directories.
260
261* Wed Aug 18 2004 Jacco de Leeuw <jacco2@dds.nl>
262- Removed 'leftnexthop=' lines. Not relevant for recent versions
263  of FreeS/WAN and derivates.
264
265* Tue Jan 20 2004 Jacco de Leeuw <jacco2@dds.nl>  0.69-9jdl
266- Added "noccp" because of too much MPPE/CCP messages sometimes.
267
268* Wed Dec 31 2003 Jacco de Leeuw <jacco2@dds.nl>
269- Added patch in order to prevent StopCCN messages.
270
271* Sat Aug 23 2003 Jacco de Leeuw <jacco2@dds.nl>
272- MTU/MRU 1410 seems to be the lowest possible for MSL2TP.
273  For Windows 2000/XP it doesn't seem to matter.
274- Typo in l2tpd.conf (192.168.128/25).
275
276* Fri Aug 8 2003 Jacco de Leeuw <jacco2@dds.nl>  0.69-8jdl
277- Added MTU/MRU 1400 to options.l2tpd. I don't know the optimal
278  value but some apps had problems with the default value.
279
280* Fri Aug 1 2003 Jacco de Leeuw <jacco2@dds.nl>
281- Added workaround for the missing hostname bug in the MSL2TP client
282  ('Specify your hostname', error 629: "You have been disconnected
283  from the computer you are dialing").
284
285* Sun Jul 20 2003 Jacco de Leeuw <jacco2@dds.nl>  0.69-7jdl
286- Added the "listen-addr" global parameter for l2tpd.conf. By
287  default, the daemon listens on *all* interfaces. Use
288  "listen-addr" if you want it to bind to one specific
289  IP address (interface), for security reasons. (See also:
290  http://www.jacco2.dds.nl/networking/freeswan-l2tp.html#Firewallwarning)
291- Explained in l2tpd.conf that two different IP addresses should be
292  used for 'listen-addr' and 'local ip'.
293- Modified init script. Upgrades should work better now. You
294  still need to start/chkconfig l2tpd manually.
295- Renamed the example Openswan .conf files to better reflect
296  the situation. There are two variants using different portselectors.
297  Previously I thought Windows 2000/XP used portselector 17/0
298  and the rest used 17/1701. But with the release of an updated
299  IPsec client by Microsoft, it turns out that 17/0 must have
300  been a mistake: the updated client now also uses 17/1701.
301
302* Thu Apr 10 2003 Jacco de Leeuw <jacco2@dds.nl>  0.69-6jdl
303- Changed sample chap-secrets to be valid only for specific
304  IP addresses.
305
306* Thu Mar 13 2003 Bernhard Thoni <tech-role@tronicplanet.de>
307- Adjustments for SuSE8.x (thanks, Bernhard!)
308- Added sample chap-secrets.
309
310* Thu Mar 6 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-5jdl
311- Replaced Dominique's patch by Damion de Soto's, which does not
312  depend on the N_HDLC kernel module.
313
314* Wed Feb 26 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-4jdl
315- Seperate example config files for Win9x (MSL2TP) and Win2K/XP
316  due to left/rightprotoport differences.
317  Fixing preun for Red Hat.
318
319* Mon Feb 3 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl
320- Mandrake uses /etc/freeswan/ instead of /etc/ipsec.d/
321  Error fixed: source6 was used for both PSK and CERT.
322
323* Wed Jan 29 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl
324- Added Dominique Cressatti's pty patch in another attempt to
325  prevent the Windows 2000 Professional "loopback detected" error.
326  Seems to work!
327
328* Wed Dec 25 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-2jdl
329- Added 'connect-delay' to PPP parameters in an attempt to
330  prevent the Windows 2000 Professional "loopback detected" error.
331  Didn't seem to work.
332
333* Fri Dec 13 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl
334- Did not build on Red Hat 8.0. Solved by adding comments(?!).
335  Bug detected in spec file: chkconfig --list l2tpd does not work
336  on Red Hat 8.0. Not important enough to look into yet.
337
338* Sun Nov 17 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl
339- Tested on Red Hat, required some changes. No gprintf. Used different
340  pty patch, otherwise wouldn't run. Added buildroot sanity check.
341
342* Sun Nov 10 2002 Jacco de Leeuw <jacco2@dds.nl>
343- Specfile adapted from Mandrake Cooker. The original RPM can be
344  retrieved through:
345  http://www.rpmfind.net/linux/rpm2html/search.php?query=l2tpd
346- Config path changed from /etc/l2tp/ to /etc/l2tpd/
347  (Seems more logical and rp-l2tp already uses /etc/l2tp/).
348- Do not run at boot or install. The original RPM uses a config file
349  which is completely commented out, but it still starts l2tpd on all
350  interfaces. Could be a security risk. This RPM does not start l2tpd,
351  the sysadmin has to edit the config file and start l2tpd explicitly.
352- Renamed patches to start with l2tpd-
353- Added dependencies for pppd, glibc-devel.
354- Use %%{name} as much as possible.
355- l2tp-secrets contains passwords, thus should not be world readable.
356- Removed dependency on rpm-helper.
357
358* Mon Oct 21 2002 Lenny Cartier <lenny@mandrakesoft.com> 0.69-3mdk
359- from Per 0yvind Karlsen <peroyvind@delonic.no> :
360 - PreReq and Requires
361 - Fix preun_service
362
363* Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-2mdk
364- Move l2tpd from /usr/bin to /usr/sbin
365- Added SysV initscript
366- Patch0
367- Patch1
368
369* Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-1mdk
370- Initial release
Note: See TracBrowser for help on using the repository browser.