source: projects/specs/trunk/x/xl2tpd/xl2tpd-vl.spec @ 12529

Revision 12529, 15.9 KB checked in by tomop, 3 years ago (diff)

updated 5 packages

ModemManager?-1.14.10-1

NetworkManager-1.28.0-1

libpcap-1.10.0-1

ppp-2.4.9-1

xl2tpd-1.3.16-1

Line 
1%bcond_with systemd
2
3%define src_dir_name xl2tpd-%{version}
4
5Summary: Layer 2 Tunnelling Protocol Daemon (RFC 2661)
6Name: xl2tpd
7Version: 1.3.16
8Release: 1%{?_dist_release}%{?with_systemd:.systemd}
9Group: network,servers,security
10Vendor: Project Vine
11Distribution: Vine Linux
12Packager: tomop
13
14# No version specified.
15License: GPL+
16Url: http://www.xelerance.com/software/xl2tpd/
17Source0: https://github.com/xelerance/xl2tpd/archive/v%{version}.tar.gz#/xl2tpd-%{version}.tar.gz
18Source1: xl2tpd.service
19Source2: tmpfiles-xl2tpd.conf
20
21Patch1: 0001-fix-ppp-options.patch
22Patch2: 0002-fix-initscript.patch
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
25Requires: ppp
26BuildRequires: libpcap-devel
27BuildRequires: openssl-devel
28%if %{with systemd}
29%{?systemd_requires}
30%else
31Requires(post): /sbin/chkconfig
32Requires(preun): /sbin/chkconfig
33Requires(preun): /sbin/service
34%endif
35
36%description
37xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
38L2TP allows you to tunnel PPP over UDP. Some ISPs use L2TP to tunnel user
39sessions from dial-in servers (modem banks, ADSL DSLAMs) to back-end PPP
40servers. Another important application is Virtual Private Networks where
41the IPsec protocol is used to secure the L2TP connection (L2TP/IPsec,
42RFC 3193). The L2TP/IPsec protocol is mainly used by Windows and
43Mac OS X clients. On Linux, xl2tpd can be used in combination with IPsec
44implementations such as Openswan.
45Example configuration files for such a setup are included in this RPM.
46
47xl2tpd works by opening a pseudo-tty for communicating with pppd.
48It runs completely in userspace.
49
50xl2tpd supports IPsec SA Reference tracking to enable overlapping internak
51NAT'ed IP's by different clients (eg all clients connecting from their
52linksys internal IP 192.168.1.101) as well as multiple clients behind
53the same NAT router.
54
55xl2tpd supports the pppol2tp kernel mode operations on 2.6.23 or higher,
56or via a patch in contrib for 2.4.x kernels.
57
58Xl2tpd is based on the 0.69 L2TP by Jeff McAdams <jeffm@iglou.com>
59It was de-facto maintained by Jacco de Leeuw <jacco2@dds.nl> in 2002 and 2003.
60
61
62%debug_package
63
64
65%prep
66%autosetup -p1 -n %{src_dir_name}
67
68sed -i -e "s|/var/run|/run|" \
69        file.h \
70        l2tp.h \
71        xl2tpd-control.c \
72        packaging/fedora/xl2tpd.init \
73        doc/*
74
75%build
76export CFLAGS="$CFLAGS -fPIC -Wall -DTRUST_PPPD_TO_DIE"
77export DFLAGS="$RPM_OPT_FLAGS -g "
78export LDFLAGS="$LDFLAGS -pie -Wl,-z,relro -Wl,-z,now"
79#DFLAGS="$RPM_OPT_FLAGS -g -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_FLOW -DDEBUG_PAYLOAD -DDEBUG_CONTROL -DDEBUG_CONTROL_XMIT -DDEBUG_FLOW_MORE -DDEBUG_MAGIC -DDEBUG_ENTROPY -DDEBUG_HIDDEN -DDEBUG_PPPD -DDEBUG_AAA -DDEBUG_FILE -DDEBUG_FLOW -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_ZLB -DDEBUG_AUTH"
80
81make %{_smp_mflags}
82
83
84%install
85rm -rf %{buildroot}
86make DESTDIR=%{buildroot} PREFIX=%{_prefix} install
87install -p -D -m644 examples/xl2tpd.conf %{buildroot}%{_sysconfdir}/xl2tpd/xl2tpd.conf
88install -p -D -m644 examples/ppp-options.xl2tpd %{buildroot}%{_sysconfdir}/ppp/options.xl2tpd
89install -p -D -m600 doc/l2tp-secrets.sample %{buildroot}%{_sysconfdir}/xl2tpd/l2tp-secrets
90install -p -D -m600 examples/chapsecrets.sample %{buildroot}%{_sysconfdir}/ppp/chap-secrets.sample
91install -p -D -m755 -d %{buildroot}%{_localstatedir}/run/xl2tpd
92
93%if %{with systemd}
94install -d 0755 %{buildroot}%{_unitdir}
95mkdir -p %{buildroot}/%{_tmpfilesdir}
96install -m 0644 %{SOURCE1} %{buildroot}%{_unitdir}/xl2tpd.service
97install -m 0644 %{SOURCE2} %{buildroot}/%{_tmpfilesdir}/%{name}.conf
98%else
99install -p -D -m755 packaging/fedora/xl2tpd.init %{buildroot}%{_initrddir}/xl2tpd
100%endif
101
102
103%clean
104rm -rf %{buildroot}
105
106
107%post
108%if %{with systemd}
109%systemd_preun xl2tpd.service
110%else
111/sbin/chkconfig --add xl2tpd
112%endif
113
114%preun
115%if %{with systemd}
116%systemd_post xl2tpd.service
117%else
118if [ $1 -eq 0 -o /bin/systemctl ]; then
119  /sbin/service xl2tpd stop > /dev/null 2>&1
120  /sbin/chkconfig --del xl2tpd
121fi
122%endif
123
124%postun
125%if %{with systemd}
126%systemd_postun_with_restart xl2tpd.service
127%else
128if [ $1 -ge 1 ]; then
129  /sbin/service xl2tpd condrestart 2>&1 >/dev/null
130fi
131%endif
132
133
134%files
135%defattr(-,root,root)
136%license LICENSE
137%doc BUGS CHANGES CREDITS README* TODO
138%doc doc/README.patents examples/chapsecrets.sample
139%{_sbindir}/xl2tpd
140%{_sbindir}/xl2tpd-control
141%{_bindir}/pfc
142%{_mandir}/*/*
143%dir %{_sysconfdir}/xl2tpd
144%config(noreplace) %{_sysconfdir}/xl2tpd/*
145%config(noreplace) %{_sysconfdir}/ppp/*
146%ghost %dir /run/xl2tpd
147%ghost %attr(0600,root,root) /run/xl2tpd/l2tp-control
148%if %{with systemd}
149%{_unitdir}/*
150%{_tmpfilesdir}/*
151%else
152%attr(0755,root,root)  %{_initrddir}/xl2tpd
153%endif
154
155
156%changelog
157* Mon Feb 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.16-1
158- new upstream release.
159
160* Thu Aug 13 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.15-1
161- new upstream release.
162- added systemd support (disabled as default).
163
164* Sat Jan 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.13-1
165- new upstream release.
166
167* Tue Dec 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.10.1-1
168- new upstream release.
169
170* Tue Mar 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.9-1
171- new upstream release.
172
173* Wed Apr  2 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.6-1
174- new upstream release.
175
176* Sun Jan 05 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.3-1
177- new upstream release.
178
179* Sat Sep 29 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
180- new upstream release.
181
182* Fri Sep 16 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
183- new upstream release.
184
185* Fri Apr 22 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.8-2
186- built for Vine Linux.
187
188* Wed Feb 23 2011 Paul Wouters <paul@xelerance.com> - 1.2.8-1
189- Updated to 1.2.8
190- Add ghosting for l2tp pipe (bz#656725)
191
192* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.7-3
193- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
194
195* Tue Nov 30 2010 Paul Wouters <paul@xelerance.com> - 1.2.7-2
196- fix md5 of init script in sources
197
198* Tue Nov 30 2010 Paul Wouters <paul@xelerance.com> - 1.2.7-1
199- Updated to 1.2.7
200- Added more DEBUG build options to the make command
201- Minor cleanups
202
203* Sat Jan 09 2010 Paul Wouters <paul@xelerance.com> - 1.2.5-2
204- Bump for EVR
205
206* Sat Jan 09 2010 Paul Wouters <paul@xelerance.com> - 1.2.5-1
207- Upgraded to 1.2.5. (fixes interop with two Windows machines behind same NAT)
208- Fix mix space/tab in spec file
209- Added missing keyword Default-Stop
210
211* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.4-4
212- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
213
214* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-3
215- Bump version for tagging mistake
216
217* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-2
218-Fix initscript for https://bugzilla.redhat.com/show_bug.cgi?id=247100
219
220* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-1
221- Upgraded to 1.2.4
222- Merged spec file with upstream
223
224* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
225- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
226
227* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.2.0-1
228- Updated to new upstream release
229
230* Sat Sep  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.12-3
231- fix license tag
232
233* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.12-2
234- Autorebuild for GCC 4.3
235
236* Fri Oct 26 2007 Paul Wouters <paul@xelerance.com> 1.1.12-1
237- Upgraded to new release upstream
238- Removed l2tpd to xl2tpd migration in post
239
240* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.1.11-3
241- Rebuild for selinux ppc32 issue.
242
243* Sat Jul 28 2007 Paul Wouters <paul@xelerance.com> 1.1.11-2
244- Upgraded to 1.1.11
245- Include new split README.*
246
247* Mon Mar 19 2007 Paul Wouters <paul@xelerance.com> 1.1.09-1
248- Upgraded to 1.1.09
249
250* Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-2
251- Bump for EVR
252
253* Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-1
254- Upgraded to 1.1.08
255- This works around the ppp-2.4.2-6.4 issue of not dying on SIGTERM
256
257* Tue Feb 20 2007 Paul Wouters <paul@xelerance.com> 1.1.07-2
258- Fixed version usage in source macro
259
260* Tue Feb 20 2007 Paul Wouters <paul@xelerance.com> 1.1.07-1
261- Upgraded to 1.1.07
262- Added /var/run/xl2tpd to the spec file so this pacakge
263  owns /var/run/xl2tpd
264 
265* Thu Dec  7 2006 Paul Wouters <paul@xelerance.com> 1.1.06-5
266- Changed space/tab replacing method
267
268* Wed Dec  6 2006 Paul Wouters <paul@xelerance.com> 1.1.06-4
269- Added -p to keep original timestamps
270- Added temporary hack to change space/tab in init file.
271- Added /sbin/service dependancy
272
273* Tue Dec  5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-3
274- Added Requires(post) / Requires(preun)
275- changed init file to create /var/run/xl2tpd fixed a tab/space
276- changed control file to be within /var/run/xl2tpd/
277
278* Tue Dec  5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-2
279- Changed Mr. Karlsen's name to not be a utf8 problem
280- Fixed Obosoletes/Provides to be more specific wrt l2tpd.
281- Added dist tag which accidentally got deleted.
282
283* Mon Dec  4 2006 Paul Wouters <paul@xelerance.com> 1.1.06-1
284- Rebased spec file on Fedora Extras copy, but using xl2tpd as package name
285
286* Sun Nov 27 2005 Paul Wouters <paul@xelerance.com> 0.69.20051030
287- Pulled up sourceforget.net CVS fixes.
288- various debugging added, but debugging should not be on by default.
289- async/sync conversion routines must be ready for possibility that the read
290  will block due to routing loops.
291- refactor control socket handling.
292- move all logic about pty usage to pty.c. Try ptmx first, if it fails try
293  legacy ptys
294- rename log() to l2tp_log(), as "log" is a math function.
295- if we aren't deamonized, then log to stderr.
296- added install: and DESTDIR support.
297
298* Thu Oct 20 2005 Paul Wouters <paul@xelerance.com> 0.69-13
299- Removed suse/mandrake specifics. Comply for Fedora Extras guidelines
300
301* Tue Jun 21 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-12jdl
302- Added log() patch by Paul Wouters so that l2tpd compiles on FC4.
303
304* Sat Jun 4 2005 Jacco de Leeuw <jacco2@dds.nl>
305- l2tpd.org has been hijacked. Project moved back to SourceForge:
306  http://l2tpd.sourceforge.net
307
308* Tue May 3 2005 Jacco de Leeuw <jacco2@dds.nl>
309- Small Makefile fixes. Explicitly use gcc instead of cc.
310  Network services library was not linked on Solaris due to typo.
311
312* Thu Mar 17 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-11jdl
313- Choosing between SysV or BSD style ptys is now configurable through
314  a compile-time boolean "unix98pty".
315
316* Fri Feb 4 2005 Jacco de Leeuw <jacco2@dds.nl>
317- Added code from Roaring Penguin (rp-l2tp) to support SysV-style ptys.
318  Requires the N_HDLC kernel module.
319
320* Fri Nov 26 2004 Jacco de Leeuw <jacco2@dds.nl>
321- Updated the README.
322
323* Wed Nov 10 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl
324- Patch by Marald Klein and Roger Luethi. Fixes writing PID file.
325  (http://l2tpd.graffl.net/msg01790.html)
326  Long overdue. Rereleasing 10jdl.
327
328* Tue Nov 9 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl
329- [SECURITY FIX] Added fix from Debian because of a bss-based
330  buffer overflow.
331  (http://www.mail-archive.com/l2tpd-devel@l2tpd.org/msg01071.html)
332- Mandrake's FreeS/WAN, Openswan and Strongswan RPMS use configuration
333  directories /etc/{freeswan,openswan,strongswan}. Install our
334  configuration files to /etc/ipsec.d and create symbolic links in
335  those directories.
336
337* Wed Aug 18 2004 Jacco de Leeuw <jacco2@dds.nl>
338- Removed 'leftnexthop=' lines. Not relevant for recent versions
339  of FreeS/WAN and derivates.
340
341* Tue Jan 20 2004 Jacco de Leeuw <jacco2@dds.nl>  0.69-9jdl
342- Added "noccp" because of too much MPPE/CCP messages sometimes.
343
344* Wed Dec 31 2003 Jacco de Leeuw <jacco2@dds.nl>
345- Added patch in order to prevent StopCCN messages.
346
347* Sat Aug 23 2003 Jacco de Leeuw <jacco2@dds.nl>
348- MTU/MRU 1410 seems to be the lowest possible for MSL2TP.
349  For Windows 2000/XP it doesn't seem to matter.
350- Typo in l2tpd.conf (192.168.128/25).
351
352* Fri Aug 8 2003 Jacco de Leeuw <jacco2@dds.nl>  0.69-8jdl
353- Added MTU/MRU 1400 to options.l2tpd. I don't know the optimal
354  value but some apps had problems with the default value.
355
356* Fri Aug 1 2003 Jacco de Leeuw <jacco2@dds.nl>
357- Added workaround for the missing hostname bug in the MSL2TP client
358  ('Specify your hostname', error 629: "You have been disconnected
359  from the computer you are dialing").
360
361* Sun Jul 20 2003 Jacco de Leeuw <jacco2@dds.nl>  0.69-7jdl
362- Added the "listen-addr" global parameter for l2tpd.conf. By
363  default, the daemon listens on *all* interfaces. Use
364  "listen-addr" if you want it to bind to one specific
365  IP address (interface), for security reasons. (See also:
366  http://www.jacco2.dds.nl/networking/freeswan-l2tp.html#Firewallwarning)
367- Explained in l2tpd.conf that two different IP addresses should be
368  used for 'listen-addr' and 'local ip'.
369- Modified init script. Upgrades should work better now. You
370  still need to start/chkconfig l2tpd manually.
371- Renamed the example Openswan .conf files to better reflect
372  the situation. There are two variants using different portselectors.
373  Previously I thought Windows 2000/XP used portselector 17/0
374  and the rest used 17/1701. But with the release of an updated
375  IPsec client by Microsoft, it turns out that 17/0 must have
376  been a mistake: the updated client now also uses 17/1701.
377
378* Thu Apr 10 2003 Jacco de Leeuw <jacco2@dds.nl>  0.69-6jdl
379- Changed sample chap-secrets to be valid only for specific
380  IP addresses.
381
382* Thu Mar 13 2003 Bernhard Thoni <tech-role@tronicplanet.de>
383- Adjustments for SuSE8.x (thanks, Bernhard!)
384- Added sample chap-secrets.
385
386* Thu Mar 6 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-5jdl
387- Replaced Dominique's patch by Damion de Soto's, which does not
388  depend on the N_HDLC kernel module.
389
390* Wed Feb 26 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-4jdl
391- Seperate example config files for Win9x (MSL2TP) and Win2K/XP
392  due to left/rightprotoport differences.
393  Fixing preun for Red Hat.
394
395* Mon Feb 3 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl
396- Mandrake uses /etc/freeswan/ instead of /etc/ipsec.d/
397  Error fixed: source6 was used for both PSK and CERT.
398
399* Wed Jan 29 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl
400- Added Dominique Cressatti's pty patch in another attempt to
401  prevent the Windows 2000 Professional "loopback detected" error.
402  Seems to work!
403
404* Wed Dec 25 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-2jdl
405- Added 'connect-delay' to PPP parameters in an attempt to
406  prevent the Windows 2000 Professional "loopback detected" error.
407  Didn't seem to work.
408
409* Fri Dec 13 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl
410- Did not build on Red Hat 8.0. Solved by adding comments(?!).
411  Bug detected in spec file: chkconfig --list l2tpd does not work
412  on Red Hat 8.0. Not important enough to look into yet.
413
414* Sun Nov 17 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl
415- Tested on Red Hat, required some changes. No gprintf. Used different
416  pty patch, otherwise wouldn't run. Added buildroot sanity check.
417
418* Sun Nov 10 2002 Jacco de Leeuw <jacco2@dds.nl>
419- Specfile adapted from Mandrake Cooker. The original RPM can be
420  retrieved through:
421  http://www.rpmfind.net/linux/rpm2html/search.php?query=l2tpd
422- Config path changed from /etc/l2tp/ to /etc/l2tpd/
423  (Seems more logical and rp-l2tp already uses /etc/l2tp/).
424- Do not run at boot or install. The original RPM uses a config file
425  which is completely commented out, but it still starts l2tpd on all
426  interfaces. Could be a security risk. This RPM does not start l2tpd,
427  the sysadmin has to edit the config file and start l2tpd explicitly.
428- Renamed patches to start with l2tpd-
429- Added dependencies for pppd, glibc-devel.
430- Use %%{name} as much as possible.
431- l2tp-secrets contains passwords, thus should not be world readable.
432- Removed dependency on rpm-helper.
433
434* Mon Oct 21 2002 Lenny Cartier <lenny@mandrakesoft.com> 0.69-3mdk
435- from Per 0yvind Karlsen <peroyvind@delonic.no> :
436 - PreReq and Requires
437 - Fix preun_service
438
439* Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-2mdk
440- Move l2tpd from /usr/bin to /usr/sbin
441- Added SysV initscript
442- Patch0
443- Patch1
444
445* Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-1mdk
446- Initial release
Note: See TracBrowser for help on using the repository browser.