source: projects/specs/trunk/x/xchat/xchat-vl.spec @ 521

Revision 521, 19.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Nobody likely uses this so we disable it
2%define with_tclplugin 0
3
4%define name xchat
5%define version 2.8.6
6%define release 4%{?_dist_release}
7
8Summary:   GTK2 based graphical IRC client
9Summary(ja):   GTK2 ベースのグラフィカル IRC クライアント
10Name:      %{name}
11Version:   %{version}
12Release:   %{release}
13Group:     Applications/Internet
14License:   GPL
15URL:       http://www.xchat.org/
16
17Source0: http://www.xchat.org/files/source/2.0/xchat-%{version}.tar.bz2
18
19Patch10: http://xchat.org/files/source/2.8/patches/xc286-smallfixes.diff
20
21# Vine
22#Source100: xchat-2.4.5-ja.po
23Patch100: http://takuo.jp/junk/xchat/99_plus.dpatch
24Patch110: http://takuo.jp/junk/xchat/99_x_dialog.dpatch
25Patch200: xchat-2.8.6_defaultserver-vine.patch
26
27# xchat MUST have the version of perl installed which was used to compile
28# it, or else the embeded perl interpreter will break.
29Requires: %(perl -le 'use Config; print $Config{archlibexp}')
30
31BuildRequires: glib2-devel >= 2.2.0
32BuildRequires: gtk2-devel >= 2.2.0
33BuildRequires: bison >= 1.35
34BuildRequires: gettext, sed
35BuildRequires: perl, python-devel, openssl-devel, pkgconfig
36BuildRequires: autoconf
37BuildRequires: GConf2-devel
38BuildRequires: dbus-devel >= 1.0
39
40Requires(post): GConf2 >= 2.14
41Requires(preun): GConf2 >= 2.14
42
43Buildroot: %{_tmppath}/%{name}-%{version}-root
44
45
46%description
47X-Chat is an easy to use graphical IRC chat client for the X Window
48System.
49
50%description -l ja
51X-ChatはGTK2ベースのXウィンドウシステム用のIRCクライアントです。
52
53
54%prep
55%setup -q
56
57%patch10 -p1
58
59%patch100 -p1 -b .plus
60%patch110 -p1 -b .dialog
61
62%patch200 -p1 -b .servlist
63
64sed -i -e 's/#define GTK_DISABLE_DEPRECATED//g' src/fe-gtk/*.c
65
66
67%build
68touch NEWS ABOUT-NLS
69libtoolize --copy --force
70aclocal
71automake
72autoconf
73# Remove CVS files from source dirs so they're not installed into doc dirs.
74find . -name CVS -type d | xargs rm -rf
75
76export CFLAGS="$RPM_OPT_FLAGS $(perl -MExtUtils::Embed -e ccopts)"
77export LDFLAGS=$(perl -MExtUtils::Embed -e ldopts)
78
79if pkg-config openssl ; then
80        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
81        export CPPFLAGS="$CPPFLAGS `pkg-config --cflags-only-I openssl`"
82        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
83fi
84%configure --disable-textfe \
85           --enable-openssl \
86           --enable-python \
87           --disable-spell \
88%if %{with_tclplugin}
89           --enable-tcl \
90%endif     
91           --enable-ipv6
92
93make %{?_smp_mflags}
94
95
96%install
97rm -rf $RPM_BUILD_ROOT
98make DESTDIR=$RPM_BUILD_ROOT install
99
100# Remove unwanted stuff
101rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
102rm -f $RPM_BUILD_ROOT%{_libdir}/xchat/plugins/*.la
103#rm -f $RPM_BUILD_ROOT%{_datadir}/applications/xchat.desktop
104#rm -f $RPM_BUILD_ROOT/etc/X11/applnk/Internet/xchat.desktop
105
106%find_lang %name
107
108
109%files -f %{name}.lang
110%defattr(-,root,root)
111%doc README ChangeLog
112%{_sysconfdir}/gconf/schemas/*
113%{_bindir}/xchat
114%{_libdir}/xchat/plugins/*.so
115%{_datadir}/applications/xchat.desktop
116%{_datadir}/dbus-1/services/*
117%{_datadir}/pixmaps/*
118
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123
124%post
125# Install schema
126export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
127gconftool-2 --makefile-install-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
128
129%pre
130if [ "$1" -gt 1 -a -f "/etc/gconf/schemas/apps_xchat_url_handler.schemas" ]; then
131  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
132  gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
133fi
134
135%preun
136if [ "$1" -eq 0 ]; then
137  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
138  gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
139fi
140
141
142%changelog
143* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.6-4
144- rebuilt with python-2.6.4-3
145
146* Tue Nov 03 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-3
147- updated Patch200 (Vine channel's default encoding to UTF-8)
148
149* Wed Apr 08 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-2
150- rebuilt with gtk2-2.16.0
151- don't #define GTK_DISABLE_DEPRECATED (fixes build against current GTK+)
152- add Patch200 (set default server connection for Vine people)
153- TODO: update ja.po
154
155* Mon Sep 01 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-1
156- updated to 2.8.6
157- drop/add patches
158
159* Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-1
160- new versioning policy
161- rebuilt with perl-5.10.0
162- spec in UTF-8
163
164* Tue Jan 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-0vl1
165- updated to 2.8.4 with updated plus patch and upstream patches (14-16)
166
167* Tue Jun 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.2-0vl1
168- updated to 2.8.2 with plus patch
169
170* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.8-0vl4
171- rebuild with dbus-1.0
172
173* Wed Nov 29 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.6.8-0vl3
174- build without libsexy.
175
176* Thu Nov 23 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl2
177- added Patch10 and Patch20 for possible crashes under certain environments
178
179* Thu Oct 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl1
180- updated to 2.6.8 with plus patch
181
182* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl1
183- new upstream release
184- updated ja.po
185- added Patch1 from http://www.xchat.org/files/source/2.4/patches/
186- added Patches from Fedora
187  * Sun May 15 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-3
188  - Prevent interception of down arrow during Input Method (#144588 tagoh)
189  * Thu Apr 14 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-2
190  - fix plugins on lib64 (#113188 Ville Skytta)
191  * Tue Jan  4 2005 Christopher Aillon <caillon@redhat.com> 1:2.4.1-2
192  - Add Dan Reed's CTCP patch to support multiline messages (#136545)
193  * Tue Aug 17 2004 Daniel Reed <djr@redhat.com> 1:2.4.0-2
194  - #125846 Change xchat.desktop names to "IRC"
195
196* Sun Jan 09 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl4
197- rebuild with perl-5.8.6-0vl2
198
199* Tue Jul  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl3
200- rebuild with perl-5.8.2-0vl2
201- updated ja.po
202
203* Mon Jun 21 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl2
204- resume othersview patch (Patch21)
205
206* Sun Jun 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl1
207- new upstream release
208- updated Patch10
209- dropped unneeded patches
210- updated ja.po
211
212* Fri Nov  7 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl5
213- build with perl-5.8.2
214
215* Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl4
216- build with perl-5.8.1
217- change spec file's encoding: shift_jis -> euc-jp
218
219* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl3
220- add ja.po
221
222* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl2
223- add patch21 from debian to support othersview.
224
225* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl1
226- build for Vine Linux based on rawhide
227- some parts is merged with Vine Linux 1.8.10-0vl2
228  * Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.10-0vl2
229  - rebuilt against gnome-libs-1.4.2-0vl2 (for db1/db4 matters)
230  - add BuildRequires: automake14, autoconf213
231  - modified source10 (openprojects has been renamed to freenode)
232  * Tue Aug 13 2002 IWAI Masaharu <iwai@alib.jp> 1.8.10-0vl1
233  - upstream update
234  - updated plus patch
235  - moved xchat.desktop to %%{_sysconfdir}/X11/applnk/Internet by upstream
236  * Thu Jul 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl3
237  - use source10 instead of patch10 for server list
238  - default server for #VineUsers changed to OpenProjects Network's
239  * Wed Mar 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl2
240  - now with 1.8.8 plus patch
241  * Sat Mar 16 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.8-0vl1
242  - upstream release
243  - updated vine-serverlist.patch
244  - stop to apply plus patch
245    ( xchat-1.8.4 has the security hole... )
246  * Tue Oct  2 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl3
247  - removed backup files for %%patch0 in Document Directory
248  * Sun Sep 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.4-0vl2
249  - updated to 1.8.4 release with plus patch :-)
250  * Sun Sep 30 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl1
251  - upstream release
252  * Mon Sep  3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
253  - 1.8.3-0vl1
254  - upstream release
255  - add xchat-text
256  - add docs: COPYING FAQ plugins/* scripts-perl/* scripts-python/*
257  * Fri Aug  3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
258  - 1.8.2-0vl1
259  - upstream release
260  * Sat Jul 21 2001 <iwaim@cc.mbn.or.jp>
261  - 1.8.1-0vl1
262  - upstream release
263  - modified server.vine patch
264  * Sun Jul 15 2001 <sagami@vinelinux.org>
265  - 1.6.4.1-0vl3: prefix -> _prefix
266  - OLD_PO_FILE_INPUT=yes to build with new gettext
267  - use %%{find_lang}
268  * Wed Apr 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
269  - 1.6.4.1-0vl2
270  - fix CFLAGS for e-paned
271  * Tue Feb  6 2001 Takuo KITAME <kitame@northeye.org>
272  - 1.6.3.1-0vl1
273  - New upstream release
274  * Tue Oct 31 2000 Jun Nishii <jun@vinelinux.org>
275  - 1.5.9.4-0vl1
276  - This is the first release of xchat-plus.
277  * Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
278  - added w3m patch
279  * Wed Apr  12 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
280  - updated to 1.4.2
281  * Thu Mar  14 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
282  - updated to 1.4.1
283  - separated ja_nls patch to more_ja_nls and libjcode patches.
284  * Sat Mar  04 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
285  - modified mb_fix patch for cut & paste.
286  * Fri Feb  11 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
287  - updated to 1.4.0
288  * Wed Feb  2 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
289  - updated to 1.3.13
290  * Mon Jan 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
291  - modified mb_fix patch
292  * Wed Jan  5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
293  - updated to 1.3.10
294  * Wed Dec  8 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
295  - updated to 1.3.8
296  - added mb_fix patch
297  * Tue Nov  9 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
298  - update to 1.3.6
299  * Sun Oct 17 1999 Jun NISHII <jun@flatout.org>
300  - merge ja-patch
301
302* Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-7
303- Added back BuildRequires autoconf, and call autoconf prior to ./configure
304  as it seems to make xchat build successfully.  Have not bothered to figure
305  out why calling autoconf is needed.  Something for a rainy day.
306
307* Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-6
308- Removed gnome-libs BuildRequires as it is bogus now
309- Removed autoconf BuildRequires and usage, as it should be unneeded
310- Added new BuildRequires on gettext, bison >= 1.35, glib2-devel >= 2.0.3,
311  gtk2-devel >= 2.0.3, /bin/sed  (#91676 - Warren Togami)
312- Removed dead patches: xchat-1.8.9-perlcrypt.patch, xchat-1.8.9-korean-fontset.patch
313
314* Wed May 21 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-5
315- Removed xchat.desktop file, as it was earlier replacedwith a patch
316- Converted xchat-2.0.2-redhat-desktop-file.patch to be UTF-8 clean now,
317  instead of the various random legacy mix of encodings it was, updating
318  the following: es, ko, uk, zh_TW
319
320* Tue May 20 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-4
321- Replace explicit perl package name-epoch-version Requires added in 2.0.2-3
322  with a more robust and generic solution of querying perl for the archlibexp
323  dir during building, and requiring it instead
324
325* Tue May 20 2003 Bill Nottingham <notting@redhat.com> 2.0.2-3
326- rebuild against new (old?) perl, add epoch to dependency
327
328* Sat May 17 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-1
329- Updated to new xchat 2.0.2 based on GTK2
330- Dropped unneeded patches xchat-1.8.1-konqueror.patch,
331  xchat-1.8.4-fix-USE_GNOME.patch
332- Updated xchat-2.0.2-freenode.patch to refer to Openprojects.net
333- Removed doc/xchat.sgml doc/*.html scripts-python scripts-perl from %%doc
334- Added xchat-2.0.2-redhat-desktop-file.patch to patch the supplied xchat
335  desktop file, instead of replacing it and trying to stay in sync
336- Added xchat-2.0.2-lib64-cleanup-for-python.patch which fixes build problems
337  on lib64 archs, and replaces xchat-multilib.patch
338- Added with_tclplugin macro and default it to disabled
339
340* Mon Mar 17 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-8
341- Added xchat-1.8.11-nickall.patch which was written by Fabio Olive Leite,
342  sent to me by Rik van Riel
343
344* Wed Feb 19 2003 Bill Nottingham <notting@redhat.com> 1.8.11-7
345- ship single desktop in %{_datadir}/applications, not /etc/X11/applnk
346
347* Fri Jan 31 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-6
348- Added xchat-1.8.11-freenode.patch to rename all openprojects.net entries
349  to freenode.net in the default server list.  Patch courtesy of Dan Burcaw
350  from bug (#81704)
351
352* Wed Jan 22 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-5
353- Removed double .desktop file (#81874,82315)
354
355* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 1.8.11-4
356- rebuilt
357
358* Tue Jan  7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-3
359- Add bugfix from xchat.org xc1811fixststint.diff
360
361* Tue Jan  7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-2
362- Remove CVS files from source dirs so they're not installed into doc dirs.
363
364* Tue Jan  7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-1
365- Update to xchat 1.8.11 bugfix release, fixes various runtime crashes
366- Remove now included patches: xchat-1.8.10-urlhandler-open-in-new-tab.patch,
367  xchat-1.8.10-beep-beep-beep.patch
368
369* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 1.8.10-13
370- Pick up OpenSSL configuration from pkgconfig, if available
371- Add openssl-devel and pkgconfig as buildreqs
372
373* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.8.10-12
374- Fix broken libpython path on multilibbed systems (patch13)
375- _smp_mflags
376
377* Tue Nov 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-11
378- Added xchat-1.8.10-urlhandler-open-in-new-tab.patch to offer the option of
379  opening a URL in a new tab of an existing browser window rather than a new
380  window
381
382* Sat Nov 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-10
383- Added BuildRequires: python-devel to hopefully pick up a missing dep
384  causing package build failure in timp's nightly builds.
385- Removed dead patches
386- Updated package summary and description to be more user friendly by
387  rewording, and removing scary words like GNOME, GTK and other irrelevance
388
389* Wed Nov 13 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-9
390- Made sure {_sysconfdir}/X11/applnk/Internet/xchat.desktop gets packaged
391- Removed some conditional weirdness in %%files list.  This may break xchat
392  erratum releases on Red Hat Linux 7.x.  May need to be fixed in future.
393
394* Fri Aug 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-7
395- Added Requires line so that xchat requires the exact version of perl
396  be installed, that was used to compile it, since the embedded perl
397  interpreter will break, if you upgrade perl
398
399* Thu Aug 15 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-6
400- Fix Bill's beep beep beep bug (#71651)
401
402* Wed Aug 14 2002 Jonathan Blandford <jrb@redhat.com> 1.8.10-5
403- actually install the desktop file.
404
405* Fri Aug  9 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-3
406- Added http://xchat.org/files/source/1.8/patches/xc1810fixme.diff to fix
407  bug with using /ME in a /QUERY window.  (#71179)
408
409* Wed Aug  7 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-2
410- Updated to xchat 1.8.10 to fix a few bugs where a remote ircd could cause
411  the xchat client to crash.  This is a bugfix only release.
412
413* Tue Aug  6 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-10
414- Added Korean fontset support to fix bug (#69771)
415
416* Mon Aug  5 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-9
417- Enabled python scripting which was somehow disabled somewhere along the
418  line by default in upstream sources, and we missed catching it. (#70816)
419
420* Sun Aug  4 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-8
421- Created new-style net-xchat.desktop file (#69541)
422
423* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.8.9-7
424- automated rebuild
425
426* Tue Jun 18 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-6
427- updated the package description
428- Added CFLAGS and LDFLAGS export vars before configure to fix rpath problem
429
430* Sun May 26 2002 Tim Powers <timp@redhat.com>
431- automated rebuild
432
433* Mon May 20 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-2
434- Updated to xchat 1.8.9
435
436* Mon Apr  8 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-5
437- Re-enabled GNOME support due to user complaints of pixmaps missing, key
438  bindings, and other fairly important features no longer working.
439
440* Tue Mar 27 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-4
441- Disabled GNOME support since it doesn't seem too useful anyways, and forces
442  all xchat users to install GNOME libs even if they use KDE. (#59626)
443- Updated URL and source lines in spec.
444
445* Wed Mar  6 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-1
446- Updated to xchat 1.8.8
447
448* Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-6
449- Built in new buildroot
450
451* Tue Feb  5 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-5
452- Added xchat-1.8.7-use-sysconf-to-detect-cpus.patch to use glibc's sysconf()
453  to detect the number of processors available.
454
455* Mon Feb  4 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-4
456- Enabled IPv6 support as per the request for enhancement (#52124)
457
458* Thu Jan 24 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-3
459- Rebuilt in new build environment
460
461* Thu Jan 10 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-2
462- Updated to xchat 1.8.7
463- New release fixes security vulnerability in CTCP reply
464- Built erratum for all supported releases (1.8.7-1.62.0, 1.8.7-1.70.0,
465  1.8.7-1.71.0, 1.8.7-1.72.0)
466- Removed konqueror patch as it is integrated now.
467
468* Sat Jan  5 2002 Mike A. Harris <mharris@redhat.com> 1.8.6-2
469- Enabled ssl support with --enable-openssl
470- Also built releases 1.72.0, 1.71.0, 1.70.0, 1.62.0 for erratum release
471
472* Mon Dec 10 2001 Mike A. Harris <mharris@redhat.com> 1.8.6-1
473- Updated to xchat 1.8.6
474
475* Tue Nov 13 2001 Mike A. Harris <mharris@redhat.com> 1.8.5-1
476- Updated to xchat 1.8.5
477- Added f to rm -r in install and clean sections
478
479* Sun Oct  7 2001 Mike A. Harris <mharris@redhat.com> 1.8.4-1
480- Updated to 1.8.4, now using tar.bz2
481- Removed kanjiconv-fix patch as it is integrated now
482- Added xchat-1.8.4-fix-USE_GNOME.patch to fix simple ifdef USE_GNOME typo
483
484* Fri Jul 13 2001 Akira TAGOH <tagoh@redhat.com> 1.8.1-2
485- fixed check locale.
486- don't save kanji_conv.
487  always check locale. however anyone can change the option from
488  the settings menu.
489
490* Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
491- upgrade to 1.8.1
492- remove autoconnect patch since it's upstream
493- remove japanese patch, upstream seems to have applied
494  parts of it and changelog says there's upstream support.
495  (this patch was pretty huge to maintain in an SRPM anyway...)
496- put scripts-python scripts-perl in docs bug #28521
497- remove patch to include locale.h, gone upstream
498- upgrade konqueror patch
499
500* Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
501- nevermind, BuildRequires gnome-libs, that should
502  close #48923
503
504* Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
505- fix file list to not include absolute path "/usr/share/..."
506  no idea how that ever worked at all. closes #48923
507
508* Mon Jun 25 2001 Karsten Hopp <karsten@redhat.de>
509- use konqueror, not kfmclient on URLs
510
511* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
512- langify
513- use %%{_tmppath}
514- make it compile
515
516* Tue Feb 13 2001 Akira TAGOH <tagoh@redhat.com>
517- Added Japanese patch.
518
519* Tue Feb 13 2001 Havoc Pennington <hp@redhat.com>
520- patch that may fix autoconnections (bug 27093)
521
522* Mon Jan 22 2001 Havoc Pennington <hp@redhat.com>
523- 1.6.3
524- remove patch to desktop file (Internet->Application), seems to
525  have gone upstream
526
527* Sat Dec 9 2000 Havoc Pennington <hp@redhat.com>
528- Remove security fix which has been merged upstream
529- upgrade to 1.6.1
530
531* Sat Aug 19 2000 Havoc Pennington <hp@redhat.com>
532- Don't use /bin/sh to interpret URLs from the net
533
534* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
535- Updated Epoch
536
537* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
538- automatic rebuild
539
540* Mon Jun 19 2000 Havoc Pennington <hp@redhat.com>
541- Install HTML docs
542
543* Fri Jun 16 2000 Preston Brown <pbrown@redhat.com>
544- fix desktop entry
545
546* Fri May 19 2000 Havoc Pennington <hp@redhat.com>
547- rebuild for the Winston tree, update to 1.4.2
Note: See TracBrowser for help on using the repository browser.