source: projects/specs/trunk/x/xchat/xchat-vl.spec @ 2506

Revision 2506, 20.0 KB checked in by Takemikaduchi, 13 years ago (diff)

wireshark: new upstream release, others: rebuild with openssl-1.0.0c

Line 
1# Nobody likely uses this so we disable it
2%define with_tclplugin 0
3
4%define name xchat
5%define version 2.8.6
6%define release 5%{?_dist_release}
7
8Summary:   GTK2 based graphical IRC client
9Summary(ja):   GTK2 ベースのグラフィカル IRC クライアント
10Name:      %{name}
11Version:   %{version}
12Release:   %{release}
13Group:     Applications/Internet
14License:   GPL
15URL:       http://www.xchat.org/
16
17Source0: http://www.xchat.org/files/source/2.0/xchat-%{version}.tar.bz2
18
19Patch10: http://xchat.org/files/source/2.8/patches/xc286-smallfixes.diff
20
21# Vine
22#Source100: xchat-2.4.5-ja.po
23Patch100: http://takuo.jp/junk/xchat/99_plus.dpatch
24Patch110: http://takuo.jp/junk/xchat/99_x_dialog.dpatch
25Patch200: xchat-2.8.6_defaultserver-vine.patch
26Patch201: xchat-2.8.6-x86_64.patch
27
28# xchat MUST have the version of perl installed which was used to compile
29# it, or else the embeded perl interpreter will break.
30Requires: %(perl -le 'use Config; print $Config{archlibexp}')
31
32BuildRequires: glib2-devel >= 2.2.0
33BuildRequires: gtk2-devel >= 2.2.0
34BuildRequires: bison >= 1.35
35BuildRequires: gettext, sed
36BuildRequires: perl, python-devel, openssl-devel, pkgconfig
37BuildRequires: autoconf
38BuildRequires: GConf2-devel
39BuildRequires: dbus-devel >= 1.0
40BuildRequires: tcl
41
42Requires(post): GConf2 >= 2.14
43Requires(preun): GConf2 >= 2.14
44
45Buildroot: %{_tmppath}/%{name}-%{version}-root
46
47
48%description
49X-Chat is an easy to use graphical IRC chat client for the X Window
50System.
51
52%description -l ja
53X-ChatはGTK2ベースのXウィンドウシステム用のIRCクライアントです。
54
55
56%prep
57%setup -q
58
59%patch10 -p1
60
61%patch100 -p1 -b .plus
62%patch110 -p1 -b .dialog
63
64%patch200 -p1 -b .servlist
65%patch201 -p1 -b .x86_64
66
67sed -i -e 's/#define GTK_DISABLE_DEPRECATED//g' src/fe-gtk/*.c
68
69
70%build
71touch NEWS ABOUT-NLS
72libtoolize --copy --force
73aclocal
74automake
75autoconf
76# Remove CVS files from source dirs so they're not installed into doc dirs.
77find . -name CVS -type d | xargs rm -rf
78
79export CFLAGS="$RPM_OPT_FLAGS $(perl -MExtUtils::Embed -e ccopts)"
80export LDFLAGS=$(perl -MExtUtils::Embed -e ldopts)
81
82if pkg-config openssl ; then
83        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
84        export CPPFLAGS="$CPPFLAGS `pkg-config --cflags-only-I openssl`"
85        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
86fi
87%configure --disable-textfe \
88           --enable-openssl \
89           --enable-python \
90           --disable-spell \
91%if %{with_tclplugin}
92           --enable-tcl \
93%endif     
94           --enable-ipv6
95
96make %{?_smp_mflags}
97
98
99%install
100rm -rf $RPM_BUILD_ROOT
101make DESTDIR=$RPM_BUILD_ROOT install
102
103# Remove unwanted stuff
104rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
105rm -f $RPM_BUILD_ROOT%{_libdir}/xchat/plugins/*.la
106#rm -f $RPM_BUILD_ROOT%{_datadir}/applications/xchat.desktop
107#rm -f $RPM_BUILD_ROOT/etc/X11/applnk/Internet/xchat.desktop
108
109%find_lang %name
110
111
112%files -f %{name}.lang
113%defattr(-,root,root)
114%doc README ChangeLog
115%{_sysconfdir}/gconf/schemas/*
116%{_bindir}/xchat
117%{_libdir}/xchat/plugins/*.so
118%{_datadir}/applications/xchat.desktop
119%{_datadir}/dbus-1/services/*
120%{_datadir}/pixmaps/*
121
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126
127%post
128# Install schema
129export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
130gconftool-2 --makefile-install-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
131
132%pre
133if [ "$1" -gt 1 -a -f "/etc/gconf/schemas/apps_xchat_url_handler.schemas" ]; then
134  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
135  gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
136fi
137
138%preun
139if [ "$1" -eq 0 ]; then
140  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
141  gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
142fi
143
144
145%changelog
146* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-5
147- rebuild with openssl-1.0.0c
148- add BuildRequires: tcl
149- add Patch201 (xchat-2.8.6-x86_64.patch)
150
151* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.6-4
152- rebuilt with python-2.6.4-3
153
154* Tue Nov 03 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-3
155- updated Patch200 (Vine channel's default encoding to UTF-8)
156
157* Wed Apr 08 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-2
158- rebuilt with gtk2-2.16.0
159- don't #define GTK_DISABLE_DEPRECATED (fixes build against current GTK+)
160- add Patch200 (set default server connection for Vine people)
161- TODO: update ja.po
162
163* Mon Sep 01 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-1
164- updated to 2.8.6
165- drop/add patches
166
167* Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-1
168- new versioning policy
169- rebuilt with perl-5.10.0
170- spec in UTF-8
171
172* Tue Jan 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-0vl1
173- updated to 2.8.4 with updated plus patch and upstream patches (14-16)
174
175* Tue Jun 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.2-0vl1
176- updated to 2.8.2 with plus patch
177
178* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.8-0vl4
179- rebuild with dbus-1.0
180
181* Wed Nov 29 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.6.8-0vl3
182- build without libsexy.
183
184* Thu Nov 23 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl2
185- added Patch10 and Patch20 for possible crashes under certain environments
186
187* Thu Oct 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl1
188- updated to 2.6.8 with plus patch
189
190* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl1
191- new upstream release
192- updated ja.po
193- added Patch1 from http://www.xchat.org/files/source/2.4/patches/
194- added Patches from Fedora
195  * Sun May 15 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-3
196  - Prevent interception of down arrow during Input Method (#144588 tagoh)
197  * Thu Apr 14 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-2
198  - fix plugins on lib64 (#113188 Ville Skytta)
199  * Tue Jan  4 2005 Christopher Aillon <caillon@redhat.com> 1:2.4.1-2
200  - Add Dan Reed's CTCP patch to support multiline messages (#136545)
201  * Tue Aug 17 2004 Daniel Reed <djr@redhat.com> 1:2.4.0-2
202  - #125846 Change xchat.desktop names to "IRC"
203
204* Sun Jan 09 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl4
205- rebuild with perl-5.8.6-0vl2
206
207* Tue Jul  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl3
208- rebuild with perl-5.8.2-0vl2
209- updated ja.po
210
211* Mon Jun 21 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl2
212- resume othersview patch (Patch21)
213
214* Sun Jun 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl1
215- new upstream release
216- updated Patch10
217- dropped unneeded patches
218- updated ja.po
219
220* Fri Nov  7 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl5
221- build with perl-5.8.2
222
223* Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl4
224- build with perl-5.8.1
225- change spec file's encoding: shift_jis -> euc-jp
226
227* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl3
228- add ja.po
229
230* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl2
231- add patch21 from debian to support othersview.
232
233* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl1
234- build for Vine Linux based on rawhide
235- some parts is merged with Vine Linux 1.8.10-0vl2
236  * Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.10-0vl2
237  - rebuilt against gnome-libs-1.4.2-0vl2 (for db1/db4 matters)
238  - add BuildRequires: automake14, autoconf213
239  - modified source10 (openprojects has been renamed to freenode)
240  * Tue Aug 13 2002 IWAI Masaharu <iwai@alib.jp> 1.8.10-0vl1
241  - upstream update
242  - updated plus patch
243  - moved xchat.desktop to %%{_sysconfdir}/X11/applnk/Internet by upstream
244  * Thu Jul 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl3
245  - use source10 instead of patch10 for server list
246  - default server for #VineUsers changed to OpenProjects Network's
247  * Wed Mar 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl2
248  - now with 1.8.8 plus patch
249  * Sat Mar 16 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.8-0vl1
250  - upstream release
251  - updated vine-serverlist.patch
252  - stop to apply plus patch
253    ( xchat-1.8.4 has the security hole... )
254  * Tue Oct  2 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl3
255  - removed backup files for %%patch0 in Document Directory
256  * Sun Sep 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.4-0vl2
257  - updated to 1.8.4 release with plus patch :-)
258  * Sun Sep 30 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl1
259  - upstream release
260  * Mon Sep  3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
261  - 1.8.3-0vl1
262  - upstream release
263  - add xchat-text
264  - add docs: COPYING FAQ plugins/* scripts-perl/* scripts-python/*
265  * Fri Aug  3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
266  - 1.8.2-0vl1
267  - upstream release
268  * Sat Jul 21 2001 <iwaim@cc.mbn.or.jp>
269  - 1.8.1-0vl1
270  - upstream release
271  - modified server.vine patch
272  * Sun Jul 15 2001 <sagami@vinelinux.org>
273  - 1.6.4.1-0vl3: prefix -> _prefix
274  - OLD_PO_FILE_INPUT=yes to build with new gettext
275  - use %%{find_lang}
276  * Wed Apr 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
277  - 1.6.4.1-0vl2
278  - fix CFLAGS for e-paned
279  * Tue Feb  6 2001 Takuo KITAME <kitame@northeye.org>
280  - 1.6.3.1-0vl1
281  - New upstream release
282  * Tue Oct 31 2000 Jun Nishii <jun@vinelinux.org>
283  - 1.5.9.4-0vl1
284  - This is the first release of xchat-plus.
285  * Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
286  - added w3m patch
287  * Wed Apr  12 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
288  - updated to 1.4.2
289  * Thu Mar  14 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
290  - updated to 1.4.1
291  - separated ja_nls patch to more_ja_nls and libjcode patches.
292  * Sat Mar  04 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
293  - modified mb_fix patch for cut & paste.
294  * Fri Feb  11 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
295  - updated to 1.4.0
296  * Wed Feb  2 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
297  - updated to 1.3.13
298  * Mon Jan 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
299  - modified mb_fix patch
300  * Wed Jan  5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
301  - updated to 1.3.10
302  * Wed Dec  8 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
303  - updated to 1.3.8
304  - added mb_fix patch
305  * Tue Nov  9 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
306  - update to 1.3.6
307  * Sun Oct 17 1999 Jun NISHII <jun@flatout.org>
308  - merge ja-patch
309
310* Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-7
311- Added back BuildRequires autoconf, and call autoconf prior to ./configure
312  as it seems to make xchat build successfully.  Have not bothered to figure
313  out why calling autoconf is needed.  Something for a rainy day.
314
315* Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-6
316- Removed gnome-libs BuildRequires as it is bogus now
317- Removed autoconf BuildRequires and usage, as it should be unneeded
318- Added new BuildRequires on gettext, bison >= 1.35, glib2-devel >= 2.0.3,
319  gtk2-devel >= 2.0.3, /bin/sed  (#91676 - Warren Togami)
320- Removed dead patches: xchat-1.8.9-perlcrypt.patch, xchat-1.8.9-korean-fontset.patch
321
322* Wed May 21 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-5
323- Removed xchat.desktop file, as it was earlier replacedwith a patch
324- Converted xchat-2.0.2-redhat-desktop-file.patch to be UTF-8 clean now,
325  instead of the various random legacy mix of encodings it was, updating
326  the following: es, ko, uk, zh_TW
327
328* Tue May 20 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-4
329- Replace explicit perl package name-epoch-version Requires added in 2.0.2-3
330  with a more robust and generic solution of querying perl for the archlibexp
331  dir during building, and requiring it instead
332
333* Tue May 20 2003 Bill Nottingham <notting@redhat.com> 2.0.2-3
334- rebuild against new (old?) perl, add epoch to dependency
335
336* Sat May 17 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-1
337- Updated to new xchat 2.0.2 based on GTK2
338- Dropped unneeded patches xchat-1.8.1-konqueror.patch,
339  xchat-1.8.4-fix-USE_GNOME.patch
340- Updated xchat-2.0.2-freenode.patch to refer to Openprojects.net
341- Removed doc/xchat.sgml doc/*.html scripts-python scripts-perl from %%doc
342- Added xchat-2.0.2-redhat-desktop-file.patch to patch the supplied xchat
343  desktop file, instead of replacing it and trying to stay in sync
344- Added xchat-2.0.2-lib64-cleanup-for-python.patch which fixes build problems
345  on lib64 archs, and replaces xchat-multilib.patch
346- Added with_tclplugin macro and default it to disabled
347
348* Mon Mar 17 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-8
349- Added xchat-1.8.11-nickall.patch which was written by Fabio Olive Leite,
350  sent to me by Rik van Riel
351
352* Wed Feb 19 2003 Bill Nottingham <notting@redhat.com> 1.8.11-7
353- ship single desktop in %{_datadir}/applications, not /etc/X11/applnk
354
355* Fri Jan 31 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-6
356- Added xchat-1.8.11-freenode.patch to rename all openprojects.net entries
357  to freenode.net in the default server list.  Patch courtesy of Dan Burcaw
358  from bug (#81704)
359
360* Wed Jan 22 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-5
361- Removed double .desktop file (#81874,82315)
362
363* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 1.8.11-4
364- rebuilt
365
366* Tue Jan  7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-3
367- Add bugfix from xchat.org xc1811fixststint.diff
368
369* Tue Jan  7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-2
370- Remove CVS files from source dirs so they're not installed into doc dirs.
371
372* Tue Jan  7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-1
373- Update to xchat 1.8.11 bugfix release, fixes various runtime crashes
374- Remove now included patches: xchat-1.8.10-urlhandler-open-in-new-tab.patch,
375  xchat-1.8.10-beep-beep-beep.patch
376
377* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 1.8.10-13
378- Pick up OpenSSL configuration from pkgconfig, if available
379- Add openssl-devel and pkgconfig as buildreqs
380
381* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.8.10-12
382- Fix broken libpython path on multilibbed systems (patch13)
383- _smp_mflags
384
385* Tue Nov 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-11
386- Added xchat-1.8.10-urlhandler-open-in-new-tab.patch to offer the option of
387  opening a URL in a new tab of an existing browser window rather than a new
388  window
389
390* Sat Nov 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-10
391- Added BuildRequires: python-devel to hopefully pick up a missing dep
392  causing package build failure in timp's nightly builds.
393- Removed dead patches
394- Updated package summary and description to be more user friendly by
395  rewording, and removing scary words like GNOME, GTK and other irrelevance
396
397* Wed Nov 13 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-9
398- Made sure {_sysconfdir}/X11/applnk/Internet/xchat.desktop gets packaged
399- Removed some conditional weirdness in %%files list.  This may break xchat
400  erratum releases on Red Hat Linux 7.x.  May need to be fixed in future.
401
402* Fri Aug 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-7
403- Added Requires line so that xchat requires the exact version of perl
404  be installed, that was used to compile it, since the embedded perl
405  interpreter will break, if you upgrade perl
406
407* Thu Aug 15 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-6
408- Fix Bill's beep beep beep bug (#71651)
409
410* Wed Aug 14 2002 Jonathan Blandford <jrb@redhat.com> 1.8.10-5
411- actually install the desktop file.
412
413* Fri Aug  9 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-3
414- Added http://xchat.org/files/source/1.8/patches/xc1810fixme.diff to fix
415  bug with using /ME in a /QUERY window.  (#71179)
416
417* Wed Aug  7 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-2
418- Updated to xchat 1.8.10 to fix a few bugs where a remote ircd could cause
419  the xchat client to crash.  This is a bugfix only release.
420
421* Tue Aug  6 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-10
422- Added Korean fontset support to fix bug (#69771)
423
424* Mon Aug  5 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-9
425- Enabled python scripting which was somehow disabled somewhere along the
426  line by default in upstream sources, and we missed catching it. (#70816)
427
428* Sun Aug  4 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-8
429- Created new-style net-xchat.desktop file (#69541)
430
431* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.8.9-7
432- automated rebuild
433
434* Tue Jun 18 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-6
435- updated the package description
436- Added CFLAGS and LDFLAGS export vars before configure to fix rpath problem
437
438* Sun May 26 2002 Tim Powers <timp@redhat.com>
439- automated rebuild
440
441* Mon May 20 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-2
442- Updated to xchat 1.8.9
443
444* Mon Apr  8 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-5
445- Re-enabled GNOME support due to user complaints of pixmaps missing, key
446  bindings, and other fairly important features no longer working.
447
448* Tue Mar 27 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-4
449- Disabled GNOME support since it doesn't seem too useful anyways, and forces
450  all xchat users to install GNOME libs even if they use KDE. (#59626)
451- Updated URL and source lines in spec.
452
453* Wed Mar  6 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-1
454- Updated to xchat 1.8.8
455
456* Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-6
457- Built in new buildroot
458
459* Tue Feb  5 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-5
460- Added xchat-1.8.7-use-sysconf-to-detect-cpus.patch to use glibc's sysconf()
461  to detect the number of processors available.
462
463* Mon Feb  4 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-4
464- Enabled IPv6 support as per the request for enhancement (#52124)
465
466* Thu Jan 24 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-3
467- Rebuilt in new build environment
468
469* Thu Jan 10 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-2
470- Updated to xchat 1.8.7
471- New release fixes security vulnerability in CTCP reply
472- Built erratum for all supported releases (1.8.7-1.62.0, 1.8.7-1.70.0,
473  1.8.7-1.71.0, 1.8.7-1.72.0)
474- Removed konqueror patch as it is integrated now.
475
476* Sat Jan  5 2002 Mike A. Harris <mharris@redhat.com> 1.8.6-2
477- Enabled ssl support with --enable-openssl
478- Also built releases 1.72.0, 1.71.0, 1.70.0, 1.62.0 for erratum release
479
480* Mon Dec 10 2001 Mike A. Harris <mharris@redhat.com> 1.8.6-1
481- Updated to xchat 1.8.6
482
483* Tue Nov 13 2001 Mike A. Harris <mharris@redhat.com> 1.8.5-1
484- Updated to xchat 1.8.5
485- Added f to rm -r in install and clean sections
486
487* Sun Oct  7 2001 Mike A. Harris <mharris@redhat.com> 1.8.4-1
488- Updated to 1.8.4, now using tar.bz2
489- Removed kanjiconv-fix patch as it is integrated now
490- Added xchat-1.8.4-fix-USE_GNOME.patch to fix simple ifdef USE_GNOME typo
491
492* Fri Jul 13 2001 Akira TAGOH <tagoh@redhat.com> 1.8.1-2
493- fixed check locale.
494- don't save kanji_conv.
495  always check locale. however anyone can change the option from
496  the settings menu.
497
498* Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
499- upgrade to 1.8.1
500- remove autoconnect patch since it's upstream
501- remove japanese patch, upstream seems to have applied
502  parts of it and changelog says there's upstream support.
503  (this patch was pretty huge to maintain in an SRPM anyway...)
504- put scripts-python scripts-perl in docs bug #28521
505- remove patch to include locale.h, gone upstream
506- upgrade konqueror patch
507
508* Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
509- nevermind, BuildRequires gnome-libs, that should
510  close #48923
511
512* Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
513- fix file list to not include absolute path "/usr/share/..."
514  no idea how that ever worked at all. closes #48923
515
516* Mon Jun 25 2001 Karsten Hopp <karsten@redhat.de>
517- use konqueror, not kfmclient on URLs
518
519* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
520- langify
521- use %%{_tmppath}
522- make it compile
523
524* Tue Feb 13 2001 Akira TAGOH <tagoh@redhat.com>
525- Added Japanese patch.
526
527* Tue Feb 13 2001 Havoc Pennington <hp@redhat.com>
528- patch that may fix autoconnections (bug 27093)
529
530* Mon Jan 22 2001 Havoc Pennington <hp@redhat.com>
531- 1.6.3
532- remove patch to desktop file (Internet->Application), seems to
533  have gone upstream
534
535* Sat Dec 9 2000 Havoc Pennington <hp@redhat.com>
536- Remove security fix which has been merged upstream
537- upgrade to 1.6.1
538
539* Sat Aug 19 2000 Havoc Pennington <hp@redhat.com>
540- Don't use /bin/sh to interpret URLs from the net
541
542* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
543- Updated Epoch
544
545* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
546- automatic rebuild
547
548* Mon Jun 19 2000 Havoc Pennington <hp@redhat.com>
549- Install HTML docs
550
551* Fri Jun 16 2000 Preston Brown <pbrown@redhat.com>
552- fix desktop entry
553
554* Fri May 19 2000 Havoc Pennington <hp@redhat.com>
555- rebuild for the Winston tree, update to 1.4.2
Note: See TracBrowser for help on using the repository browser.