source: projects/specs/trunk/x/xarchiver/xarchiver-vl.spec @ 960

Revision 960, 6.6 KB checked in by kudoh, 14 years ago (diff)
Line 
1Name:           xarchiver
2Version:        0.5.2
3Release:        3%{?_dist_release}
4Summary:        Archive manager for Xfce
5Summary(ja):    Xfceのアーカイブマネージャ
6
7Group:          Applications/Archiving
8License:        GPLv2+
9URL:            http://xarchiver.xfce.org/
10Source0:        http://downloads.sourceforge.net/xarchiver/xarchiver-%{version}.tar.bz2
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires:  gtk2-devel, libxml2-devel, gettext, desktop-file-utils
14BuildRequires:  glib2-devel >= 2.10.0 intltool >= 0.31
15#BuildRequires:  xfce4-dev-tools >= 4.3.90.2
16Requires:       binutils, bzip2, cpio, gzip, xdg-utils, tar, unzip, zip
17
18
19%description
20Xarchiver is a lightweight GTK2 only frontend for manipulating 7z, bzip2,
21gzip, iso, rar, lha, tar, zip, RPM and deb files. It allows you to create
22archives and add, extract, and delete files from them. Password protected
23archives in the 7z, rar, and zip formats are supported.
24
25
26%prep
27%setup -q
28# fix spurious executable permissions of some debug files
29chmod -x src/mime.*
30
31%build
32%configure
33make %{?_smp_mflags}
34
35
36%install
37rm -rf $RPM_BUILD_ROOT
38make install DESTDIR=$RPM_BUILD_ROOT
39
40# We need to install xarchiver.tap as fedora-xarchiver.tap, because the name
41# has to match the basename of the desktop-file in %{_datadir}/applications.
42rm $RPM_BUILD_ROOT%{_libexecdir}/thunar-archive-plugin/xarchiver.tap
43install -p -m 755 xarchiver.tap \
44   $RPM_BUILD_ROOT%{_libexecdir}/thunar-archive-plugin/vine-xarchiver.tap
45
46%find_lang %{name}
47desktop-file-install --vendor vine                         \
48        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications         \
49        --add-category="Utility"                            \
50        --delete-original                                       \
51        ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop
52
53# remove duplicate docs
54rm $RPM_BUILD_ROOT%{_docdir}/%{name}/{AUTHORS,COPYING,ChangeLog,NEWS,README,TODO}
55
56
57%post
58touch --no-create %{_datadir}/icons/hicolor
59if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
60  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
61fi
62update-desktop-database &> /dev/null || :
63
64
65%postun
66touch --no-create %{_datadir}/icons/hicolor
67if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
68  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
69fi
70update-desktop-database &> /dev/null || :
71
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76
77%files -f %{name}.lang
78%defattr(-,root,root,-)
79%doc AUTHORS COPYING ChangeLog NEWS README TODO
80%doc %{_docdir}/%{name}/
81%{_bindir}/%{name}
82%{_datadir}/applications/vine-%{name}.desktop
83%{_datadir}/icons/hicolor/*/apps/%{name}.png
84%{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
85%dir %{_datadir}/pixmaps/%{name}/
86%{_datadir}/pixmaps/%{name}/%{name}*.png
87%dir %{_libexecdir}/thunar-archive-plugin/
88%{_libexecdir}/thunar-archive-plugin/vine-xarchiver.tap
89
90
91%changelog
92* Fri May 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.5.2-3
93- fixed desktop-file-install --add-category section
94- added BuildRequires: glib2-devel >= 2.10.0 intltool >= 0.31
95
96* Sun Apr 5 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.5.2-2vl5
97- fixed BuildRoot tag
98
99* Mon Mar 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.5.2-1vl5
100- initial release for VineSeed (import Fedora Package)
101
102* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.2-3
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
104
105* Tue Nov 25 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.2-2
106- Include HTML documentation
107
108* Tue Nov 25 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.2-1
109- Update to 0.5.2
110
111* Sun Nov 09 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.1-1
112- Update to 0.5.1 stable release
113
114* Sun Oct 26 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.0-0.1.rc1
115- Update to 0.5.0rc1
116- Fix crash when opening zipped PDF files (#467619)
117- Update gtk-icon-cache scriptlets
118
119* Sat Oct 11 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.0-0.1.beta2
120- Update to 0.5.0beta2
121
122* Sun Aug 31 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.0-0.1.beta1
123- Update to 0.5.0beta1
124- Remove xdg-open.patch as xarchiver now uses xdg-open by default
125
126* Sat Apr 19 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.6.20070103svn24249
127- Remove additional mime-types from desktop-file-install to make sure we don't break livecds
128
129* Fri Mar 14 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.5.20070103svn24249
130- Use xdg-open instead of htmlview (#437554)
131
132* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.9-0.4.20070103svn24249
133- Autorebuild for GCC 4.3
134
135* Tue Aug 28 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.3.20070103svn24249
136- Rebuild for BuildID feature
137- Update license tag
138
139* Fri Mar 02 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.2.20070103svn24249
140- Downgrade to SVN release 24249 in order to fix #230154 temporarily.
141
142* Sun Jan 28 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.1.20070128svn24772
143- Update to SVN release 24772 of January 28th 2007.
144
145* Wed Jan 03 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.1.20070103svn
146- Update to SVN r24249 of January 3rd 2007.
147- Add mimetype application/x-deb again since opening of debs now is secure.
148
149* Wed Dec 13 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.1.20061213svn
150- Update to SVN r24096 of December 13th 2006.
151
152* Wed Dec 06 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.6-3
153- Add deb.patch to prevent opening of .a files as debs.
154- Don't add mimetype for x-ar (archiver can't handle ar archive).
155
156* Wed Nov 29 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.6-2
157- Add htmlview.patch.
158
159* Tue Nov 28 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.6-1
160- Update to 0.4.6.
161- Update %%description.
162- Require binutils, cpio and htmlview.
163- Add mimetypes application/x-ar, application/x-cd-image and application/x-deb.
164
165* Tue Nov 27 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.4-1
166- Update to 0.4.4.
167
168* Sat Nov 25 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.2-0.3.rc2
169- Install xarchiver.png also in %%{_datadir}/icons/hicolor/48x48/apps/.
170
171* Sat Nov 25 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.2-0.2.rc2
172- Drop subpackage and own %%{_libexecdir}/thunar-archive-plugin/ (#198098).
173
174* Sun Nov 12 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.2-0.1.rc2
175- Update to 0.4.2.RC2.
176
177* Wed Sep 13 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.0-1
178- Update to 0.4.0.
179
180* Tue Sep 05 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.9.2-0.beta2
181- Initial package.
Note: See TracBrowser for help on using the repository browser.