source: projects/specs/trunk/x/xarchiver/xarchiver-vl.spec @ 521

Revision 521, 6.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           xarchiver
2Version:        0.5.2
3Release:        2%{?_dist_release}
4Summary:        Archive manager for Xfce
5Summary(ja):        Xfceのアーカイブマネージャ
6
7Group:          Applications/Archiving
8License:        GPLv2+
9URL:            http://xarchiver.xfce.org/
10Source0:        http://downloads.sourceforge.net/xarchiver/xarchiver-%{version}.tar.bz2
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires:  gtk2-devel, libxml2-devel, gettext, desktop-file-utils
14#BuildRequires:  xfce4-dev-tools >= 4.3.90.2
15Requires:       binutils, bzip2, cpio, gzip, xdg-utils, tar, unzip, zip
16
17%description
18Xarchiver is a lightweight GTK2 only frontend for manipulating 7z, bzip2,
19gzip, iso, rar, lha, tar, zip, RPM and deb files. It allows you to create
20archives and add, extract, and delete files from them. Password protected
21archives in the 7z, rar, and zip formats are supported.
22
23
24%prep
25%setup -q
26# fix spurious executable permissions of some debug files
27chmod -x src/mime.*
28
29
30%build
31%configure
32make %{?_smp_mflags}
33
34
35%install
36rm -rf $RPM_BUILD_ROOT
37make install DESTDIR=$RPM_BUILD_ROOT
38
39# We need to install xarchiver.tap as fedora-xarchiver.tap, because the name
40# has to match the basename of the desktop-file in %{_datadir}/applications.
41rm $RPM_BUILD_ROOT%{_libexecdir}/thunar-archive-plugin/xarchiver.tap
42install -p -m 755 xarchiver.tap \
43   $RPM_BUILD_ROOT%{_libexecdir}/thunar-archive-plugin/vine-xarchiver.tap
44
45%find_lang %{name}
46desktop-file-install --vendor vine                         \
47        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications         \
48        --add-category="Compression"                            \
49        --delete-original                                       \
50        ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop
51
52# remove duplicate docs
53rm $RPM_BUILD_ROOT%{_docdir}/%{name}/{AUTHORS,COPYING,ChangeLog,NEWS,README,TODO}
54
55
56%post
57touch --no-create %{_datadir}/icons/hicolor
58if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
59  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
60fi
61update-desktop-database &> /dev/null || :
62
63
64%postun
65touch --no-create %{_datadir}/icons/hicolor
66if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
67  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
68fi
69update-desktop-database &> /dev/null || :
70
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75
76%files -f %{name}.lang
77%defattr(-,root,root,-)
78%doc AUTHORS COPYING ChangeLog NEWS README TODO
79%doc %{_docdir}/%{name}/
80%{_bindir}/%{name}
81%{_datadir}/applications/vine-%{name}.desktop
82%{_datadir}/icons/hicolor/*/apps/%{name}.png
83%{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
84%dir %{_datadir}/pixmaps/%{name}/
85%{_datadir}/pixmaps/%{name}/%{name}*.png
86%dir %{_libexecdir}/thunar-archive-plugin/
87%{_libexecdir}/thunar-archive-plugin/vine-xarchiver.tap
88
89
90%changelog
91* Sun Apr 5 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.5.2-2vl5
92- fixed BuildRoot tag
93
94* Mon Mar 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.5.2-1vl5
95- initial release for VineSeed (import Fedora Package)
96
97* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.2-3
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
99
100* Tue Nov 25 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.2-2
101- Include HTML documentation
102
103* Tue Nov 25 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.2-1
104- Update to 0.5.2
105
106* Sun Nov 09 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.1-1
107- Update to 0.5.1 stable release
108
109* Sun Oct 26 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.0-0.1.rc1
110- Update to 0.5.0rc1
111- Fix crash when opening zipped PDF files (#467619)
112- Update gtk-icon-cache scriptlets
113
114* Sat Oct 11 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.0-0.1.beta2
115- Update to 0.5.0beta2
116
117* Sun Aug 31 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.0-0.1.beta1
118- Update to 0.5.0beta1
119- Remove xdg-open.patch as xarchiver now uses xdg-open by default
120
121* Sat Apr 19 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.6.20070103svn24249
122- Remove additional mime-types from desktop-file-install to make sure we don't break livecds
123
124* Fri Mar 14 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.5.20070103svn24249
125- Use xdg-open instead of htmlview (#437554)
126
127* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.9-0.4.20070103svn24249
128- Autorebuild for GCC 4.3
129
130* Tue Aug 28 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.3.20070103svn24249
131- Rebuild for BuildID feature
132- Update license tag
133
134* Fri Mar 02 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.2.20070103svn24249
135- Downgrade to SVN release 24249 in order to fix #230154 temporarily.
136
137* Sun Jan 28 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.1.20070128svn24772
138- Update to SVN release 24772 of January 28th 2007.
139
140* Wed Jan 03 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.1.20070103svn
141- Update to SVN r24249 of January 3rd 2007.
142- Add mimetype application/x-deb again since opening of debs now is secure.
143
144* Wed Dec 13 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.1.20061213svn
145- Update to SVN r24096 of December 13th 2006.
146
147* Wed Dec 06 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.6-3
148- Add deb.patch to prevent opening of .a files as debs.
149- Don't add mimetype for x-ar (archiver can't handle ar archive).
150
151* Wed Nov 29 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.6-2
152- Add htmlview.patch.
153
154* Tue Nov 28 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.6-1
155- Update to 0.4.6.
156- Update %%description.
157- Require binutils, cpio and htmlview.
158- Add mimetypes application/x-ar, application/x-cd-image and application/x-deb.
159
160* Tue Nov 27 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.4-1
161- Update to 0.4.4.
162
163* Sat Nov 25 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.2-0.3.rc2
164- Install xarchiver.png also in %%{_datadir}/icons/hicolor/48x48/apps/.
165
166* Sat Nov 25 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.2-0.2.rc2
167- Drop subpackage and own %%{_libexecdir}/thunar-archive-plugin/ (#198098).
168
169* Sun Nov 12 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.2-0.1.rc2
170- Update to 0.4.2.RC2.
171
172* Wed Sep 13 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.0-1
173- Update to 0.4.0.
174
175* Tue Sep 05 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.9.2-0.beta2
176- Initial package.
Note: See TracBrowser for help on using the repository browser.