source: projects/specs/trunk/w/wxGTK3/wxGTK3-vl.spec @ 9122

Revision 9122, 7.1 KB checked in by kudoh, 9 years ago (diff)

new upstream release

Line 
1%global srcname wxWidgets
2%global wxgtkname wxGTK3
3%global wxbasename wxBase3
4
5%global gtkver 3
6
7Name:           %{wxgtkname}
8Version:        3.0.2
9Release:        1%{?_dist_release}
10Summary:        GTK port of the wxWidgets GUI library
11License:        wxWidgets
12Group:          System Environment/Libraries
13URL:            http://www.wxwidgets.org/
14Source0:        http://downloads.sf.net/wxwindows/%{srcname}-%{version}.tar.bz2
15##Source1:        http://downloads.sf.net/wxwindows/%{srcname}-%{version}-docs-html.tar.bz2
16Source10:       wx-config
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  gtk%{gtkver}-devel
20#Note webkitgtk (GTK2) does not appear to be supported
21
22BuildRequires:  WebKit3-gtk-devel
23BuildRequires:  zlib-devel
24BuildRequires:  libpng-devel
25BuildRequires:  libjpeg-turbo-devel
26BuildRequires:  libtiff-devel
27BuildRequires:  expat-devel
28BuildRequires:  SDL-devel
29BuildRequires:  libgnomeprintui-devel
30BuildRequires:  libGLU-devel
31BuildRequires:  libSM-devel
32BuildRequires:  gstreamer-plugins-base-devel
33BuildRequires:  GConf2-devel
34BuildRequires:  gettext
35BuildRequires:  cppunit-devel
36BuildRequires:  libmspack-devel
37
38Provides:       %{srcname} = %{version}-%{release}
39Requires:       %{wxbasename}%{?_isa} = %{version}-%{release}
40
41%description
42wxWidgets is the GTK port of the C++ cross-platform wxWidgets
43GUI library, offering classes for all common GUI controls as well as a
44comprehensive set of helper classes for most common application tasks,
45ranging from networking to HTML display and image manipulation.
46
47
48%package        devel
49Group:          Development/Libraries
50Summary:        Development files for the wxGTK3 library
51Requires:       %{name}%{?_isa} = %{version}-%{release}
52Requires:       %{wxbasename} = %{version}-%{release}
53Requires:       gtk%{gtkver}-devel
54Requires:       libGLU-devel
55Provides:       %{srcname}-devel = %{version}-%{release}
56
57%description devel
58This package include files needed to link with the wxGTK3 library.
59wxWidgets is the GTK port of the C++ cross-platform wxWidgets
60GUI library, offering classes for all common GUI controls as well as a
61comprehensive set of helper classes for most common application tasks,
62ranging from networking to HTML display and image manipulation.
63
64
65%package -n     %{wxbasename}
66Summary:        Non-GUI support classes from the wxWidgets library
67Group:          System Environment/Libraries
68
69%description -n %{wxbasename}
70Every wxWidgets application must link against this library. It contains
71mandatory classes that any wxWidgets code depends on (like wxString) and
72portability classes that abstract differences between platforms. wxBase can
73be used to develop console mode applications -- it does not require any GUI
74libraries or the X Window System.
75
76
77#%package        docs
78#Group:          Development/Libraries
79#Summary:        Documentation for the wxGTK3 library
80#Requires:       %{name} = %{version}-%{release}
81#Provides:       %{srcname}-docs = %{version}-%{release}
82#BuildArch:      noarch
83
84#%description docs
85#This package provides documentation for the %{srcname} library.
86
87
88%prep
89%setup -q -n %{srcname}-%{version}
90
91# in case of gtk3
92%if %{gtkver} == 3
93sed -i -e 's|gtk2|gtk3|' %{SOURCE10}
94%endif
95
96# patch some installed files to avoid conflicts with 2.8.*
97sed -i -e 's|aclocal)|aclocal/wxwin3.m4)|' Makefile.in
98sed -i -e 's|wxstd.mo|wxstd3.mo|' Makefile.in
99sed -i -e 's|wxmsw.mo|wxmsw3.mo|' Makefile.in
100
101# rename docs directory
102#mv %{srcname}-%{version} html
103
104sed -i -e 's|/usr/lib\b|%{_libdir}|' wx-config.in configure
105
106# fix plugin dir for 64-bit
107sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp
108
109
110%build
111# likely still dereferences type-punned pointers
112CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
113CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
114# fix unused-direct-shlib-dependency error:
115export LDFLAGS="-Wl,--as-needed"
116
117%configure \
118  --with-gtk=%{gtkver} \
119  --with-opengl \
120  --with-sdl \
121  --with-gnomeprint \
122  --with-libmspack \
123  --enable-intl \
124  --enable-no_deps \
125  --disable-rpath \
126  --enable-ipv6 \
127  --enable-utf8 \
128
129make %{?_smp_mflags}
130
131%install
132%makeinstall
133
134# install our multilib-aware wrapper
135rm %{buildroot}%{_bindir}/wx-config
136rm %{buildroot}%{_bindir}/wxrc
137install -p -m 755 %{SOURCE10} %{buildroot}%{_bindir}/wx-config-3.0
138
139# move bakefiles to avoid conflicts with 2.8.*
140mkdir %{buildroot}%{_datadir}/bakefile/presets/wx3
141mv %{buildroot}%{_datadir}/bakefile/presets/*.* %{buildroot}%{_datadir}/bakefile/presets/wx3
142
143%find_lang wxstd3
144%find_lang wxmsw3
145cat wxmsw3.lang >> wxstd3.lang
146
147%check
148pushd tests
149make %{?_smp_mflags} test
150popd
151
152%post -p /sbin/ldconfig
153%postun -p /sbin/ldconfig
154
155%post -n %{wxbasename} -p /sbin/ldconfig
156%postun -n %{wxbasename} -p /sbin/ldconfig
157
158%files -f wxstd3.lang
159%doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
160%doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
161%{_libdir}/libwx_gtk%{gtkver}u_adv-*.so.*
162%{_libdir}/libwx_gtk%{gtkver}u_aui-*.so.*
163%{_libdir}/libwx_gtk%{gtkver}u_core-*.so.*
164%{_libdir}/libwx_gtk%{gtkver}u_html-*.so.*
165%{_libdir}/libwx_gtk%{gtkver}u_gl-*.so.*
166%{_libdir}/libwx_gtk%{gtkver}u_media-*.so.*
167%{_libdir}/libwx_gtk%{gtkver}u_propgrid-*.so.*
168%{_libdir}/libwx_gtk%{gtkver}u_qa-*.so.*
169%{_libdir}/libwx_gtk%{gtkver}u_ribbon-*.so.*
170%{_libdir}/libwx_gtk%{gtkver}u_richtext-*.so.*
171%{_libdir}/libwx_gtk%{gtkver}u_stc-*.so.*
172%if %{gtkver} == 3
173%{_libdir}/libwx_gtk%{gtkver}u_webview-*.so.*
174%endif
175%{_libdir}/libwx_gtk%{gtkver}u_xrc-*.so.*
176
177%files devel
178%{_bindir}/wx-config*
179%{_bindir}/wxrc-3.0
180%{_includedir}/wx-3.0
181%{_libdir}/libwx_*.so
182%{_libdir}/wx
183%{_datadir}/aclocal/wxwin3.m4
184%{_datadir}/bakefile/presets/wx3/
185
186%files -n %{wxbasename}
187%doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
188%doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
189%{_libdir}/libwx_baseu-*.so.*
190%{_libdir}/libwx_baseu_net-*.so.*
191%{_libdir}/libwx_baseu_xml-*.so.*
192
193#%files docs
194#%doc html
195
196%changelog
197* Sat Nov 29 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
198- new upstream release
199
200* Fri Sep 05 2014 Toshiharu Kudoh <kudoh@vinelinux.org> - 3.0.1-1
201- initial build for Vine Linux
202
203* Sat Jul 5 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.1-1
204- Bump to 3.0.1 RH#1076617
205
206* Tue Mar 18 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-6
207- Removed disable-catch_segvs, see RH#1076617
208
209* Mon Mar 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-5
210- Renable combat28 - without it causes bugs RH#1076617 and a few others
211
212* Wed Feb 19 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-4
213- Fixed GTK3 bug with wx-config
214- Fixed a unused-direct-shlib-dependency error
215
216* Mon Feb 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-3
217- Added patch to avoid build fail on gtk 3.10+
218- Reverted patching to make devel package compatible with wxGTK-devel
219- Added combatibility for RHEL 6+
220- Changed all mention of GTK3 and GTK2 to GTK for consistency
221
222* Mon Feb 10 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-2
223- Changed to build against gtk3
224- Add webkit to build requires
225- Removed patching to make devel package compatible with wxGTK-devel
226- Disable 2.8.* combatibility (redundant functionality)
227
228* Sat Jan 4 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-1
229- Initial build of wxwidgets version 3, mostly based on wxGTK spec
Note: See TracBrowser for help on using the repository browser.