source: projects/specs/trunk/w/wxGTK3/wxGTK3-vl.spec @ 10464

Revision 10464, 7.2 KB checked in by tomop, 8 years ago (diff)

wxGTK3-3.0.2-2

Line 
1%global srcname wxWidgets
2%global wxgtkname wxGTK3
3%global wxbasename wxBase3
4
5%global gtkver 3
6
7Name:           %{wxgtkname}
8Version:        3.0.2
9Release:        2%{?_dist_release}
10Summary:        GTK port of the wxWidgets GUI library
11License:        wxWidgets
12Group:          System Environment/Libraries
13URL:            http://www.wxwidgets.org/
14Vendor:         Project Vine
15Distribution:   Vine Linux
16
17Source0:        http://downloads.sf.net/wxwindows/%{srcname}-%{version}.tar.bz2
18##Source1:        http://downloads.sf.net/wxwindows/%{srcname}-%{version}-docs-html.tar.bz2
19Source10:       wx-config
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires:  gtk%{gtkver}-devel
23#Note webkitgtk (GTK2) does not appear to be supported
24
25BuildRequires:  WebKit3-gtk-devel
26BuildRequires:  zlib-devel
27BuildRequires:  libpng-devel
28BuildRequires:  libjpeg-turbo-devel
29BuildRequires:  libtiff-devel
30BuildRequires:  expat-devel
31BuildRequires:  SDL-devel
32BuildRequires:  libgnomeprintui-devel
33BuildRequires:  libGLU-devel
34BuildRequires:  libSM-devel
35BuildRequires:  gstreamer-plugins-base-devel
36BuildRequires:  GConf2-devel
37BuildRequires:  gettext
38BuildRequires:  cppunit-devel
39BuildRequires:  libmspack-devel
40
41Provides:       %{srcname} = %{version}-%{release}
42Requires:       %{wxbasename}%{?_isa} = %{version}-%{release}
43
44%description
45wxWidgets is the GTK port of the C++ cross-platform wxWidgets
46GUI library, offering classes for all common GUI controls as well as a
47comprehensive set of helper classes for most common application tasks,
48ranging from networking to HTML display and image manipulation.
49
50
51%package        devel
52Group:          Development/Libraries
53Summary:        Development files for the wxGTK3 library
54Requires:       %{name}%{?_isa} = %{version}-%{release}
55Requires:       %{wxbasename} = %{version}-%{release}
56Requires:       gtk%{gtkver}-devel
57Requires:       libGLU-devel
58Provides:       %{srcname}-devel = %{version}-%{release}
59
60%description devel
61This package include files needed to link with the wxGTK3 library.
62wxWidgets is the GTK port of the C++ cross-platform wxWidgets
63GUI library, offering classes for all common GUI controls as well as a
64comprehensive set of helper classes for most common application tasks,
65ranging from networking to HTML display and image manipulation.
66
67
68%package -n     %{wxbasename}
69Summary:        Non-GUI support classes from the wxWidgets library
70Group:          System Environment/Libraries
71
72%description -n %{wxbasename}
73Every wxWidgets application must link against this library. It contains
74mandatory classes that any wxWidgets code depends on (like wxString) and
75portability classes that abstract differences between platforms. wxBase can
76be used to develop console mode applications -- it does not require any GUI
77libraries or the X Window System.
78
79
80#%package        docs
81#Group:          Development/Libraries
82#Summary:        Documentation for the wxGTK3 library
83#Requires:       %{name} = %{version}-%{release}
84#Provides:       %{srcname}-docs = %{version}-%{release}
85#BuildArch:      noarch
86
87#%description docs
88#This package provides documentation for the %{srcname} library.
89
90
91%prep
92%setup -q -n %{srcname}-%{version}
93
94# in case of gtk3
95%if %{gtkver} == 3
96sed -i -e 's|gtk2|gtk3|' %{SOURCE10}
97%endif
98
99# patch some installed files to avoid conflicts with 2.8.*
100sed -i -e 's|aclocal)|aclocal/wxwin3.m4)|' Makefile.in
101sed -i -e 's|wxstd.mo|wxstd3.mo|' Makefile.in
102sed -i -e 's|wxmsw.mo|wxmsw3.mo|' Makefile.in
103
104# rename docs directory
105#mv %{srcname}-%{version} html
106
107sed -i -e 's|/usr/lib\b|%{_libdir}|' wx-config.in configure
108
109# fix plugin dir for 64-bit
110sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp
111
112
113%build
114# likely still dereferences type-punned pointers
115CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
116CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
117# fix unused-direct-shlib-dependency error:
118export LDFLAGS="-Wl,--as-needed"
119
120%configure \
121  --with-gtk=%{gtkver} \
122  --with-opengl \
123  --with-sdl \
124  --with-gnomeprint \
125  --with-libmspack \
126  --enable-intl \
127  --enable-no_deps \
128  --disable-rpath \
129  --enable-ipv6 \
130  --enable-utf8 \
131
132make %{?_smp_mflags}
133
134%install
135%makeinstall
136
137# install our multilib-aware wrapper
138rm %{buildroot}%{_bindir}/wx-config
139rm %{buildroot}%{_bindir}/wxrc
140install -p -m 755 %{SOURCE10} %{buildroot}%{_bindir}/wx-config-3.0
141
142# move bakefiles to avoid conflicts with 2.8.*
143mkdir %{buildroot}%{_datadir}/bakefile/presets/wx3
144mv %{buildroot}%{_datadir}/bakefile/presets/*.* %{buildroot}%{_datadir}/bakefile/presets/wx3
145
146%find_lang wxstd3
147%find_lang wxmsw3
148cat wxmsw3.lang >> wxstd3.lang
149
150%check
151pushd tests
152make %{?_smp_mflags} test
153popd
154
155%post -p /sbin/ldconfig
156%postun -p /sbin/ldconfig
157
158%post -n %{wxbasename} -p /sbin/ldconfig
159%postun -n %{wxbasename} -p /sbin/ldconfig
160
161%files -f wxstd3.lang
162%doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
163%doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
164%{_libdir}/libwx_gtk%{gtkver}u_adv-*.so.*
165%{_libdir}/libwx_gtk%{gtkver}u_aui-*.so.*
166%{_libdir}/libwx_gtk%{gtkver}u_core-*.so.*
167%{_libdir}/libwx_gtk%{gtkver}u_html-*.so.*
168%{_libdir}/libwx_gtk%{gtkver}u_gl-*.so.*
169%{_libdir}/libwx_gtk%{gtkver}u_media-*.so.*
170%{_libdir}/libwx_gtk%{gtkver}u_propgrid-*.so.*
171%{_libdir}/libwx_gtk%{gtkver}u_qa-*.so.*
172%{_libdir}/libwx_gtk%{gtkver}u_ribbon-*.so.*
173%{_libdir}/libwx_gtk%{gtkver}u_richtext-*.so.*
174%{_libdir}/libwx_gtk%{gtkver}u_stc-*.so.*
175%if %{gtkver} == 3
176%{_libdir}/libwx_gtk%{gtkver}u_webview-*.so.*
177%endif
178%{_libdir}/libwx_gtk%{gtkver}u_xrc-*.so.*
179
180%files devel
181%{_bindir}/wx-config*
182%{_bindir}/wxrc-3.0
183%{_includedir}/wx-3.0
184%{_libdir}/libwx_*.so
185%{_libdir}/wx
186%{_datadir}/aclocal/wxwin3.m4
187%{_datadir}/bakefile/presets/wx3/
188
189%files -n %{wxbasename}
190%doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
191%doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
192%{_libdir}/libwx_baseu-*.so.*
193%{_libdir}/libwx_baseu_net-*.so.*
194%{_libdir}/libwx_baseu_xml-*.so.*
195
196#%files docs
197#%doc html
198
199%changelog
200* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.2-2
201- rebuilt with new toolchain.
202
203* Sat Nov 29 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
204- new upstream release
205
206* Fri Sep 05 2014 Toshiharu Kudoh <kudoh@vinelinux.org> - 3.0.1-1
207- initial build for Vine Linux
208
209* Sat Jul 5 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.1-1
210- Bump to 3.0.1 RH#1076617
211
212* Tue Mar 18 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-6
213- Removed disable-catch_segvs, see RH#1076617
214
215* Mon Mar 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-5
216- Renable combat28 - without it causes bugs RH#1076617 and a few others
217
218* Wed Feb 19 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-4
219- Fixed GTK3 bug with wx-config
220- Fixed a unused-direct-shlib-dependency error
221
222* Mon Feb 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-3
223- Added patch to avoid build fail on gtk 3.10+
224- Reverted patching to make devel package compatible with wxGTK-devel
225- Added combatibility for RHEL 6+
226- Changed all mention of GTK3 and GTK2 to GTK for consistency
227
228* Mon Feb 10 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-2
229- Changed to build against gtk3
230- Add webkit to build requires
231- Removed patching to make devel package compatible with wxGTK-devel
232- Disable 2.8.* combatibility (redundant functionality)
233
234* Sat Jan 4 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-1
235- Initial build of wxwidgets version 3, mostly based on wxGTK spec
Note: See TracBrowser for help on using the repository browser.