source: projects/specs/trunk/w/wpa_supplicant/wpa_supplicant-vl.spec @ 10104

Revision 10104, 12.0 KB checked in by Takemikaduchi, 8 years ago (diff)

VirtualBox?, caja, mate-system-monitor nmap, wireshark: new upstream release
others: rebuild

Line 
1%define build_gui 1
2
3Summary: WPA/WPA2/IEEE 802.1X Supplicant
4Name: wpa_supplicant
5Version: 2.5
6Release: 2%{?_dist_release}
7License: BSD
8Group: System Environment/Base
9URL: http://w1.fi/wpa_supplicant/
10
11Source0: http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
12Source1: %{name}.build-config
13Source2: %{name}.conf
14Source3: %{name}.init.d
15Source4: %{name}.sysconfig
16Source6: %{name}.logrotate
17
18# distro specific customization and not suitable for upstream,
19# works around busted drivers
20Patch0: wpa_supplicant-assoc-timeout.patch
21# ensures that debug output gets flushed immediately to help diagnose driver
22# bugs, not suitable for upstream
23Patch1: wpa_supplicant-flush-debug-output.patch
24# disto specific customization for log paths, not suitable for upstream
25Patch2: wpa_supplicant-dbus-service-file-args.patch
26# quiet an annoying and frequent syslog message
27Patch3: wpa_supplicant-quiet-scan-results-message.patch
28# allow more private key encryption algorithms
29Patch5: wpa_supplicant-openssl-more-algs.patch
30# Less aggressive roaming; signal strength is wildly variable
31Patch8: rh837402-less-aggressive-roaming.patch
32# CVE-2015-1863, backport from upstream master, will be in 2.5
33# http://w1.fi/cgit/hostap/commit/?id=9ed4eee345f85e3025c33c6e20aa25696e341ccd
34Patch9: 0001-P2P-Validate-SSID-element-length-before-copying-it-C.patch
35# Fix a crash - rh #1231973
36# http://w1.fi/cgit/hostap/commit/wpa_supplicant/dbus/dbus_new_handlers.c?id=8a78e227df1ead19be8e12a4108e448887e64d6f
37Patch10: rh1231973-dbus-fix-operations-for-p2p-mgmt.patch
38# Fix a security issue - rh #rh1241907
39# http://w1.fi/security/2015-5/0001-NFC-Fix-payload-length-validation-in-NDEF-record-par.patch
40Patch11: rh1241907-NFC-Fix-payload-length-validation-in-NDEF-record-par.patch
41
42## Vine patches
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-root
45%if %{build_gui}
46BuildRequires: qt4-devel
47%endif
48BuildRequires: openssl-devel
49BuildRequires: readline-devel
50BuildRequires: dbus-devel
51BuildRequires: libnl3-devel
52BuildRequires: docbook-utils
53
54Requires(post): /sbin/chkconfig
55Requires(preun): /sbin/chkconfig /sbin/service
56Requires(postun): /sbin/service
57
58%description
59wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
60for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
61component that is used in the client stations. It implements key negotiation
62with a WPA Authenticator and it controls the roaming and IEEE 802.11
63authentication/association of the wlan driver.
64
65%if %{build_gui}
66%package gui
67Summary: Graphical User Interface for %{name}
68Summary(ja): %{name} のグラフィカルユーザインタフェース
69Group: Applications/System
70
71%description gui
72Graphical User Interface for wpa_supplicant written using QT4
73
74%description -l ja gui
75QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
76%endif
77
78%prep
79%setup -q
80%patch0 -p1 -b .assoc-timeout
81%patch1 -p1 -b .flush-debug-output
82%patch2 -p1 -b .dbus-service-file
83%patch3 -p1 -b .quiet-scan-results-msg
84%patch5 -p1 -b .more-openssl-algs
85%patch8 -p1 -b .rh837402-less-aggressive-roaming
86
87%build
88pushd wpa_supplicant
89  cp %{SOURCE1} .config
90
91  CFLAGS="${CFLAGS:-%optflags} -fPIE -DPIE" ; export CFLAGS ;
92  CXXFLAGS="${CXXFLAGS:-%optflags} -fPIE -DPIE" ; export CXXFLAGS ;
93  LDFLAGS="${LDFLAGS:-%optflags} -pie -Wl,-z,now" ; export LDFLAGS ;
94  # yes, BINDIR=_sbindir
95  BINDIR="%{_sbindir}" ; export BINDIR ;
96  LIBDIR="%{_libdir}" ; export LIBDIR ;
97  make %{?_smp_mflags}
98%if %{build_gui}
99  QTDIR=%{_libdir}/qt4 make wpa_gui-qt4 %{?_smp_mflags}
100%endif
101  make eapol_test
102popd
103
104%install
105rm -rf %{buildroot}
106
107# init scripts
108install -D -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
109install -D -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
110install -D -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
111
112# config
113install -D -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
114
115# binary
116install -d %{buildroot}/%{_sbindir}
117install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
118install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
119install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
120install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
121install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
122install -D -m 0644 %{name}/dbus/fi.epitest.hostap.WPASupplicant.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
123
124%if %{build_gui}
125# gui
126install -d %{buildroot}/%{_bindir}
127install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
128%endif
129
130# running
131mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
132
133# man pages
134install -d %{buildroot}%{_mandir}/man{5,8}
135install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
136install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
137
138# some cleanup in docs
139rm -f  %{name}/doc/.cvsignore
140rm -rf %{name}/doc/docbook
141chmod -R 0644 %{name}/examples/*.py
142
143%clean
144rm -rf %{buildroot}
145
146%post
147if [ $1 = 1 ]; then
148    /sbin/chkconfig --add %{name}
149fi
150
151%preun
152if [ $1 = 0 ]; then
153    /sbin/service %{name} stop > /dev/null 2>&1
154    killall -TERM wpa_supplicant >/dev/null 2>&1
155    /sbin/chkconfig --del %{name}
156fi
157
158%postun
159if [ $1 -ge 1 ]; then
160    /sbin/service %{name} condrestart > /dev/null 2>&1
161fi
162
163%files
164%defattr(-, root, root)
165%doc COPYING %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
166%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
167%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
168%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
169%{_sysconfdir}/rc.d/init.d/%{name}
170%{_sysconfdir}/dbus-1/system.d/%{name}.conf
171%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
172%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
173%{_sbindir}/wpa_passphrase
174%{_sbindir}/wpa_supplicant
175%{_sbindir}/wpa_cli
176%dir %{_localstatedir}/run/%{name}
177%dir %{_sysconfdir}/%{name}
178%{_mandir}/man8/*
179%{_mandir}/man5/*
180
181%if %{build_gui}
182%files gui
183%defattr(-, root, root)
184%{_bindir}/wpa_gui
185%endif
186
187%changelog
188* Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-2
189- rebuild with openssl-1.0.2g
190
191* Thu Oct 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-1
192- update to 2.5
193- update SOURCE1
194- remove Patch7 (libnl3-includes.patch)
195- add Patch 9,10,11 from Fedora
196- remove Patch 6, 700
197
198* Thu Feb  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.3-1
199- updated to 2.3
200- built with libnl3 instead of libnl
201- added Patch 6, 7 and 8 from Fedora
202- added Patch700
203
204  * Mon Aug 22 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.3-3
205- import Patch8 from Fedora 1:0.7.3-9 to fix some crashes
206  - Wed Jul 27 2011 Dan Williams <dcbw@redhat.com> - 1:0.7.3-9
207  - Fix various crashes with D-Bus interface (rh #678625) (rh #725517)
208
209* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
210- rebuild with openssl-1.0.0c
211- add BuildRequires: qt4-designer, libnl-devel
212
213* Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
214- new upstream release
215- update patches
216- change License to BSD due to linkage against OpsnSSL since there is no
217  OpenSSL exception in upstream GPLv2 license text.
218- build with qt4
219- update build config
220
221* Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
222- new upstream release
223- remove hostap/madwifi/prism54 drivers, use 'wext' instead.
224- drop upstream patches
225- import some fedora patches
226  - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
227  - Better scanning behavior on resume from suspend/hibernate
228  - Better interaction with newer kernels and drivers
229
230* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
231- start wpa_supplicant by default.
232
233* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
234- new upstream release
235- import some fedora patches
236
237* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
238- rebuild with new openssl
239
240* Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
241- new upstream release
242
243* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
244- initial build for Vine Linux based on FC package.
245
246* Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
247- Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
248- Fix up madwifi-ng private ioctl()s for r1331 and later
249- Update madwifi headers to r1475
250
251* Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
252- Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
253
254* Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
255- Fix control interface key obfuscation a bit
256
257* Sun Apr  2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
258- Work around older & incorrect drivers that return null-terminated SSIDs
259
260* Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
261- Add patch to make orinoco happy with WEP keys
262- Enable Prism54-specific driver
263- Disable ipw-specific driver; ipw2x00 should be using WEXT instead
264
265* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
266- Increase association timeout, mainly for drivers that don't
267        fully support WPA ioctls yet
268
269* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
270- Add additional BuildRequires #rh181914#
271- Add prereq on chkconfig #rh182905# #rh182906#
272- Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
273
274* Wed Mar  1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
275- Install wpa_passphrase too #rh183480#
276
277* Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
278- Don't expose private data on the control interface unless requested
279
280* Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
281- Downgrade to 0.4.8 stable release rather than a dev release
282
283* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
284- Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
285
286* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
287- Move initscript to /etc/rc.d/init.d
288
289* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
290- bump again for double-long bug on ppc(64)
291
292* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
293- rebuilt for new gcc4.1 snapshot and glibc changes
294
295* Sun Feb  5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
296- Update to 0.5.1
297- Add WE auth fallback to actually work with older drivers
298
299* Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
300- Bring package into Fedora Core
301- Add ap_scan control interface patch
302- Enable madwifi-ng driver
303
304* Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
305- upgrade to 0.4.7
306- added package w/ wpa_gui in it
307
308* Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
309- upgrade to 0.4.6
310- adding ctrl interface changes recommended
311  by Hugo Paredes <hugo.paredes@e-know.org>
312
313* Sun Oct  9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
314- upgrade to 0.4.5
315- updated config file wpa_supplicant is built with
316  especially, the ipw2100 driver changed to just ipw
317  and enabled a bunch more EAP
318- disabled dist tag
319
320* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
321- fix typo in init script
322
323* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
324- fixing init script using fedora-extras' template
325- removing chkconfig default startup
326
327* Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
328- upgrade to 0.4.2
329- new sample conf file that will use any unrestricted AP
330- make sysconfig config entry
331- new BuildRoot for Fedora Extras
332- adding dist tag to Release
333
334* Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
335- upgrade to 0.3.8
336
337* Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
338- compile ipw driver in
339
340* Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
341- upgrade to 0.3.6
342
343* Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
344- fixing init script
345
346* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
347- fixing init script
348- adding post/preun items to add/remove via chkconfig
349
350* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
351- adding sysV scripts
352
353* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
354- Initial RPM release.
355
Note: See TracBrowser for help on using the repository browser.