source: projects/specs/trunk/w/wpa_supplicant/wpa_supplicant-vl.spec @ 10458

Revision 10458, 12.1 KB checked in by tomop, 8 years ago (diff)

wpa_supplicant-2.5-3

Line 
1%define build_gui 1
2
3Summary: WPA/WPA2/IEEE 802.1X Supplicant
4Name: wpa_supplicant
5Version: 2.5
6Release: 3%{?_dist_release}
7License: BSD
8Group: System Environment/Base
9URL: http://w1.fi/wpa_supplicant/
10Vendor: Project Vine
11Distribution: Vine Linux
12
13Source0: http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
14Source1: %{name}.build-config
15Source2: %{name}.conf
16Source3: %{name}.init.d
17Source4: %{name}.sysconfig
18Source6: %{name}.logrotate
19
20# distro specific customization and not suitable for upstream,
21# works around busted drivers
22Patch0: wpa_supplicant-assoc-timeout.patch
23# ensures that debug output gets flushed immediately to help diagnose driver
24# bugs, not suitable for upstream
25Patch1: wpa_supplicant-flush-debug-output.patch
26# disto specific customization for log paths, not suitable for upstream
27Patch2: wpa_supplicant-dbus-service-file-args.patch
28# quiet an annoying and frequent syslog message
29Patch3: wpa_supplicant-quiet-scan-results-message.patch
30# allow more private key encryption algorithms
31Patch5: wpa_supplicant-openssl-more-algs.patch
32# Less aggressive roaming; signal strength is wildly variable
33Patch8: rh837402-less-aggressive-roaming.patch
34# CVE-2015-1863, backport from upstream master, will be in 2.5
35# http://w1.fi/cgit/hostap/commit/?id=9ed4eee345f85e3025c33c6e20aa25696e341ccd
36Patch9: 0001-P2P-Validate-SSID-element-length-before-copying-it-C.patch
37# Fix a crash - rh #1231973
38# http://w1.fi/cgit/hostap/commit/wpa_supplicant/dbus/dbus_new_handlers.c?id=8a78e227df1ead19be8e12a4108e448887e64d6f
39Patch10: rh1231973-dbus-fix-operations-for-p2p-mgmt.patch
40# Fix a security issue - rh #rh1241907
41# http://w1.fi/security/2015-5/0001-NFC-Fix-payload-length-validation-in-NDEF-record-par.patch
42Patch11: rh1241907-NFC-Fix-payload-length-validation-in-NDEF-record-par.patch
43
44## Vine patches
45
46BuildRoot: %{_tmppath}/%{name}-%{version}-root
47%if %{build_gui}
48BuildRequires: qt4-devel
49%endif
50BuildRequires: openssl-devel
51BuildRequires: readline-devel
52BuildRequires: dbus-devel
53BuildRequires: libnl3-devel
54BuildRequires: docbook-utils
55
56Requires(post): /sbin/chkconfig
57Requires(preun): /sbin/chkconfig /sbin/service
58Requires(postun): /sbin/service
59
60%description
61wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
62for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
63component that is used in the client stations. It implements key negotiation
64with a WPA Authenticator and it controls the roaming and IEEE 802.11
65authentication/association of the wlan driver.
66
67%if %{build_gui}
68%package gui
69Summary: Graphical User Interface for %{name}
70Summary(ja): %{name} のグラフィカルユーザインタフェース
71Group: Applications/System
72
73%description gui
74Graphical User Interface for wpa_supplicant written using QT4
75
76%description -l ja gui
77QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
78%endif
79
80%prep
81%setup -q
82%patch0 -p1 -b .assoc-timeout
83%patch1 -p1 -b .flush-debug-output
84%patch2 -p1 -b .dbus-service-file
85%patch3 -p1 -b .quiet-scan-results-msg
86%patch5 -p1 -b .more-openssl-algs
87%patch8 -p1 -b .rh837402-less-aggressive-roaming
88
89%build
90pushd wpa_supplicant
91  cp %{SOURCE1} .config
92
93  CFLAGS="${CFLAGS:-%optflags} -fPIE -DPIE" ; export CFLAGS ;
94  CXXFLAGS="${CXXFLAGS:-%optflags} -fPIE -DPIE" ; export CXXFLAGS ;
95  LDFLAGS="${LDFLAGS:-%optflags} -pie -Wl,-z,now" ; export LDFLAGS ;
96  # yes, BINDIR=_sbindir
97  BINDIR="%{_sbindir}" ; export BINDIR ;
98  LIBDIR="%{_libdir}" ; export LIBDIR ;
99  make %{?_smp_mflags}
100%if %{build_gui}
101  QTDIR=%{_libdir}/qt4 make wpa_gui-qt4 %{?_smp_mflags}
102%endif
103  make eapol_test
104popd
105
106%install
107rm -rf %{buildroot}
108
109# init scripts
110install -D -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
111install -D -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
112install -D -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
113
114# config
115install -D -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
116
117# binary
118install -d %{buildroot}/%{_sbindir}
119install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
120install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
121install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
122install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
123install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
124install -D -m 0644 %{name}/dbus/fi.epitest.hostap.WPASupplicant.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
125
126%if %{build_gui}
127# gui
128install -d %{buildroot}/%{_bindir}
129install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
130%endif
131
132# running
133mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
134
135# man pages
136install -d %{buildroot}%{_mandir}/man{5,8}
137install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
138install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
139
140# some cleanup in docs
141rm -f  %{name}/doc/.cvsignore
142rm -rf %{name}/doc/docbook
143chmod -R 0644 %{name}/examples/*.py
144
145%clean
146rm -rf %{buildroot}
147
148%post
149if [ $1 = 1 ]; then
150    /sbin/chkconfig --add %{name}
151fi
152
153%preun
154if [ $1 = 0 ]; then
155    /sbin/service %{name} stop > /dev/null 2>&1
156    killall -TERM wpa_supplicant >/dev/null 2>&1
157    /sbin/chkconfig --del %{name}
158fi
159
160%postun
161if [ $1 -ge 1 ]; then
162    /sbin/service %{name} condrestart > /dev/null 2>&1
163fi
164
165%files
166%defattr(-, root, root)
167%doc COPYING %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
168%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
169%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
170%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
171%{_sysconfdir}/rc.d/init.d/%{name}
172%{_sysconfdir}/dbus-1/system.d/%{name}.conf
173%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
174%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
175%{_sbindir}/wpa_passphrase
176%{_sbindir}/wpa_supplicant
177%{_sbindir}/wpa_cli
178%dir %{_localstatedir}/run/%{name}
179%dir %{_sysconfdir}/%{name}
180%{_mandir}/man8/*
181%{_mandir}/man5/*
182
183%if %{build_gui}
184%files gui
185%defattr(-, root, root)
186%{_bindir}/wpa_gui
187%endif
188
189%changelog
190* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.5-3
191- rebuilt with new toolchain.
192
193* Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-2
194- rebuild with openssl-1.0.2g
195
196* Thu Oct 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-1
197- update to 2.5
198- update SOURCE1
199- remove Patch7 (libnl3-includes.patch)
200- add Patch 9,10,11 from Fedora
201- remove Patch 6, 700
202
203* Thu Feb  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.3-1
204- updated to 2.3
205- built with libnl3 instead of libnl
206- added Patch 6, 7 and 8 from Fedora
207- added Patch700
208
209  * Mon Aug 22 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.3-3
210- import Patch8 from Fedora 1:0.7.3-9 to fix some crashes
211  - Wed Jul 27 2011 Dan Williams <dcbw@redhat.com> - 1:0.7.3-9
212  - Fix various crashes with D-Bus interface (rh #678625) (rh #725517)
213
214* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
215- rebuild with openssl-1.0.0c
216- add BuildRequires: qt4-designer, libnl-devel
217
218* Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
219- new upstream release
220- update patches
221- change License to BSD due to linkage against OpsnSSL since there is no
222  OpenSSL exception in upstream GPLv2 license text.
223- build with qt4
224- update build config
225
226* Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
227- new upstream release
228- remove hostap/madwifi/prism54 drivers, use 'wext' instead.
229- drop upstream patches
230- import some fedora patches
231  - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
232  - Better scanning behavior on resume from suspend/hibernate
233  - Better interaction with newer kernels and drivers
234
235* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
236- start wpa_supplicant by default.
237
238* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
239- new upstream release
240- import some fedora patches
241
242* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
243- rebuild with new openssl
244
245* Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
246- new upstream release
247
248* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
249- initial build for Vine Linux based on FC package.
250
251* Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
252- Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
253- Fix up madwifi-ng private ioctl()s for r1331 and later
254- Update madwifi headers to r1475
255
256* Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
257- Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
258
259* Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
260- Fix control interface key obfuscation a bit
261
262* Sun Apr  2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
263- Work around older & incorrect drivers that return null-terminated SSIDs
264
265* Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
266- Add patch to make orinoco happy with WEP keys
267- Enable Prism54-specific driver
268- Disable ipw-specific driver; ipw2x00 should be using WEXT instead
269
270* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
271- Increase association timeout, mainly for drivers that don't
272        fully support WPA ioctls yet
273
274* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
275- Add additional BuildRequires #rh181914#
276- Add prereq on chkconfig #rh182905# #rh182906#
277- Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
278
279* Wed Mar  1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
280- Install wpa_passphrase too #rh183480#
281
282* Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
283- Don't expose private data on the control interface unless requested
284
285* Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
286- Downgrade to 0.4.8 stable release rather than a dev release
287
288* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
289- Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
290
291* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
292- Move initscript to /etc/rc.d/init.d
293
294* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
295- bump again for double-long bug on ppc(64)
296
297* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
298- rebuilt for new gcc4.1 snapshot and glibc changes
299
300* Sun Feb  5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
301- Update to 0.5.1
302- Add WE auth fallback to actually work with older drivers
303
304* Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
305- Bring package into Fedora Core
306- Add ap_scan control interface patch
307- Enable madwifi-ng driver
308
309* Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
310- upgrade to 0.4.7
311- added package w/ wpa_gui in it
312
313* Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
314- upgrade to 0.4.6
315- adding ctrl interface changes recommended
316  by Hugo Paredes <hugo.paredes@e-know.org>
317
318* Sun Oct  9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
319- upgrade to 0.4.5
320- updated config file wpa_supplicant is built with
321  especially, the ipw2100 driver changed to just ipw
322  and enabled a bunch more EAP
323- disabled dist tag
324
325* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
326- fix typo in init script
327
328* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
329- fixing init script using fedora-extras' template
330- removing chkconfig default startup
331
332* Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
333- upgrade to 0.4.2
334- new sample conf file that will use any unrestricted AP
335- make sysconfig config entry
336- new BuildRoot for Fedora Extras
337- adding dist tag to Release
338
339* Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
340- upgrade to 0.3.8
341
342* Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
343- compile ipw driver in
344
345* Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
346- upgrade to 0.3.6
347
348* Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
349- fixing init script
350
351* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
352- fixing init script
353- adding post/preun items to add/remove via chkconfig
354
355* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
356- adding sysV scripts
357
358* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
359- Initial RPM release.
360
Note: See TracBrowser for help on using the repository browser.