source: projects/specs/trunk/w/wordpress/wordpress-vl.spec @ 869

Revision 869, 8.0 KB checked in by daisuke, 14 years ago (diff)

new package: wordpress

Line 
1Summary: WordPress blogging software
2Summary(ja): WordPress ブログソフトウエア
3URL: http://www.wordpress.org
4Name: wordpress
5Version: 2.9.2
6Group: Applications/Publishing
7Release: 1%{?_dist_release}
8License: GPLv2
9#Source0: http://wordpress.org/%{name}-%{version}.tar.gz
10Source0: http://ja.wordpress.org/wordpress-%{version}-ja.tar.gz
11Source1: wordpress-httpd-conf
12Source2: README.wordpress
13Source3: README.ja.wordpress
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15Requires: php5
16BuildArch: noarch
17
18%description
19Wordpress is an online publishing / weblog package that makes it very easy,
20almost trivial, to get information out to people on the web.
21
22%prep
23%setup -q -n wordpress
24# disable wp_version_check, updates are always installed via rpm
25sed -i -e "s,\(.*\)'wp_version_check'\(.*\),#\1'wp_version_check'\2,g" \
26        wp-includes/update.php
27# disable update_nag() function
28sed -i -e "s,\(.*\)'update_nag'\(.*\),#\1'update_nag'\2,g; \
29        s,\(.*\)\$msg .=\(.*\),\1\$msg .= '';,g;" \
30        wp-admin/includes/update.php
31# fix file encoding
32sed -i -e 's/\r//' license.txt
33
34%install
35mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/wordpress
36mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wordpress
37install -m 0644 -D -p %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/httpd/conf.d/wordpress.conf
38cp -pr * ${RPM_BUILD_ROOT}%{_datadir}/wordpress
39cat wp-config-sample.php | sed -e "s|dirname(__FILE__).'/'|'/usr/share/wordpress/'|g" > \
40        ${RPM_BUILD_ROOT}%{_sysconfdir}/wordpress/wp-config.php
41/bin/ln -sf ../../../etc/wordpress/wp-config.php ${RPM_BUILD_ROOT}%{_datadir}/wordpress/wp-config.php
42/bin/cp %{SOURCE2} ./README.vine
43/bin/cp %{SOURCE3} ./README.ja.vine
44# Remove empty files to make rpmlint happy
45find ${RPM_BUILD_ROOT} -type f -empty -exec rm -f {} \;
46# These are docs, remove them from here, docify them later
47rm -f ${RPM_BUILD_ROOT}%{_datadir}/wordpress/{license.txt,readme.html}
48
49%clean
50rm -rf ${RPM_BUILD_ROOT}
51
52%post
53if [ "$1" -eq 1 ]; then
54  if [ "$LANG"="ja_JP.UTF-8" ]; then
55    echo "Wordpress: MySQL に Wordpress データベースを作成する必要があります。"
56    echo "Wordpress: %{_docdir}/%{name}-%{version}/README.ja を参照して初期設定を行って下さい。"
57  else
58    echo "Wordpress: You may need to setup your MySQL database for Wordpress."
59    echo "Wordpress: Please read "%{_docdir}/%{name}-%{version}/README.ja" to initial setup."
60  fi
61fi
62
63%files
64%defattr(-,root,root,-)
65%config(noreplace) %{_sysconfdir}/httpd/conf.d/wordpress.conf
66%dir %{_datadir}/wordpress
67%{_datadir}/wordpress/wp-admin
68%{_datadir}/wordpress/wp-content
69%{_datadir}/wordpress/wp-includes
70%{_datadir}/wordpress/index.php
71%doc license.txt
72%doc readme.html
73%doc README.fedora
74%{_datadir}/wordpress/wp-atom.php
75%{_datadir}/wordpress/wp-app.php
76%{_datadir}/wordpress/wp-blog-header.php
77%{_datadir}/wordpress/wp-comments-post.php
78%{_datadir}/wordpress/wp-commentsrss2.php
79%{_datadir}/wordpress/wp-config-sample.php
80%{_datadir}/wordpress/wp-config.php
81%config(noreplace) %{_sysconfdir}/wordpress/wp-config.php
82%{_datadir}/wordpress/wp-cron.php
83%{_datadir}/wordpress/wp-feed.php
84%{_datadir}/wordpress/wp-links-opml.php
85%{_datadir}/wordpress/wp-load.php
86%{_datadir}/wordpress/wp-login.php
87%{_datadir}/wordpress/wp-mail.php
88%{_datadir}/wordpress/wp-pass.php
89%{_datadir}/wordpress/wp-rdf.php
90%{_datadir}/wordpress/wp-register.php
91%{_datadir}/wordpress/wp-rss.php
92%{_datadir}/wordpress/wp-rss2.php
93%{_datadir}/wordpress/wp-settings.php
94%{_datadir}/wordpress/wp-trackback.php
95%{_datadir}/wordpress/xmlrpc.php
96%dir %{_sysconfdir}/wordpress
97
98%changelog
99* Tue Apr 20 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.2-1
100- initial build for Vine Linux based on fedora package
101- update to 2.9.2 japanese version
102
103* Mon Nov 16 2009 Adrian Reber <adrian@lisas.de> - 2.8.6-2
104- updated to 2.8.6 (Security Release)
105
106* Wed Oct 21 2009 Adrian Reber <adrian@lisas.de> - 2.8.5-1
107- updated to 2.8.5 (Hardening Release)
108
109* Sun Aug 30 2009 Adrian Reber <adrian@lisas.de> - 2.8.4-1
110- updated to 2.8.4 (security fixes were already available with 2.8.3-2)
111
112* Tue Aug 11 2009 Adrian Reber <adrian@lisas.de> - 2.8.3-2
113- another security update to fix "Remote admin reset password":
114  http://lists.grok.org.uk/pipermail/full-disclosure/2009-August/070137.html
115
116* Mon Aug 03 2009 Adrian Reber <adrian@lisas.de> - 2.8.3-1
117- updated to 2.8.3 for security fixes
118
119* Tue Jul 28 2009 Adrian Reber <adrian@lisas.de> - 2.8.2-1
120- updated to 2.8.2 for security fixes - BZ 512900
121- fixed "wrong-script-end-of-line-encoding" of license.txt
122- correctly disable auto update check
123- fixed an error message from 'find' during the build
124
125* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.1-2
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
127
128* Fri Jul 10 2009 Adrian Reber <adrian@lisas.de> - 2.8.1-1
129- updated to 2.8.1 for security fixes - BZ 510745
130
131* Mon Jun 22 2009 Adrian Reber <adrian@lisas.de> - 2.8-1
132- updated to 2.8
133
134* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.1-2
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
136
137* Wed Feb 11 2009 Adrian Reber <adrian@lisas.de> - 2.7.1-1
138- updated to 2.7.1
139
140* Wed Nov 26 2008 Adrian Reber <adrian@lisas.de> - 2.6.5-2
141- updated to 2.6.5
142
143* Fri Oct 24 2008 Adrian Reber <adrian@lisas.de> - 2.6.3-1
144- updated to 2.6.3
145
146* Tue Sep 09 2008 Adrian Reber <adrian@lisas.de> - 2.6.2-1
147- updated to 2.6.2
148
149* Sun Aug 24 2008 Adrian Reber <adrian@lisas.de> - 2.6.1-1
150- updated to 2.6.1
151
152* Mon Jul 21 2008 Adrian Reber <adrian@lisas.de> - 2.6-1
153- updated to 2.6
154
155* Sat Apr 26 2008 Adrian Reber <adrian@lisas.de> - 2.5.1-1
156- updated to 2.5.1 for security fixes - BZ 444396
157
158* Fri Feb  8 2008 John Berninger <john at ncphotography dot com> - 2.3.3-0
159- update to 2.3.3 for security fixes - BZ 431547
160
161* Sun Dec 30 2007 Adrian Reber <adrian@lisas.de> - 2.3.2-1
162- updated to 2.3.2 (bz 426431, Draft Information Disclosure)
163
164* Tue Oct 30 2007 Adrian Reber <adrian@lisas.de> - 2.3.1-1
165- updated to 2.3.1 (bz 357731, wordpress XSS issue)
166
167* Mon Oct 15 2007 Adrian Reber <adrian@lisas.de> - 2.3-1
168- updated to 2.3
169- disabled wordpress-core-update
170
171* Tue Sep 11 2007 Adrian Reber <adrian@lisas.de> - 2.2.3-0
172- updated to 2.2.3 (security release)
173
174* Wed Aug 29 2007 John Berninger <john at ncphotography dot com> - 2.2.2-0
175- update to upstream 2.2.2
176- license tag update
177
178* Mon Apr 16 2007 john Berninger <jwb at redhat dot com> - 2.1.3-1
179- update to 2.1.3 final - bz235912
180
181* Mon Mar 26 2007 John Berninger <jwb at redhat dot com> - 2.1.3-rc2
182- update to 2.1.3rc2 for bz 233703
183
184* Sat Mar  3 2007 John Berninger <jwb at redhat dot com> - 2.1.2-0
185- update to 2.1.2 - backdoor exploit introduced upstream in 2.1.1 - bz 230825
186
187* Tue Feb 27 2007 John Berninger <jwb at redhat dot com> - 2.1.1-0
188- update to 2.1.1 to fix vuln in bz 229991
189
190* Wed Jan 31 2007 John Berninger <jwb at redhat dot com> - 2.1-0
191- update to v2.1 to fix multiple bz/vuln's
192
193* Sun Dec  3 2006 John Berninger <jwb at redhat dot com> - 2.0.5-2
194- Remove mysql-server dependency
195
196* Sun Dec  3 2006 John Berninger <jwb at redhat dot com> - 2.0.5-1
197- Update to upstream 2.0.5 to fix vuln in bz 213985
198
199* Thu Oct 26 2006 John Berninger <jwb at redhat dot com> - 2.0.4-1
200- Doc fix for BZ 207822
201
202* Sat Aug 12 2006 John Berninger <jwb at redhat dot com> - 2.0.4-0
203- Upstream security vulns - bz 201989
204
205* Sun Jul 23 2006 John Berninger <jwb at redhat dot com> - 2.0.3-4
206- Fix broken upgrade path from FE4
207
208* Tue Jul  4 2006 John Berninger <jwb at redhat dot com> - 2.0.3-3
209- Add a README.fedora file
210- Add php-mysql requires
211
212* Tue Jun 20 2006 John Berninger <jwb at redhat dot com> - 2.0.3-2
213- Remove use of installprefix macro
214- %%{_datadir}/wordpress/wp-config.php is not a config file
215- Symlink is relative
216
217* Mon Jun 19 2006 John Berninger <jwb at redhat dot com> - 2.0.3-1
218- Changes from Jarod Wilson as below
219- Update to 2.0.3
220- Rearrange to use /usr/share/wordpress and /etc/wordpress
221- Remove patch (included upstream)
222- Remove empty files to make rpmlint happy
223
224* Tue May 30 2006 John Berninger <jwb at redhat dot com> - 2.0.2-1
225- Added patch for \n cache injection - upstream changeset #3797
226
227* Sat May 27 2006 John Berninger <jwb at redhat dot com> - 2.0.2-0
228- Initial build
Note: See TracBrowser for help on using the repository browser.