source: projects/specs/trunk/w/wordpress/wordpress-vl.spec @ 870

Revision 870, 8.1 KB checked in by daisuke, 14 years ago (diff)

wordpress: fixed typo

Line 
1Summary: WordPress blogging software
2Summary(ja): WordPress ブログソフトウエア
3URL: http://www.wordpress.org
4Name: wordpress
5Version: 2.9.2
6Group: Applications/Publishing
7Release: 1%{?_dist_release}
8License: GPLv2
9#Source0: http://wordpress.org/%{name}-%{version}.tar.gz
10Source0: http://ja.wordpress.org/wordpress-%{version}-ja.tar.gz
11Source1: wordpress-httpd-conf
12Source2: README.wordpress
13Source3: README.ja.wordpress
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15Requires: php5
16BuildArch: noarch
17
18%description
19Wordpress is an online publishing / weblog package that makes it very easy,
20almost trivial, to get information out to people on the web.
21
22%prep
23%setup -q -n wordpress
24# disable wp_version_check, updates are always installed via rpm
25sed -i -e "s,\(.*\)'wp_version_check'\(.*\),#\1'wp_version_check'\2,g" \
26        wp-includes/update.php
27# disable update_nag() function
28sed -i -e "s,\(.*\)'update_nag'\(.*\),#\1'update_nag'\2,g; \
29        s,\(.*\)\$msg .=\(.*\),\1\$msg .= '';,g;" \
30        wp-admin/includes/update.php
31# fix file encoding
32sed -i -e 's/\r//' license.txt
33
34%install
35mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/wordpress
36mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wordpress
37install -m 0644 -D -p %{SOURCE1} ${RPM_BUILD_ROOT}%{_sysconfdir}/httpd/conf.d/wordpress.conf
38cp -pr * ${RPM_BUILD_ROOT}%{_datadir}/wordpress
39cat wp-config-sample.php | sed -e "s|dirname(__FILE__).'/'|'/usr/share/wordpress/'|g" > \
40        ${RPM_BUILD_ROOT}%{_sysconfdir}/wordpress/wp-config.php
41/bin/ln -sf ../../../etc/wordpress/wp-config.php ${RPM_BUILD_ROOT}%{_datadir}/wordpress/wp-config.php
42/bin/cp %{SOURCE2} ./README.vine
43/bin/cp %{SOURCE3} ./README.ja.vine
44# Remove empty files to make rpmlint happy
45find ${RPM_BUILD_ROOT} -type f -empty -exec rm -f {} \;
46# These are docs, remove them from here, docify them later
47rm -f ${RPM_BUILD_ROOT}%{_datadir}/wordpress/{license.txt,readme.html}
48
49%clean
50rm -rf ${RPM_BUILD_ROOT}
51
52%post
53if [ "$1" -eq 1 ]; then
54  if [ "$LANG"="ja_JP.UTF-8" ]; then
55    echo "Wordpress: MySQL に Wordpress データベースを作成する必要があります。"
56    echo "Wordpress: %{_docdir}/%{name}-%{version}/README.ja.vine を参照して"
57    echo "Wordpress: 初期設定を行って下さい。"
58  else
59    echo "Wordpress: You may need to setup your MySQL database for Wordpress."
60    echo "Wordpress: Please read \"%{_docdir}/%{name}-%{version}/README.vine\""
61    echo "Wordpress: to initial setup."
62  fi
63fi
64
65%files
66%defattr(-,root,root,-)
67%config(noreplace) %{_sysconfdir}/httpd/conf.d/wordpress.conf
68%dir %{_datadir}/wordpress
69%{_datadir}/wordpress/wp-admin
70%{_datadir}/wordpress/wp-content
71%{_datadir}/wordpress/wp-includes
72%{_datadir}/wordpress/index.php
73%doc license.txt
74%doc readme.html
75%doc README.vine
76%doc README.ja.vine
77%{_datadir}/wordpress/wp-atom.php
78%{_datadir}/wordpress/wp-app.php
79%{_datadir}/wordpress/wp-blog-header.php
80%{_datadir}/wordpress/wp-comments-post.php
81%{_datadir}/wordpress/wp-commentsrss2.php
82%{_datadir}/wordpress/wp-config-sample.php
83%{_datadir}/wordpress/wp-config.php
84%config(noreplace) %{_sysconfdir}/wordpress/wp-config.php
85%{_datadir}/wordpress/wp-cron.php
86%{_datadir}/wordpress/wp-feed.php
87%{_datadir}/wordpress/wp-links-opml.php
88%{_datadir}/wordpress/wp-load.php
89%{_datadir}/wordpress/wp-login.php
90%{_datadir}/wordpress/wp-mail.php
91%{_datadir}/wordpress/wp-pass.php
92%{_datadir}/wordpress/wp-rdf.php
93%{_datadir}/wordpress/wp-register.php
94%{_datadir}/wordpress/wp-rss.php
95%{_datadir}/wordpress/wp-rss2.php
96%{_datadir}/wordpress/wp-settings.php
97%{_datadir}/wordpress/wp-trackback.php
98%{_datadir}/wordpress/xmlrpc.php
99%dir %{_sysconfdir}/wordpress
100
101%changelog
102* Tue Apr 20 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.2-1
103- initial build for Vine Linux based on fedora package
104- update to 2.9.2 japanese version
105
106* Mon Nov 16 2009 Adrian Reber <adrian@lisas.de> - 2.8.6-2
107- updated to 2.8.6 (Security Release)
108
109* Wed Oct 21 2009 Adrian Reber <adrian@lisas.de> - 2.8.5-1
110- updated to 2.8.5 (Hardening Release)
111
112* Sun Aug 30 2009 Adrian Reber <adrian@lisas.de> - 2.8.4-1
113- updated to 2.8.4 (security fixes were already available with 2.8.3-2)
114
115* Tue Aug 11 2009 Adrian Reber <adrian@lisas.de> - 2.8.3-2
116- another security update to fix "Remote admin reset password":
117  http://lists.grok.org.uk/pipermail/full-disclosure/2009-August/070137.html
118
119* Mon Aug 03 2009 Adrian Reber <adrian@lisas.de> - 2.8.3-1
120- updated to 2.8.3 for security fixes
121
122* Tue Jul 28 2009 Adrian Reber <adrian@lisas.de> - 2.8.2-1
123- updated to 2.8.2 for security fixes - BZ 512900
124- fixed "wrong-script-end-of-line-encoding" of license.txt
125- correctly disable auto update check
126- fixed an error message from 'find' during the build
127
128* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.1-2
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
130
131* Fri Jul 10 2009 Adrian Reber <adrian@lisas.de> - 2.8.1-1
132- updated to 2.8.1 for security fixes - BZ 510745
133
134* Mon Jun 22 2009 Adrian Reber <adrian@lisas.de> - 2.8-1
135- updated to 2.8
136
137* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.1-2
138- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
139
140* Wed Feb 11 2009 Adrian Reber <adrian@lisas.de> - 2.7.1-1
141- updated to 2.7.1
142
143* Wed Nov 26 2008 Adrian Reber <adrian@lisas.de> - 2.6.5-2
144- updated to 2.6.5
145
146* Fri Oct 24 2008 Adrian Reber <adrian@lisas.de> - 2.6.3-1
147- updated to 2.6.3
148
149* Tue Sep 09 2008 Adrian Reber <adrian@lisas.de> - 2.6.2-1
150- updated to 2.6.2
151
152* Sun Aug 24 2008 Adrian Reber <adrian@lisas.de> - 2.6.1-1
153- updated to 2.6.1
154
155* Mon Jul 21 2008 Adrian Reber <adrian@lisas.de> - 2.6-1
156- updated to 2.6
157
158* Sat Apr 26 2008 Adrian Reber <adrian@lisas.de> - 2.5.1-1
159- updated to 2.5.1 for security fixes - BZ 444396
160
161* Fri Feb  8 2008 John Berninger <john at ncphotography dot com> - 2.3.3-0
162- update to 2.3.3 for security fixes - BZ 431547
163
164* Sun Dec 30 2007 Adrian Reber <adrian@lisas.de> - 2.3.2-1
165- updated to 2.3.2 (bz 426431, Draft Information Disclosure)
166
167* Tue Oct 30 2007 Adrian Reber <adrian@lisas.de> - 2.3.1-1
168- updated to 2.3.1 (bz 357731, wordpress XSS issue)
169
170* Mon Oct 15 2007 Adrian Reber <adrian@lisas.de> - 2.3-1
171- updated to 2.3
172- disabled wordpress-core-update
173
174* Tue Sep 11 2007 Adrian Reber <adrian@lisas.de> - 2.2.3-0
175- updated to 2.2.3 (security release)
176
177* Wed Aug 29 2007 John Berninger <john at ncphotography dot com> - 2.2.2-0
178- update to upstream 2.2.2
179- license tag update
180
181* Mon Apr 16 2007 john Berninger <jwb at redhat dot com> - 2.1.3-1
182- update to 2.1.3 final - bz235912
183
184* Mon Mar 26 2007 John Berninger <jwb at redhat dot com> - 2.1.3-rc2
185- update to 2.1.3rc2 for bz 233703
186
187* Sat Mar  3 2007 John Berninger <jwb at redhat dot com> - 2.1.2-0
188- update to 2.1.2 - backdoor exploit introduced upstream in 2.1.1 - bz 230825
189
190* Tue Feb 27 2007 John Berninger <jwb at redhat dot com> - 2.1.1-0
191- update to 2.1.1 to fix vuln in bz 229991
192
193* Wed Jan 31 2007 John Berninger <jwb at redhat dot com> - 2.1-0
194- update to v2.1 to fix multiple bz/vuln's
195
196* Sun Dec  3 2006 John Berninger <jwb at redhat dot com> - 2.0.5-2
197- Remove mysql-server dependency
198
199* Sun Dec  3 2006 John Berninger <jwb at redhat dot com> - 2.0.5-1
200- Update to upstream 2.0.5 to fix vuln in bz 213985
201
202* Thu Oct 26 2006 John Berninger <jwb at redhat dot com> - 2.0.4-1
203- Doc fix for BZ 207822
204
205* Sat Aug 12 2006 John Berninger <jwb at redhat dot com> - 2.0.4-0
206- Upstream security vulns - bz 201989
207
208* Sun Jul 23 2006 John Berninger <jwb at redhat dot com> - 2.0.3-4
209- Fix broken upgrade path from FE4
210
211* Tue Jul  4 2006 John Berninger <jwb at redhat dot com> - 2.0.3-3
212- Add a README.fedora file
213- Add php-mysql requires
214
215* Tue Jun 20 2006 John Berninger <jwb at redhat dot com> - 2.0.3-2
216- Remove use of installprefix macro
217- %%{_datadir}/wordpress/wp-config.php is not a config file
218- Symlink is relative
219
220* Mon Jun 19 2006 John Berninger <jwb at redhat dot com> - 2.0.3-1
221- Changes from Jarod Wilson as below
222- Update to 2.0.3
223- Rearrange to use /usr/share/wordpress and /etc/wordpress
224- Remove patch (included upstream)
225- Remove empty files to make rpmlint happy
226
227* Tue May 30 2006 John Berninger <jwb at redhat dot com> - 2.0.2-1
228- Added patch for \n cache injection - upstream changeset #3797
229
230* Sat May 27 2006 John Berninger <jwb at redhat dot com> - 2.0.2-0
231- Initial build
Note: See TracBrowser for help on using the repository browser.