source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 9115

Revision 9115, 6.6 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1## NOTE: Lots of files in various subdirectories have the same name (such as
2## "LICENSE") so this short macro allows us to distinguish them by using their
3## directory names (from the source tree) as prefixes for the files.
4%global add_to_license_files() \
5        mkdir -p _license_files ; \
6        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
7
8Name:           webkitgtk4
9Version:        2.6.4
10Release:        1%{?_dist_release}
11Summary:        GTK+ Web content engine library
12
13License:        LGPLv2
14URL:            http://www.webkitgtk.org/
15Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
16
17Patch0:         webkit-1.1.14-nspluginwrapper.patch
18Patch2:         webkitgtk-2.5.90-cloop_fix.patch
19Patch3:         webkitgtk-2.5.2-commit_align.patch
20
21BuildRequires:  at-spi2-core-devel
22BuildRequires:  bison
23BuildRequires:  cairo-devel
24BuildRequires:  cmake
25BuildRequires:  enchant-devel
26BuildRequires:  flex
27BuildRequires:  fontconfig-devel
28BuildRequires:  freetype-devel
29BuildRequires:  geoclue2-devel
30BuildRequires:  gettext
31BuildRequires:  glib2-devel
32BuildRequires:  gobject-introspection-devel
33BuildRequires:  gperf
34BuildRequires:  gstreamer1-devel
35BuildRequires:  gstreamer1-plugins-base-devel
36BuildRequires:  gtk2-devel
37BuildRequires:  gtk3-devel
38BuildRequires:  harfbuzz-icu-devel
39BuildRequires:  libicu-devel
40BuildRequires:  libjpeg-turbo-devel
41BuildRequires:  libpng-devel
42BuildRequires:  libsecret-devel
43BuildRequires:  libsoup-devel
44BuildRequires:  libwebp-devel
45BuildRequires:  libxslt-devel
46BuildRequires:  libXt-devel
47BuildRequires:  mesa-libGL-devel
48BuildRequires:  pcre-devel
49BuildRequires:  ruby
50BuildRequires:  sqlite3-devel
51%ifarch ppc
52BuildRequires:  libatomic
53%endif
54Requires:       geoclue2
55
56# Obsolete libwebkit2gtk from the webkitgtk3 package
57Obsoletes:      libwebkit2gtk < 2.4.5-3
58Provides:       libwebkit2gtk = %{version}-%{release}
59
60# Filter out provides for private libraries
61%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
62
63%description
64WebKitGTK+ is the port of the portable web rendering engine WebKit to the
65GTK+ platform.
66
67This package contains WebKitGTK+ for GTK+ 3.
68
69%package        devel
70Summary:        Development files for %{name}
71Requires:       %{name} = %{version}-%{release}
72
73%description    devel
74The %{name}-devel package contains libraries, build data, and header
75files for developing applications that use %{name}.
76
77%prep
78%setup -q -n webkitgtk-%{version}
79%patch0 -p1 -b .nspluginwrapper
80%patch2 -p1 -b .cloop_fix
81%ifarch %{power64} aarch64 ppc
82%patch3 -p1 -b .commit_align
83%endif
84
85# Remove bundled libraries
86rm -rf Source/ThirdParty/leveldb/
87rm -rf Source/ThirdParty/gtest/
88rm -rf Source/ThirdParty/qunit/
89
90%build
91# Use linker flags to reduce memory consumption
92%global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
93
94%ifarch s390 %{arm}
95# Decrease debuginfo verbosity to reduce memory consumption even more
96%global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
97%endif
98
99%ifarch ppc
100# Use linker flag -relax to get WebKit build under ppc(32) with JIT disabled
101%global optflags %{optflags} -Wl,-relax -latomic
102%endif
103
104%global optflags %{optflags} -DENABLE_YARR_JIT=0
105
106mkdir -p %{_target_platform}
107pushd %{_target_platform}
108%cmake \
109  -DPORT=GTK \
110  -DCMAKE_BUILD_TYPE=Release \
111  -DENABLE_JIT=OFF \
112  -DENABLE_LLINT_C_LOOP=ON \
113  ..
114popd
115
116make %{?_smp_mflags} -C %{_target_platform}
117
118%install
119%make_install -C %{_target_platform}
120
121%find_lang WebKit2GTK-4.0
122
123# Finally, copy over and rename various files for %%license inclusion
124%add_to_license_files Source/JavaScriptCore/COPYING.LIB
125%add_to_license_files Source/JavaScriptCore/icu/LICENSE
126%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
127%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
128%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/murmurhash/LICENSE
129%add_to_license_files Source/WebCore/icu/LICENSE
130%add_to_license_files Source/WebCore/LICENSE-APPLE
131%add_to_license_files Source/WebCore/LICENSE-LGPL-2
132%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
133%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
134%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
135%add_to_license_files Source/WTF/icu/LICENSE
136%add_to_license_files Source/WTF/wtf/dtoa/COPYING
137%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
138
139%post -p /sbin/ldconfig
140%postun -p /sbin/ldconfig
141
142%files -f WebKit2GTK-4.0.lang
143%license _license_files/*
144%{_libdir}/libjavascriptcoregtk-4.0.so.*
145%{_libdir}/libwebkit2gtk-4.0.so.*
146%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
147%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
148%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
149%{_libdir}/webkit2gtk-4.0/
150%{_libexecdir}/webkit2gtk-4.0/
151
152%files devel
153%{_bindir}/jsc
154%{_includedir}/webkitgtk-4.0/
155%{_libdir}/libjavascriptcoregtk-4.0.so
156%{_libdir}/libwebkit2gtk-4.0.so
157%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
158%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
159%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
160%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
161%{_datadir}/gir-1.0/WebKit2-4.0.gir
162%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
163
164%changelog
165* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
166- new upstream release
167
168* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
169- new upstream release
170
171* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
172- initial build for Vine Linux
173
174
175* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
176- Add the wrongly removed CLoop patch and remove the one that was upstreamed
177
178* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
179- Update to 2.6.0
180
181* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
182- Update to 2.5.90
183
184* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
185- Obsolete libwebkit2gtk from the webkitgtk3 package
186
187* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
188- rebuild for ICU 53.1
189
190* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
191- Add support for secondary arches
192
193* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
194- Add webkitgtk-2.5.3-toggle-buttons.patch
195
196* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
197- More package review fixes (#1131284)
198- Correct the license tag to read LGPLv2
199- Filter out provides for private libraries
200
201* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
202- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
203
204* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
205- Update to 2.5.3
206
207* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
208- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.