source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 12422

Revision 12422, 10.4 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

bind-9.11.20-1

samba-4.12.5-1

webkitgtk4-2.28.2-1

Line 
1%bcond_with clang
2
3## NOTE: Lots of files in various subdirectories have the same name (such as
4## "LICENSE") so this short macro allows us to distinguish them by using their
5## directory names (from the source tree) as prefixes for the files.
6%global add_to_license_files() \
7        mkdir -p _license_files ; \
8        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
9
10Name:           webkitgtk4
11Version:        2.28.2
12Release:        1%{?_dist_release}
13Summary:        GTK+ Web content engine library
14Group:          System Environment/Libraries
15Vendor:         Project Vine
16Distribution:   Vine Linux
17
18License:        LGPLv2
19URL:            http://www.webkitgtk.org/
20Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
21
22%if %{with clang}
23BuildRequires:  clang
24BuildRequires:  lld
25%endif
26BuildRequires:  at-spi2-core-devel
27BuildRequires:  bison
28BuildRequires:  bubblewrap
29BuildRequires:  cairo-devel
30BuildRequires:  cmake
31BuildRequires:  enchant2-devel
32BuildRequires:  flex
33BuildRequires:  fontconfig-devel
34BuildRequires:  freetype-devel
35BuildRequires:  geoclue2-devel
36BuildRequires:  gettext
37BuildRequires:  glib2-devel
38BuildRequires:  gobject-introspection-devel
39BuildRequires:  gperf
40BuildRequires:  gstreamer1-devel
41BuildRequires:  gstreamer1-plugins-base-devel
42BuildRequires:  gtk2-devel
43BuildRequires:  gtk3-devel
44BuildRequires:  harfbuzz-icu-devel
45BuildRequires:  libicu-devel
46BuildRequires:  libjpeg-turbo-devel
47BuildRequires:  libpng-devel
48BuildRequires:  libseccomp-devel
49BuildRequires:  libsecret-devel
50BuildRequires:  libsoup-devel
51BuildRequires:  libwebp-devel
52BuildRequires:  libxslt-devel
53BuildRequires:  libXt-devel
54BuildRequires:  ninja
55BuildRequires:  mesa-libGL-devel
56BuildRequires:  pcre-devel
57BuildRequires:  python3-devel
58BuildRequires:  ruby
59BuildRequires:  sqlite3-devel
60BuildRequires:  libnotify-devel
61BuildRequires:  hyphen-devel
62BuildRequires:  woff2-devel
63BuildRequires:  xdg-dbus-proxy
64Requires:       geoclue2
65
66# for sandbox
67Requires:       bubblewrap
68Requires:       xdg-dbus-proxy
69
70# Require the jsc subpackage
71Requires:       %{name}-jsc = %{version}-%{release}
72
73# Obsolete libwebkit2gtk from the webkitgtk3 package
74Obsoletes:      libwebkit2gtk < 2.4.5-3
75Provides:       libwebkit2gtk = %{version}-%{release}
76
77# Filter out provides for private libraries
78%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
79
80%description
81WebKitGTK+ is the port of the portable web rendering engine WebKit to the
82GTK+ platform.
83
84This package contains WebKitGTK+ for GTK+ 3.
85
86%package        devel
87Summary:        Development files for %{name}
88Group:                  Development/Libraries
89Requires:       %{name} = %{version}-%{release}
90Requires:       %{name}-jsc-devel = %{version}-%{release}
91
92%description    devel
93The %{name}-devel package contains libraries, build data, and header
94files for developing applications that use %{name}.
95
96%package        jsc
97Summary:        JavaScript engine from %{name}
98Group:                  System Environment/Libraries
99
100%description    jsc
101This package contains JavaScript engine from %{name}.
102
103%package        jsc-devel
104Summary:        Development files for JavaScript engine from %{name}
105Group:                  Development/Libraries
106Requires:       %{name}-jsc = %{version}-%{release}
107
108%description    jsc-devel
109The %{name}-jsc-devel package contains libraries, build data, and header
110files for developing applications that use JavaScript engine from %{name}.
111
112
113%debug_package
114
115
116%prep
117%setup -q -n webkitgtk-%{version}
118
119# Remove bundled libraries
120rm -rf Source/ThirdParty/leveldb/
121rm -rf Source/ThirdParty/gtest/
122rm -rf Source/ThirdParty/qunit/
123
124%build
125# binutils-2.23 doesn't support "reduce-memory-overheads"
126# Use linker flags to reduce memory consumption
127# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
128
129%if %{with clang}
130%ifnarch x86_64
131%define cflags_add --rtlib=compiler-rt
132%endif
133
134%global optflags  %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
135%else
136%global optflags  %{optflags} -DENABLE_YARR_JIT=0
137%endif
138
139mkdir -p %{_target_platform}
140pushd %{_target_platform}
141
142%if %{with clang}
143export CC=clang
144export CXX=clang++
145export LD=ld.lld
146%endif
147
148%cmake \
149  -GNinja \
150%if %{with clang}
151  -DCOMPILER_IS_CLANG=ON \
152  -DCMAKE_CXX_COMPILER=clang++ \
153%endif
154  -DPORT=GTK \
155  -DCMAKE_BUILD_TYPE=Release \
156  -DENABLE_JIT=OFF \
157  -DENABLE_LLINT_C_LOOP=ON \
158  -DUSE_GSTREAMER_GL=OFF \
159  -DUSE_OPENJPEG=OFF \
160  -DENABLE_GTKDOC=OFF \
161  ..
162popd
163
164ninja -C %{_target_platform}
165
166%install
167DESTDIR=%{buildroot} ninja -C %{_target_platform} install
168
169%find_lang WebKit2GTK-4.0
170
171# Finally, copy over and rename various files for %%license inclusion
172%add_to_license_files Source/JavaScriptCore/COPYING.LIB
173%add_to_license_files Source/JavaScriptCore/icu/LICENSE
174%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
175%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
176%add_to_license_files Source/WebCore/icu/LICENSE
177%add_to_license_files Source/WebCore/LICENSE-APPLE
178%add_to_license_files Source/WebCore/LICENSE-LGPL-2
179%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
180%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
181%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
182%add_to_license_files Source/WTF/icu/LICENSE
183%add_to_license_files Source/WTF/wtf/dtoa/COPYING
184%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
185
186%post -p /sbin/ldconfig
187%postun -p /sbin/ldconfig
188%post jsc -p /sbin/ldconfig
189%postun jsc -p /sbin/ldconfig
190
191%files -f WebKit2GTK-4.0.lang
192%license _license_files/*
193%{_libdir}/libwebkit2gtk-4.0.so.*
194%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
195%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
196%{_libdir}/webkit2gtk-4.0/
197%{_libexecdir}/webkit2gtk-4.0/*
198%exclude %{_libexecdir}/webkit2gtk-4.0/jsc
199%{_bindir}/WebKitWebDriver
200
201%files jsc
202%license _license_files/*JavaScriptCore*
203%dir %{_libexecdir}/webkit2gtk-4.0/
204%{_libexecdir}/webkit2gtk-4.0/jsc
205%{_libdir}/libjavascriptcoregtk-4.0.so.*
206%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
207
208%files devel
209%{_includedir}/webkitgtk-4.0/*
210%exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
211%{_libdir}/libwebkit2gtk-4.0.so
212%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
213%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
214%{_datadir}/gir-1.0/WebKit2-4.0.gir
215%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
216
217%files jsc-devel
218%dir %{_includedir}/webkitgtk-4.0
219%{_includedir}/webkitgtk-4.0/JavaScriptCore/
220%{_libdir}/libjavascriptcoregtk-4.0.so
221%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
222%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
223
224%changelog
225* Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.2-1
226- new upstream release.
227
228* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.1-1
229- new upstream release.
230- rebuilt with libicu67.
231
232* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-2
233- rebuilt with libicu66.
234
235* Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-1
236- new upstream release.
237- dropped Patch1: fixed in upstream.
238
239* Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.1-1
240- new upstream release.
241- built with icu-65.
242
243* Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
244- new upstream release.
245- switched build-system to ninja.
246
247* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
248- new upstream release.
249
250* Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
251- new upstream release.
252
253* Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
254- new upstream release.
255- added subpackages webkitgtk4-jsc{,-devel}.
256
257* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
258- new upstream release.
259
260* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
261- rebuilt with new toolchain.
262
263* Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
264- new upstream release
265  (including security fix for CVE-2016-1856,1857)
266
267* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
268- new upstream release
269- remove Patch0
270- add BuildRequires: libnotify-devel, hyphen-devel
271
272* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
273- rebuild with gnutls-3.4.7
274
275* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
276- rebuild with icu-56.1
277
278* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
279- new upstream release
280
281* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
282- new upstream release
283
284* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
285- new upstream release
286
287* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
288- new upstream release
289
290* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
291- new upstream release
292
293* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
294- new upstream release
295- update Patch0
296
297* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
298- new upstream release
299
300* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
301- add Group tag
302
303* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
304- new upstream release
305
306* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
307- new upstream release
308
309* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
310- initial build for Vine Linux
311
312
313* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
314- Add the wrongly removed CLoop patch and remove the one that was upstreamed
315
316* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
317- Update to 2.6.0
318
319* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
320- Update to 2.5.90
321
322* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
323- Obsolete libwebkit2gtk from the webkitgtk3 package
324
325* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
326- rebuild for ICU 53.1
327
328* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
329- Add support for secondary arches
330
331* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
332- Add webkitgtk-2.5.3-toggle-buttons.patch
333
334* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
335- More package review fixes (#1131284)
336- Correct the license tag to read LGPLv2
337- Filter out provides for private libraries
338
339* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
340- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
341
342* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
343- Update to 2.5.3
344
345* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
346- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.