source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 12386

Revision 12386, 10.3 KB checked in by tomop, 4 years ago (diff)

updated 15 packages

epiphany-3.30.5-3

evolution-data-server-3.30.5-3

harfbuzz-2.6.4-2

icu-67.1-1

libvisio-0.1.7-3

php74-7.4.5-2

postfix-3.5.1-2

qt5-qtbase-5.12.8-2

qt5-qtlocation-5.12.8-2

qt5-qtwebengine-5.12.8-2

samba-4.12.1-2

tracker-miners-2.3.3-2

tracker-2.3.4-1

webkitgtk4-2.28.1-1

xfsprogs-5.6.0-1

Line 
1%bcond_with clang
2
3## NOTE: Lots of files in various subdirectories have the same name (such as
4## "LICENSE") so this short macro allows us to distinguish them by using their
5## directory names (from the source tree) as prefixes for the files.
6%global add_to_license_files() \
7        mkdir -p _license_files ; \
8        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
9
10Name:           webkitgtk4
11Version:        2.28.1
12Release:        1%{?_dist_release}
13Summary:        GTK+ Web content engine library
14Group:          System Environment/Libraries
15Vendor:         Project Vine
16Distribution:   Vine Linux
17
18License:        LGPLv2
19URL:            http://www.webkitgtk.org/
20Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
21
22%if %{with clang}
23BuildRequires:  clang
24BuildRequires:  lld
25%endif
26BuildRequires:  at-spi2-core-devel
27BuildRequires:  bison
28BuildRequires:  bubblewrap
29BuildRequires:  cairo-devel
30BuildRequires:  cmake
31BuildRequires:  enchant-devel
32BuildRequires:  flex
33BuildRequires:  fontconfig-devel
34BuildRequires:  freetype-devel
35BuildRequires:  geoclue2-devel
36BuildRequires:  gettext
37BuildRequires:  glib2-devel
38BuildRequires:  gobject-introspection-devel
39BuildRequires:  gperf
40BuildRequires:  gstreamer1-devel
41BuildRequires:  gstreamer1-plugins-base-devel
42BuildRequires:  gtk2-devel
43BuildRequires:  gtk3-devel
44BuildRequires:  harfbuzz-icu-devel
45BuildRequires:  libicu-devel
46BuildRequires:  libjpeg-turbo-devel
47BuildRequires:  libpng-devel
48BuildRequires:  libseccomp-devel
49BuildRequires:  libsecret-devel
50BuildRequires:  libsoup-devel
51BuildRequires:  libwebp-devel
52BuildRequires:  libxslt-devel
53BuildRequires:  libXt-devel
54BuildRequires:  ninja
55BuildRequires:  mesa-libGL-devel
56BuildRequires:  pcre-devel
57BuildRequires:  python3-devel
58BuildRequires:  ruby
59BuildRequires:  sqlite3-devel
60BuildRequires:  libnotify-devel
61BuildRequires:  hyphen-devel
62BuildRequires:  woff2-devel
63BuildRequires:  xdg-dbus-proxy
64Requires:       geoclue2
65
66# for sandbox
67Requires:       bubblewrap
68Requires:       xdg-dbus-proxy
69
70# Require the jsc subpackage
71Requires:       %{name}-jsc = %{version}-%{release}
72
73# Obsolete libwebkit2gtk from the webkitgtk3 package
74Obsoletes:      libwebkit2gtk < 2.4.5-3
75Provides:       libwebkit2gtk = %{version}-%{release}
76
77# Filter out provides for private libraries
78%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
79
80%description
81WebKitGTK+ is the port of the portable web rendering engine WebKit to the
82GTK+ platform.
83
84This package contains WebKitGTK+ for GTK+ 3.
85
86%package        devel
87Summary:        Development files for %{name}
88Group:                  Development/Libraries
89Requires:       %{name} = %{version}-%{release}
90Requires:       %{name}-jsc-devel = %{version}-%{release}
91
92%description    devel
93The %{name}-devel package contains libraries, build data, and header
94files for developing applications that use %{name}.
95
96%package        jsc
97Summary:        JavaScript engine from %{name}
98Group:                  System Environment/Libraries
99
100%description    jsc
101This package contains JavaScript engine from %{name}.
102
103%package        jsc-devel
104Summary:        Development files for JavaScript engine from %{name}
105Group:                  Development/Libraries
106Requires:       %{name}-jsc = %{version}-%{release}
107
108%description    jsc-devel
109The %{name}-jsc-devel package contains libraries, build data, and header
110files for developing applications that use JavaScript engine from %{name}.
111
112
113%prep
114%setup -q -n webkitgtk-%{version}
115
116# Remove bundled libraries
117rm -rf Source/ThirdParty/leveldb/
118rm -rf Source/ThirdParty/gtest/
119rm -rf Source/ThirdParty/qunit/
120
121%build
122# binutils-2.23 doesn't support "reduce-memory-overheads"
123# Use linker flags to reduce memory consumption
124# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
125
126%if %{with clang}
127%ifnarch x86_64
128%define cflags_add --rtlib=compiler-rt
129%endif
130
131%global optflags  %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
132%else
133%global optflags  %{optflags} -DENABLE_YARR_JIT=0
134%endif
135
136mkdir -p %{_target_platform}
137pushd %{_target_platform}
138
139%if %{with clang}
140export CC=clang
141export CXX=clang++
142export LD=ld.lld
143%endif
144
145%cmake \
146  -GNinja \
147%if %{with clang}
148  -DCOMPILER_IS_CLANG=ON \
149  -DCMAKE_CXX_COMPILER=clang++ \
150%endif
151  -DPORT=GTK \
152  -DCMAKE_BUILD_TYPE=Release \
153  -DENABLE_JIT=OFF \
154  -DENABLE_LLINT_C_LOOP=ON \
155  -DUSE_GSTREAMER_GL=OFF \
156  -DUSE_OPENJPEG=OFF \
157  -DENABLE_GTKDOC=OFF \
158  ..
159popd
160
161ninja -C %{_target_platform}
162
163%install
164DESTDIR=%{buildroot} ninja -C %{_target_platform} install
165
166%find_lang WebKit2GTK-4.0
167
168# Finally, copy over and rename various files for %%license inclusion
169%add_to_license_files Source/JavaScriptCore/COPYING.LIB
170%add_to_license_files Source/JavaScriptCore/icu/LICENSE
171%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
172%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
173%add_to_license_files Source/WebCore/icu/LICENSE
174%add_to_license_files Source/WebCore/LICENSE-APPLE
175%add_to_license_files Source/WebCore/LICENSE-LGPL-2
176%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
177%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
178%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
179%add_to_license_files Source/WTF/icu/LICENSE
180%add_to_license_files Source/WTF/wtf/dtoa/COPYING
181%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
182
183%post -p /sbin/ldconfig
184%postun -p /sbin/ldconfig
185%post jsc -p /sbin/ldconfig
186%postun jsc -p /sbin/ldconfig
187
188%files -f WebKit2GTK-4.0.lang
189%license _license_files/*
190%{_libdir}/libwebkit2gtk-4.0.so.*
191%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
192%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
193%{_libdir}/webkit2gtk-4.0/
194%{_libexecdir}/webkit2gtk-4.0/*
195%exclude %{_libexecdir}/webkit2gtk-4.0/jsc
196%{_bindir}/WebKitWebDriver
197
198%files jsc
199%license _license_files/*JavaScriptCore*
200%dir %{_libexecdir}/webkit2gtk-4.0/
201%{_libexecdir}/webkit2gtk-4.0/jsc
202%{_libdir}/libjavascriptcoregtk-4.0.so.*
203%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
204
205%files devel
206%{_includedir}/webkitgtk-4.0/*
207%exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
208%{_libdir}/libwebkit2gtk-4.0.so
209%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
210%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
211%{_datadir}/gir-1.0/WebKit2-4.0.gir
212%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
213
214%files jsc-devel
215%dir %{_includedir}/webkitgtk-4.0
216%{_includedir}/webkitgtk-4.0/JavaScriptCore/
217%{_libdir}/libjavascriptcoregtk-4.0.so
218%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
219%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
220
221%changelog
222* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.1-1
223- new upstream release.
224- rebuilt with libicu67.
225
226* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-2
227- rebuilt with libicu66.
228
229* Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-1
230- new upstream release.
231- dropped Patch1: fixed in upstream.
232
233* Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.1-1
234- new upstream release.
235- built with icu-65.
236
237* Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
238- new upstream release.
239- switched build-system to ninja.
240
241* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
242- new upstream release.
243
244* Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
245- new upstream release.
246
247* Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
248- new upstream release.
249- added subpackages webkitgtk4-jsc{,-devel}.
250
251* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
252- new upstream release.
253
254* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
255- rebuilt with new toolchain.
256
257* Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
258- new upstream release
259  (including security fix for CVE-2016-1856,1857)
260
261* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
262- new upstream release
263- remove Patch0
264- add BuildRequires: libnotify-devel, hyphen-devel
265
266* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
267- rebuild with gnutls-3.4.7
268
269* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
270- rebuild with icu-56.1
271
272* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
273- new upstream release
274
275* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
276- new upstream release
277
278* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
279- new upstream release
280
281* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
282- new upstream release
283
284* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
285- new upstream release
286
287* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
288- new upstream release
289- update Patch0
290
291* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
292- new upstream release
293
294* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
295- add Group tag
296
297* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
298- new upstream release
299
300* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
301- new upstream release
302
303* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
304- initial build for Vine Linux
305
306
307* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
308- Add the wrongly removed CLoop patch and remove the one that was upstreamed
309
310* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
311- Update to 2.6.0
312
313* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
314- Update to 2.5.90
315
316* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
317- Obsolete libwebkit2gtk from the webkitgtk3 package
318
319* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
320- rebuild for ICU 53.1
321
322* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
323- Add support for secondary arches
324
325* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
326- Add webkitgtk-2.5.3-toggle-buttons.patch
327
328* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
329- More package review fixes (#1131284)
330- Correct the license tag to read LGPLv2
331- Filter out provides for private libraries
332
333* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
334- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
335
336* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
337- Update to 2.5.3
338
339* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
340- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.