source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 12344

Revision 12344, 10.2 KB checked in by tomop, 4 years ago (diff)

updated 10 packages

epiphany-3.30.5-2

evolution-data-server-3.30.5-2

gnucash-3.8b-1

harfbuzz-2.6.4-1

libboost-1.66.0-5

tracker-miners-2.3.3-1

tracker-2.2.2-3

webkitgtk4-2.28.0-2

xfsdump-3.1.9-1

xfsprogs-5.5.0-1

Line 
1%bcond_with clang
2
3## NOTE: Lots of files in various subdirectories have the same name (such as
4## "LICENSE") so this short macro allows us to distinguish them by using their
5## directory names (from the source tree) as prefixes for the files.
6%global add_to_license_files() \
7        mkdir -p _license_files ; \
8        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
9
10Name:           webkitgtk4
11Version:        2.28.0
12Release:        2%{?_dist_release}
13Summary:        GTK+ Web content engine library
14
15License:        LGPLv2
16Group:          System Environment/Libraries
17URL:            http://www.webkitgtk.org/
18Vendor:         Project Vine
19Distribution:   Vine Linux
20
21Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
22
23%if %{with clang}
24BuildRequires:  clang
25BuildRequires:  lld
26%endif
27BuildRequires:  at-spi2-core-devel
28BuildRequires:  bison
29BuildRequires:  bubblewrap
30BuildRequires:  cairo-devel
31BuildRequires:  cmake
32BuildRequires:  enchant-devel
33BuildRequires:  flex
34BuildRequires:  fontconfig-devel
35BuildRequires:  freetype-devel
36BuildRequires:  geoclue2-devel
37BuildRequires:  gettext
38BuildRequires:  glib2-devel
39BuildRequires:  gobject-introspection-devel
40BuildRequires:  gperf
41BuildRequires:  gstreamer1-devel
42BuildRequires:  gstreamer1-plugins-base-devel
43BuildRequires:  gtk2-devel
44BuildRequires:  gtk3-devel
45BuildRequires:  harfbuzz-icu-devel
46BuildRequires:  libicu-devel
47BuildRequires:  libjpeg-turbo-devel
48BuildRequires:  libpng-devel
49BuildRequires:  libseccomp-devel
50BuildRequires:  libsecret-devel
51BuildRequires:  libsoup-devel
52BuildRequires:  libwebp-devel
53BuildRequires:  libxslt-devel
54BuildRequires:  libXt-devel
55BuildRequires:  ninja
56BuildRequires:  mesa-libGL-devel
57BuildRequires:  pcre-devel
58BuildRequires:  python3-devel
59BuildRequires:  ruby
60BuildRequires:  sqlite3-devel
61BuildRequires:  libnotify-devel
62BuildRequires:  hyphen-devel
63BuildRequires:  woff2-devel
64BuildRequires:  xdg-dbus-proxy
65Requires:       geoclue2
66
67# for sandbox
68Requires:       bubblewrap
69Requires:       xdg-dbus-proxy
70
71# Require the jsc subpackage
72Requires:       %{name}-jsc = %{version}-%{release}
73
74# Obsolete libwebkit2gtk from the webkitgtk3 package
75Obsoletes:      libwebkit2gtk < 2.4.5-3
76Provides:       libwebkit2gtk = %{version}-%{release}
77
78# Filter out provides for private libraries
79%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
80
81%description
82WebKitGTK+ is the port of the portable web rendering engine WebKit to the
83GTK+ platform.
84
85This package contains WebKitGTK+ for GTK+ 3.
86
87%package        devel
88Summary:        Development files for %{name}
89Group:                  Development/Libraries
90Requires:       %{name} = %{version}-%{release}
91Requires:       %{name}-jsc-devel = %{version}-%{release}
92
93%description    devel
94The %{name}-devel package contains libraries, build data, and header
95files for developing applications that use %{name}.
96
97%package        jsc
98Summary:        JavaScript engine from %{name}
99Group:                  System Environment/Libraries
100
101%description    jsc
102This package contains JavaScript engine from %{name}.
103
104%package        jsc-devel
105Summary:        Development files for JavaScript engine from %{name}
106Group:                  Development/Libraries
107Requires:       %{name}-jsc = %{version}-%{release}
108
109%description    jsc-devel
110The %{name}-jsc-devel package contains libraries, build data, and header
111files for developing applications that use JavaScript engine from %{name}.
112
113
114%prep
115%setup -q -n webkitgtk-%{version}
116
117# Remove bundled libraries
118rm -rf Source/ThirdParty/leveldb/
119rm -rf Source/ThirdParty/gtest/
120rm -rf Source/ThirdParty/qunit/
121
122%build
123# binutils-2.23 doesn't support "reduce-memory-overheads"
124# Use linker flags to reduce memory consumption
125# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
126
127%if %{with clang}
128%ifnarch x86_64
129%define cflags_add --rtlib=compiler-rt
130%endif
131
132%global optflags  %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
133%else
134%global optflags  %{optflags} -DENABLE_YARR_JIT=0
135%endif
136
137mkdir -p %{_target_platform}
138pushd %{_target_platform}
139
140%if %{with clang}
141export CC=clang
142export CXX=clang++
143export LD=ld.lld
144%endif
145
146%cmake \
147  -GNinja \
148%if %{with clang}
149  -DCOMPILER_IS_CLANG=ON \
150  -DCMAKE_CXX_COMPILER=clang++ \
151%endif
152  -DPORT=GTK \
153  -DCMAKE_BUILD_TYPE=Release \
154  -DENABLE_JIT=OFF \
155  -DENABLE_LLINT_C_LOOP=ON \
156  -DUSE_GSTREAMER_GL=OFF \
157  -DUSE_OPENJPEG=OFF \
158  -DENABLE_GTKDOC=OFF \
159  ..
160popd
161
162ninja -C %{_target_platform}
163
164%install
165DESTDIR=%{buildroot} ninja -C %{_target_platform} install
166
167%find_lang WebKit2GTK-4.0
168
169# Finally, copy over and rename various files for %%license inclusion
170%add_to_license_files Source/JavaScriptCore/COPYING.LIB
171%add_to_license_files Source/JavaScriptCore/icu/LICENSE
172%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
173%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
174%add_to_license_files Source/WebCore/icu/LICENSE
175%add_to_license_files Source/WebCore/LICENSE-APPLE
176%add_to_license_files Source/WebCore/LICENSE-LGPL-2
177%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
178%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
179%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
180%add_to_license_files Source/WTF/icu/LICENSE
181%add_to_license_files Source/WTF/wtf/dtoa/COPYING
182%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
183
184%post -p /sbin/ldconfig
185%postun -p /sbin/ldconfig
186%post jsc -p /sbin/ldconfig
187%postun jsc -p /sbin/ldconfig
188
189%files -f WebKit2GTK-4.0.lang
190%license _license_files/*
191%{_libdir}/libwebkit2gtk-4.0.so.*
192%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
193%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
194%{_libdir}/webkit2gtk-4.0/
195%{_libexecdir}/webkit2gtk-4.0/*
196%exclude %{_libexecdir}/webkit2gtk-4.0/jsc
197%{_bindir}/WebKitWebDriver
198
199%files jsc
200%license _license_files/*JavaScriptCore*
201%dir %{_libexecdir}/webkit2gtk-4.0/
202%{_libexecdir}/webkit2gtk-4.0/jsc
203%{_libdir}/libjavascriptcoregtk-4.0.so.*
204%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
205
206%files devel
207%{_includedir}/webkitgtk-4.0/*
208%exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
209%{_libdir}/libwebkit2gtk-4.0.so
210%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
211%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
212%{_datadir}/gir-1.0/WebKit2-4.0.gir
213%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
214
215%files jsc-devel
216%dir %{_includedir}/webkitgtk-4.0
217%{_includedir}/webkitgtk-4.0/JavaScriptCore/
218%{_libdir}/libjavascriptcoregtk-4.0.so
219%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
220%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
221
222%changelog
223* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-2
224- rebuilt with libicu66.
225
226* Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-1
227- new upstream release.
228- dropped Patch1: fixed in upstream.
229
230* Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.1-1
231- new upstream release.
232- built with icu-65.
233
234* Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
235- new upstream release.
236- switched build-system to ninja.
237
238* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
239- new upstream release.
240
241* Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
242- new upstream release.
243
244* Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
245- new upstream release.
246- added subpackages webkitgtk4-jsc{,-devel}.
247
248* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
249- new upstream release.
250
251* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
252- rebuilt with new toolchain.
253
254* Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
255- new upstream release
256  (including security fix for CVE-2016-1856,1857)
257
258* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
259- new upstream release
260- remove Patch0
261- add BuildRequires: libnotify-devel, hyphen-devel
262
263* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
264- rebuild with gnutls-3.4.7
265
266* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
267- rebuild with icu-56.1
268
269* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
270- new upstream release
271
272* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
273- new upstream release
274
275* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
276- new upstream release
277
278* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
279- new upstream release
280
281* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
282- new upstream release
283
284* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
285- new upstream release
286- update Patch0
287
288* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
289- new upstream release
290
291* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
292- add Group tag
293
294* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
295- new upstream release
296
297* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
298- new upstream release
299
300* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
301- initial build for Vine Linux
302
303
304* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
305- Add the wrongly removed CLoop patch and remove the one that was upstreamed
306
307* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
308- Update to 2.6.0
309
310* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
311- Update to 2.5.90
312
313* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
314- Obsolete libwebkit2gtk from the webkitgtk3 package
315
316* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
317- rebuild for ICU 53.1
318
319* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
320- Add support for secondary arches
321
322* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
323- Add webkitgtk-2.5.3-toggle-buttons.patch
324
325* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
326- More package review fixes (#1131284)
327- Correct the license tag to read LGPLv2
328- Filter out provides for private libraries
329
330* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
331- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
332
333* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
334- Update to 2.5.3
335
336* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
337- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.