source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 12263

Revision 12263, 10.0 KB checked in by tomop, 5 years ago (diff)

updated 10 packages

epiphany-3.30.5-1

evolution-data-server-3.30.5-1

harfbuzz-2.6.2-1

icu-65.1-1

icu60-60.3-2

libboost-1.66.0-4

php73-7.3.10-1

postfix-3.4.7-1

webkitgtk4-2.26.1-1

xfsprogs-5.2.1-2

Line 
1%bcond_with clang
2
3## NOTE: Lots of files in various subdirectories have the same name (such as
4## "LICENSE") so this short macro allows us to distinguish them by using their
5## directory names (from the source tree) as prefixes for the files.
6%global add_to_license_files() \
7        mkdir -p _license_files ; \
8        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
9
10Name:           webkitgtk4
11Version:        2.26.1
12Release:        1%{?_dist_release}
13Summary:        GTK+ Web content engine library
14
15License:        LGPLv2
16Group:          System Environment/Libraries
17URL:            http://www.webkitgtk.org/
18Vendor:         Project Vine
19Distribution:   Vine Linux
20
21Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
22
23# from upstream
24Patch1:         WebKit-icu-65.1-fix.patch
25
26%if %{with clang}
27BuildRequires:  clang
28BuildRequires:  lld
29%endif
30BuildRequires:  at-spi2-core-devel
31BuildRequires:  bison
32BuildRequires:  bubblewrap
33BuildRequires:  cairo-devel
34BuildRequires:  cmake
35BuildRequires:  enchant-devel
36BuildRequires:  flex
37BuildRequires:  fontconfig-devel
38BuildRequires:  freetype-devel
39BuildRequires:  geoclue2-devel
40BuildRequires:  gettext
41BuildRequires:  glib2-devel
42BuildRequires:  gobject-introspection-devel
43BuildRequires:  gperf
44BuildRequires:  gstreamer1-devel
45BuildRequires:  gstreamer1-plugins-base-devel
46BuildRequires:  gtk2-devel
47BuildRequires:  gtk3-devel
48BuildRequires:  harfbuzz-icu-devel
49BuildRequires:  libicu-devel
50BuildRequires:  libjpeg-turbo-devel
51BuildRequires:  libpng-devel
52BuildRequires:  libseccomp-devel
53BuildRequires:  libsecret-devel
54BuildRequires:  libsoup-devel
55BuildRequires:  libwebp-devel
56BuildRequires:  libxslt-devel
57BuildRequires:  libXt-devel
58BuildRequires:  ninja
59BuildRequires:  mesa-libGL-devel
60BuildRequires:  pcre-devel
61BuildRequires:  python3-devel
62BuildRequires:  ruby
63BuildRequires:  sqlite3-devel
64BuildRequires:  libnotify-devel
65BuildRequires:  hyphen-devel
66BuildRequires:  woff2-devel
67BuildRequires:  xdg-dbus-proxy
68Requires:       geoclue2
69
70# for sandbox
71Requires:       bubblewrap
72Requires:       xdg-dbus-proxy
73
74# Require the jsc subpackage
75Requires:       %{name}-jsc = %{version}-%{release}
76
77# Obsolete libwebkit2gtk from the webkitgtk3 package
78Obsoletes:      libwebkit2gtk < 2.4.5-3
79Provides:       libwebkit2gtk = %{version}-%{release}
80
81# Filter out provides for private libraries
82%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
83
84%description
85WebKitGTK+ is the port of the portable web rendering engine WebKit to the
86GTK+ platform.
87
88This package contains WebKitGTK+ for GTK+ 3.
89
90%package        devel
91Summary:        Development files for %{name}
92Group:                  Development/Libraries
93Requires:       %{name} = %{version}-%{release}
94Requires:       %{name}-jsc-devel = %{version}-%{release}
95
96%description    devel
97The %{name}-devel package contains libraries, build data, and header
98files for developing applications that use %{name}.
99
100%package        jsc
101Summary:        JavaScript engine from %{name}
102Group:                  System Environment/Libraries
103
104%description    jsc
105This package contains JavaScript engine from %{name}.
106
107%package        jsc-devel
108Summary:        Development files for JavaScript engine from %{name}
109Group:                  Development/Libraries
110Requires:       %{name}-jsc = %{version}-%{release}
111
112%description    jsc-devel
113The %{name}-jsc-devel package contains libraries, build data, and header
114files for developing applications that use JavaScript engine from %{name}.
115
116
117%prep
118%setup -q -n webkitgtk-%{version}
119%patch1 -p1 -b .icu65
120
121# Remove bundled libraries
122rm -rf Source/ThirdParty/leveldb/
123rm -rf Source/ThirdParty/gtest/
124rm -rf Source/ThirdParty/qunit/
125
126%build
127# binutils-2.23 doesn't support "reduce-memory-overheads"
128# Use linker flags to reduce memory consumption
129# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
130
131%if %{with clang}
132%ifnarch x86_64
133%define cflags_add --rtlib=compiler-rt
134%endif
135
136%global optflags  %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
137%else
138%global optflags  %{optflags} -DENABLE_YARR_JIT=0
139%endif
140
141mkdir -p %{_target_platform}
142pushd %{_target_platform}
143
144%if %{with clang}
145export CC=clang
146export CXX=clang++
147export LD=ld.lld
148%endif
149
150%cmake \
151  -GNinja \
152%if %{with clang}
153  -DCOMPILER_IS_CLANG=ON \
154  -DCMAKE_CXX_COMPILER=clang++ \
155%endif
156  -DPORT=GTK \
157  -DCMAKE_BUILD_TYPE=Release \
158  -DENABLE_JIT=OFF \
159  -DENABLE_LLINT_C_LOOP=ON \
160  -DUSE_GSTREAMER_GL=OFF \
161  -DUSE_OPENJPEG=OFF \
162  -DENABLE_GTKDOC=OFF \
163  ..
164popd
165
166ninja -C %{_target_platform}
167
168%install
169DESTDIR=%{buildroot} ninja -C %{_target_platform} install
170
171%find_lang WebKit2GTK-4.0
172
173# Finally, copy over and rename various files for %%license inclusion
174%add_to_license_files Source/JavaScriptCore/COPYING.LIB
175%add_to_license_files Source/JavaScriptCore/icu/LICENSE
176%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
177%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
178%add_to_license_files Source/WebCore/icu/LICENSE
179%add_to_license_files Source/WebCore/LICENSE-APPLE
180%add_to_license_files Source/WebCore/LICENSE-LGPL-2
181%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
182%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
183%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
184%add_to_license_files Source/WTF/icu/LICENSE
185%add_to_license_files Source/WTF/wtf/dtoa/COPYING
186%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
187
188%post -p /sbin/ldconfig
189%postun -p /sbin/ldconfig
190%post jsc -p /sbin/ldconfig
191%postun jsc -p /sbin/ldconfig
192
193%files -f WebKit2GTK-4.0.lang
194%license _license_files/*
195%{_libdir}/libwebkit2gtk-4.0.so.*
196%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
197%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
198%{_libdir}/webkit2gtk-4.0/
199%{_libexecdir}/webkit2gtk-4.0/*
200%exclude %{_libexecdir}/webkit2gtk-4.0/jsc
201%{_bindir}/WebKitWebDriver
202
203%files jsc
204%license _license_files/*JavaScriptCore*
205%dir %{_libexecdir}/webkit2gtk-4.0/
206%{_libexecdir}/webkit2gtk-4.0/jsc
207%{_libdir}/libjavascriptcoregtk-4.0.so.*
208%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
209
210%files devel
211%{_includedir}/webkitgtk-4.0/*
212%exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
213%{_libdir}/libwebkit2gtk-4.0.so
214%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
215%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
216%{_datadir}/gir-1.0/WebKit2-4.0.gir
217%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
218
219%files jsc-devel
220%dir %{_includedir}/webkitgtk-4.0
221%{_includedir}/webkitgtk-4.0/JavaScriptCore/
222%{_libdir}/libjavascriptcoregtk-4.0.so
223%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
224%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
225
226%changelog
227* Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.1-1
228- new upstream release.
229- built with icu-65.
230
231* Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
232- new upstream release.
233- switched build-system to ninja.
234
235* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
236- new upstream release.
237
238* Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
239- new upstream release.
240
241* Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
242- new upstream release.
243- added subpackages webkitgtk4-jsc{,-devel}.
244
245* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
246- new upstream release.
247
248* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
249- rebuilt with new toolchain.
250
251* Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
252- new upstream release
253  (including security fix for CVE-2016-1856,1857)
254
255* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
256- new upstream release
257- remove Patch0
258- add BuildRequires: libnotify-devel, hyphen-devel
259
260* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
261- rebuild with gnutls-3.4.7
262
263* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
264- rebuild with icu-56.1
265
266* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
267- new upstream release
268
269* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
270- new upstream release
271
272* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
273- new upstream release
274
275* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
276- new upstream release
277
278* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
279- new upstream release
280
281* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
282- new upstream release
283- update Patch0
284
285* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
286- new upstream release
287
288* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
289- add Group tag
290
291* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
292- new upstream release
293
294* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
295- new upstream release
296
297* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
298- initial build for Vine Linux
299
300
301* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
302- Add the wrongly removed CLoop patch and remove the one that was upstreamed
303
304* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
305- Update to 2.6.0
306
307* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
308- Update to 2.5.90
309
310* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
311- Obsolete libwebkit2gtk from the webkitgtk3 package
312
313* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
314- rebuild for ICU 53.1
315
316* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
317- Add support for secondary arches
318
319* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
320- Add webkitgtk-2.5.3-toggle-buttons.patch
321
322* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
323- More package review fixes (#1131284)
324- Correct the license tag to read LGPLv2
325- Filter out provides for private libraries
326
327* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
328- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
329
330* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
331- Update to 2.5.3
332
333* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
334- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.