source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 12222

Revision 12222, 9.9 KB checked in by tomop, 5 years ago (diff)

updated 5 packages

bubblewrap-0.3.3-4

cmake-3.15.3-1

jsoncpp-1.9.1-1

webkitgtk4-2.26.0-1

xdg-dbus-proxy-0.1.2-1

Line 
1%bcond_with clang
2
3## NOTE: Lots of files in various subdirectories have the same name (such as
4## "LICENSE") so this short macro allows us to distinguish them by using their
5## directory names (from the source tree) as prefixes for the files.
6%global add_to_license_files() \
7        mkdir -p _license_files ; \
8        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
9
10Name:           webkitgtk4
11Version:        2.26.0
12Release:        1%{?_dist_release}
13Summary:        GTK+ Web content engine library
14
15License:        LGPLv2
16Group:          System Environment/Libraries
17URL:            http://www.webkitgtk.org/
18Vendor:         Project Vine
19Distribution:   Vine Linux
20
21Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
22
23Patch3:         webkitgtk-2.5.2-commit_align.patch
24
25%if %{with clang}
26BuildRequires:  clang
27BuildRequires:  lld
28%endif
29BuildRequires:  at-spi2-core-devel
30BuildRequires:  bison
31BuildRequires:  bubblewrap
32BuildRequires:  cairo-devel
33BuildRequires:  cmake
34BuildRequires:  enchant-devel
35BuildRequires:  flex
36BuildRequires:  fontconfig-devel
37BuildRequires:  freetype-devel
38BuildRequires:  geoclue2-devel
39BuildRequires:  gettext
40BuildRequires:  glib2-devel
41BuildRequires:  gobject-introspection-devel
42BuildRequires:  gperf
43BuildRequires:  gstreamer1-devel
44BuildRequires:  gstreamer1-plugins-base-devel
45BuildRequires:  gtk2-devel
46BuildRequires:  gtk3-devel
47BuildRequires:  harfbuzz-icu-devel
48BuildRequires:  libicu-devel
49BuildRequires:  libjpeg-turbo-devel
50BuildRequires:  libpng-devel
51BuildRequires:  libseccomp-devel
52BuildRequires:  libsecret-devel
53BuildRequires:  libsoup-devel
54BuildRequires:  libwebp-devel
55BuildRequires:  libxslt-devel
56BuildRequires:  libXt-devel
57BuildRequires:  ninja
58BuildRequires:  mesa-libGL-devel
59BuildRequires:  pcre-devel
60BuildRequires:  python3-devel
61BuildRequires:  ruby
62BuildRequires:  sqlite3-devel
63BuildRequires:  libnotify-devel
64BuildRequires:  hyphen-devel
65BuildRequires:  woff2-devel
66BuildRequires:  xdg-dbus-proxy
67#Requires:       geoclue2
68
69# for sandbox
70Requires:       bubblewrap
71Requires:       xdg-dbus-proxy
72
73# Require the jsc subpackage
74Requires:       %{name}-jsc = %{version}-%{release}
75
76# Obsolete libwebkit2gtk from the webkitgtk3 package
77Obsoletes:      libwebkit2gtk < 2.4.5-3
78Provides:       libwebkit2gtk = %{version}-%{release}
79
80# Filter out provides for private libraries
81%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
82
83%description
84WebKitGTK+ is the port of the portable web rendering engine WebKit to the
85GTK+ platform.
86
87This package contains WebKitGTK+ for GTK+ 3.
88
89%package        devel
90Summary:        Development files for %{name}
91Group:                  Development/Libraries
92Requires:       %{name} = %{version}-%{release}
93Requires:       %{name}-jsc-devel = %{version}-%{release}
94
95%description    devel
96The %{name}-devel package contains libraries, build data, and header
97files for developing applications that use %{name}.
98
99%package        jsc
100Summary:        JavaScript engine from %{name}
101Group:                  System Environment/Libraries
102
103%description    jsc
104This package contains JavaScript engine from %{name}.
105
106%package        jsc-devel
107Summary:        Development files for JavaScript engine from %{name}
108Group:                  Development/Libraries
109Requires:       %{name}-jsc = %{version}-%{release}
110
111%description    jsc-devel
112The %{name}-jsc-devel package contains libraries, build data, and header
113files for developing applications that use JavaScript engine from %{name}.
114
115
116%prep
117%setup -q -n webkitgtk-%{version}
118%ifarch %{power64} aarch64 ppc
119%patch3 -p1 -b .commit_align
120%endif
121
122# Remove bundled libraries
123rm -rf Source/ThirdParty/leveldb/
124rm -rf Source/ThirdParty/gtest/
125rm -rf Source/ThirdParty/qunit/
126
127%build
128# binutils-2.23 doesn't support "reduce-memory-overheads"
129# Use linker flags to reduce memory consumption
130# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
131
132%if %{with clang}
133%ifnarch x86_64
134%define cflags_add --rtlib=compiler-rt
135%endif
136
137%global optflags  %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
138%else
139%global optflags  %{optflags} -DENABLE_YARR_JIT=0
140%endif
141
142mkdir -p %{_target_platform}
143pushd %{_target_platform}
144
145%if %{with clang}
146export CC=clang
147export CXX=clang++
148export LD=ld.lld
149%endif
150
151%cmake \
152  -GNinja \
153%if %{with clang}
154  -DCOMPILER_IS_CLANG=ON \
155  -DCMAKE_CXX_COMPILER=clang++ \
156%endif
157  -DPORT=GTK \
158  -DCMAKE_BUILD_TYPE=Release \
159  -DENABLE_JIT=OFF \
160  -DENABLE_LLINT_C_LOOP=ON \
161  -DUSE_GSTREAMER_GL=OFF \
162  -DUSE_OPENJPEG=OFF \
163  -DENABLE_GTKDOC=OFF \
164  ..
165popd
166
167ninja -C %{_target_platform}
168
169%install
170DESTDIR=%{buildroot} ninja -C %{_target_platform} install
171
172%find_lang WebKit2GTK-4.0
173
174# Finally, copy over and rename various files for %%license inclusion
175%add_to_license_files Source/JavaScriptCore/COPYING.LIB
176%add_to_license_files Source/JavaScriptCore/icu/LICENSE
177%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
178%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
179%add_to_license_files Source/WebCore/icu/LICENSE
180%add_to_license_files Source/WebCore/LICENSE-APPLE
181%add_to_license_files Source/WebCore/LICENSE-LGPL-2
182%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
183%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
184%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
185%add_to_license_files Source/WTF/icu/LICENSE
186%add_to_license_files Source/WTF/wtf/dtoa/COPYING
187%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
188
189%post -p /sbin/ldconfig
190%postun -p /sbin/ldconfig
191%post jsc -p /sbin/ldconfig
192%postun jsc -p /sbin/ldconfig
193
194%files -f WebKit2GTK-4.0.lang
195%license _license_files/*
196%{_libdir}/libwebkit2gtk-4.0.so.*
197%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
198%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
199%{_libdir}/webkit2gtk-4.0/
200%{_libexecdir}/webkit2gtk-4.0/*
201%exclude %{_libexecdir}/webkit2gtk-4.0/jsc
202%{_bindir}/WebKitWebDriver
203
204%files jsc
205%license _license_files/*JavaScriptCore*
206%dir %{_libexecdir}/webkit2gtk-4.0/
207%{_libexecdir}/webkit2gtk-4.0/jsc
208%{_libdir}/libjavascriptcoregtk-4.0.so.*
209%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
210
211%files devel
212%{_includedir}/webkitgtk-4.0/*
213%exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
214%{_libdir}/libwebkit2gtk-4.0.so
215%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
216%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
217%{_datadir}/gir-1.0/WebKit2-4.0.gir
218%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
219
220%files jsc-devel
221%dir %{_includedir}/webkitgtk-4.0
222%{_includedir}/webkitgtk-4.0/JavaScriptCore/
223%{_libdir}/libjavascriptcoregtk-4.0.so
224%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
225%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
226
227%changelog
228* Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
229- new upstream release.
230- switched build-system to ninja.
231
232* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
233- new upstream release.
234
235* Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
236- new upstream release.
237
238* Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
239- new upstream release.
240- added subpackages webkitgtk4-jsc{,-devel}.
241
242* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
243- new upstream release.
244
245* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
246- rebuilt with new toolchain.
247
248* Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
249- new upstream release
250  (including security fix for CVE-2016-1856,1857)
251
252* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
253- new upstream release
254- remove Patch0
255- add BuildRequires: libnotify-devel, hyphen-devel
256
257* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
258- rebuild with gnutls-3.4.7
259
260* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
261- rebuild with icu-56.1
262
263* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
264- new upstream release
265
266* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
267- new upstream release
268
269* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
270- new upstream release
271
272* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
273- new upstream release
274
275* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
276- new upstream release
277
278* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
279- new upstream release
280- update Patch0
281
282* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
283- new upstream release
284
285* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
286- add Group tag
287
288* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
289- new upstream release
290
291* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
292- new upstream release
293
294* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
295- initial build for Vine Linux
296
297
298* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
299- Add the wrongly removed CLoop patch and remove the one that was upstreamed
300
301* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
302- Update to 2.6.0
303
304* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
305- Update to 2.5.90
306
307* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
308- Obsolete libwebkit2gtk from the webkitgtk3 package
309
310* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
311- rebuild for ICU 53.1
312
313* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
314- Add support for secondary arches
315
316* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
317- Add webkitgtk-2.5.3-toggle-buttons.patch
318
319* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
320- More package review fixes (#1131284)
321- Correct the license tag to read LGPLv2
322- Filter out provides for private libraries
323
324* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
325- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
326
327* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
328- Update to 2.5.3
329
330* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
331- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.