source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 12121

Revision 12121, 9.6 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%bcond_without clang
2
3## NOTE: Lots of files in various subdirectories have the same name (such as
4## "LICENSE") so this short macro allows us to distinguish them by using their
5## directory names (from the source tree) as prefixes for the files.
6%global add_to_license_files() \
7        mkdir -p _license_files ; \
8        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
9
10Name:           webkitgtk4
11Version:        2.24.3
12Release:        1%{?_dist_release}
13Summary:        GTK+ Web content engine library
14
15License:        LGPLv2
16Group:                  System Environment/Libraries
17URL:            http://www.webkitgtk.org/
18Vendor:         Project Vine
19Distribution:   Vine Linux
20
21Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
22
23Patch3:         webkitgtk-2.5.2-commit_align.patch
24
25%if %{with clang}
26BuildRequires:  clang
27BuildRequires:  lld
28%endif
29BuildRequires:  at-spi2-core-devel
30BuildRequires:  bison
31BuildRequires:  cairo-devel
32BuildRequires:  cmake
33BuildRequires:  enchant-devel
34BuildRequires:  flex
35BuildRequires:  fontconfig-devel
36BuildRequires:  freetype-devel
37BuildRequires:  geoclue2-devel
38BuildRequires:  gettext
39BuildRequires:  glib2-devel
40BuildRequires:  gobject-introspection-devel
41BuildRequires:  gperf
42BuildRequires:  gstreamer1-devel
43BuildRequires:  gstreamer1-plugins-base-devel
44BuildRequires:  gtk2-devel
45BuildRequires:  gtk3-devel
46BuildRequires:  harfbuzz-icu-devel
47BuildRequires:  libicu-devel
48BuildRequires:  libjpeg-turbo-devel
49BuildRequires:  libpng-devel
50BuildRequires:  libsecret-devel
51BuildRequires:  libsoup-devel
52BuildRequires:  libwebp-devel
53BuildRequires:  libxslt-devel
54BuildRequires:  libXt-devel
55BuildRequires:  mesa-libGL-devel
56BuildRequires:  pcre-devel
57BuildRequires:  ruby
58BuildRequires:  sqlite3-devel
59BuildRequires:  libnotify-devel
60BuildRequires:  hyphen-devel
61BuildRequires:  woff2-devel
62%ifarch ppc
63BuildRequires:  libatomic
64%endif
65Requires:       geoclue2
66
67# Require the jsc subpackage
68Requires:       %{name}-jsc = %{version}-%{release}
69
70# Obsolete libwebkit2gtk from the webkitgtk3 package
71Obsoletes:      libwebkit2gtk < 2.4.5-3
72Provides:       libwebkit2gtk = %{version}-%{release}
73
74# Filter out provides for private libraries
75%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
76
77%description
78WebKitGTK+ is the port of the portable web rendering engine WebKit to the
79GTK+ platform.
80
81This package contains WebKitGTK+ for GTK+ 3.
82
83%package        devel
84Summary:        Development files for %{name}
85Group:                  Development/Libraries
86Requires:       %{name} = %{version}-%{release}
87Requires:       %{name}-jsc-devel = %{version}-%{release}
88
89%description    devel
90The %{name}-devel package contains libraries, build data, and header
91files for developing applications that use %{name}.
92
93%package        jsc
94Summary:        JavaScript engine from %{name}
95Group:                  System Environment/Libraries
96
97%description    jsc
98This package contains JavaScript engine from %{name}.
99
100%package        jsc-devel
101Summary:        Development files for JavaScript engine from %{name}
102Group:                  Development/Libraries
103Requires:       %{name}-jsc = %{version}-%{release}
104
105%description    jsc-devel
106The %{name}-jsc-devel package contains libraries, build data, and header
107files for developing applications that use JavaScript engine from %{name}.
108
109
110%prep
111%setup -q -n webkitgtk-%{version}
112%ifarch %{power64} aarch64 ppc
113%patch3 -p1 -b .commit_align
114%endif
115
116# Remove bundled libraries
117rm -rf Source/ThirdParty/leveldb/
118rm -rf Source/ThirdParty/gtest/
119rm -rf Source/ThirdParty/qunit/
120
121%build
122# binutils-2.23 doesn't support "reduce-memory-overheads"
123# Use linker flags to reduce memory consumption
124# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
125
126%if %{with clang}
127%ifnarch x86_64
128%define cflags_add --rtlib=compiler-rt
129%endif
130
131%global optflags  %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
132%else
133%global optflags  %{optflags} -DENABLE_YARR_JIT=0
134%endif
135
136mkdir -p %{_target_platform}
137pushd %{_target_platform}
138
139%if %{with clang}
140export CC=clang
141export CXX=clang++
142export LD=ld.lld
143%endif
144
145%cmake \
146%if %{with clang}
147  -DCOMPILER_IS_CLANG=ON \
148  -DCMAKE_CXX_COMPILER=clang++ \
149%endif
150  -DPORT=GTK \
151  -DCMAKE_BUILD_TYPE=Release \
152  -DENABLE_JIT=OFF \
153  -DENABLE_LLINT_C_LOOP=ON \
154  -DUSE_GSTREAMER_GL=OFF \
155  -DUSE_OPENJPEG=OFF \
156  ..
157popd
158
159make %{?_smp_mflags} -C %{_target_platform}
160
161%install
162%make_install -C %{_target_platform}
163
164%find_lang WebKit2GTK-4.0
165
166# Finally, copy over and rename various files for %%license inclusion
167%add_to_license_files Source/JavaScriptCore/COPYING.LIB
168%add_to_license_files Source/JavaScriptCore/icu/LICENSE
169%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
170%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
171%add_to_license_files Source/WebCore/icu/LICENSE
172%add_to_license_files Source/WebCore/LICENSE-APPLE
173%add_to_license_files Source/WebCore/LICENSE-LGPL-2
174%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
175%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
176%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
177%add_to_license_files Source/WTF/icu/LICENSE
178%add_to_license_files Source/WTF/wtf/dtoa/COPYING
179%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
180
181%post -p /sbin/ldconfig
182%postun -p /sbin/ldconfig
183%post jsc -p /sbin/ldconfig
184%postun jsc -p /sbin/ldconfig
185
186%files -f WebKit2GTK-4.0.lang
187%license _license_files/*
188%{_libdir}/libwebkit2gtk-4.0.so.*
189%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
190%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
191%{_libdir}/webkit2gtk-4.0/
192%{_libexecdir}/webkit2gtk-4.0/*
193%exclude %{_libexecdir}/webkit2gtk-4.0/jsc
194%{_bindir}/WebKitWebDriver
195
196%files jsc
197%license _license_files/*JavaScriptCore*
198%dir %{_libexecdir}/webkit2gtk-4.0/
199%{_libexecdir}/webkit2gtk-4.0/jsc
200%{_libdir}/libjavascriptcoregtk-4.0.so.*
201%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
202
203%files devel
204%{_includedir}/webkitgtk-4.0/*
205%exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
206%{_libdir}/libwebkit2gtk-4.0.so
207%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
208%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
209%{_datadir}/gir-1.0/WebKit2-4.0.gir
210%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
211
212%files jsc-devel
213%dir %{_includedir}/webkitgtk-4.0
214%{_includedir}/webkitgtk-4.0/JavaScriptCore/
215%{_libdir}/libjavascriptcoregtk-4.0.so
216%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
217%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
218
219%changelog
220* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
221
222* Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
223- new upstream release.
224
225* Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
226- new upstream release.
227- added subpackages webkitgtk4-jsc{,-devel}.
228
229* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
230- new upstream release.
231
232* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
233- rebuilt with new toolchain.
234
235* Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
236- new upstream release
237  (including security fix for CVE-2016-1856,1857)
238
239* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
240- new upstream release
241- remove Patch0
242- add BuildRequires: libnotify-devel, hyphen-devel
243
244* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
245- rebuild with gnutls-3.4.7
246
247* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
248- rebuild with icu-56.1
249
250* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
251- new upstream release
252
253* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
254- new upstream release
255
256* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
257- new upstream release
258
259* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
260- new upstream release
261
262* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
263- new upstream release
264
265* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
266- new upstream release
267- update Patch0
268
269* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
270- new upstream release
271
272* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
273- add Group tag
274
275* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
276- new upstream release
277
278* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
279- new upstream release
280
281* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
282- initial build for Vine Linux
283
284
285* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
286- Add the wrongly removed CLoop patch and remove the one that was upstreamed
287
288* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
289- Update to 2.6.0
290
291* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
292- Update to 2.5.90
293
294* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
295- Obsolete libwebkit2gtk from the webkitgtk3 package
296
297* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
298- rebuild for ICU 53.1
299
300* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
301- Add support for secondary arches
302
303* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
304- Add webkitgtk-2.5.3-toggle-buttons.patch
305
306* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
307- More package review fixes (#1131284)
308- Correct the license tag to read LGPLv2
309- Filter out provides for private libraries
310
311* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
312- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
313
314* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
315- Update to 2.5.3
316
317* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
318- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.