source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 11436

Revision 11436, 9.2 KB checked in by tomop, 6 years ago (diff)

webkitgtk4-2.18.5-1

Line 
1## NOTE: Lots of files in various subdirectories have the same name (such as
2## "LICENSE") so this short macro allows us to distinguish them by using their
3## directory names (from the source tree) as prefixes for the files.
4%global add_to_license_files() \
5        mkdir -p _license_files ; \
6        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
7
8Name:           webkitgtk4
9Version:        2.18.5
10Release:        1%{?_dist_release}
11Summary:        GTK+ Web content engine library
12
13License:        LGPLv2
14Group:                  System Environment/Libraries
15URL:            http://www.webkitgtk.org/
16Vendor:         Project Vine
17Distribution:   Vine Linux
18
19Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
20
21Patch3:         webkitgtk-2.5.2-commit_align.patch
22
23BuildRequires:  at-spi2-core-devel
24BuildRequires:  bison
25BuildRequires:  cairo-devel
26BuildRequires:  cmake
27BuildRequires:  enchant-devel
28BuildRequires:  flex
29BuildRequires:  fontconfig-devel
30BuildRequires:  freetype-devel
31BuildRequires:  geoclue2-devel
32BuildRequires:  gettext
33BuildRequires:  glib2-devel
34BuildRequires:  gobject-introspection-devel
35BuildRequires:  gperf
36BuildRequires:  gstreamer1-devel
37BuildRequires:  gstreamer1-plugins-base-devel
38BuildRequires:  gtk2-devel
39BuildRequires:  gtk3-devel
40BuildRequires:  harfbuzz-icu-devel
41BuildRequires:  libicu-devel
42BuildRequires:  libjpeg-turbo-devel
43BuildRequires:  libpng-devel
44BuildRequires:  libsecret-devel
45BuildRequires:  libsoup-devel
46BuildRequires:  libwebp-devel
47BuildRequires:  libxslt-devel
48BuildRequires:  libXt-devel
49BuildRequires:  mesa-libGL-devel
50BuildRequires:  pcre-devel
51BuildRequires:  ruby
52BuildRequires:  sqlite3-devel
53BuildRequires:  libnotify-devel
54BuildRequires:  hyphen-devel
55%ifarch ppc
56BuildRequires:  libatomic
57%endif
58Requires:       geoclue2
59
60# Require the jsc subpackage
61Requires:       %{name}-jsc = %{version}-%{release}
62
63# Obsolete libwebkit2gtk from the webkitgtk3 package
64Obsoletes:      libwebkit2gtk < 2.4.5-3
65Provides:       libwebkit2gtk = %{version}-%{release}
66
67# Filter out provides for private libraries
68%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
69
70%description
71WebKitGTK+ is the port of the portable web rendering engine WebKit to the
72GTK+ platform.
73
74This package contains WebKitGTK+ for GTK+ 3.
75
76%package        devel
77Summary:        Development files for %{name}
78Group:                  Development/Libraries
79Requires:       %{name} = %{version}-%{release}
80Requires:       %{name}-jsc-devel = %{version}-%{release}
81
82%description    devel
83The %{name}-devel package contains libraries, build data, and header
84files for developing applications that use %{name}.
85
86%package        jsc
87Summary:        JavaScript engine from %{name}
88Group:                  System Environment/Libraries
89
90%description    jsc
91This package contains JavaScript engine from %{name}.
92
93%package        jsc-devel
94Summary:        Development files for JavaScript engine from %{name}
95Group:                  Development/Libraries
96Requires:       %{name}-jsc = %{version}-%{release}
97
98%description    jsc-devel
99The %{name}-jsc-devel package contains libraries, build data, and header
100files for developing applications that use JavaScript engine from %{name}.
101
102
103%prep
104%setup -q -n webkitgtk-%{version}
105%ifarch %{power64} aarch64 ppc
106%patch3 -p1 -b .commit_align
107%endif
108
109# Remove bundled libraries
110rm -rf Source/ThirdParty/leveldb/
111rm -rf Source/ThirdParty/gtest/
112rm -rf Source/ThirdParty/qunit/
113
114%build
115# binutils-2.23 doesn't support "reduce-memory-overheads"
116# Use linker flags to reduce memory consumption
117# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
118
119%ifarch s390 %{arm}
120# Decrease debuginfo verbosity to reduce memory consumption even more
121%global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
122%endif
123
124%ifarch ppc
125# Use linker flag -relax to get WebKit build under ppc(32) with JIT disabled
126%global optflags %{optflags} -Wl,-relax -latomic
127%endif
128
129%global optflags %{optflags} -DENABLE_YARR_JIT=0
130
131mkdir -p %{_target_platform}
132pushd %{_target_platform}
133%cmake \
134  -DPORT=GTK \
135  -DCMAKE_BUILD_TYPE=Release \
136  -DENABLE_JIT=OFF \
137  -DENABLE_LLINT_C_LOOP=ON \
138  ..
139popd
140
141make %{?_smp_mflags} -C %{_target_platform}
142
143%install
144%make_install -C %{_target_platform}
145
146%find_lang WebKit2GTK-4.0
147
148# Finally, copy over and rename various files for %%license inclusion
149%add_to_license_files Source/JavaScriptCore/COPYING.LIB
150%add_to_license_files Source/JavaScriptCore/icu/LICENSE
151%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
152%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
153%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/murmurhash/LICENSE
154%add_to_license_files Source/WebCore/icu/LICENSE
155%add_to_license_files Source/WebCore/LICENSE-APPLE
156%add_to_license_files Source/WebCore/LICENSE-LGPL-2
157%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
158%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
159%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
160%add_to_license_files Source/WTF/icu/LICENSE
161%add_to_license_files Source/WTF/wtf/dtoa/COPYING
162%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
163
164%post -p /sbin/ldconfig
165%postun -p /sbin/ldconfig
166%post jsc -p /sbin/ldconfig
167%postun jsc -p /sbin/ldconfig
168
169%files -f WebKit2GTK-4.0.lang
170%license _license_files/*
171%{_libdir}/libwebkit2gtk-4.0.so.*
172%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
173%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
174%{_libdir}/webkit2gtk-4.0/
175%{_libexecdir}/webkit2gtk-4.0/*
176%exclude %{_libexecdir}/webkit2gtk-4.0/jsc
177%{_bindir}/WebKitWebDriver
178
179%files jsc
180%license _license_files/*JavaScriptCore*
181%dir %{_libexecdir}/webkit2gtk-4.0/
182%{_libexecdir}/webkit2gtk-4.0/jsc
183%{_libdir}/libjavascriptcoregtk-4.0.so.*
184%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
185
186%files devel
187%{_includedir}/webkitgtk-4.0/*
188%exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
189%{_libdir}/libwebkit2gtk-4.0.so
190%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
191%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
192%{_datadir}/gir-1.0/WebKit2-4.0.gir
193%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
194
195%files jsc-devel
196%dir %{_includedir}/webkitgtk-4.0
197%{_includedir}/webkitgtk-4.0/JavaScriptCore/
198%{_libdir}/libjavascriptcoregtk-4.0.so
199%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
200%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
201
202%changelog
203* Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
204- new upstream release.
205- added subpackages webkitgtk4-jsc{,-devel}.
206
207* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
208- new upstream release.
209
210* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
211- rebuilt with new toolchain.
212
213* Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
214- new upstream release
215  (including security fix for CVE-2016-1856,1857)
216
217* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
218- new upstream release
219- remove Patch0
220- add BuildRequires: libnotify-devel, hyphen-devel
221
222* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
223- rebuild with gnutls-3.4.7
224
225* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
226- rebuild with icu-56.1
227
228* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
229- new upstream release
230
231* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
232- new upstream release
233
234* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
235- new upstream release
236
237* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
238- new upstream release
239
240* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
241- new upstream release
242
243* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
244- new upstream release
245- update Patch0
246
247* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
248- new upstream release
249
250* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
251- add Group tag
252
253* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
254- new upstream release
255
256* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
257- new upstream release
258
259* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
260- initial build for Vine Linux
261
262
263* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
264- Add the wrongly removed CLoop patch and remove the one that was upstreamed
265
266* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
267- Update to 2.6.0
268
269* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
270- Update to 2.5.90
271
272* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
273- Obsolete libwebkit2gtk from the webkitgtk3 package
274
275* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
276- rebuild for ICU 53.1
277
278* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
279- Add support for secondary arches
280
281* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
282- Add webkitgtk-2.5.3-toggle-buttons.patch
283
284* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
285- More package review fixes (#1131284)
286- Correct the license tag to read LGPLv2
287- Filter out provides for private libraries
288
289* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
290- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
291
292* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
293- Update to 2.5.3
294
295* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
296- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.