source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 10430

Revision 10430, 7.9 KB checked in by tomop, 8 years ago (diff)

webkitgtk4-2.12.3-2

Line 
1## NOTE: Lots of files in various subdirectories have the same name (such as
2## "LICENSE") so this short macro allows us to distinguish them by using their
3## directory names (from the source tree) as prefixes for the files.
4%global add_to_license_files() \
5        mkdir -p _license_files ; \
6        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
7
8Name:           webkitgtk4
9Version:        2.12.3
10Release:        2%{?_dist_release}
11Summary:        GTK+ Web content engine library
12
13License:        LGPLv2
14Group:                  Development/Libraries
15URL:            http://www.webkitgtk.org/
16Vendor:         Project Vine
17Distribution:   Vine Linux
18
19Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
20
21Patch3:         webkitgtk-2.5.2-commit_align.patch
22
23BuildRequires:  at-spi2-core-devel
24BuildRequires:  bison
25BuildRequires:  cairo-devel
26BuildRequires:  cmake
27BuildRequires:  enchant-devel
28BuildRequires:  flex
29BuildRequires:  fontconfig-devel
30BuildRequires:  freetype-devel
31BuildRequires:  geoclue2-devel
32BuildRequires:  gettext
33BuildRequires:  glib2-devel
34BuildRequires:  gobject-introspection-devel
35BuildRequires:  gperf
36BuildRequires:  gstreamer1-devel
37BuildRequires:  gstreamer1-plugins-base-devel
38BuildRequires:  gtk2-devel
39BuildRequires:  gtk3-devel
40BuildRequires:  harfbuzz-icu-devel
41BuildRequires:  libicu-devel
42BuildRequires:  libjpeg-turbo-devel
43BuildRequires:  libpng-devel
44BuildRequires:  libsecret-devel
45BuildRequires:  libsoup-devel
46BuildRequires:  libwebp-devel
47BuildRequires:  libxslt-devel
48BuildRequires:  libXt-devel
49BuildRequires:  mesa-libGL-devel
50BuildRequires:  pcre-devel
51BuildRequires:  ruby
52BuildRequires:  sqlite3-devel
53BuildRequires:  libnotify-devel
54BuildRequires:  hyphen-devel
55%ifarch ppc
56BuildRequires:  libatomic
57%endif
58Requires:       geoclue2
59
60# Obsolete libwebkit2gtk from the webkitgtk3 package
61Obsoletes:      libwebkit2gtk < 2.4.5-3
62Provides:       libwebkit2gtk = %{version}-%{release}
63
64# Filter out provides for private libraries
65%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
66
67%description
68WebKitGTK+ is the port of the portable web rendering engine WebKit to the
69GTK+ platform.
70
71This package contains WebKitGTK+ for GTK+ 3.
72
73%package        devel
74Summary:        Development files for %{name}
75Group:                  Development/Libraries
76Requires:       %{name} = %{version}-%{release}
77
78%description    devel
79The %{name}-devel package contains libraries, build data, and header
80files for developing applications that use %{name}.
81
82%prep
83%setup -q -n webkitgtk-%{version}
84%ifarch %{power64} aarch64 ppc
85%patch3 -p1 -b .commit_align
86%endif
87
88# Remove bundled libraries
89rm -rf Source/ThirdParty/leveldb/
90rm -rf Source/ThirdParty/gtest/
91rm -rf Source/ThirdParty/qunit/
92
93%build
94# binutils-2.23 doesn't support "reduce-memory-overheads"
95# Use linker flags to reduce memory consumption
96# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
97
98%ifarch s390 %{arm}
99# Decrease debuginfo verbosity to reduce memory consumption even more
100%global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
101%endif
102
103%ifarch ppc
104# Use linker flag -relax to get WebKit build under ppc(32) with JIT disabled
105%global optflags %{optflags} -Wl,-relax -latomic
106%endif
107
108%global optflags %{optflags} -DENABLE_YARR_JIT=0
109
110mkdir -p %{_target_platform}
111pushd %{_target_platform}
112%cmake \
113  -DPORT=GTK \
114  -DCMAKE_BUILD_TYPE=Release \
115  -DENABLE_JIT=OFF \
116  -DENABLE_LLINT_C_LOOP=ON \
117  ..
118popd
119
120make %{?_smp_mflags} -C %{_target_platform}
121
122%install
123%make_install -C %{_target_platform}
124
125%find_lang WebKit2GTK-4.0
126
127# Finally, copy over and rename various files for %%license inclusion
128%add_to_license_files Source/JavaScriptCore/COPYING.LIB
129%add_to_license_files Source/JavaScriptCore/icu/LICENSE
130%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
131%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
132%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/murmurhash/LICENSE
133%add_to_license_files Source/WebCore/icu/LICENSE
134%add_to_license_files Source/WebCore/LICENSE-APPLE
135%add_to_license_files Source/WebCore/LICENSE-LGPL-2
136%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
137%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
138%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
139%add_to_license_files Source/WTF/icu/LICENSE
140%add_to_license_files Source/WTF/wtf/dtoa/COPYING
141%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
142
143%post -p /sbin/ldconfig
144%postun -p /sbin/ldconfig
145
146%files -f WebKit2GTK-4.0.lang
147%license _license_files/*
148%{_libdir}/libjavascriptcoregtk-4.0.so.*
149%{_libdir}/libwebkit2gtk-4.0.so.*
150%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
151%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
152%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
153%{_libdir}/webkit2gtk-4.0/
154%{_libexecdir}/webkit2gtk-4.0/
155
156%files devel
157%{_bindir}/jsc
158%{_includedir}/webkitgtk-4.0/
159%{_libdir}/libjavascriptcoregtk-4.0.so
160%{_libdir}/libwebkit2gtk-4.0.so
161%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
162%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
163%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
164%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
165%{_datadir}/gir-1.0/WebKit2-4.0.gir
166%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
167
168%changelog
169* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
170- rebuilt with new toolchain.
171
172* Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
173- new upstream release
174  (including security fix for CVE-2016-1856,1857)
175
176* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
177- new upstream release
178- remove Patch0
179- add BuildRequires: libnotify-devel, hyphen-devel
180
181* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
182- rebuild with gnutls-3.4.7
183
184* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
185- rebuild with icu-56.1
186
187* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
188- new upstream release
189
190* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
191- new upstream release
192
193* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
194- new upstream release
195
196* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
197- new upstream release
198
199* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
200- new upstream release
201
202* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
203- new upstream release
204- update Patch0
205
206* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
207- new upstream release
208
209* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
210- add Group tag
211
212* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
213- new upstream release
214
215* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
216- new upstream release
217
218* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
219- initial build for Vine Linux
220
221
222* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
223- Add the wrongly removed CLoop patch and remove the one that was upstreamed
224
225* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
226- Update to 2.6.0
227
228* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
229- Update to 2.5.90
230
231* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
232- Obsolete libwebkit2gtk from the webkitgtk3 package
233
234* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
235- rebuild for ICU 53.1
236
237* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
238- Add support for secondary arches
239
240* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
241- Add webkitgtk-2.5.3-toggle-buttons.patch
242
243* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
244- More package review fixes (#1131284)
245- Correct the license tag to read LGPLv2
246- Filter out provides for private libraries
247
248* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
249- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
250
251* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
252- Update to 2.5.3
253
254* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
255- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.