source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 10250

Revision 10250, 7.6 KB checked in by Takemikaduchi, 8 years ago (diff)

binutils-2.26,gcc-4.9.3,glibc-2.23

Line 
1## NOTE: Lots of files in various subdirectories have the same name (such as
2## "LICENSE") so this short macro allows us to distinguish them by using their
3## directory names (from the source tree) as prefixes for the files.
4%global add_to_license_files() \
5        mkdir -p _license_files ; \
6        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
7
8Name:           webkitgtk4
9Version:        2.12.2
10Release:        1%{?_dist_release}
11Summary:        GTK+ Web content engine library
12
13License:        LGPLv2
14Group:                  Development/Libraries
15URL:            http://www.webkitgtk.org/
16Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
17
18Patch3:         webkitgtk-2.5.2-commit_align.patch
19
20BuildRequires:  at-spi2-core-devel
21BuildRequires:  bison
22BuildRequires:  cairo-devel
23BuildRequires:  cmake
24BuildRequires:  enchant-devel
25BuildRequires:  flex
26BuildRequires:  fontconfig-devel
27BuildRequires:  freetype-devel
28BuildRequires:  geoclue2-devel
29BuildRequires:  gettext
30BuildRequires:  glib2-devel
31BuildRequires:  gobject-introspection-devel
32BuildRequires:  gperf
33BuildRequires:  gstreamer1-devel
34BuildRequires:  gstreamer1-plugins-base-devel
35BuildRequires:  gtk2-devel
36BuildRequires:  gtk3-devel
37BuildRequires:  harfbuzz-icu-devel
38BuildRequires:  libicu-devel
39BuildRequires:  libjpeg-turbo-devel
40BuildRequires:  libpng-devel
41BuildRequires:  libsecret-devel
42BuildRequires:  libsoup-devel
43BuildRequires:  libwebp-devel
44BuildRequires:  libxslt-devel
45BuildRequires:  libXt-devel
46BuildRequires:  mesa-libGL-devel
47BuildRequires:  pcre-devel
48BuildRequires:  ruby
49BuildRequires:  sqlite3-devel
50BuildRequires:  libnotify-devel
51BuildRequires:  hyphen-devel
52%ifarch ppc
53BuildRequires:  libatomic
54%endif
55Requires:       geoclue2
56
57# Obsolete libwebkit2gtk from the webkitgtk3 package
58Obsoletes:      libwebkit2gtk < 2.4.5-3
59Provides:       libwebkit2gtk = %{version}-%{release}
60
61# Filter out provides for private libraries
62%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
63
64%description
65WebKitGTK+ is the port of the portable web rendering engine WebKit to the
66GTK+ platform.
67
68This package contains WebKitGTK+ for GTK+ 3.
69
70%package        devel
71Summary:        Development files for %{name}
72Group:                  Development/Libraries
73Requires:       %{name} = %{version}-%{release}
74
75%description    devel
76The %{name}-devel package contains libraries, build data, and header
77files for developing applications that use %{name}.
78
79%prep
80%setup -q -n webkitgtk-%{version}
81%ifarch %{power64} aarch64 ppc
82%patch3 -p1 -b .commit_align
83%endif
84
85# Remove bundled libraries
86rm -rf Source/ThirdParty/leveldb/
87rm -rf Source/ThirdParty/gtest/
88rm -rf Source/ThirdParty/qunit/
89
90%build
91# binutils-2.23 doesn't support "reduce-memory-overheads"
92# Use linker flags to reduce memory consumption
93# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
94
95%ifarch s390 %{arm}
96# Decrease debuginfo verbosity to reduce memory consumption even more
97%global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
98%endif
99
100%ifarch ppc
101# Use linker flag -relax to get WebKit build under ppc(32) with JIT disabled
102%global optflags %{optflags} -Wl,-relax -latomic
103%endif
104
105%global optflags %{optflags} -DENABLE_YARR_JIT=0
106
107mkdir -p %{_target_platform}
108pushd %{_target_platform}
109%cmake \
110  -DPORT=GTK \
111  -DCMAKE_BUILD_TYPE=Release \
112  -DENABLE_JIT=OFF \
113  -DENABLE_LLINT_C_LOOP=ON \
114  ..
115popd
116
117make %{?_smp_mflags} -C %{_target_platform}
118
119%install
120%make_install -C %{_target_platform}
121
122%find_lang WebKit2GTK-4.0
123
124# Finally, copy over and rename various files for %%license inclusion
125%add_to_license_files Source/JavaScriptCore/COPYING.LIB
126%add_to_license_files Source/JavaScriptCore/icu/LICENSE
127%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
128%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
129%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/murmurhash/LICENSE
130%add_to_license_files Source/WebCore/icu/LICENSE
131%add_to_license_files Source/WebCore/LICENSE-APPLE
132%add_to_license_files Source/WebCore/LICENSE-LGPL-2
133%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
134%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
135%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
136%add_to_license_files Source/WTF/icu/LICENSE
137%add_to_license_files Source/WTF/wtf/dtoa/COPYING
138%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
139
140%post -p /sbin/ldconfig
141%postun -p /sbin/ldconfig
142
143%files -f WebKit2GTK-4.0.lang
144%license _license_files/*
145%{_libdir}/libjavascriptcoregtk-4.0.so.*
146%{_libdir}/libwebkit2gtk-4.0.so.*
147%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
148%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
149%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
150%{_libdir}/webkit2gtk-4.0/
151%{_libexecdir}/webkit2gtk-4.0/
152
153%files devel
154%{_bindir}/jsc
155%{_includedir}/webkitgtk-4.0/
156%{_libdir}/libjavascriptcoregtk-4.0.so
157%{_libdir}/libwebkit2gtk-4.0.so
158%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
159%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
160%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
161%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
162%{_datadir}/gir-1.0/WebKit2-4.0.gir
163%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
164
165%changelog
166* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
167- new upstream release
168- remove Patch0
169- add BuildRequires: libnotify-devel, hyphen-devel
170
171* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
172- rebuild with gnutls-3.4.7
173
174* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
175- rebuild with icu-56.1
176
177* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
178- new upstream release
179
180* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
181- new upstream release
182
183* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
184- new upstream release
185
186* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
187- new upstream release
188
189* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
190- new upstream release
191
192* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
193- new upstream release
194- update Patch0
195
196* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
197- new upstream release
198
199* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
200- add Group tag
201
202* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
203- new upstream release
204
205* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
206- new upstream release
207
208* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
209- initial build for Vine Linux
210
211
212* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
213- Add the wrongly removed CLoop patch and remove the one that was upstreamed
214
215* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
216- Update to 2.6.0
217
218* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
219- Update to 2.5.90
220
221* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
222- Obsolete libwebkit2gtk from the webkitgtk3 package
223
224* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
225- rebuild for ICU 53.1
226
227* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
228- Add support for secondary arches
229
230* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
231- Add webkitgtk-2.5.3-toggle-buttons.patch
232
233* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
234- More package review fixes (#1131284)
235- Correct the license tag to read LGPLv2
236- Filter out provides for private libraries
237
238* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
239- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
240
241* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
242- Update to 2.5.3
243
244* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
245- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.