source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 9909

Revision 9909, 7.6 KB checked in by Takemikaduchi, 8 years ago (diff)

NetworkManager: move file
others: rebuild with gnutls-3.4.7

Line 
1## NOTE: Lots of files in various subdirectories have the same name (such as
2## "LICENSE") so this short macro allows us to distinguish them by using their
3## directory names (from the source tree) as prefixes for the files.
4%global add_to_license_files() \
5        mkdir -p _license_files ; \
6        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
7
8Name:           webkitgtk4
9Version:        2.8.5
10Release:        3%{?_dist_release}
11Summary:        GTK+ Web content engine library
12
13License:        LGPLv2
14Group:                  Development/Libraries
15URL:            http://www.webkitgtk.org/
16Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
17
18Patch0:                 webkitgtk-2.7.4-nspluginwrapper.patch
19Patch2:         webkitgtk-2.5.90-cloop_fix.patch
20Patch3:         webkitgtk-2.5.2-commit_align.patch
21
22BuildRequires:  at-spi2-core-devel
23BuildRequires:  bison
24BuildRequires:  cairo-devel
25BuildRequires:  cmake
26BuildRequires:  enchant-devel
27BuildRequires:  flex
28BuildRequires:  fontconfig-devel
29BuildRequires:  freetype-devel
30BuildRequires:  geoclue2-devel
31BuildRequires:  gettext
32BuildRequires:  glib2-devel
33BuildRequires:  gobject-introspection-devel
34BuildRequires:  gperf
35BuildRequires:  gstreamer1-devel
36BuildRequires:  gstreamer1-plugins-base-devel
37BuildRequires:  gtk2-devel
38BuildRequires:  gtk3-devel
39BuildRequires:  harfbuzz-icu-devel
40BuildRequires:  libicu-devel
41BuildRequires:  libjpeg-turbo-devel
42BuildRequires:  libpng-devel
43BuildRequires:  libsecret-devel
44BuildRequires:  libsoup-devel
45BuildRequires:  libwebp-devel
46BuildRequires:  libxslt-devel
47BuildRequires:  libXt-devel
48BuildRequires:  mesa-libGL-devel
49BuildRequires:  pcre-devel
50BuildRequires:  ruby
51BuildRequires:  sqlite3-devel
52%ifarch ppc
53BuildRequires:  libatomic
54%endif
55Requires:       geoclue2
56
57# Obsolete libwebkit2gtk from the webkitgtk3 package
58Obsoletes:      libwebkit2gtk < 2.4.5-3
59Provides:       libwebkit2gtk = %{version}-%{release}
60
61# Filter out provides for private libraries
62%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
63
64%description
65WebKitGTK+ is the port of the portable web rendering engine WebKit to the
66GTK+ platform.
67
68This package contains WebKitGTK+ for GTK+ 3.
69
70%package        devel
71Summary:        Development files for %{name}
72Group:                  Development/Libraries
73Requires:       %{name} = %{version}-%{release}
74
75%description    devel
76The %{name}-devel package contains libraries, build data, and header
77files for developing applications that use %{name}.
78
79%prep
80%setup -q -n webkitgtk-%{version}
81%patch0 -p1 -b .nspluginwrapper
82#%patch2 -p1 -b .cloop_fix
83%ifarch %{power64} aarch64 ppc
84%patch3 -p1 -b .commit_align
85%endif
86
87# Remove bundled libraries
88rm -rf Source/ThirdParty/leveldb/
89rm -rf Source/ThirdParty/gtest/
90rm -rf Source/ThirdParty/qunit/
91
92%build
93# binutils-2.23 doesn't support "reduce-memory-overheads"
94# Use linker flags to reduce memory consumption
95# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
96
97%ifarch s390 %{arm}
98# Decrease debuginfo verbosity to reduce memory consumption even more
99%global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
100%endif
101
102%ifarch ppc
103# Use linker flag -relax to get WebKit build under ppc(32) with JIT disabled
104%global optflags %{optflags} -Wl,-relax -latomic
105%endif
106
107%global optflags %{optflags} -DENABLE_YARR_JIT=0
108
109mkdir -p %{_target_platform}
110pushd %{_target_platform}
111%cmake \
112  -DPORT=GTK \
113  -DCMAKE_BUILD_TYPE=Release \
114  -DENABLE_JIT=OFF \
115  -DENABLE_LLINT_C_LOOP=ON \
116  ..
117popd
118
119make %{?_smp_mflags} -C %{_target_platform}
120
121%install
122%make_install -C %{_target_platform}
123
124%find_lang WebKit2GTK-4.0
125
126# Finally, copy over and rename various files for %%license inclusion
127%add_to_license_files Source/JavaScriptCore/COPYING.LIB
128%add_to_license_files Source/JavaScriptCore/icu/LICENSE
129%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
130%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
131%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/murmurhash/LICENSE
132%add_to_license_files Source/WebCore/icu/LICENSE
133%add_to_license_files Source/WebCore/LICENSE-APPLE
134%add_to_license_files Source/WebCore/LICENSE-LGPL-2
135%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
136%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
137%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
138%add_to_license_files Source/WTF/icu/LICENSE
139%add_to_license_files Source/WTF/wtf/dtoa/COPYING
140%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
141
142%post -p /sbin/ldconfig
143%postun -p /sbin/ldconfig
144
145%files -f WebKit2GTK-4.0.lang
146%license _license_files/*
147%{_libdir}/libjavascriptcoregtk-4.0.so.*
148%{_libdir}/libwebkit2gtk-4.0.so.*
149%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
150%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
151%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
152%{_libdir}/webkit2gtk-4.0/
153%{_libexecdir}/webkit2gtk-4.0/
154
155%files devel
156%{_bindir}/jsc
157%{_includedir}/webkitgtk-4.0/
158%{_libdir}/libjavascriptcoregtk-4.0.so
159%{_libdir}/libwebkit2gtk-4.0.so
160%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
161%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
162%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
163%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
164%{_datadir}/gir-1.0/WebKit2-4.0.gir
165%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
166
167%changelog
168* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
169- rebuild with gnutls-3.4.7
170
171* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
172- rebuild with icu-56.1
173
174* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
175- new upstream release
176
177* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
178- new upstream release
179
180* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
181- new upstream release
182
183* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
184- new upstream release
185
186* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
187- new upstream release
188
189* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
190- new upstream release
191- update Patch0
192
193* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
194- new upstream release
195
196* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
197- add Group tag
198
199* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
200- new upstream release
201
202* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
203- new upstream release
204
205* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
206- initial build for Vine Linux
207
208
209* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
210- Add the wrongly removed CLoop patch and remove the one that was upstreamed
211
212* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
213- Update to 2.6.0
214
215* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
216- Update to 2.5.90
217
218* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
219- Obsolete libwebkit2gtk from the webkitgtk3 package
220
221* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
222- rebuild for ICU 53.1
223
224* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
225- Add support for secondary arches
226
227* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
228- Add webkitgtk-2.5.3-toggle-buttons.patch
229
230* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
231- More package review fixes (#1131284)
232- Correct the license tag to read LGPLv2
233- Filter out provides for private libraries
234
235* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
236- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
237
238* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
239- Update to 2.5.3
240
241* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
242- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.