source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 12005

Revision 12005, 9.4 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

RevLine 
[12005]1%bcond_without clang
2
[9073]3## NOTE: Lots of files in various subdirectories have the same name (such as
4## "LICENSE") so this short macro allows us to distinguish them by using their
5## directory names (from the source tree) as prefixes for the files.
6%global add_to_license_files() \
7        mkdir -p _license_files ; \
8        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
9
10Name:           webkitgtk4
[12005]11Version:        2.22.5
[11372]12Release:        1%{?_dist_release}
[9073]13Summary:        GTK+ Web content engine library
14
15License:        LGPLv2
[11436]16Group:                  System Environment/Libraries
[9073]17URL:            http://www.webkitgtk.org/
[10430]18Vendor:         Project Vine
19Distribution:   Vine Linux
20
[9073]21Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
22
23Patch3:         webkitgtk-2.5.2-commit_align.patch
24
[12005]25%if %{with clang}
26BuildRequires:  clang
27BuildRequires:  lld
28%endif
[9073]29BuildRequires:  at-spi2-core-devel
30BuildRequires:  bison
31BuildRequires:  cairo-devel
32BuildRequires:  cmake
33BuildRequires:  enchant-devel
34BuildRequires:  flex
35BuildRequires:  fontconfig-devel
36BuildRequires:  freetype-devel
37BuildRequires:  geoclue2-devel
38BuildRequires:  gettext
39BuildRequires:  glib2-devel
40BuildRequires:  gobject-introspection-devel
41BuildRequires:  gperf
42BuildRequires:  gstreamer1-devel
43BuildRequires:  gstreamer1-plugins-base-devel
44BuildRequires:  gtk2-devel
45BuildRequires:  gtk3-devel
46BuildRequires:  harfbuzz-icu-devel
47BuildRequires:  libicu-devel
48BuildRequires:  libjpeg-turbo-devel
49BuildRequires:  libpng-devel
50BuildRequires:  libsecret-devel
51BuildRequires:  libsoup-devel
52BuildRequires:  libwebp-devel
53BuildRequires:  libxslt-devel
54BuildRequires:  libXt-devel
55BuildRequires:  mesa-libGL-devel
56BuildRequires:  pcre-devel
57BuildRequires:  ruby
58BuildRequires:  sqlite3-devel
[10250]59BuildRequires:  libnotify-devel
60BuildRequires:  hyphen-devel
[12005]61BuildRequires:  woff2-devel
[9073]62%ifarch ppc
63BuildRequires:  libatomic
64%endif
65Requires:       geoclue2
66
[11436]67# Require the jsc subpackage
68Requires:       %{name}-jsc = %{version}-%{release}
69
[9073]70# Obsolete libwebkit2gtk from the webkitgtk3 package
71Obsoletes:      libwebkit2gtk < 2.4.5-3
72Provides:       libwebkit2gtk = %{version}-%{release}
73
74# Filter out provides for private libraries
75%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
76
77%description
78WebKitGTK+ is the port of the portable web rendering engine WebKit to the
79GTK+ platform.
80
81This package contains WebKitGTK+ for GTK+ 3.
82
83%package        devel
84Summary:        Development files for %{name}
[9121]85Group:                  Development/Libraries
[9073]86Requires:       %{name} = %{version}-%{release}
[11436]87Requires:       %{name}-jsc-devel = %{version}-%{release}
[9073]88
89%description    devel
90The %{name}-devel package contains libraries, build data, and header
91files for developing applications that use %{name}.
92
[11436]93%package        jsc
94Summary:        JavaScript engine from %{name}
95Group:                  System Environment/Libraries
96
97%description    jsc
98This package contains JavaScript engine from %{name}.
99
100%package        jsc-devel
101Summary:        Development files for JavaScript engine from %{name}
102Group:                  Development/Libraries
103Requires:       %{name}-jsc = %{version}-%{release}
104
105%description    jsc-devel
106The %{name}-jsc-devel package contains libraries, build data, and header
107files for developing applications that use JavaScript engine from %{name}.
108
109
[9073]110%prep
111%setup -q -n webkitgtk-%{version}
112%ifarch %{power64} aarch64 ppc
113%patch3 -p1 -b .commit_align
114%endif
115
116# Remove bundled libraries
117rm -rf Source/ThirdParty/leveldb/
118rm -rf Source/ThirdParty/gtest/
119rm -rf Source/ThirdParty/qunit/
120
121%build
[9475]122# binutils-2.23 doesn't support "reduce-memory-overheads"
[9073]123# Use linker flags to reduce memory consumption
[9475]124# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
[9073]125
[12005]126%if %{with clang}
127%ifnarch x86_64
128%define cflags_add --rtlib=compiler-rt
[9073]129%endif
130
[12005]131%global optflags  %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
132%else
133%global optflags  %{optflags} -DENABLE_YARR_JIT=0
[9073]134%endif
135
136mkdir -p %{_target_platform}
137pushd %{_target_platform}
[12005]138
139export CC=clang
140export CXX=clang++
141export LD=ld.lld
142
[9073]143%cmake \
[12005]144%if %{with clang}
145  -DCOMPILER_IS_CLANG=ON \
146  -DCMAKE_CXX_COMPILER=clang++ \
147%endif
[9073]148  -DPORT=GTK \
149  -DCMAKE_BUILD_TYPE=Release \
150  -DENABLE_JIT=OFF \
151  -DENABLE_LLINT_C_LOOP=ON \
[12005]152  -DUSE_GSTREAMER_GL=OFF \
[9073]153  ..
154popd
155
156make %{?_smp_mflags} -C %{_target_platform}
157
158%install
159%make_install -C %{_target_platform}
160
161%find_lang WebKit2GTK-4.0
162
163# Finally, copy over and rename various files for %%license inclusion
164%add_to_license_files Source/JavaScriptCore/COPYING.LIB
165%add_to_license_files Source/JavaScriptCore/icu/LICENSE
166%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
167%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
168%add_to_license_files Source/WebCore/icu/LICENSE
169%add_to_license_files Source/WebCore/LICENSE-APPLE
170%add_to_license_files Source/WebCore/LICENSE-LGPL-2
171%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
172%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
173%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
174%add_to_license_files Source/WTF/icu/LICENSE
175%add_to_license_files Source/WTF/wtf/dtoa/COPYING
176%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
177
178%post -p /sbin/ldconfig
179%postun -p /sbin/ldconfig
[11436]180%post jsc -p /sbin/ldconfig
181%postun jsc -p /sbin/ldconfig
[9073]182
183%files -f WebKit2GTK-4.0.lang
184%license _license_files/*
185%{_libdir}/libwebkit2gtk-4.0.so.*
186%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
187%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
188%{_libdir}/webkit2gtk-4.0/
[11436]189%{_libexecdir}/webkit2gtk-4.0/*
190%exclude %{_libexecdir}/webkit2gtk-4.0/jsc
[11372]191%{_bindir}/WebKitWebDriver
[9073]192
[11436]193%files jsc
194%license _license_files/*JavaScriptCore*
195%dir %{_libexecdir}/webkit2gtk-4.0/
196%{_libexecdir}/webkit2gtk-4.0/jsc
197%{_libdir}/libjavascriptcoregtk-4.0.so.*
198%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
199
[9073]200%files devel
[11436]201%{_includedir}/webkitgtk-4.0/*
202%exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
[9073]203%{_libdir}/libwebkit2gtk-4.0.so
204%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
205%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
206%{_datadir}/gir-1.0/WebKit2-4.0.gir
207%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
208
[11436]209%files jsc-devel
210%dir %{_includedir}/webkitgtk-4.0
211%{_includedir}/webkitgtk-4.0/JavaScriptCore/
212%{_libdir}/libjavascriptcoregtk-4.0.so
213%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
214%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
215
[9073]216%changelog
[12005]217* Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
218- new upstream release.
219
[11436]220* Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
221- new upstream release.
222- added subpackages webkitgtk4-jsc{,-devel}.
223
[11372]224* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
225- new upstream release.
226
[10430]227* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
228- rebuilt with new toolchain.
229
[10369]230* Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
231- new upstream release
232  (including security fix for CVE-2016-1856,1857)
233
[10250]234* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
235- new upstream release
236- remove Patch0
237- add BuildRequires: libnotify-devel, hyphen-devel
238
[9909]239* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
240- rebuild with gnutls-3.4.7
241
[9791]242* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
243- rebuild with icu-56.1
244
[9715]245* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
246- new upstream release
247
[9672]248* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
249- new upstream release
250
[9573]251* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
252- new upstream release
253
[9569]254* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
255- new upstream release
256
[9520]257* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
258- new upstream release
259
[9475]260* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
261- new upstream release
262- update Patch0
263
[9398]264* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
265- new upstream release
266
[9121]267* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
268- add Group tag
269
[9115]270* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
271- new upstream release
272
[9102]273* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
274- new upstream release
275
[9073]276* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
277- initial build for Vine Linux
278
279
280* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
281- Add the wrongly removed CLoop patch and remove the one that was upstreamed
282
283* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
284- Update to 2.6.0
285
286* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
287- Update to 2.5.90
288
289* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
290- Obsolete libwebkit2gtk from the webkitgtk3 package
291
292* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
293- rebuild for ICU 53.1
294
295* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
296- Add support for secondary arches
297
298* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
299- Add webkitgtk-2.5.3-toggle-buttons.patch
300
301* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
302- More package review fixes (#1131284)
303- Correct the license tag to read LGPLv2
304- Filter out provides for private libraries
305
306* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
307- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
308
309* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
310- Update to 2.5.3
311
312* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
313- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.