source: projects/specs/trunk/w/w3m/w3m-vl.spec @ 8957

Revision 8957, 12.7 KB checked in by inagaki, 10 years ago (diff)

2014-09-18 Ryoichi INAGAKI <ryo1@…>

  • eboard, kasumi, w3m and xmlto: removed libpng12 denpendency


Line 
1#define __perl_requires %{_rpmconfigdir}/perl.req | grep -v w3mhelp
2#define __find_requires /bin/true
3
4%define _docdir %{_defaultdocdir}
5
6#%define cvsdate 20060815
7
8Summary: A Pager with WWW capability
9Summary(ja): World Wide Web に対応したページャ
10Name: w3m
11Version: 0.5.3
12Release: 2%{?_dist_release}
13
14License: BSD
15Group: Applications/Internet
16URL: http://w3m.sourceforge.net/
17
18Source0: %{name}-%{version}.tar.gz
19Source1: w3m.sh
20Source2: w3m.csh
21Source10: w3m-term
22Source11: filter-requires-w3m.sh
23
24Patch200: w3m-fh-def.patch
25Patch201: w3m-gc7.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: gc-devel >= 7.0
29BuildRequires: gtk2-devel
30BuildRequires: ncurses-devel
31BuildRequires: openssl-devel >= 0.9
32BuildRequires: sed
33Requires: perl
34Requires: openssl >= 0.9
35Requires(post): alternatives
36Requires(preun): alternatives
37
38Provides: webclient, pager
39Obsoletes: w3m-m17n
40
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: shaolin
45
46# work around for [VineSeed-x86_64:00178]
47%define __perl_requires %{SOURCE11}
48
49%description
50w3m is a pager with WWW capability. It IS a pager, but it can be
51used as a text-mode WWW browser. The features of w3m are as follows:
52- When reading HTML document, you can follow links and view images
53  (using external image viewer).
54- It has 'internet message mode', which determines the type of document
55  from header. If the Content-Type: field of the document is text/html,
56  that document is displayed as HTML document.
57- You can change URL description like 'http://hogege.net' in plain text
58  into link to that URL.
59
60%description -l ja
61w3m は,ページャfmをベースに開発された World Wide Web に対応したページャ
62です.fm の機能に加えて、w3m の特徴には,次のようなものがあります.
63
64・WWW 対応なので,HTML の文書を読んでいる時には,その中のリンクを辿った
65  り,画像を見ることができる.
66・Internet message 表示のためのモードがある.この時,Content-Type: が
67  text/html の場合は,自動的に HTML の文書として表示する.また,自力で
68 MIME header のデコードをする.
69・見ている plain text 文書中に URL 表記があった場合,その部分からリンク
70  をたどることができる.
71
72%package img
73Summary: inline image extension support utilities for w3m
74Summary(ja): w3m 用インライン画像拡張サポートユーティリティ
75Group: Applications/Internet
76Requires: %{name} = %{version}-%{release}
77
78%description img
79w3m-img provides some utilities to support inline
80images for w3m
81on terminal emulator in X Window System environments.
82
83%description -l ja img
84w3m-img は X 環境のターミナルエミュレータ上の w3m でインライン画像を
85表示するためのユーティリティです。
86
87%prep
88%setup -q
89%patch200 -p0 -b .fh
90%patch201 -p1 -b .gc7
91
92find Bonus -type f | \
93    xargs sed -i -e "s|/usr/local/bin/ruby|/usr/bin/ruby|g;"
94
95%build
96%configure \
97        --enable-japanese=E \
98        --with-termlib=ncurses \
99        --enable-image=x11 \
100        --with-imagelib=gtk2 \
101        --with-browser=gnome-open \
102        --with-mailer=gnome-open \
103        --with-editor=%{_sysbindir}/vi
104sed -i -e 's|#define USE_GPM 1|/* #undef USE_GPM */|' config.h
105sed -i -e 's|\-lgpm||g' Makefile
106sed -i -e 's|\-ldl|\-ldl \-lX11|g' Makefile
107make %{?_smp_mflags}
108
109%install
110rm -rf %{buildroot}
111make install DESTDIR=%{buildroot}
112
113mkdir -p %{buildroot}/etc/profile.d
114cp %{SOURCE1} %{buildroot}/etc/profile.d/w3m.sh
115cp %{SOURCE2} %{buildroot}/etc/profile.d/w3m.csh
116
117mkdir -p %{buildroot}%{_bindir}
118cp %{SOURCE10} %{buildroot}%{_bindir}/w3m-term
119chmod +x %{buildroot}%{_bindir}/w3m-term
120
121mkdir -p %{buildroot}%{_mandir}/{man1,ja/man1}
122install -p -m 644 doc-jp/w3m.1 %{buildroot}%{_mandir}/ja/man1
123install -p -m 644 doc/w3m.1 %{buildroot}%{_mandir}/man1
124# dont include duplicated man pages and CVS directory in doc
125rm -f doc-jp/w3m.1 doc/w3m.1
126find . -type d -name "CVS" | xargs rm -rf
127
128# prepare system-wide preference file
129mkdir -p %{buildroot}%{_sysconfdir}/w3m
130
131# prepare applnk
132%define applnkdir /etc/X11/applnk/Internet
133mkdir -p %{buildroot}/%{applnkdir}
134cat > %{buildroot}/%{applnkdir}/%{name}.desktop <<EOF
135[Desktop Entry]
136Name=%{name}
137Type=Application
138Comment=A Pager with WWW capability
139Comment[ja]=WWW対応ページャ
140Exec=w3m-term
141Terminal=false
142EOF
143
144# eliminate executable bit in %doc
145find Bonus/ -type f -perm +111 | xargs -r chmod -x
146
147
148%clean
149rm -rf %{buildroot}
150
151%post
152%{_syssbindir}/update-alternatives --install /usr/bin/pager pager /usr/bin/w3m 30
153
154%preun
155if [ "$1" = "0" ]; then
156  %{_syssbindir}/update-alternatives --remove pager /usr/bin/w3m
157fi
158
159
160%files
161%defattr(-,root,root)
162%doc Bonus ChangeLog NEWS README doc doc-jp
163%attr(755,root,root) %config /etc/profile.d/*
164%config(missingok) %{applnkdir}/%{name}.desktop
165%dir %{_sysconfdir}/w3m
166%{_bindir}/w3m*
167%exclude %{_libexecdir}/w3m/w3mimgdisplay
168%{_libexecdir}/w3m/
169%{_datadir}/w3m/
170%{_datadir}/locale/*/LC_MESSAGES/*
171%{_mandir}/ja/man1/w3m.1*
172%{_mandir}/man1/w3m*
173
174%files img
175%{_libexecdir}/w3m/w3mimgdisplay
176
177%changelog
178* Mon Sep 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.5.3-2
179- updated Source11 to call /usr/lib/rpm/perl.req
180- added Patch200 and 201 for building current environment
181- rebuilt for removing libpng12 dependency
182
183* Thu Apr 21 2011 IWAI, Masaharu <iwai@alib.jp> 0.5.3-1
184- new upstream release
185- drop unnecessary patches: upstream fixed
186 - ambwidth patch (Patch10)
187 - sudden crash patch (Patch11)
188 - x86_64 patch (Patch100)
189
190* Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.5.2-7
191- rebuild with openssl-1.0.0c
192- add Patch100 (w3m-0.5.2-x86_64-vine.patch)
193
194* Sun Sep 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-6
195- add Patch10 to fix display utf8 ambiguous width characters
196  (from: http://www.j10n.org/files/w3m-cvs-1.914-ambwidth.patch)
197- add Patch11 to fix sudden crash
198  (from: http://www.sic.med.tohoku.ac.jp/~satodai/w3m-dev/200708.month/4286.html)
199
200* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-5
201- rebuilt with gcc-4.4.3-3 on ppc
202
203* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-4
204- rebuilt with new toolchain
205
206* Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-2
207- spec in utf-8
208- remove Requires: indexhtml
209- set HTTP_HOME to http://vinelinux.org/
210- update w3m-term
211
212* Wed Apr 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.2-1
213- new upstream release
214- dropped Patch100 (merged into upstream)
215
216* Sun Jun  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1.20060815-0vl6
217- rebuilt with new toolchain and environment
218
219* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl5
220- add Provides: pager
221- add Requires(post,preun): alternatives
222
223* Tue Apr 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl3
224- add update-alternatives: pager in %post and %preun scriptlet
225
226* Fri Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
227- 0.5.1.20060815-0vl2
228- rebuilt for VineSeed
229
230* Sat Dec 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
231- 0.5.1.20060815-0vl1.1
232- add patch100 for fix "inputAnswer()" SSL Certificate Handling Vulnerabilit
233
234* Tue Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp>
235- update to cvs snapshot
236- use gtk2 for w3m-img instead of gdk-pixbuf
237
238* Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.5.1-0vl6
239- use filter-requires-w3m.sh as find-requires (rpm's bug?)
240
241* Sat Sep 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl5
242- use %%{_docdir}/Vine/index.html as default homepage
243
244* Sun Jul 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl4
245- change default editor to %%{_sysbindir}/vi
246- use ncurses explicitly as termlib
247
248* Sun Jul 11 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl3
249- fix typo
250- add BuildPrereq: gtk+-devel, gdk-pixbuf-devel
251
252* Wed Jul 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
253- rebuild without gpm
254
255* Wed May  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
256- new upstream release
257- Obsoletes: w3m-m17n
258
259* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl2
260- add message catalogs to %%files
261
262* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl1
263- new upstream release
264- fix w3mimgdisplay path in w3m-term
265
266* Sun Dec 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
267- new upstream release
268- split w3mimgdisplay to w3m-img subpackage.
269- Requires: gc >= 6.2
270
271* Sat May 31 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.4.1-0vl1
272- new upstream release
273
274* Tue Feb 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4-0vl1
275- new upstream release
276
277* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.2-0vl1
278- new upstream release.
279  w3m 0.3.2.2 - 2002-12-06
280  * security fix: html_quote for img alt attributes
281
282* Fri Nov 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl2
283- change default page path to /usr/doc/HTML.
284  this should be changed to /usr/share/doc in next release.
285  ( TODO: indexhtml package )
286
287* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl1
288- new upstream release
289  w3m 0.3.2.1 - 2002-11-27
290  * security fix: html_quote for frame contents
291  * backport from w3m 0.3.2+cvs
292    - fix segmentation fault by large complex table.
293      [w3m-dev 03371][w3m-dev 03438]
294
295* Wed Nov  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
296- new upstream release
297  w3m 0.3.2 - 2002-11-05
298  * ~/.netrc: password for ftp
299  * rc: display_lineinfo: display current line number
300  * rc: passwd_file: passwd file for HTTP auth
301  * func: MARK_WORD
302  * rc: imgsize: obsoleted
303  * w3m-img for framebuffer merged
304
305* Mon Sep 30 2002 Tomoya TAKA <taka@vinelinux.org> 0.3.1-0vl2
306- replace gc with an old version on alpha (Source20)
307
308* Wed Jul 17 2002 IWAI Masaharu <iwai@alib.jp> 0.3.1-0vl1
309- upstream release
310- coped new configure options
311
312* Sun Apr 21 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.3-0vl2
313- fixed configure option ([VineSeed:06372])
314- added openssl-devel version in {Build,}Requires
315
316* Mon Mar 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3-0vl1
317- updated in sync with upstream 0.3 release
318  (now w3m-img patch is included in the upstream version)
319
320* Tue Feb 05 2002 Toru Sagami <sagami@vinelinux.org> 0.2.5-0vl1
321- w3m-0.2.5 with 0.2.5+cvs-1.302
322
323* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl2
324- eliminate executable bit in %doc
325- spec cleanup
326
327* Wed Jan 16 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl1
328- updated to current stable release
329
330* Thu Jan 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.3.2-0vl1
331- updated to new upstream release
332- FIXME: system-wide /etc/w3m/w3mconfig should be prepared. Anyone? :)
333
334* Fri Sep 28 2001 <masato@nets.ce.hiroshima-cu.ac.jp>
335- 0.2.1-0vl9
336- added sparc patch
337
338* Thu Aug 23 2001 <shom@vinelinux.org>
339- 0.2.1-0vl8: add w3m-term script
340
341* Mon Aug 06 2001 <sagami@vinelinux.org>
342- 0.2.1-0vl7: added imlib-devel ncurses-devel for BuildPreReq
343- update img patch to version 1.10 from 1.9
344
345* Mon Aug  6 2001 Jun Nishii <jun@vinelinux.org> 0.2.1-0vl6
346- added img patch
347
348* Mon Jul 16 2001 <sagami@vinelinux.org>
349- 0.2.1-0vl5: spec file clean up
350- openssl-devel for BuildPrereq, not openssl
351- install more sophisticated w3m.sh w3m.csh with any %%{_docdir} definition
352
353* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
354- 0.2.1-0vl4
355- rebuilt with openssl-0.9.6b
356
357* Sun Jun 24 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
358- 0.2.1-0vl3
359- security fixes (http://www.lac.co.jp/security/snsadv/32.html)
360
361* Sat Jun 09 2001 <sagami@vinelinux.org>
362- 0.2.1-0vl2: minor spec fixes(URL, License and etc.)
363- actually rebuilt with ncurses5 (i386)
364
365* Sat Mar 24 2001 Yoichi Imai <yoichi@silver-forest.com>
366- 0.2.1-0vl1
367
368* Wed Dec 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
369- 0.1.10-0vl6
370- use better macros
371- rebuilt with ncurses5
372
373* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
374- w3m-0.1.10-0vl5
375- use applnk instead of wmconfig
376- use openssl
377
378* Thu Jul 27 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
379- w3m-0.1.10-0vl4
380- fix typo in w3m.csh and w3m.wmconfig
381
382* Sun Jul 09 2000 Toru Sagami <czs14350@nifty.ne.jp>
383- w3m-0.1.10-0vl3
384- provide default HTTP_HOME in /etc/profile.d
385
386* Fri Jul 07 2000 Toru Sagami <czs14350@nifty.ne.jp>
387- Provides: webclient, Requires: indexhtml (capability of lynx)
388- added w3m.wmconfig
389- give them(who?) RPM_OPT_FLAGS(what?)
390- dont include duplicated man pages and CVS directory in doc
391
392* Wed Jun 21 2000 Jun Nishii <jun@vinelinux.org>
393- 0.1.10-0vl1
394
395* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
396- fix spec file
397
398* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
399- updated from 0.1.4 to 0.1.6
400
401* Thu Jan 13 2000 Yoichi Imai <yoichi@silver-forest.com>
402- updated from 991203 to 0.1.4
403
404* Fri Dec 03 1999 Yoichi Imai <yoichi@silver-forest.com>
405- updated from 991028 to 991203
406
407* Sat Oct 30 1999 Yoichi Imai <bonaim@mutt.freemail.ne.jp>
408- updated from 990820 to 991028
409
410* Thu Aug 26 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
411- updated from 990716 to 990820
412
413* Wed Aug 11 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
414- initial Release to VinePlus
Note: See TracBrowser for help on using the repository browser.