source: projects/specs/trunk/w/w3m/w3m-vl.spec @ 521

Revision 521, 11.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _docdir %{_defaultdocdir}
2
3%define cvsdate 20060815
4
5Summary: A Pager with WWW capability
6Summary(ja): World Wide Web に対応したページャ
7Name: w3m
8Version: 0.5.2
9Release: 5%{?_dist_release}
10Group: Applications/Internet
11License: BSD
12URL: http://w3m.sourceforge.net/
13Source0: %{name}-%{version}.tar.gz
14Source1: w3m.sh
15Source2: w3m.csh
16Source10: w3m-term
17Source11: filter-requires-w3m.sh
18
19Requires: perl, openssl >= 0.9, gc >= 6.2
20Requires(post,preun): alternatives
21Provides: webclient, pager
22Obsoletes: w3m-m17n
23
24BuildRequires: openssl-devel >= 0.9
25BuildRequires: ncurses-devel
26BuildRequires: gc-devel >= 6.2
27BuildRequires: sed
28BuildRequires: gtk2-devel
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30
31Vendor: Project Vine
32Distribution: Vine Linux
33
34# work around for [VineSeed-x86_64:00178]
35%define __find_requires %{SOURCE11}
36
37%description
38w3m is a pager with WWW capability. It IS a pager, but it can be
39used as a text-mode WWW browser. The features of w3m are as follows:
40- When reading HTML document, you can follow links and view images
41  (using external image viewer).
42- It has 'internet message mode', which determines the type of document
43  from header. If the Content-Type: field of the document is text/html,
44  that document is displayed as HTML document.
45- You can change URL description like 'http://hogege.net' in plain text
46  into link to that URL.
47
48%description -l ja
49w3m は,ページャfmをベースに開発された World Wide Web に対応したページャ
50です.fm の機能に加えて、w3m の特徴には,次のようなものがあります.
51
52・WWW 対応なので,HTML の文書を読んでいる時には,その中のリンクを辿った
53  り,画像を見ることができる.
54・Internet message 表示のためのモードがある.この時,Content-Type: が
55  text/html の場合は,自動的に HTML の文書として表示する.また,自力で
56 MIME header のデコードをする.
57・見ている plain text 文書中に URL 表記があった場合,その部分からリンク
58  をたどることができる.
59
60%package img
61Summary: inline image extension support utilities for w3m
62Summary(ja): w3m 用インライン画像拡張サポートユーティリティ
63Group: Applications/Internet
64Requires: %{name} = %{version}-%{release}
65
66%description img
67w3m-img provides some utilities to support inline
68images for w3m
69on terminal emulator in X Window System environments.
70
71%description -l ja img
72w3m-img は X 環境のターミナルエミュレータ上の w3m でインライン画像を
73表示するためのユーティリティです。
74
75%prep
76%setup -q
77find Bonus -type f | \
78    xargs sed -i -e "s|/usr/local/bin/ruby|/usr/bin/ruby|g;"
79
80%build
81%configure \
82        --enable-japanese=E \
83        --with-termlib=ncurses \
84        --enable-image=x11 \
85        --with-imagelib=gtk2 \
86        --with-browser=gnome-open \
87        --with-mailer=gnome-open \
88        --with-editor=%{_sysbindir}/vi
89sed -i -e 's|#define USE_GPM 1|/* #undef USE_GPM */|' config.h
90sed -i -e 's|\-lgpm||g' Makefile
91make %{?_smp_mflags}
92
93
94%install
95rm -rf %{buildroot}
96make install DESTDIR=%{buildroot}
97
98mkdir -p %{buildroot}/etc/profile.d
99cp %{SOURCE1} %{buildroot}/etc/profile.d/w3m.sh
100cp %{SOURCE2} %{buildroot}/etc/profile.d/w3m.csh
101
102mkdir -p %{buildroot}%{_bindir}
103cp %{SOURCE10} %{buildroot}%{_bindir}/w3m-term
104chmod +x %{buildroot}%{_bindir}/w3m-term
105
106mkdir -p %{buildroot}%{_mandir}/{man1,ja/man1}
107install -p -m 644 doc-jp/w3m.1 %{buildroot}%{_mandir}/ja/man1
108install -p -m 644 doc/w3m.1 %{buildroot}%{_mandir}/man1
109# dont include duplicated man pages and CVS directory in doc
110rm -f doc-jp/w3m.1 doc/w3m.1
111find . -type d -name "CVS" | xargs rm -rf
112
113# prepare system-wide preference file
114mkdir -p %{buildroot}%{_sysconfdir}/w3m
115
116# prepare applnk
117%define applnkdir /etc/X11/applnk/Internet
118mkdir -p %{buildroot}/%{applnkdir}
119cat > %{buildroot}/%{applnkdir}/%{name}.desktop <<EOF
120[Desktop Entry]
121Name=%{name}
122Type=Application
123Comment=A Pager with WWW capability
124Comment[ja]=WWW対応ページャ
125Exec=w3m-term
126Terminal=false
127EOF
128
129# eliminate executable bit in %doc
130find Bonus/ -type f -perm +111 | xargs -r chmod -x
131
132
133%clean
134rm -rf %{buildroot}
135
136%post
137%{_syssbindir}/update-alternatives --install /usr/bin/pager pager /usr/bin/w3m 30
138
139%preun
140if [ "$1" = "0" ]; then
141  %{_syssbindir}/update-alternatives --remove pager /usr/bin/w3m
142fi
143
144
145%files
146%defattr(-,root,root)
147%doc Bonus ChangeLog NEWS README doc doc-jp
148%attr(755,root,root) %config /etc/profile.d/*
149%config(missingok) %{applnkdir}/%{name}.desktop
150%dir %{_sysconfdir}/w3m
151%{_bindir}/w3m*
152%exclude %{_libexecdir}/w3m/w3mimgdisplay
153%{_libexecdir}/w3m/
154%{_datadir}/w3m/
155%{_datadir}/locale/*/LC_MESSAGES/*
156%{_mandir}/ja/man1/w3m.1*
157%{_mandir}/man1/w3m*
158
159%files img
160%{_libexecdir}/w3m/w3mimgdisplay
161
162%changelog
163* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-5
164- rebuilt with gcc-4.4.3-3 on ppc
165
166* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-4
167- rebuilt with new toolchain
168
169* Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-2
170- spec in utf-8
171- remove Requires: indexhtml
172- set HTTP_HOME to http://vinelinux.org/
173- update w3m-term
174
175* Wed Apr 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.2-1
176- new upstream release
177- dropped Patch100 (merged into upstream)
178
179* Sun Jun  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1.20060815-0vl6
180- rebuilt with new toolchain and environment
181
182* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl5
183- add Provides: pager
184- add Requires(post,preun): alternatives
185
186* Tue Apr 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl3
187- add update-alternatives: pager in %post and %preun scriptlet
188
189* Fri Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
190- 0.5.1.20060815-0vl2
191- rebuilt for VineSeed
192
193* Sat Dec 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
194- 0.5.1.20060815-0vl1.1
195- add patch100 for fix "inputAnswer()" SSL Certificate Handling Vulnerabilit
196
197* Tue Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp>
198- update to cvs snapshot
199- use gtk2 for w3m-img instead of gdk-pixbuf
200
201* Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.5.1-0vl6
202- use filter-requires-w3m.sh as find-requires (rpm's bug?)
203
204* Sat Sep 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl5
205- use %%{_docdir}/Vine/index.html as default homepage
206
207* Sun Jul 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl4
208- change default editor to %%{_sysbindir}/vi
209- use ncurses explicitly as termlib
210
211* Sun Jul 11 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl3
212- fix typo
213- add BuildPrereq: gtk+-devel, gdk-pixbuf-devel
214
215* Wed Jul 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
216- rebuild without gpm
217
218* Wed May  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
219- new upstream release
220- Obsoletes: w3m-m17n
221
222* Fri Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl2
223- add message catalogs to %%files
224
225* Fri Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl1
226- new upstream release
227- fix w3mimgdisplay path in w3m-term
228
229* Sun Dec 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
230- new upstream release
231- split w3mimgdisplay to w3m-img subpackage.
232- Requires: gc >= 6.2
233
234* Sat May 31 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.4.1-0vl1
235- new upstream release
236
237* Tue Feb 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4-0vl1
238- new upstream release
239
240* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.2-0vl1
241- new upstream release.
242  w3m 0.3.2.2 - 2002-12-06
243  * security fix: html_quote for img alt attributes
244
245* Fri Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl2
246- change default page path to /usr/doc/HTML.
247  this should be changed to /usr/share/doc in next release.
248  ( TODO: indexhtml package )
249
250* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl1
251- new upstream release
252  w3m 0.3.2.1 - 2002-11-27
253  * security fix: html_quote for frame contents
254  * backport from w3m 0.3.2+cvs
255    - fix segmentation fault by large complex table.
256      [w3m-dev 03371][w3m-dev 03438]
257
258* Wed Nov  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
259- new upstream release
260  w3m 0.3.2 - 2002-11-05
261  * ~/.netrc: password for ftp
262  * rc: display_lineinfo: display current line number
263  * rc: passwd_file: passwd file for HTTP auth
264  * func: MARK_WORD
265  * rc: imgsize: obsoleted
266  * w3m-img for framebuffer merged
267
268* Mon Sep 30 2002 Tomoya TAKA <taka@vinelinux.org> 0.3.1-0vl2
269- replace gc with an old version on alpha (Source20)
270
271* Wed Jul 17 2002 IWAI Masaharu <iwai@alib.jp> 0.3.1-0vl1
272- upstream release
273- coped new configure options
274
275* Sun Apr 21 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.3-0vl2
276- fixed configure option ([VineSeed:06372])
277- added openssl-devel version in {Build,}Requires
278
279* Mon Mar 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3-0vl1
280- updated in sync with upstream 0.3 release
281  (now w3m-img patch is included in the upstream version)
282
283* Tue Feb 05 2002 Toru Sagami <sagami@vinelinux.org> 0.2.5-0vl1
284- w3m-0.2.5 with 0.2.5+cvs-1.302
285
286* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl2
287- eliminate executable bit in %doc
288- spec cleanup
289
290* Wed Jan 16 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl1
291- updated to current stable release
292
293* Thu Jan 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.3.2-0vl1
294- updated to new upstream release
295- FIXME: system-wide /etc/w3m/w3mconfig should be prepared. Anyone? :)
296
297* Fri Sep 28 2001 <masato@nets.ce.hiroshima-cu.ac.jp>
298- 0.2.1-0vl9
299- added sparc patch
300
301* Thu Aug 23 2001 <shom@vinelinux.org>
302- 0.2.1-0vl8: add w3m-term script
303
304* Mon Aug 06 2001 <sagami@vinelinux.org>
305- 0.2.1-0vl7: added imlib-devel ncurses-devel for BuildPreReq
306- update img patch to version 1.10 from 1.9
307
308* Mon Aug  6 2001 Jun Nishii <jun@vinelinux.org> 0.2.1-0vl6
309- added img patch
310
311* Mon Jul 16 2001 <sagami@vinelinux.org>
312- 0.2.1-0vl5: spec file clean up
313- openssl-devel for BuildPrereq, not openssl
314- install more sophisticated w3m.sh w3m.csh with any %%{_docdir} definition
315
316* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
317- 0.2.1-0vl4
318- rebuilt with openssl-0.9.6b
319
320* Sun Jun 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
321- 0.2.1-0vl3
322- security fixes (http://www.lac.co.jp/security/snsadv/32.html)
323
324* Sat Jun 09 2001 <sagami@vinelinux.org>
325- 0.2.1-0vl2: minor spec fixes(URL, License and etc.)
326- actually rebuilt with ncurses5 (i386)
327
328* Sat Mar 24 2001 Yoichi Imai <yoichi@silver-forest.com>
329- 0.2.1-0vl1
330
331* Wed Dec 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
332- 0.1.10-0vl6
333- use better macros
334- rebuilt with ncurses5
335
336* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
337- w3m-0.1.10-0vl5
338- use applnk instead of wmconfig
339- use openssl
340
341* Thu Jul 27 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
342- w3m-0.1.10-0vl4
343- fix typo in w3m.csh and w3m.wmconfig
344
345* Sun Jul 09 2000 Toru Sagami <czs14350@nifty.ne.jp>
346- w3m-0.1.10-0vl3
347- provide default HTTP_HOME in /etc/profile.d
348
349* Fri Jul 07 2000 Toru Sagami <czs14350@nifty.ne.jp>
350- Provides: webclient, Requires: indexhtml (capability of lynx)
351- added w3m.wmconfig
352- give them(who?) RPM_OPT_FLAGS(what?)
353- dont include duplicated man pages and CVS directory in doc
354
355* Wed Jun 21 2000 Jun Nishii <jun@vinelinux.org>
356- 0.1.10-0vl1
357
358* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
359- fix spec file
360
361* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
362- updated from 0.1.4 to 0.1.6
363
364* Thu Jan 13 2000 Yoichi Imai <yoichi@silver-forest.com>
365- updated from 991203 to 0.1.4
366
367* Fri Dec 03 1999 Yoichi Imai <yoichi@silver-forest.com>
368- updated from 991028 to 991203
369
370* Sat Oct 30 1999 Yoichi Imai <bonaim@mutt.freemail.ne.jp>
371- updated from 990820 to 991028
372
373* Tue Aug 26 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
374- updated from 990716 to 990820
375
376* Wed Aug 11 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
377- initial Release to VinePlus
Note: See TracBrowser for help on using the repository browser.