source: projects/specs/trunk/w/w3m/w3m-vl.spec @ 10290

Revision 10290, 12.9 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with openssl-1.0.2

Line 
1#define __perl_requires %{_rpmconfigdir}/perl.req | grep -v w3mhelp
2#define __find_requires /bin/true
3
4%define _docdir %{_defaultdocdir}
5
6#%define cvsdate 20060815
7
8Summary: A Pager with WWW capability
9Summary(ja): World Wide Web に対応したページャ
10Name: w3m
11Version: 0.5.3
12Release: 4%{?_dist_release}
13
14License: BSD
15Group: Applications/Internet
16URL: http://w3m.sourceforge.net/
17
18Source0: %{name}-%{version}.tar.gz
19Source1: w3m.sh
20Source2: w3m.csh
21Source10: w3m-term
22Source11: filter-requires-w3m.sh
23
24Patch200: w3m-fh-def.patch
25Patch201: w3m-gc7.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: gc-devel >= 7.0
29BuildRequires: gtk2-devel
30BuildRequires: ncurses-devel
31BuildRequires: openssl-devel >= 0.9
32BuildRequires: sed
33Requires: perl
34Requires: openssl >= 0.9
35Requires(post): alternatives
36Requires(preun): alternatives
37
38Provides: webclient, pager
39Obsoletes: w3m-m17n
40
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: shaolin
45
46# work around for [VineSeed-x86_64:00178]
47%define __perl_requires %{SOURCE11}
48
49%description
50w3m is a pager with WWW capability. It IS a pager, but it can be
51used as a text-mode WWW browser. The features of w3m are as follows:
52- When reading HTML document, you can follow links and view images
53  (using external image viewer).
54- It has 'internet message mode', which determines the type of document
55  from header. If the Content-Type: field of the document is text/html,
56  that document is displayed as HTML document.
57- You can change URL description like 'http://hogege.net' in plain text
58  into link to that URL.
59
60%description -l ja
61w3m は,ページャfmをベースに開発された World Wide Web に対応したページャ
62です.fm の機能に加えて、w3m の特徴には,次のようなものがあります.
63
64・WWW 対応なので,HTML の文書を読んでいる時には,その中のリンクを辿った
65  り,画像を見ることができる.
66・Internet message 表示のためのモードがある.この時,Content-Type: が
67  text/html の場合は,自動的に HTML の文書として表示する.また,自力で
68 MIME header のデコードをする.
69・見ている plain text 文書中に URL 表記があった場合,その部分からリンク
70  をたどることができる.
71
72%package img
73Summary: inline image extension support utilities for w3m
74Summary(ja): w3m 用インライン画像拡張サポートユーティリティ
75Group: Applications/Internet
76Requires: %{name} = %{version}-%{release}
77
78%description img
79w3m-img provides some utilities to support inline
80images for w3m
81on terminal emulator in X Window System environments.
82
83%description -l ja img
84w3m-img は X 環境のターミナルエミュレータ上の w3m でインライン画像を
85表示するためのユーティリティです。
86
87%prep
88%setup -q
89%patch200 -p0 -b .fh
90%patch201 -p1 -b .gc7
91
92find Bonus -type f | \
93    xargs sed -i -e "s|/usr/local/bin/ruby|/usr/bin/ruby|g;"
94
95%build
96%configure \
97        --enable-japanese=E \
98        --with-termlib=ncurses \
99        --enable-image=x11 \
100        --with-imagelib=gtk2 \
101        --with-browser=gnome-open \
102        --with-mailer=gnome-open \
103        --with-editor=%{_sysbindir}/vi
104sed -i -e 's|#define USE_GPM 1|/* #undef USE_GPM */|' config.h
105sed -i -e 's|\-lgpm||g' Makefile
106sed -i -e 's|\-ldl|\-ldl \-lX11|g' Makefile
107make %{?_smp_mflags}
108
109%install
110rm -rf %{buildroot}
111make install DESTDIR=%{buildroot}
112
113mkdir -p %{buildroot}/etc/profile.d
114cp %{SOURCE1} %{buildroot}/etc/profile.d/w3m.sh
115cp %{SOURCE2} %{buildroot}/etc/profile.d/w3m.csh
116
117mkdir -p %{buildroot}%{_bindir}
118cp %{SOURCE10} %{buildroot}%{_bindir}/w3m-term
119chmod +x %{buildroot}%{_bindir}/w3m-term
120
121mkdir -p %{buildroot}%{_mandir}/{man1,ja/man1}
122install -p -m 644 doc-jp/w3m.1 %{buildroot}%{_mandir}/ja/man1
123install -p -m 644 doc/w3m.1 %{buildroot}%{_mandir}/man1
124# dont include duplicated man pages and CVS directory in doc
125rm -f doc-jp/w3m.1 doc/w3m.1
126find . -type d -name "CVS" | xargs rm -rf
127
128# prepare system-wide preference file
129mkdir -p %{buildroot}%{_sysconfdir}/w3m
130
131mkdir -p %{buildroot}%{_datadir}/applications
132cat > %{buildroot}%{_datadir}/applications/%{name}.desktop <<EOF
133[Desktop Entry]
134Name=%{name}
135Type=Application
136Comment=A Pager with WWW capability
137Comment[ja]=WWW対応ページャ
138Exec=w3m-term
139Terminal=false
140Categories=Network;
141EOF
142
143# eliminate executable bit in %doc
144find Bonus/ -type f -perm +111 | xargs -r chmod -x
145
146
147%clean
148rm -rf %{buildroot}
149
150%post
151%{_syssbindir}/update-alternatives --install /usr/bin/pager pager /usr/bin/w3m 30
152
153%preun
154if [ "$1" = "0" ]; then
155  %{_syssbindir}/update-alternatives --remove pager /usr/bin/w3m
156fi
157
158
159%files
160%defattr(-,root,root)
161%doc Bonus ChangeLog NEWS README doc doc-jp
162%attr(755,root,root) %config /etc/profile.d/*
163%dir %{_sysconfdir}/w3m
164%{_bindir}/w3m*
165%exclude %{_libexecdir}/w3m/w3mimgdisplay
166%{_libexecdir}/w3m/
167%{_datadir}/applications/%{name}.desktop
168%{_datadir}/w3m/
169%{_datadir}/locale/*/LC_MESSAGES/*
170%{_mandir}/ja/man1/w3m.1*
171%{_mandir}/man1/w3m*
172
173%files img
174%{_libexecdir}/w3m/w3mimgdisplay
175
176%changelog
177* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.3-4
178- rebuild with openssl-1.0.2
179
180* Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.3-3
181- change localtion of desktop file
182
183* Mon Sep 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.5.3-2
184- updated Source11 to call /usr/lib/rpm/perl.req
185- added Patch200 and 201 for building current environment
186- rebuilt for removing libpng12 dependency
187
188* Thu Apr 21 2011 IWAI, Masaharu <iwai@alib.jp> 0.5.3-1
189- new upstream release
190- drop unnecessary patches: upstream fixed
191 - ambwidth patch (Patch10)
192 - sudden crash patch (Patch11)
193 - x86_64 patch (Patch100)
194
195* Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.5.2-7
196- rebuild with openssl-1.0.0c
197- add Patch100 (w3m-0.5.2-x86_64-vine.patch)
198
199* Sun Sep 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-6
200- add Patch10 to fix display utf8 ambiguous width characters
201  (from: http://www.j10n.org/files/w3m-cvs-1.914-ambwidth.patch)
202- add Patch11 to fix sudden crash
203  (from: http://www.sic.med.tohoku.ac.jp/~satodai/w3m-dev/200708.month/4286.html)
204
205* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-5
206- rebuilt with gcc-4.4.3-3 on ppc
207
208* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-4
209- rebuilt with new toolchain
210
211* Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-2
212- spec in utf-8
213- remove Requires: indexhtml
214- set HTTP_HOME to http://vinelinux.org/
215- update w3m-term
216
217* Wed Apr 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.2-1
218- new upstream release
219- dropped Patch100 (merged into upstream)
220
221* Sun Jun  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1.20060815-0vl6
222- rebuilt with new toolchain and environment
223
224* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl5
225- add Provides: pager
226- add Requires(post,preun): alternatives
227
228* Tue Apr 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl3
229- add update-alternatives: pager in %post and %preun scriptlet
230
231* Fri Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
232- 0.5.1.20060815-0vl2
233- rebuilt for VineSeed
234
235* Sat Dec 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
236- 0.5.1.20060815-0vl1.1
237- add patch100 for fix "inputAnswer()" SSL Certificate Handling Vulnerabilit
238
239* Tue Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp>
240- update to cvs snapshot
241- use gtk2 for w3m-img instead of gdk-pixbuf
242
243* Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.5.1-0vl6
244- use filter-requires-w3m.sh as find-requires (rpm's bug?)
245
246* Sat Sep 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl5
247- use %%{_docdir}/Vine/index.html as default homepage
248
249* Sun Jul 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl4
250- change default editor to %%{_sysbindir}/vi
251- use ncurses explicitly as termlib
252
253* Sun Jul 11 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl3
254- fix typo
255- add BuildPrereq: gtk+-devel, gdk-pixbuf-devel
256
257* Wed Jul 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
258- rebuild without gpm
259
260* Wed May  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
261- new upstream release
262- Obsoletes: w3m-m17n
263
264* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl2
265- add message catalogs to %%files
266
267* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl1
268- new upstream release
269- fix w3mimgdisplay path in w3m-term
270
271* Sun Dec 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
272- new upstream release
273- split w3mimgdisplay to w3m-img subpackage.
274- Requires: gc >= 6.2
275
276* Sat May 31 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.4.1-0vl1
277- new upstream release
278
279* Tue Feb 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4-0vl1
280- new upstream release
281
282* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.2-0vl1
283- new upstream release.
284  w3m 0.3.2.2 - 2002-12-06
285  * security fix: html_quote for img alt attributes
286
287* Fri Nov 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl2
288- change default page path to /usr/doc/HTML.
289  this should be changed to /usr/share/doc in next release.
290  ( TODO: indexhtml package )
291
292* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl1
293- new upstream release
294  w3m 0.3.2.1 - 2002-11-27
295  * security fix: html_quote for frame contents
296  * backport from w3m 0.3.2+cvs
297    - fix segmentation fault by large complex table.
298      [w3m-dev 03371][w3m-dev 03438]
299
300* Wed Nov  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
301- new upstream release
302  w3m 0.3.2 - 2002-11-05
303  * ~/.netrc: password for ftp
304  * rc: display_lineinfo: display current line number
305  * rc: passwd_file: passwd file for HTTP auth
306  * func: MARK_WORD
307  * rc: imgsize: obsoleted
308  * w3m-img for framebuffer merged
309
310* Mon Sep 30 2002 Tomoya TAKA <taka@vinelinux.org> 0.3.1-0vl2
311- replace gc with an old version on alpha (Source20)
312
313* Wed Jul 17 2002 IWAI Masaharu <iwai@alib.jp> 0.3.1-0vl1
314- upstream release
315- coped new configure options
316
317* Sun Apr 21 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.3-0vl2
318- fixed configure option ([VineSeed:06372])
319- added openssl-devel version in {Build,}Requires
320
321* Mon Mar 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3-0vl1
322- updated in sync with upstream 0.3 release
323  (now w3m-img patch is included in the upstream version)
324
325* Tue Feb 05 2002 Toru Sagami <sagami@vinelinux.org> 0.2.5-0vl1
326- w3m-0.2.5 with 0.2.5+cvs-1.302
327
328* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl2
329- eliminate executable bit in %doc
330- spec cleanup
331
332* Wed Jan 16 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl1
333- updated to current stable release
334
335* Thu Jan 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.3.2-0vl1
336- updated to new upstream release
337- FIXME: system-wide /etc/w3m/w3mconfig should be prepared. Anyone? :)
338
339* Fri Sep 28 2001 <masato@nets.ce.hiroshima-cu.ac.jp>
340- 0.2.1-0vl9
341- added sparc patch
342
343* Thu Aug 23 2001 <shom@vinelinux.org>
344- 0.2.1-0vl8: add w3m-term script
345
346* Mon Aug 06 2001 <sagami@vinelinux.org>
347- 0.2.1-0vl7: added imlib-devel ncurses-devel for BuildPreReq
348- update img patch to version 1.10 from 1.9
349
350* Mon Aug  6 2001 Jun Nishii <jun@vinelinux.org> 0.2.1-0vl6
351- added img patch
352
353* Mon Jul 16 2001 <sagami@vinelinux.org>
354- 0.2.1-0vl5: spec file clean up
355- openssl-devel for BuildPrereq, not openssl
356- install more sophisticated w3m.sh w3m.csh with any %%{_docdir} definition
357
358* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
359- 0.2.1-0vl4
360- rebuilt with openssl-0.9.6b
361
362* Sun Jun 24 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
363- 0.2.1-0vl3
364- security fixes (http://www.lac.co.jp/security/snsadv/32.html)
365
366* Sat Jun 09 2001 <sagami@vinelinux.org>
367- 0.2.1-0vl2: minor spec fixes(URL, License and etc.)
368- actually rebuilt with ncurses5 (i386)
369
370* Sat Mar 24 2001 Yoichi Imai <yoichi@silver-forest.com>
371- 0.2.1-0vl1
372
373* Wed Dec 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
374- 0.1.10-0vl6
375- use better macros
376- rebuilt with ncurses5
377
378* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
379- w3m-0.1.10-0vl5
380- use applnk instead of wmconfig
381- use openssl
382
383* Thu Jul 27 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
384- w3m-0.1.10-0vl4
385- fix typo in w3m.csh and w3m.wmconfig
386
387* Sun Jul 09 2000 Toru Sagami <czs14350@nifty.ne.jp>
388- w3m-0.1.10-0vl3
389- provide default HTTP_HOME in /etc/profile.d
390
391* Fri Jul 07 2000 Toru Sagami <czs14350@nifty.ne.jp>
392- Provides: webclient, Requires: indexhtml (capability of lynx)
393- added w3m.wmconfig
394- give them(who?) RPM_OPT_FLAGS(what?)
395- dont include duplicated man pages and CVS directory in doc
396
397* Wed Jun 21 2000 Jun Nishii <jun@vinelinux.org>
398- 0.1.10-0vl1
399
400* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
401- fix spec file
402
403* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
404- updated from 0.1.4 to 0.1.6
405
406* Thu Jan 13 2000 Yoichi Imai <yoichi@silver-forest.com>
407- updated from 991203 to 0.1.4
408
409* Fri Dec 03 1999 Yoichi Imai <yoichi@silver-forest.com>
410- updated from 991028 to 991203
411
412* Sat Oct 30 1999 Yoichi Imai <bonaim@mutt.freemail.ne.jp>
413- updated from 990820 to 991028
414
415* Thu Aug 26 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
416- updated from 990716 to 990820
417
418* Wed Aug 11 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
419- initial Release to VinePlus
Note: See TracBrowser for help on using the repository browser.