source: projects/specs/trunk/v/vsftpd/vsftpd-vl.spec @ 8294

Revision 8294, 10.1 KB checked in by kudoh, 10 years ago (diff)

rebuilt and new upstream release

Line 
1%{!?tcp_wrappers:%define tcp_wrappers 1}
2
3Summary: vsftpd - Very Secure Ftp Daemon
4Name: vsftpd
5Version: 3.0.2
6Release: 2%{?_dist_release}
7License: GPL
8Group: System Environment/Daemons
9URL: https://security.appspot.com/vsftpd.html
10Source: ftp://vsftpd.beasts.org/users/cevans/%{name}-%{version}.tar.gz
11Source1: vsftpd.xinetd
12Source2: vsftpd.pam
13Source3: vsftpd.ftpusers
14Source4: vsftpd.user_list
15Source5: vsftpd.init
16Source6: vsftpd_conf_migrate.sh
17Source7: vsftpd.service
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21# Build patches
22Patch1: vsftpd-2.1.0-libs.patch
23Patch2: vsftpd-2.1.0-build_ssl.patch
24Patch3: vsftpd-2.1.0-tcp_wrappers.patch
25
26# Use /etc/vsftpd/ instead of /etc/
27Patch4: vsftpd-2.1.0-configuration.patch
28
29# These need review
30Patch5: vsftpd-2.1.0-pam_hostname.patch
31Patch6: vsftpd-close-std-fds.patch
32Patch7: vsftpd-2.1.0-filter.patch
33Patch9: vsftpd-2.1.0-userlist_log.patch
34
35Patch10: vsftpd-2.1.0-trim.patch
36Patch12: vsftpd-2.1.1-daemonize_plus.patch
37Patch14: vsftpd-2.2.0-wildchar.patch
38
39Patch16: vsftpd-2.2.2-clone.patch
40Patch19: vsftpd-2.3.4-sd.patch
41Patch20: vsftpd-2.3.4-sqb.patch
42Patch21: vsftpd-2.3.5-aslim.patch
43Patch22: vsftpd-3.0.0-tz.patch
44Patch23: vsftpd-3.0.0-xferlog.patch
45Patch24: vsftpd-3.0.0-logrotate.patch
46
47Patch25: 07-utf8.patch
48
49#Vine custom
50Patch100: vsftpd-vine.patch
51
52%if %{tcp_wrappers}
53BuildRequires: tcp_wrappers
54%endif
55
56BuildRequires: libcap-devel
57BuildRequires: pam-devel
58BuildRequires: openssl-devel
59
60Requires: libcap
61Requires: logrotate
62Requires: openssl
63Requires: pam
64
65Requires(preun): /sbin/service
66Requires(postun): /sbin/service
67
68Provides: ftpserver
69
70%description
71vsftpd is a Very Secure FTP daemon. It was written completely from
72scratch.
73
74%prep
75%setup -q -n %{name}-%{version}
76cp %{SOURCE1} .
77
78%patch1 -p1 -b .libs
79%patch2 -p1 -b .build_ssl
80%if %{tcp_wrappers}
81%patch3 -p1 -b .tcp_wrappers
82%endif
83%patch4 -p1 -b .configuration
84%patch5 -p1 -b .pam_hostname
85%patch6 -p1 -b .close_fds
86%patch7 -p1 -b .filter
87%patch9 -p1 -b .userlist_log
88%patch10 -p1 -b .trim
89%patch12 -p1 -b .daemonize_plus
90%patch14 -p1 -b .wildchar
91%patch16 -p1 -b .clone
92%patch19 -p1 -b .sd
93%patch20 -p1 -b .sqb
94%patch21 -p1 -b .aslim
95%patch22 -p1 -b .tz
96%patch23 -p1 -b .xferlog
97%patch24 -p1 -b .logrotate
98
99%patch25 -p1
100
101%patch100 -p1 -b .vine_custom
102
103%build
104make CFLAGS="$RPM_OPT_FLAGS -fpie -pipe" \
105     LINK="-pie -lssl" \
106     %{?_smp_mflags}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110mkdir -p $RPM_BUILD_ROOT%{_sbindir}
111mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
112mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{vsftpd,pam.d,logrotate.d,rc.d/init.d}
113mkdir -p $RPM_BUILD_ROOT%{_mandir}/man{5,8}
114
115install -m 755 vsftpd  $RPM_BUILD_ROOT%{_sbindir}/vsftpd
116install -m 600 vsftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/vsftpd.conf
117install -m 644 vsftpd.conf.5 $RPM_BUILD_ROOT/%{_mandir}/man5/
118install -m 644 vsftpd.8 $RPM_BUILD_ROOT/%{_mandir}/man8/
119install -m 644 RedHat/vsftpd.log $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/vsftpd
120install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/vsftpd
121install -m 600 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/ftpusers
122install -m 600 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/user_list
123install -m 755 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/vsftpd
124install -m 744 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/vsftpd_conf_migrate.sh
125
126mkdir -p $RPM_BUILD_ROOT/var/ftp/pub
127
128%clean
129[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
130
131%post
132/sbin/chkconfig --add vsftpd
133#/usr/sbin/usermod -d /var/ftp ftp >/dev/null 2>&1 || :
134
135%preun
136if [ $1 = 0 ]; then
137 /sbin/service vsftpd stop > /dev/null 2>&1
138 /sbin/chkconfig --del vsftpd
139fi
140
141%files
142%defattr(-,root,root,-)
143%{_sbindir}/vsftpd
144%dir %{_sysconfdir}/vsftpd
145%{_sysconfdir}/vsftpd/vsftpd_conf_migrate.sh
146%{_sysconfdir}/rc.d/init.d/vsftpd
147%config(noreplace) %{_sysconfdir}/vsftpd/ftpusers
148%config(noreplace) %{_sysconfdir}/vsftpd/user_list
149%config(noreplace) %{_sysconfdir}/vsftpd/vsftpd.conf
150%config(noreplace) %{_sysconfdir}/pam.d/vsftpd
151%config(noreplace) %{_sysconfdir}/logrotate.d/vsftpd
152%doc FAQ INSTALL BUGS AUDIT Changelog LICENSE README README.security REWARD
153%doc SPEED TODO BENCHMARKS COPYING SECURITY/ EXAMPLE/ TUNING SIZE vsftpd.xinetd
154%{_mandir}/man5/vsftpd.conf.*
155%{_mandir}/man8/vsftpd.*
156%{_var}/ftp
157
158
159%changelog
160* Sat Mar 08 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.3-2
161- rebuilt with new toolchain
162- changed URL
163
164* Sat Mar 30 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
165- new upstream release
166- synced Fedora rawhide sources
167  - deleted customized configure for IPv6 in Patch4
168- added Patch25 from Debian to add UTF-8 support
169
170* Mon Oct  6 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.7-1
171- new upstream release
172- update patches from FedoraCore
173- add Source6 from FedoraCore
174
175* Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.5-0vl1
176- new upstream release
177- build with openssl-0.9.8e
178
179* Fri Sep  9 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.3-0vl1
180- new upstream release
181
182* Thu Mar  3 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.2-0vl1
183- new upstream release
184- disable patch5
185
186* Sat Nov 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-5vl2
187- rename patch1 and disable anonymous FTP
188
189* Mon Oct 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-5vl1
190- build for VineSeed
191- remove lines about s390, pie and patch4
192- add %%{_datadir}/empty to %%files
193- rename patch1 and add "use_localtime=YES"
194- remove Prereq: /sbin/chkconfig, /sbin/service, /usr/sbin/usermod
195  because they must be installed
196- remove Obsoletes: anonftp
197- remove BuildRequires: libcap-devel and Requires: libcap
198
199* Fri Oct 01 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-5
200- vsftpd under xinetd reads its config file (#134314)
201
202* Thu Sep 16 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-4
203- spec file changed, ftp dir change commented (#130119)
204- added doc files (#113056)
205
206* Wed Sep 08 2004 Jan Kratochvil <project-vsftpd@jankratochvil.net>
207- update for 2.0.1 for SSL
208
209* Fri Aug 27 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-2
210- vsftpd.conf file changed, default IPv6 support
211
212* Fri Aug 20 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-1
213- tcp_wrapper patch updated, signal patch updated
214- upgrade to 2.0.1, fixes several bugs, RHEL and FC builds
215
216* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
217- rebuilt
218
219* Wed May 19 2004 Bill Nottingham <notting@redhat.com> 1.2.1-6
220- fix the logrotate config (#116253)
221
222* Mon May  3 2004 Bill Nottingham <notting@redhat.com> 1.2.1-5
223- fix all references to vsftpd.conf to be /etc/vsftpd/vsftpd.conf,
224  including in the binary (#121199, #104075)
225
226* Thu Mar 25 2004 Bill Nottingham <notting@redhat.com> 1.2.1-4
227- don't call malloc()/free() in signal handlers (#119136,
228  <olivier.baudron@m4x.org>)
229
230* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
231- rebuilt
232
233* Mon Nov 24 2003 Karsten Hopp <karsten@redhat.de> 1.2.1-1
234- update to 1.2.1, which fixes #89765 and lot of other issues
235- remove manpage patch, it isn't required anymore
236- clean up init script
237- don't use script to find libs to link with (lib64 issues)
238
239* Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
240- allow compiling without tcp_wrappers support
241
242* Mon Sep 15 2003 Bill Nottingham <notting@redhat.com> 1.2.0-4
243- fix errant newline (#104443)
244
245* Fri Aug  8 2003 Bill Nottingham <notting@redhat.com> 1.2.0-3
246- tweak man page (#84584, #72798)
247- buildprereqs for pie (#99336)
248- free ride through the build system to fix (#101582)
249
250* Thu Jun 26 2003 Bill Nottingham <notting@redhat.com> 1.2.0-2
251- update to 1.2.0
252
253* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
254- rebuilt
255
256* Mon Apr 28 2003 Bill Nottingham <notting@redhat.com> 1.1.3-9
257- fix tcp_wrappers usage (#89765, <dale@riyescott.com>)
258
259* Fri Feb 28 2003 Nalin Dahyabhai <nalin@redhat.com> 1.1.3-8
260- enable use of tcp_wrappers
261
262* Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 1.1.3-7
263- provide /var/ftp & /var/ftp/pub. obsolete anonftp.
264
265* Mon Feb 10 2003 Bill Nottingham <notting@redhat.com> 1.1.3-6
266- clean up comments in init script (#83962)
267
268* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
269- rebuilt
270
271* Mon Dec 30 2002 Florian La Roche <Florian.LaRoche@redhat.de>
272- change to /etc/rc.d/init.d for better compatibility
273
274* Mon Dec 16 2002 Bill Nottingham <notting@redhat.com> 1.1.3-3
275- fix initscript perms
276- fix typo in initscript (#76587)
277
278* Fri Dec 13 2002 Bill Nottingham <notting@redhat.com> 1.1.3-2
279- update to 1.1.3
280- run standalone, don't run by default
281- fix reqs
282 
283* Fri Nov 22 2002 Joe Orton <jorton@redhat.com> 1.1.0-3
284- fix use with xinetd-ipv6; add flags=IPv4 in xinetd file (#78410)
285
286* Tue Nov 12 2002 Nalin Dahyabhai <nalin@redhat.com> 1.0.1-9
287- remove absolute paths from PAM configuration so that the right modules get
288  used for whichever arch we're built for on multilib systems
289
290* Thu Aug 15 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-8
291- -D_FILE_OFFSET_BITS=64
292- smp make
293- remove forced optflags=-g for lack of supporting documentation
294 
295* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
296- automated rebuild
297
298* Thu May 23 2002 Tim Powers <timp@redhat.com>
299- automated rebuild
300
301* Wed Apr 10 2002 Bill Nottingham <notting@redhat.com> 1.0.1-5
302- don't spit out ugly errors if anonftp isn't installed (#62987)
303- fix horribly broken userlist setup (#62321)
304
305* Thu Feb 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.0.1-4
306- s/Copyright/License/
307- add "missingok" to the logrotate script, so we don't get errors
308  when nothing has happened
309
310* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
311- automated rebuild
312
313* Wed Nov 28 2001 Bill Nottingham <notting@redhat.com>
314- initial packaging for RHL, munge included specfile
315
316* Thu Mar 22 2001 Seth Vidal <skvidal@phy.duke.edu>
317- updated to 0.0.15
318- added entry for vsftpd.8 man page
319- added entry for vsftpd.log logrotate file
320- added TUNING file to docs list
321
322* Wed Mar 7 2001 Seth Vidal <skvidal@phy.duke.edu>
323- Updated to 0.0.14
324- made %%files entry for man page
325
326* Wed Feb 21 2001 Seth Vidal <skvidal@phy.duke.edu>
327- Updated to 0.0.13
328
329* Mon Feb 12 2001 Seth Vidal <skvidal@phy.duke.edu>
330- Updated to 0.0.12
331
332* Wed Feb 7 2001 Seth Vidal <skvidal@phy.duke.edu>
333- updated to 0.0.11
334
335* Thu Feb 1 2001 Seth Vidal <skvidal@phy.duke.edu>
336- Update to 0.0.10
337
338* Thu Feb 1 2001 Seth Vidal <skvidal@phy.duke.edu>
339- First RPM packaging
340- Stolen items from wu-ftpd's pam setup
341- Separated rh 7 and rh 6.X's packages
342- Built for Rh6
Note: See TracBrowser for help on using the repository browser.