source: projects/specs/trunk/v/vsftpd/vsftpd-vl.spec @ 7599

Revision 7599, 10.0 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1%{!?tcp_wrappers:%define tcp_wrappers 1}
2
3Summary: vsftpd - Very Secure Ftp Daemon
4Name: vsftpd
5Version: 3.0.2
6Release: 1%{?_dist_release}
7License: GPL
8Group: System Environment/Daemons
9URL: http://vsftpd.beasts.org/
10Source: ftp://vsftpd.beasts.org/users/cevans/%{name}-%{version}.tar.gz
11Source1: vsftpd.xinetd
12Source2: vsftpd.pam
13Source3: vsftpd.ftpusers
14Source4: vsftpd.user_list
15Source5: vsftpd.init
16Source6: vsftpd_conf_migrate.sh
17Source7: vsftpd.service
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21# Build patches
22Patch1: vsftpd-2.1.0-libs.patch
23Patch2: vsftpd-2.1.0-build_ssl.patch
24Patch3: vsftpd-2.1.0-tcp_wrappers.patch
25
26# Use /etc/vsftpd/ instead of /etc/
27Patch4: vsftpd-2.1.0-configuration.patch
28
29# These need review
30Patch5: vsftpd-2.1.0-pam_hostname.patch
31Patch6: vsftpd-close-std-fds.patch
32Patch7: vsftpd-2.1.0-filter.patch
33Patch9: vsftpd-2.1.0-userlist_log.patch
34
35Patch10: vsftpd-2.1.0-trim.patch
36Patch12: vsftpd-2.1.1-daemonize_plus.patch
37Patch14: vsftpd-2.2.0-wildchar.patch
38
39Patch16: vsftpd-2.2.2-clone.patch
40Patch19: vsftpd-2.3.4-sd.patch
41Patch20: vsftpd-2.3.4-sqb.patch
42Patch21: vsftpd-2.3.5-aslim.patch
43Patch22: vsftpd-3.0.0-tz.patch
44Patch23: vsftpd-3.0.0-xferlog.patch
45Patch24: vsftpd-3.0.0-logrotate.patch
46
47Patch25: 07-utf8.patch
48
49#Vine custom
50Patch100: vsftpd-vine.patch
51
52%if %{tcp_wrappers}
53BuildRequires: tcp_wrappers
54%endif
55
56BuildRequires: libcap-devel
57BuildRequires: pam-devel
58BuildRequires: openssl-devel
59
60Requires: libcap
61Requires: logrotate
62Requires: openssl
63Requires: pam
64
65Requires(preun): /sbin/service
66Requires(postun): /sbin/service
67
68Provides: ftpserver
69
70%description
71vsftpd is a Very Secure FTP daemon. It was written completely from
72scratch.
73
74%prep
75%setup -q -n %{name}-%{version}
76cp %{SOURCE1} .
77
78%patch1 -p1 -b .libs
79%patch2 -p1 -b .build_ssl
80%if %{tcp_wrappers}
81%patch3 -p1 -b .tcp_wrappers
82%endif
83%patch4 -p1 -b .configuration
84%patch5 -p1 -b .pam_hostname
85%patch6 -p1 -b .close_fds
86%patch7 -p1 -b .filter
87%patch9 -p1 -b .userlist_log
88%patch10 -p1 -b .trim
89%patch12 -p1 -b .daemonize_plus
90%patch14 -p1 -b .wildchar
91%patch16 -p1 -b .clone
92%patch19 -p1 -b .sd
93%patch20 -p1 -b .sqb
94%patch21 -p1 -b .aslim
95%patch22 -p1 -b .tz
96%patch23 -p1 -b .xferlog
97%patch24 -p1 -b .logrotate
98
99%patch25 -p1
100
101%patch100 -p1 -b .vine_custom
102
103%build
104make CFLAGS="$RPM_OPT_FLAGS -fpie -pipe" \
105     LINK="-pie -lssl" \
106     %{?_smp_mflags}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110mkdir -p $RPM_BUILD_ROOT%{_sbindir}
111mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
112mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{vsftpd,pam.d,logrotate.d,rc.d/init.d}
113mkdir -p $RPM_BUILD_ROOT%{_mandir}/man{5,8}
114
115install -m 755 vsftpd  $RPM_BUILD_ROOT%{_sbindir}/vsftpd
116install -m 600 vsftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/vsftpd.conf
117install -m 644 vsftpd.conf.5 $RPM_BUILD_ROOT/%{_mandir}/man5/
118install -m 644 vsftpd.8 $RPM_BUILD_ROOT/%{_mandir}/man8/
119install -m 644 RedHat/vsftpd.log $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/vsftpd
120install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/vsftpd
121install -m 600 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/ftpusers
122install -m 600 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/user_list
123install -m 755 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/vsftpd
124install -m 744 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/vsftpd_conf_migrate.sh
125
126mkdir -p $RPM_BUILD_ROOT/var/ftp/pub
127
128%clean
129[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
130
131%post
132/sbin/chkconfig --add vsftpd
133#/usr/sbin/usermod -d /var/ftp ftp >/dev/null 2>&1 || :
134
135%preun
136if [ $1 = 0 ]; then
137 /sbin/service vsftpd stop > /dev/null 2>&1
138 /sbin/chkconfig --del vsftpd
139fi
140
141%files
142%defattr(-,root,root,-)
143%{_sbindir}/vsftpd
144%dir %{_sysconfdir}/vsftpd
145%{_sysconfdir}/vsftpd/vsftpd_conf_migrate.sh
146%{_sysconfdir}/rc.d/init.d/vsftpd
147%config(noreplace) %{_sysconfdir}/vsftpd/ftpusers
148%config(noreplace) %{_sysconfdir}/vsftpd/user_list
149%config(noreplace) %{_sysconfdir}/vsftpd/vsftpd.conf
150%config(noreplace) %{_sysconfdir}/pam.d/vsftpd
151%config(noreplace) %{_sysconfdir}/logrotate.d/vsftpd
152%doc FAQ INSTALL BUGS AUDIT Changelog LICENSE README README.security REWARD
153%doc SPEED TODO BENCHMARKS COPYING SECURITY/ EXAMPLE/ TUNING SIZE vsftpd.xinetd
154%{_mandir}/man5/vsftpd.conf.*
155%{_mandir}/man8/vsftpd.*
156%{_var}/ftp
157
158
159%changelog
160* Sat Mar 30 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
161- new upstream release
162- synced Fedora rawhide sources
163  - deleted customized configure for IPv6 in Patch4
164- added Patch25 from Debian to add UTF-8 support
165
166* Mon Oct  6 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.7-1
167- new upstream release
168- update patches from FedoraCore
169- add Source6 from FedoraCore
170
171* Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.5-0vl1
172- new upstream release
173- build with openssl-0.9.8e
174
175* Fri Sep  9 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.3-0vl1
176- new upstream release
177
178* Thu Mar  3 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.2-0vl1
179- new upstream release
180- disable patch5
181
182* Sat Nov 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-5vl2
183- rename patch1 and disable anonymous FTP
184
185* Mon Oct 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-5vl1
186- build for VineSeed
187- remove lines about s390, pie and patch4
188- add %%{_datadir}/empty to %%files
189- rename patch1 and add "use_localtime=YES"
190- remove Prereq: /sbin/chkconfig, /sbin/service, /usr/sbin/usermod
191  because they must be installed
192- remove Obsoletes: anonftp
193- remove BuildRequires: libcap-devel and Requires: libcap
194
195* Fri Oct 01 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-5
196- vsftpd under xinetd reads its config file (#134314)
197
198* Thu Sep 16 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-4
199- spec file changed, ftp dir change commented (#130119)
200- added doc files (#113056)
201
202* Wed Sep 08 2004 Jan Kratochvil <project-vsftpd@jankratochvil.net>
203- update for 2.0.1 for SSL
204
205* Fri Aug 27 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-2
206- vsftpd.conf file changed, default IPv6 support
207
208* Fri Aug 20 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-1
209- tcp_wrapper patch updated, signal patch updated
210- upgrade to 2.0.1, fixes several bugs, RHEL and FC builds
211
212* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
213- rebuilt
214
215* Wed May 19 2004 Bill Nottingham <notting@redhat.com> 1.2.1-6
216- fix the logrotate config (#116253)
217
218* Mon May  3 2004 Bill Nottingham <notting@redhat.com> 1.2.1-5
219- fix all references to vsftpd.conf to be /etc/vsftpd/vsftpd.conf,
220  including in the binary (#121199, #104075)
221
222* Thu Mar 25 2004 Bill Nottingham <notting@redhat.com> 1.2.1-4
223- don't call malloc()/free() in signal handlers (#119136,
224  <olivier.baudron@m4x.org>)
225
226* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
227- rebuilt
228
229* Mon Nov 24 2003 Karsten Hopp <karsten@redhat.de> 1.2.1-1
230- update to 1.2.1, which fixes #89765 and lot of other issues
231- remove manpage patch, it isn't required anymore
232- clean up init script
233- don't use script to find libs to link with (lib64 issues)
234
235* Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
236- allow compiling without tcp_wrappers support
237
238* Mon Sep 15 2003 Bill Nottingham <notting@redhat.com> 1.2.0-4
239- fix errant newline (#104443)
240
241* Fri Aug  8 2003 Bill Nottingham <notting@redhat.com> 1.2.0-3
242- tweak man page (#84584, #72798)
243- buildprereqs for pie (#99336)
244- free ride through the build system to fix (#101582)
245
246* Thu Jun 26 2003 Bill Nottingham <notting@redhat.com> 1.2.0-2
247- update to 1.2.0
248
249* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
250- rebuilt
251
252* Mon Apr 28 2003 Bill Nottingham <notting@redhat.com> 1.1.3-9
253- fix tcp_wrappers usage (#89765, <dale@riyescott.com>)
254
255* Fri Feb 28 2003 Nalin Dahyabhai <nalin@redhat.com> 1.1.3-8
256- enable use of tcp_wrappers
257
258* Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 1.1.3-7
259- provide /var/ftp & /var/ftp/pub. obsolete anonftp.
260
261* Mon Feb 10 2003 Bill Nottingham <notting@redhat.com> 1.1.3-6
262- clean up comments in init script (#83962)
263
264* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
265- rebuilt
266
267* Mon Dec 30 2002 Florian La Roche <Florian.LaRoche@redhat.de>
268- change to /etc/rc.d/init.d for better compatibility
269
270* Mon Dec 16 2002 Bill Nottingham <notting@redhat.com> 1.1.3-3
271- fix initscript perms
272- fix typo in initscript (#76587)
273
274* Fri Dec 13 2002 Bill Nottingham <notting@redhat.com> 1.1.3-2
275- update to 1.1.3
276- run standalone, don't run by default
277- fix reqs
278 
279* Fri Nov 22 2002 Joe Orton <jorton@redhat.com> 1.1.0-3
280- fix use with xinetd-ipv6; add flags=IPv4 in xinetd file (#78410)
281
282* Tue Nov 12 2002 Nalin Dahyabhai <nalin@redhat.com> 1.0.1-9
283- remove absolute paths from PAM configuration so that the right modules get
284  used for whichever arch we're built for on multilib systems
285
286* Thu Aug 15 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-8
287- -D_FILE_OFFSET_BITS=64
288- smp make
289- remove forced optflags=-g for lack of supporting documentation
290 
291* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
292- automated rebuild
293
294* Thu May 23 2002 Tim Powers <timp@redhat.com>
295- automated rebuild
296
297* Wed Apr 10 2002 Bill Nottingham <notting@redhat.com> 1.0.1-5
298- don't spit out ugly errors if anonftp isn't installed (#62987)
299- fix horribly broken userlist setup (#62321)
300
301* Thu Feb 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.0.1-4
302- s/Copyright/License/
303- add "missingok" to the logrotate script, so we don't get errors
304  when nothing has happened
305
306* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
307- automated rebuild
308
309* Wed Nov 28 2001 Bill Nottingham <notting@redhat.com>
310- initial packaging for RHL, munge included specfile
311
312* Thu Mar 22 2001 Seth Vidal <skvidal@phy.duke.edu>
313- updated to 0.0.15
314- added entry for vsftpd.8 man page
315- added entry for vsftpd.log logrotate file
316- added TUNING file to docs list
317
318* Wed Mar 7 2001 Seth Vidal <skvidal@phy.duke.edu>
319- Updated to 0.0.14
320- made %%files entry for man page
321
322* Wed Feb 21 2001 Seth Vidal <skvidal@phy.duke.edu>
323- Updated to 0.0.13
324
325* Mon Feb 12 2001 Seth Vidal <skvidal@phy.duke.edu>
326- Updated to 0.0.12
327
328* Wed Feb 7 2001 Seth Vidal <skvidal@phy.duke.edu>
329- updated to 0.0.11
330
331* Thu Feb 1 2001 Seth Vidal <skvidal@phy.duke.edu>
332- Update to 0.0.10
333
334* Thu Feb 1 2001 Seth Vidal <skvidal@phy.duke.edu>
335- First RPM packaging
336- Stolen items from wu-ftpd's pam setup
337- Separated rh 7 and rh 6.X's packages
338- Built for Rh6
Note: See TracBrowser for help on using the repository browser.