source: projects/specs/trunk/v/vsftpd/vsftpd-vl.spec @ 521

Revision 521, 10.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?tcp_wrappers:%define tcp_wrappers 1}
2
3Summary: vsftpd - Very Secure Ftp Daemon
4Name: vsftpd
5Version: 2.0.7
6Release: 1%{?_dist_release}
7License: GPL
8Group: System Environment/Daemons
9URL: http://vsftpd.beasts.org/
10Source: ftp://vsftpd.beasts.org/users/cevans/%{name}-%{version}.tar.gz
11Source1: vsftpd.xinetd
12Source2: vsftpd.pam
13Source3: vsftpd.ftpusers
14Source4: vsftpd.user_list
15Source5: vsftpd.init
16Source6: vsftpd_conf_migrate.sh
17Patch1: vsftpd-2.0.1-vine-20041227.patch
18Patch2: vsftpd-1.0.1-missingok.patch
19Patch3: vsftpd-2.0.1-tcp_wrappers.patch
20Patch4: vsftpd-1.5.1-libs.patch
21Patch5: vsftpd-2.0.2-signal.patch
22Patch6: vsftpd-1.2.1-conffile.patch
23Patch7: vsftpd-2.0.1-build_ssl.patch
24Patch8: vsftpd-2.0.1-server_args.patch
25Patch9: vsftpd-2.0.1-dir.patch
26Patch11: vsftpd-1.2.1-nonrootconf.patch
27Patch13: vsftpd-2.0.3-background.patch
28Patch14: vsftpd-2.0.3-daemonize_fds.patch
29Patch17: vsftpd-2.0.3-pam_hostname.patch
30Patch18: vsftpd-close-std-fds.patch
31Patch19: vsftpd-2.0.5-default_ipv6.patch
32Patch20: vsftpd-2.0.5-add_ipv6_option.patch
33Patch21: vsftpd-2.0.5-correct_comments.patch
34Patch22: vsftpd-2.0.5-man.patch
35Patch23: vsftpd-2.0.4-filter.patch
36Patch26: vsftpd-2.0.5-bind_denied.patch
37Patch29: vsftpd-2.0.5-pasv_dot.patch
38Patch30: vsftpd-2.0.5-pam_end.patch
39Patch31: vsftpd-2.0.5-write_race.patch
40Patch32: vsftpd-2.0.5-fix_unique.patch
41Patch34: vsftpd-2.0.5-underscore_uname.patch
42Patch35: vsftpd-2.0.5-uname_size.patch
43Patch36: vsftpd-2.0.5-greedy.patch
44Patch37: vsftpd-2.0.6-userlist_log.patch
45Patch38: vsftpd-2.0.6-listen.patch
46BuildRoot: %{_tmppath}/%{name}-%{version}-root
47%if %{tcp_wrappers}
48BuildPrereq: tcp_wrappers
49%endif
50BuildRequires: pam-devel
51Requires: pam
52BuildRequires: libcap-devel
53Requires: libcap
54BuildRequires: openssl-devel
55Requires: openssl
56Requires: logrotate
57Provides: ftpserver
58
59%description
60vsftpd is a Very Secure FTP daemon. It was written completely from
61scratch.
62
63%prep
64%setup -q -n %{name}-%{version}
65%patch1 -p1 -b .vine
66%patch2 -p1 -b .mok
67%if %{tcp_wrappers}
68%patch3 -p1 -b .tcp_wrappers
69%endif
70%patch4 -p1 -b .libs
71cp %{SOURCE1} .
72%patch5 -p1 -b .signal
73%patch6 -p1
74%patch7 -p1 -b .build_ssl
75%patch8 -p1 -b .server_args
76%patch9 -p1 -b .dir
77%patch11 -p1 -b .nonrootconf
78%patch13 -p1 -b .background
79%patch14 -p1 -b .fds
80%patch17 -p1 -b .old-pam
81%patch18 -p1 -b .close-fds
82%patch19 -p1 -b .ipv6
83%patch20 -p1 -b .ipv6opt
84%patch21 -p1 -b .comments
85%patch22 -p1 -b .manp
86%patch23 -p1 -b .filter
87%patch26 -p1 -b .bind_denied
88%patch29 -p1 -b .pasv_dot
89%patch30 -p1 -b .pam_end
90%patch31 -p1 -b .write_race
91%patch32 -p1 -b .fix_unique
92%patch34 -p1 -b .underscore_uname
93%patch35 -p1 -b .uname_size
94%patch36 -p1 -b .greedy
95%patch37 -p1 -b .userlist_log
96%patch38 -p1 -b .listen
97
98%build
99make CFLAGS="$RPM_OPT_FLAGS -fpie -pipe" \
100     LINK="-pie -lssl" \
101     %{?_smp_mflags}
102
103%install
104[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
105mkdir -p $RPM_BUILD_ROOT/usr/sbin
106mkdir -p $RPM_BUILD_ROOT/etc
107mkdir -p $RPM_BUILD_ROOT/etc/{vsftpd,pam.d,logrotate.d,rc.d/init.d}
108mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man{5,8}
109install -m 755 vsftpd  $RPM_BUILD_ROOT/usr/sbin/vsftpd
110install -m 600 vsftpd.conf $RPM_BUILD_ROOT/etc/vsftpd/vsftpd.conf
111install -m 644 vsftpd.conf.5 $RPM_BUILD_ROOT/%{_mandir}/man5/
112install -m 644 vsftpd.8 $RPM_BUILD_ROOT/%{_mandir}/man8/
113install -m 644 RedHat/vsftpd.log $RPM_BUILD_ROOT/etc/logrotate.d/vsftpd.log
114install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/vsftpd
115install -m 600 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/ftpusers
116install -m 600 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/user_list
117install -m 755 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/vsftpd
118install -m 744 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/vsftpd/vsftpd_conf_migrate.sh
119
120mkdir -p $RPM_BUILD_ROOT/var/ftp/pub
121mkdir -p $RPM_BUILD_ROOT/%{_datadir}/empty
122
123%clean
124[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
125
126%post
127/sbin/chkconfig --add vsftpd
128#/usr/sbin/usermod -d /var/ftp ftp >/dev/null 2>&1 || :
129
130%preun
131if [ $1 = 0 ]; then
132 /sbin/service vsftpd stop > /dev/null 2>&1
133 /sbin/chkconfig --del vsftpd
134fi
135 
136
137%files
138%defattr(-,root,root)
139/usr/sbin/vsftpd
140/etc/rc.d/init.d/vsftpd
141%dir /etc/vsftpd
142%config(noreplace) /etc/vsftpd/*
143%config(noreplace) /etc/pam.d/vsftpd
144%config(noreplace) /etc/logrotate.d/vsftpd.log
145%doc FAQ INSTALL BUGS AUDIT Changelog LICENSE README README.security REWARD SPEED TODO BENCHMARKS COPYING SECURITY/ EXAMPLE/ TUNING SIZE vsftpd.xinetd
146%{_mandir}/man5/vsftpd.conf.*
147%{_mandir}/man8/vsftpd.*
148/var/ftp
149%{_datadir}/empty
150
151%changelog
152* Mon Oct  6 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.7-1
153- new upstream release
154- update patches from FedoraCore
155- add Source6 from FedoraCore
156
157* Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.5-0vl1
158- new upstream release
159- build with openssl-0.9.8e
160
161* Fri Sep  9 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.3-0vl1
162- new upstream release
163
164* Thu Mar  3 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.2-0vl1
165- new upstream release
166- disable patch5
167
168* Mon Nov 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-5vl2
169- rename patch1 and disable anonymous FTP
170
171* Mon Oct 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-5vl1
172- build for VineSeed
173- remove lines about s390, pie and patch4
174- add %%{_datadir}/empty to %%files
175- rename patch1 and add "use_localtime=YES"
176- remove Prereq: /sbin/chkconfig, /sbin/service, /usr/sbin/usermod
177  because they must be installed
178- remove Obsoletes: anonftp
179- remove BuildRequires: libcap-devel and Requires: libcap
180
181* Fri Oct 01 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-5
182- vsftpd under xinetd reads its config file (#134314)
183
184* Thu Sep 16 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-4
185- spec file changed, ftp dir change commented (#130119)
186- added doc files (#113056)
187
188* Wed Sep 08 2004 Jan Kratochvil <project-vsftpd@jankratochvil.net>
189- update for 2.0.1 for SSL
190
191* Fri Aug 27 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-2
192- vsftpd.conf file changed, default IPv6 support
193
194* Fri Aug 20 2004 Radek Vokal <rvokal@redhat.com> 2.0.1-1
195- tcp_wrapper patch updated, signal patch updated
196- upgrade to 2.0.1, fixes several bugs, RHEL and FC builds
197
198* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
199- rebuilt
200
201* Wed May 19 2004 Bill Nottingham <notting@redhat.com> 1.2.1-6
202- fix the logrotate config (#116253)
203
204* Mon May  3 2004 Bill Nottingham <notting@redhat.com> 1.2.1-5
205- fix all references to vsftpd.conf to be /etc/vsftpd/vsftpd.conf,
206  including in the binary (#121199, #104075)
207
208* Thu Mar 25 2004 Bill Nottingham <notting@redhat.com> 1.2.1-4
209- don't call malloc()/free() in signal handlers (#119136,
210  <olivier.baudron@m4x.org>)
211
212* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
213- rebuilt
214
215* Mon Nov 24 2003 Karsten Hopp <karsten@redhat.de> 1.2.1-1
216- update to 1.2.1, which fixes #89765 and lot of other issues
217- remove manpage patch, it isn't required anymore
218- clean up init script
219- don't use script to find libs to link with (lib64 issues)
220
221* Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
222- allow compiling without tcp_wrappers support
223
224* Mon Sep 15 2003 Bill Nottingham <notting@redhat.com> 1.2.0-4
225- fix errant newline (#104443)
226
227* Fri Aug  8 2003 Bill Nottingham <notting@redhat.com> 1.2.0-3
228- tweak man page (#84584, #72798)
229- buildprereqs for pie (#99336)
230- free ride through the build system to fix (#101582)
231
232* Thu Jun 26 2003 Bill Nottingham <notting@redhat.com> 1.2.0-2
233- update to 1.2.0
234
235* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
236- rebuilt
237
238* Mon Apr 28 2003 Bill Nottingham <notting@redhat.com> 1.1.3-9
239- fix tcp_wrappers usage (#89765, <dale@riyescott.com>)
240
241* Fri Feb 28 2003 Nalin Dahyabhai <nalin@redhat.com> 1.1.3-8
242- enable use of tcp_wrappers
243
244* Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 1.1.3-7
245- provide /var/ftp & /var/ftp/pub. obsolete anonftp.
246
247* Mon Feb 10 2003 Bill Nottingham <notting@redhat.com> 1.1.3-6
248- clean up comments in init script (#83962)
249
250* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
251- rebuilt
252
253* Mon Dec 30 2002 Florian La Roche <Florian.LaRoche@redhat.de>
254- change to /etc/rc.d/init.d for better compatibility
255
256* Mon Dec 16 2002 Bill Nottingham <notting@redhat.com> 1.1.3-3
257- fix initscript perms
258- fix typo in initscript (#76587)
259
260* Fri Dec 13 2002 Bill Nottingham <notting@redhat.com> 1.1.3-2
261- update to 1.1.3
262- run standalone, don't run by default
263- fix reqs
264 
265* Fri Nov 22 2002 Joe Orton <jorton@redhat.com> 1.1.0-3
266- fix use with xinetd-ipv6; add flags=IPv4 in xinetd file (#78410)
267
268* Tue Nov 12 2002 Nalin Dahyabhai <nalin@redhat.com> 1.0.1-9
269- remove absolute paths from PAM configuration so that the right modules get
270  used for whichever arch we're built for on multilib systems
271
272* Thu Aug 15 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-8
273- -D_FILE_OFFSET_BITS=64
274- smp make
275- remove forced optflags=-g for lack of supporting documentation
276 
277* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
278- automated rebuild
279
280* Thu May 23 2002 Tim Powers <timp@redhat.com>
281- automated rebuild
282
283* Wed Apr 10 2002 Bill Nottingham <notting@redhat.com> 1.0.1-5
284- don't spit out ugly errors if anonftp isn't installed (#62987)
285- fix horribly broken userlist setup (#62321)
286
287* Thu Feb 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.0.1-4
288- s/Copyright/License/
289- add "missingok" to the logrotate script, so we don't get errors
290  when nothing has happened
291
292* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
293- automated rebuild
294
295* Wed Nov 28 2001 Bill Nottingham <notting@redhat.com>
296- initial packaging for RHL, munge included specfile
297
298* Thu Mar 22 2001 Seth Vidal <skvidal@phy.duke.edu>
299- updated to 0.0.15
300- added entry for vsftpd.8 man page
301- added entry for vsftpd.log logrotate file
302- added TUNING file to docs list
303
304* Wed Mar 7 2001 Seth Vidal <skvidal@phy.duke.edu>
305- Updated to 0.0.14
306- made %%files entry for man page
307
308* Wed Feb 21 2001 Seth Vidal <skvidal@phy.duke.edu>
309- Updated to 0.0.13
310
311* Mon Feb 12 2001 Seth Vidal <skvidal@phy.duke.edu>
312- Updated to 0.0.12
313
314* Wed Feb 7 2001 Seth Vidal <skvidal@phy.duke.edu>
315- updated to 0.0.11
316
317* Fri Feb 1 2001 Seth Vidal <skvidal@phy.duke.edu>
318- Update to 0.0.10
319
320* Fri Feb 1 2001 Seth Vidal <skvidal@phy.duke.edu>
321- First RPM packaging
322- Stolen items from wu-ftpd's pam setup
323- Separated rh 7 and rh 6.X's packages
324- Built for Rh6
Note: See TracBrowser for help on using the repository browser.