source: projects/specs/trunk/v/vino/vino-vl.spec @ 7938

Revision 7938, 7.3 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1%define gtk3_version 3.10.0
2%define libgcrypt_version 1.4.6
3%define avahi_version 0.6.31
4
5Summary: A remote desktop system for GNOME
6Summary(ja): GNOME 用リモートデスクトップシステム
7Name: vino
8Version: 3.10.1
9Release: 1%{?_dist_release}
10URL: http://www.gnome.org
11License: GPL
12Group: User Interface/Desktops
13
14Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.10/%{name}-%{version}.tar.xz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Requires: gtk3 >= %{gtk3_version}
19Requires: libgcrypt >= %{libgcrypt_version}
20Requires: avahi >= %{avahi_version}
21Requires: avahi-glib >= %{avahi_version}
22Requires: NetworkManager >= 0.8
23
24BuildRequires: gtk3-devel >= %{gtk3_version}
25BuildRequires: dbus-devel >= 1.4.0
26BuildRequires: libsoup-devel >= 2.32.0
27BuildRequires: libnotify-devel >= 0.4.5
28BuildRequires: libgcrypt-devel >= %{libgcrypt_version}
29BuildRequires: avahi-devel >= %{avahi_version}
30BuildRequires: avahi-glib-devel >= %{avahi_version}
31BuildRequires: libgnome-keyring-devel >= 2.32
32BuildRequires: NetworkManager-glib-devel >= 0.8
33BuildRequires: unique3-devel >= 3.0.0
34BuildRequires: libSM-devel
35BuildRequires: libXtst-devel
36BuildRequires: libjpeg-turbo-devel
37BuildRequires: desktop-file-utils
38
39Vendor: Project Vine
40Distribution: Vine Linux
41
42%description
43Vino is a VNC server for GNOME. It allows remote users to
44connect to a running GNOME session using VNC.
45
46%description -l ja
47Vine は GNOME 用の VNC サーバです。Vino によりリモートユーザが
48VNC を利用して稼働中のGNOME セッション接続することができるよう
49になります。
50
51%prep
52%setup -q
53
54%build
55%configure \
56        --disable-schemas-install \
57        --enable-avahi \
58        --disable-gnutls \
59        --disable-session-support \
60        --disable-telepathy \
61        --enable-libnotify \
62        --enable-network-manager \
63        --enable-gnome-keyring \
64        --disable-http-server \
65        --enable-libunique=yes
66%__make %{?_smp_mflags}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70
71make install DESTDIR=$RPM_BUILD_ROOT
72
73# stuff we don't want
74rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
75
76%find_lang %{name}
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post
82touch --no-create %{_datadir}/icons/hicolor
83
84%postun
85touch --no-create %{_datadir}/icons/hicolor
86if [ -x /usr/bin/gtk-update-icon-cache ]; then
87  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
88fi
89glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
90
91%posttrans
92gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
93glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
94
95
96
97%files -f %{name}.lang
98%defattr(-,root,root)
99%doc AUTHORS ChangeLog COPYING NEWS README docs/TODO docs/remote-desktop.txt
100%{_sysconfdir}/xdg/autostart/vino-server.desktop
101%{_bindir}/*
102%{_libexecdir}/*
103%{_datadir}/GConf/gsettings/org.gnome.Vino.convert
104%{_datadir}/dbus-1/services/*
105%{_datadir}/glib-2.0/schemas/*.xml
106
107%changelog
108* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
109- new upstream release
110
111* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
112- new upstream release
113- add BuildRequires: libjpeg-turbo-devel
114
115* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
116- new upstream release
117
118* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
119- new upstream release
120- remove BuildRequires: GConf2-devel
121
122* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
123- new upstream release
124
125* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
126- new upstream release
127
128* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
129- new upstream release
130
131* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
132- new upstream release
133
134* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
135- new upstream release
136
137* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
138- new upstream release
139
140* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
141- new upstream release
142- add BuildRequires: libXtst-devel
143
144* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
145- new upstream release
146
147* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
148- new upstream release
149- change BuildRequires: unique3-devel instead of unique-devel
150
151* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
152- new upstream release
153- change BuildRequires: NetworkManager-glib-devel instead of NetworkManager-devel
154
155* Sun Dec 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
156- new upstream release
157
158* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
159- new upstream release
160
161* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
162- new upstream release
163- add BuildRequires: libSM-devel, desktop-file-utils
164- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
165
166* Sun Nov  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
167- new upstream release
168
169* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
170- new upstream release
171
172* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
173- new upstream release
174
175* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
176- new upstream release
177
178* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
179- new upstream release
180
181* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
182- new upstream release
183
184* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
185- new upstream release
186
187* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.1-1vl5
188- applied new versioning policy, spec in utf-8
189
190* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
191- new upstream release
192
193* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl3
194- run gtk-update-icon-cache in %%post script.
195
196* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
197- enable avahi, add BuildRequires: avahi-devel
198
199* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
200- new upstream release
201
202* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
203- new upstream release
204
205* Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
206- new upstream version
207
208* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
209- initial build for Vine Linux
210- add japanese summary and description.
211
212* Tue Oct 12 2004 Mark McLoughlin <markmc@redhat.com> 2.8.1-1
213- Update to 2.8.1
214- Remove backported fixes
215
216* Thu Oct  7 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1.1
217- Don't hang with metacity's "reduced resources" mode (#134240)
218- Improve the key repeat rate situation a good deal (#134451)
219
220* Wed Sep 29 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1
221- Update to 2.8.0.1
222
223* Tue Sep 21 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0-1
224- Update to 2.8.0
225- Remove upstreamed work-without-gnutls patch
226
227* Tue Sep  7 2004 Matthias Clasen <mclasen@redhat.com> 2.7.92-3
228- Disable help button until there is help (#131632)
229 
230* Wed Sep  1 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-2
231- Add patch to fix hang without GNU TLS (bug #131354)
232
233* Mon Aug 30 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-1
234- Update to 2.7.92
235
236* Tue Aug 17 2004 Mark McLoughlin <markmc@redhat.com> 2.7.91-1
237- Update to 2.7.91
238
239* Mon Aug 16 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-2
240- Define libgcrypt_version
241
242* Thu Aug 12 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-1
243- Update to 2.7.90
244
245* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 2.7.4-1
246- Update to 2.7.4
247
248* Tue Jul 13 2004 Mark McLoughlin <markmc@redhat.com> 2.7.3.1-1
249- Initial build.
Note: See TracBrowser for help on using the repository browser.