source: projects/specs/trunk/v/vino/vino-vl.spec @ 8119

Revision 8119, 7.4 KB checked in by Takemikaduchi, 10 years ago (diff)

rebuild or new upstream release

Line 
1%define gtk3_version 3.10.0
2%define libgcrypt_version 1.4.6
3%define avahi_version 0.6.31
4
5Summary: A remote desktop system for GNOME
6Summary(ja): GNOME 用リモートデスクトップシステム
7Name: vino
8Version: 3.10.1
9Release: 2%{?_dist_release}
10URL: http://www.gnome.org
11License: GPL
12Group: User Interface/Desktops
13
14Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.10/%{name}-%{version}.tar.xz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Requires: gtk3 >= %{gtk3_version}
19Requires: libgcrypt >= %{libgcrypt_version}
20Requires: avahi >= %{avahi_version}
21Requires: avahi-glib >= %{avahi_version}
22Requires: NetworkManager >= 0.8
23
24BuildRequires: gtk3-devel >= %{gtk3_version}
25BuildRequires: dbus-devel >= 1.4.0
26BuildRequires: libsoup-devel >= 2.32.0
27BuildRequires: libnotify-devel >= 0.4.5
28BuildRequires: libgcrypt-devel >= %{libgcrypt_version}
29BuildRequires: avahi-devel >= %{avahi_version}
30BuildRequires: avahi-glib-devel >= %{avahi_version}
31BuildRequires: libgnome-keyring-devel >= 2.32
32BuildRequires: NetworkManager-glib-devel >= 0.8
33BuildRequires: unique3-devel >= 3.0.0
34BuildRequires: libSM-devel
35BuildRequires: libXtst-devel
36BuildRequires: libjpeg-turbo-devel
37BuildRequires: desktop-file-utils
38
39Vendor: Project Vine
40Distribution: Vine Linux
41
42%description
43Vino is a VNC server for GNOME. It allows remote users to
44connect to a running GNOME session using VNC.
45
46%description -l ja
47Vine は GNOME 用の VNC サーバです。Vino によりリモートユーザが
48VNC を利用して稼働中のGNOME セッション接続することができるよう
49になります。
50
51%prep
52%setup -q
53
54%build
55%configure \
56        --disable-schemas-install \
57        --enable-avahi \
58        --disable-gnutls \
59        --disable-session-support \
60        --disable-telepathy \
61        --enable-libnotify \
62        --enable-network-manager \
63        --enable-gnome-keyring \
64        --disable-http-server \
65        --enable-libunique=yes
66%__make %{?_smp_mflags}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70
71make install DESTDIR=$RPM_BUILD_ROOT
72
73# stuff we don't want
74rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
75
76%find_lang %{name}
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post
82touch --no-create %{_datadir}/icons/hicolor
83
84%postun
85touch --no-create %{_datadir}/icons/hicolor
86if [ -x /usr/bin/gtk-update-icon-cache ]; then
87  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
88fi
89glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
90
91%posttrans
92gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
93glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
94
95
96
97%files -f %{name}.lang
98%defattr(-,root,root)
99%doc AUTHORS ChangeLog COPYING NEWS README docs/TODO docs/remote-desktop.txt
100%{_sysconfdir}/xdg/autostart/vino-server.desktop
101%{_bindir}/*
102%{_libexecdir}/*
103%{_datadir}/GConf/gsettings/org.gnome.Vino.convert
104%{_datadir}/dbus-1/services/*
105%{_datadir}/glib-2.0/schemas/*.xml
106
107%changelog
108* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
109- rebuild with VineSeed environment
110
111* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
112- new upstream release
113
114* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
115- new upstream release
116- add BuildRequires: libjpeg-turbo-devel
117
118* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
119- new upstream release
120
121* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
122- new upstream release
123- remove BuildRequires: GConf2-devel
124
125* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
126- new upstream release
127
128* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
129- new upstream release
130
131* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
132- new upstream release
133
134* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
135- new upstream release
136
137* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
138- new upstream release
139
140* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
141- new upstream release
142
143* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
144- new upstream release
145- add BuildRequires: libXtst-devel
146
147* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
148- new upstream release
149
150* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
151- new upstream release
152- change BuildRequires: unique3-devel instead of unique-devel
153
154* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
155- new upstream release
156- change BuildRequires: NetworkManager-glib-devel instead of NetworkManager-devel
157
158* Sun Dec 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
159- new upstream release
160
161* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
162- new upstream release
163
164* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
165- new upstream release
166- add BuildRequires: libSM-devel, desktop-file-utils
167- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
168
169* Sun Nov  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
170- new upstream release
171
172* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
173- new upstream release
174
175* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
176- new upstream release
177
178* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
179- new upstream release
180
181* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
182- new upstream release
183
184* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
185- new upstream release
186
187* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
188- new upstream release
189
190* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.1-1vl5
191- applied new versioning policy, spec in utf-8
192
193* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
194- new upstream release
195
196* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl3
197- run gtk-update-icon-cache in %%post script.
198
199* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
200- enable avahi, add BuildRequires: avahi-devel
201
202* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
203- new upstream release
204
205* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
206- new upstream release
207
208* Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
209- new upstream version
210
211* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
212- initial build for Vine Linux
213- add japanese summary and description.
214
215* Tue Oct 12 2004 Mark McLoughlin <markmc@redhat.com> 2.8.1-1
216- Update to 2.8.1
217- Remove backported fixes
218
219* Thu Oct  7 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1.1
220- Don't hang with metacity's "reduced resources" mode (#134240)
221- Improve the key repeat rate situation a good deal (#134451)
222
223* Wed Sep 29 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1
224- Update to 2.8.0.1
225
226* Tue Sep 21 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0-1
227- Update to 2.8.0
228- Remove upstreamed work-without-gnutls patch
229
230* Tue Sep  7 2004 Matthias Clasen <mclasen@redhat.com> 2.7.92-3
231- Disable help button until there is help (#131632)
232 
233* Wed Sep  1 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-2
234- Add patch to fix hang without GNU TLS (bug #131354)
235
236* Mon Aug 30 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-1
237- Update to 2.7.92
238
239* Tue Aug 17 2004 Mark McLoughlin <markmc@redhat.com> 2.7.91-1
240- Update to 2.7.91
241
242* Mon Aug 16 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-2
243- Define libgcrypt_version
244
245* Thu Aug 12 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-1
246- Update to 2.7.90
247
248* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 2.7.4-1
249- Update to 2.7.4
250
251* Tue Jul 13 2004 Mark McLoughlin <markmc@redhat.com> 2.7.3.1-1
252- Initial build.
Note: See TracBrowser for help on using the repository browser.