source: projects/specs/trunk/v/vino/vino-vl.spec @ 3801

Revision 3801, 6.5 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME packages: new upstream release, bogofilter: fix perl requirements, perl-modules: new package

Line 
1%define gtk2_version 2.22.1
2%define gconf2_version 2.32.0
3%define libgcrypt_version 1.4.6
4%define avahi_version 0.6.25
5
6Summary: A remote desktop system for GNOME
7Summary(ja): GNOME 用リモートデスクトップシステム
8Name: vino
9Version: 2.32.2
10Release: 1%{?_dist_release}
11URL: http://www.gnome.org
12License: GPL
13Group: User Interface/Desktops
14
15Source0: http://ftp.gnome.org/pub/GNOME/sources/vino/2.32/%{name}-%{version}.tar.bz2
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19Requires: GConf2 >= %{gconf2_version}
20
21Requires: gtk2 >= %{gtk2_version}
22Requires: GConf2 >= %{gconf2_version}
23Requires: libgcrypt >= %{libgcrypt_version}
24Requires: avahi >= %{avahi_version}
25Requires: avahi-glib >= %{avahi_version}
26Requires: NetworkManager >= 0.8
27
28BuildRequires: gtk2-devel >= %{gtk2_version}
29BuildRequires: GConf2-devel >= %{gconf2_version}
30BuildRequires: dbus-devel >= 1.4.0
31BuildRequires: libsoup-devel >= 2.32.0
32BuildRequires: libnotify-devel >= 0.4.5
33BuildRequires: libgcrypt-devel >= %{libgcrypt_version}
34BuildRequires: avahi-devel >= %{avahi_version}
35BuildRequires: avahi-glib-devel >= %{avahi_version}
36BuildRequires: libgnome-keyring-devel >= 2.32
37BuildRequires: NetworkManager-glib-devel >= 0.8
38BuildRequires: unique-devel >= 1.0.0
39BuildRequires: libSM-devel
40BuildRequires: desktop-file-utils
41
42%description
43Vino is a VNC server for GNOME. It allows remote users to
44connect to a running GNOME session using VNC.
45
46%description -l ja
47Vine は GNOME 用の VNC サーバです。Vino によりリモートユーザが
48VNC を利用して稼働中のGNOME セッション接続することができるよう
49になります。
50
51%prep
52%setup -q
53
54%build
55%configure \
56        --disable-schemas-install \
57        --enable-avahi \
58        --disable-gnutls \
59        --disable-session-support \
60        --disable-telepathy \
61        --enable-libnotify \
62        --enable-network-manager \
63        --enable-gnome-keyring \
64        --disable-http-server \
65        --enable-libunique=yes
66%__make %{?_smp_mflags}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70
71export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
72%makeinstall
73unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
74
75desktop-file-install --vendor gnome --delete-original                   \
76  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
77  --add-only-show-in GNOME                                              \
78  $RPM_BUILD_ROOT%{_datadir}/applications/vino-preferences.desktop
79
80# stuff we don't want
81rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
82
83%find_lang %{name}
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post
89export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
90SCHEMAS="vino-server.schemas"
91for S in $SCHEMAS; do
92  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >& /dev/null ||:
93done
94touch --no-create %{_datadir}/icons/hicolor
95if [ -x /usr/bin/gtk-update-icon-cache ]; then
96  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
97fi
98
99%postun
100touch --no-create %{_datadir}/icons/hicolor
101if [ -x /usr/bin/gtk-update-icon-cache ]; then
102  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
103fi
104
105
106%files -f %{name}.lang
107%defattr(-,root,root)
108%doc AUTHORS ChangeLog COPYING NEWS README docs/TODO docs/remote-desktop.txt
109%{_bindir}/*
110%{_libexecdir}/*
111%{_datadir}/applications/*.desktop
112%{_datadir}/dbus-1/services/*
113%{_datadir}/vino
114%{_sysconfdir}/gconf/schemas/*.schemas
115%{_sysconfdir}/xdg/autostart/vino-server.desktop
116
117%changelog
118* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
119- new upstream release
120- change BuildRequires: NetworkManager-glib-devel instead of NetworkManager-devel
121
122* Sun Dec 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
123- new upstream release
124
125* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
126- new upstream release
127
128* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
129- new upstream release
130- add BuildRequires: libSM-devel, desktop-file-utils
131- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
132
133* Sun Nov  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
134- new upstream release
135
136* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
137- new upstream release
138
139* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
140- new upstream release
141
142* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
143- new upstream release
144
145* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
146- new upstream release
147
148* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
149- new upstream release
150
151* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
152- new upstream release
153
154* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.1-1vl5
155- applied new versioning policy, spec in utf-8
156
157* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
158- new upstream release
159
160* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl3
161- run gtk-update-icon-cache in %%post script.
162
163* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
164- enable avahi, add BuildRequires: avahi-devel
165
166* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
167- new upstream release
168
169* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
170- new upstream release
171
172* Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
173- new upstream version
174
175* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
176- initial build for Vine Linux
177- add japanese summary and description.
178
179* Tue Oct 12 2004 Mark McLoughlin <markmc@redhat.com> 2.8.1-1
180- Update to 2.8.1
181- Remove backported fixes
182
183* Thu Oct  7 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1.1
184- Don't hang with metacity's "reduced resources" mode (#134240)
185- Improve the key repeat rate situation a good deal (#134451)
186
187* Wed Sep 29 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1
188- Update to 2.8.0.1
189
190* Tue Sep 21 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0-1
191- Update to 2.8.0
192- Remove upstreamed work-without-gnutls patch
193
194* Tue Sep  7 2004 Matthias Clasen <mclasen@redhat.com> 2.7.92-3
195- Disable help button until there is help (#131632)
196 
197* Wed Sep  1 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-2
198- Add patch to fix hang without GNU TLS (bug #131354)
199
200* Mon Aug 30 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-1
201- Update to 2.7.92
202
203* Tue Aug 17 2004 Mark McLoughlin <markmc@redhat.com> 2.7.91-1
204- Update to 2.7.91
205
206* Mon Aug 16 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-2
207- Define libgcrypt_version
208
209* Thu Aug 12 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-1
210- Update to 2.7.90
211
212* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 2.7.4-1
213- Update to 2.7.4
214
215* Tue Jul 13 2004 Mark McLoughlin <markmc@redhat.com> 2.7.3.1-1
216- Initial build.
Note: See TracBrowser for help on using the repository browser.