source: projects/specs/trunk/v/vino/vino-vl.spec @ 4616

Revision 4616, 6.6 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define gtk3_version 3.0.9
2%define gconf2_version 2.32.0
3%define libgcrypt_version 1.4.6
4%define avahi_version 0.6.25
5
6Summary: A remote desktop system for GNOME
7Summary(ja): GNOME 用リモートデスクトップシステム
8Name: vino
9Version: 3.1.4
10Release: 1%{?_dist_release}
11URL: http://www.gnome.org
12License: GPL
13Group: User Interface/Desktops
14
15Source0: http://ftp.gnome.org/pub/GNOME/sources/vino/3.1/%{name}-%{version}.tar.xz
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19Requires: GConf2 >= %{gconf2_version}
20
21Requires: gtk3 >= %{gtk3_version}
22Requires: GConf2 >= %{gconf2_version}
23Requires: libgcrypt >= %{libgcrypt_version}
24Requires: avahi >= %{avahi_version}
25Requires: avahi-glib >= %{avahi_version}
26Requires: NetworkManager >= 0.8
27
28BuildRequires: gtk3-devel >= %{gtk3_version}
29BuildRequires: GConf2-devel >= %{gconf2_version}
30BuildRequires: dbus-devel >= 1.4.0
31BuildRequires: libsoup-devel >= 2.32.0
32BuildRequires: libnotify-devel >= 0.4.5
33BuildRequires: libgcrypt-devel >= %{libgcrypt_version}
34BuildRequires: avahi-devel >= %{avahi_version}
35BuildRequires: avahi-glib-devel >= %{avahi_version}
36BuildRequires: libgnome-keyring-devel >= 2.32
37BuildRequires: NetworkManager-glib-devel >= 0.8
38BuildRequires: unique3-devel >= 3.0.0
39BuildRequires: libSM-devel
40BuildRequires: desktop-file-utils
41
42Vendor: Project Vine
43Distribution: Vine Linux
44
45%description
46Vino is a VNC server for GNOME. It allows remote users to
47connect to a running GNOME session using VNC.
48
49%description -l ja
50Vine は GNOME 用の VNC サーバです。Vino によりリモートユーザが
51VNC を利用して稼働中のGNOME セッション接続することができるよう
52になります。
53
54%prep
55%setup -q
56
57%build
58%configure \
59        --disable-schemas-install \
60        --enable-avahi \
61        --disable-gnutls \
62        --disable-session-support \
63        --disable-telepathy \
64        --enable-libnotify \
65        --enable-network-manager \
66        --enable-gnome-keyring \
67        --disable-http-server \
68        --enable-libunique=yes
69%__make %{?_smp_mflags}
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
75make install DESTDIR=$RPM_BUILD_ROOT
76unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
77
78#desktop-file-install --vendor gnome --delete-original                   \
79#  --dir $RPM_BUILD_ROOT%{_datadir}/applications                                \
80#  --add-only-show-in GNOME                                              \
81#  $RPM_BUILD_ROOT%{_datadir}/applications/vino-preferences.desktop
82
83# stuff we don't want
84rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
85
86%find_lang %{name}
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%post
92touch --no-create %{_datadir}/icons/hicolor
93
94%postun
95touch --no-create %{_datadir}/icons/hicolor
96if [ -x /usr/bin/gtk-update-icon-cache ]; then
97  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
98fi
99glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
100
101%posttrans
102gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
103glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
104
105
106
107%files -f %{name}.lang
108%defattr(-,root,root)
109%doc AUTHORS ChangeLog COPYING NEWS README docs/TODO docs/remote-desktop.txt
110%{_sysconfdir}/xdg/autostart/vino-server.desktop
111%{_bindir}/*
112%{_libexecdir}/*
113%{_datadir}/GConf/gsettings/org.gnome.Vino.convert
114%{_datadir}/applications/*.desktop
115%{_datadir}/dbus-1/services/*
116%{_datadir}/glib-2.0/schemas/*.xml
117%{_datadir}/vino
118
119%changelog
120* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
121- new upstream release
122- change BuildRequires: unique3-devel instead of unique-devel
123
124* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
125- new upstream release
126- change BuildRequires: NetworkManager-glib-devel instead of NetworkManager-devel
127
128* Sun Dec 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
129- new upstream release
130
131* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
132- new upstream release
133
134* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
135- new upstream release
136- add BuildRequires: libSM-devel, desktop-file-utils
137- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
138
139* Sun Nov  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
140- new upstream release
141
142* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
143- new upstream release
144
145* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
146- new upstream release
147
148* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
149- new upstream release
150
151* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
152- new upstream release
153
154* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
155- new upstream release
156
157* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
158- new upstream release
159
160* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.1-1vl5
161- applied new versioning policy, spec in utf-8
162
163* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
164- new upstream release
165
166* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl3
167- run gtk-update-icon-cache in %%post script.
168
169* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
170- enable avahi, add BuildRequires: avahi-devel
171
172* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
173- new upstream release
174
175* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
176- new upstream release
177
178* Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
179- new upstream version
180
181* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
182- initial build for Vine Linux
183- add japanese summary and description.
184
185* Tue Oct 12 2004 Mark McLoughlin <markmc@redhat.com> 2.8.1-1
186- Update to 2.8.1
187- Remove backported fixes
188
189* Thu Oct  7 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1.1
190- Don't hang with metacity's "reduced resources" mode (#134240)
191- Improve the key repeat rate situation a good deal (#134451)
192
193* Wed Sep 29 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1
194- Update to 2.8.0.1
195
196* Tue Sep 21 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0-1
197- Update to 2.8.0
198- Remove upstreamed work-without-gnutls patch
199
200* Tue Sep  7 2004 Matthias Clasen <mclasen@redhat.com> 2.7.92-3
201- Disable help button until there is help (#131632)
202 
203* Wed Sep  1 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-2
204- Add patch to fix hang without GNU TLS (bug #131354)
205
206* Mon Aug 30 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-1
207- Update to 2.7.92
208
209* Tue Aug 17 2004 Mark McLoughlin <markmc@redhat.com> 2.7.91-1
210- Update to 2.7.91
211
212* Mon Aug 16 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-2
213- Define libgcrypt_version
214
215* Thu Aug 12 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-1
216- Update to 2.7.90
217
218* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 2.7.4-1
219- Update to 2.7.4
220
221* Tue Jul 13 2004 Mark McLoughlin <markmc@redhat.com> 2.7.3.1-1
222- Initial build.
Note: See TracBrowser for help on using the repository browser.