source: projects/specs/trunk/v/vala/vala-vl.spec @ 1545

Revision 1545, 9.4 KB checked in by kudoh, 14 years ago (diff)
Line 
1%global api_ver 0.10
2
3Summary:        A modern programming language for GNOME
4Summary:        GNOME 用のモダンなプログラミング言語
5
6Name:           vala
7Version:        0.9.5
8Release:        1%{?_dist_release}
9
10Group:          Development/Languages
11# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
12License:        LGPLv2+ and BSD
13URL:            http://live.gnome.org/Vala
14Source0:        http://download.gnome.org/sources/vala/0.9/vala-%{version}.tar.bz2
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  gtk2-devel flex bison devhelp xulrunner-devel >= 1.9
18Requires:       gtk2-devel
19
20%description
21Vala is a new programming language that aims to bring modern programming
22language features to GNOME developers without imposing any additional
23runtime requirements and without using a different ABI compared to
24applications and libraries written in C.
25
26valac, the Vala compiler, is a self-hosting compiler that translates
27Vala source code into C source and header files. It uses the GObject
28type system to create classes and interfaces declared in the Vala source
29code. It's also planned to generate GIDL files when gobject-
30introspection is ready.
31
32The syntax of Vala is similar to C#, modified to better fit the GObject
33type system.
34
35
36%package        devel
37Summary:        Development files for %{name}
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40Requires:       pkgconfig
41
42%description    devel
43Vala is a new programming language that aims to bring modern programming
44language features to GNOME developers without imposing any additional
45runtime requirements and without using a different ABI compared to
46applications and libraries written in C.
47
48This package contains development files for %{name}. This is not necessary for
49using the %{name} compiler.
50
51
52%package        tools
53Summary:        Tools for creating projects and bindings for %{name}
54Group:          Development/Languages
55License:        LGPLv2+
56Requires:       %{name} = %{version}-%{release}
57Requires:       gnome-common intltool libtool
58Provides:       %{name}-vapigen = %{version}-%{release}
59Obsoletes:      %{name}-vapigen < %{version}-%{release}
60
61%description    tools
62Vala is a new programming language that aims to bring modern programming
63language features to GNOME developers without imposing any additional
64runtime requirements and without using a different ABI compared to
65applications and libraries written in C.
66
67This package contains tools to generate Vala projects, as well as API bindings
68from existing C libraries, allowing access from Vala programs.
69
70
71%package        doc
72Summary:        Documentation for %{name}
73Group:          Documentation
74License:        LGPLv2+
75Requires:       %{name} = %{version}-%{release}
76Requires:       devhelp
77Provides:       %{name}-docs = %{version}-%{release}
78Obsoletes:      %{name}-docs < %{version}-%{release}
79
80
81%description    doc
82Vala is a new programming language that aims to bring modern programming
83language features to GNOME developers without imposing any additional
84runtime requirements and without using a different ABI compared to
85applications and libraries written in C.
86
87This package contains documentation in a devhelp HTML book.
88
89
90%prep
91%setup -q
92
93%build
94%configure --enable-vapigen
95# Don't use rpath!
96sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
97sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
98make %{?_smp_mflags}
99
100# checks currently utilize installed Vala, not the one being compiled
101#%check
102#make check
103
104%install
105rm -rf $RPM_BUILD_ROOT
106make install DESTDIR=$RPM_BUILD_ROOT
107rm $RPM_BUILD_ROOT%{_libdir}/libvala-%{api_ver}.la
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%post -p /sbin/ldconfig
113
114%postun -p /sbin/ldconfig
115
116%files
117%defattr(-,root,root,-)
118%doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
119%{_bindir}/vala
120%{_bindir}/valac
121%{_bindir}/vala-%{api_ver}
122%{_bindir}/valac-%{api_ver}
123%{_datadir}/vala-%{api_ver}
124%{_libdir}/libvala-%{api_ver}.so.*
125%{_mandir}/*/valac*
126
127%files devel
128%defattr(-,root,root,-)
129%{_includedir}/vala-%{api_ver}
130%{_libdir}/libvala-%{api_ver}.so
131%{_libdir}/pkgconfig/vala-%{api_ver}.pc
132%{_datadir}/aclocal/vala.m4
133
134%files tools
135%defattr(-,root,root,-)
136%{_bindir}/vala-gen-introspect
137%{_bindir}/vapicheck
138%{_bindir}/vapigen
139%{_bindir}/vala-gen-introspect-%{api_ver}
140%{_bindir}/vapicheck-%{api_ver}
141%{_bindir}/vapigen-%{api_ver}
142%{_libdir}/vala-%{api_ver}
143%{_mandir}/*/*gen*
144
145%files doc
146%defattr(-,root,root,-)
147%{_datadir}/devhelp/books/vala-%{api_ver}
148
149
150%changelog
151* Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
152- new upstream release
153
154* Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
155- new upstream release
156
157* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
158- new upstream release
159
160* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
161- new upstream release
162- change BuildRequires: gecko-libs -> xulrunner-devel
163
164* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
165- new upstream release
166
167* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
168- new upstream release
169
170* Tue Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
171- new upstream release
172
173* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
174- initial build for Vine Linux
175
176* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
177- Update to 0.7.5
178
179* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
180- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
181
182* Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
183- Patch broken ModuleInit attribute (upstream bug 587444)
184
185* Tue Jul  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
186- Update to 0.7.4
187
188* Wed Jun  3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
189- Update to 0.7.3
190
191* Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
192- Update to 0.6.1
193
194* Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
195- Update to 0.5.7
196
197* Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
198- Update to 0.5.6
199
200* Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
201- Update to 0.5.3
202
203* Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
204- Fix bug in Emacs version detection
205
206* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
207- Use buildsystem variables to determine available Emacs version
208- BR on gecko-devel >= 1.9, since older version is also in RHEL repo
209
210* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
211- Update to 0.5.2
212
213* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
214- Update to 0.5.1
215
216* Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
217- Update to 0.3.5
218
219* Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
220- Add vala-mode for editing Vala code in Emacs
221
222* Tue Jul  1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
223- Update to 0.3.4
224
225* Wed Jun  4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
226- Update to 0.3.3
227
228* Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
229- Update to 0.3.2
230
231* Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
232- Update to 0.2.0
233
234* Wed Mar  5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
235- Update to 0.1.7
236- -tool subpackage now requires gnome-common, intltool and libtoolize
237  for out-of-the-box vala-gen-project support
238
239* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
240- Autorebuild for GCC 4.3
241
242* Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
243- Update to 0.1.6
244- Revert vapi addition, needed declarations have been inlined (r846)
245- Rename -docs subpackage to -doc, to comply with guidelines
246
247* Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
248- Manually add Gee vapi file to package (bz #428692)
249
250* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
251- Backport patch to autodetect location of automake shared files
252
253* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
254- Add build dependency on gtk2-devel
255
256* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
257- Enable project generator tool
258
259* Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
260- Update to 0.1.5
261
262* Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
263- Add build dependency on devhelp
264
265* Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
266- Update to 0.1.4
267- Put newly-added documentation in its own subpackage (depends on devhelp)
268
269* Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
270- vapigen subpackage: add missing Require: on perl-XML-Twig
271
272* Sat Sep  8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
273- Split -vapigen subpackage. It is functionally self-contained and the license
274  is more restricted
275- Updated license declarations
276
277* Wed Sep  5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
278- Licensing and URL updates
279
280* Tue Sep  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
281- Enable binding generation tools
282
283* Sun Sep  2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
284- Update to 0.1.3
285
286* Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
287- Update to 0.0.8
288
289* Wed Mar  7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
290- Update to 0.0.7
291
292* Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
293- Update to 0.0.6
294
295* Mon Nov  6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
296- Initial package
Note: See TracBrowser for help on using the repository browser.