source: projects/specs/trunk/v/vala/vala-vl.spec @ 1516

Revision 1516, 9.0 KB checked in by kudoh, 14 years ago (diff)
Line 
1Summary:        A modern programming language for GNOME
2Summary:        GNOME 用のモダンなプログラミング言語
3
4Name:           vala
5Version:        0.9.4
6Release:        1%{?_dist_release}
7
8Group:          Development/Languages
9# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
10License:        LGPLv2+ and BSD
11URL:            http://live.gnome.org/Vala
12Source0:        http://download.gnome.org/sources/vala/0.7/vala-%{version}.tar.bz2
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildRequires:  gtk2-devel flex bison devhelp xulrunner-devel >= 1.9
16Requires:       gtk2-devel
17
18%description
19Vala is a new programming language that aims to bring modern programming
20language features to GNOME developers without imposing any additional
21runtime requirements and without using a different ABI compared to
22applications and libraries written in C.
23
24valac, the Vala compiler, is a self-hosting compiler that translates
25Vala source code into C source and header files. It uses the GObject
26type system to create classes and interfaces declared in the Vala source
27code. It's also planned to generate GIDL files when gobject-
28introspection is ready.
29
30The syntax of Vala is similar to C#, modified to better fit the GObject
31type system.
32
33
34%package        devel
35Summary:        Development files for %{name}
36Group:          Development/Libraries
37Requires:       %{name} = %{version}-%{release}
38Requires:       pkgconfig
39
40%description    devel
41Vala is a new programming language that aims to bring modern programming
42language features to GNOME developers without imposing any additional
43runtime requirements and without using a different ABI compared to
44applications and libraries written in C.
45
46This package contains development files for %{name}. This is not necessary for
47using the %{name} compiler.
48
49
50%package        tools
51Summary:        Tools for creating projects and bindings for %{name}
52Group:          Development/Languages
53License:        LGPLv2+
54Requires:       %{name} = %{version}-%{release}
55Requires:       gnome-common intltool libtool
56Provides:       %{name}-vapigen = %{version}-%{release}
57Obsoletes:      %{name}-vapigen < %{version}-%{release}
58
59%description    tools
60Vala is a new programming language that aims to bring modern programming
61language features to GNOME developers without imposing any additional
62runtime requirements and without using a different ABI compared to
63applications and libraries written in C.
64
65This package contains tools to generate Vala projects, as well as API bindings
66from existing C libraries, allowing access from Vala programs.
67
68
69%package        doc
70Summary:        Documentation for %{name}
71Group:          Documentation
72License:        LGPLv2+
73Requires:       %{name} = %{version}-%{release}
74Requires:       devhelp
75Provides:       %{name}-docs = %{version}-%{release}
76Obsoletes:      %{name}-docs < %{version}-%{release}
77
78
79%description    doc
80Vala is a new programming language that aims to bring modern programming
81language features to GNOME developers without imposing any additional
82runtime requirements and without using a different ABI compared to
83applications and libraries written in C.
84
85This package contains documentation in a devhelp HTML book.
86
87
88%prep
89%setup -q
90
91
92%build
93%configure --enable-vapigen
94# Don't use rpath!
95sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
96sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
97make %{?_smp_mflags}
98
99
100# checks currently utilize installed Vala, not the one being compiled
101#%check
102#make check
103
104
105%install
106rm -rf $RPM_BUILD_ROOT
107make install DESTDIR=$RPM_BUILD_ROOT
108rm $RPM_BUILD_ROOT%{_libdir}/libvala.la
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(-,root,root,-)
119%doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
120%{_bindir}/vala
121%{_bindir}/valac
122%{_datadir}/vala
123%{_libdir}/libvala.so.*
124%{_mandir}/*/valac*
125
126%files devel
127%defattr(-,root,root,-)
128%{_includedir}/vala-1.0
129%{_libdir}/libvala.so
130%{_libdir}/pkgconfig/vala-1.0.pc
131
132%files tools
133%defattr(-,root,root,-)
134%{_bindir}/*gen*
135%{_bindir}/vapicheck
136%{_libdir}/vala
137%{_mandir}/*/*gen*
138
139%files doc
140%defattr(-,root,root,-)
141%{_datadir}/devhelp/books/vala
142
143
144%changelog
145* Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
146- new upstream release
147
148* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
149- new upstream release
150
151* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
152- new upstream release
153- change BuildRequires: gecko-libs -> xulrunner-devel
154
155* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
156- new upstream release
157
158* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
159- new upstream release
160
161* Tue Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
162- new upstream release
163
164* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
165- initial build for Vine Linux
166
167* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
168- Update to 0.7.5
169
170* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
172
173* Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
174- Patch broken ModuleInit attribute (upstream bug 587444)
175
176* Tue Jul  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
177- Update to 0.7.4
178
179* Wed Jun  3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
180- Update to 0.7.3
181
182* Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
183- Update to 0.6.1
184
185* Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
186- Update to 0.5.7
187
188* Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
189- Update to 0.5.6
190
191* Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
192- Update to 0.5.3
193
194* Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
195- Fix bug in Emacs version detection
196
197* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
198- Use buildsystem variables to determine available Emacs version
199- BR on gecko-devel >= 1.9, since older version is also in RHEL repo
200
201* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
202- Update to 0.5.2
203
204* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
205- Update to 0.5.1
206
207* Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
208- Update to 0.3.5
209
210* Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
211- Add vala-mode for editing Vala code in Emacs
212
213* Tue Jul  1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
214- Update to 0.3.4
215
216* Wed Jun  4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
217- Update to 0.3.3
218
219* Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
220- Update to 0.3.2
221
222* Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
223- Update to 0.2.0
224
225* Wed Mar  5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
226- Update to 0.1.7
227- -tool subpackage now requires gnome-common, intltool and libtoolize
228  for out-of-the-box vala-gen-project support
229
230* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
231- Autorebuild for GCC 4.3
232
233* Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
234- Update to 0.1.6
235- Revert vapi addition, needed declarations have been inlined (r846)
236- Rename -docs subpackage to -doc, to comply with guidelines
237
238* Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
239- Manually add Gee vapi file to package (bz #428692)
240
241* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
242- Backport patch to autodetect location of automake shared files
243
244* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
245- Add build dependency on gtk2-devel
246
247* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
248- Enable project generator tool
249
250* Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
251- Update to 0.1.5
252
253* Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
254- Add build dependency on devhelp
255
256* Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
257- Update to 0.1.4
258- Put newly-added documentation in its own subpackage (depends on devhelp)
259
260* Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
261- vapigen subpackage: add missing Require: on perl-XML-Twig
262
263* Sat Sep  8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
264- Split -vapigen subpackage. It is functionally self-contained and the license
265  is more restricted
266- Updated license declarations
267
268* Wed Sep  5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
269- Licensing and URL updates
270
271* Tue Sep  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
272- Enable binding generation tools
273
274* Sun Sep  2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
275- Update to 0.1.3
276
277* Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
278- Update to 0.0.8
279
280* Wed Mar  7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
281- Update to 0.0.7
282
283* Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
284- Update to 0.0.6
285
286* Mon Nov  6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
287- Initial package
Note: See TracBrowser for help on using the repository browser.