source: projects/specs/trunk/v/vala/vala-vl.spec @ 11332

Revision 11332, 13.5 KB checked in by tomop, 6 years ago (diff)

vala-0.38.4-1

Line 
1%global api_ver 0.38
2%define _unpackaged_files_terminate_build 1
3
4Summary:        A modern programming language for GNOME
5Summary(ja):    GNOME 用のモダンなプログラミング言語
6
7Name:           vala
8Version:        0.38.4
9Release:        1%{?_dist_release}
10
11Group:          Development/Languages
12# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
13License:        LGPLv2+ and BSD
14URL:            http://live.gnome.org/Vala
15Source0:        http://download.gnome.org/sources/vala/0.32/vala-%{version}.tar.xz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17
18BuildRequires:  glib2-devel
19BuildRequires:  flex
20BuildRequires:  bison
21BuildRequires:  libxslt
22BuildRequires:  graphviz-devel
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28Vala is a new programming language that aims to bring modern programming
29language features to GNOME developers without imposing any additional
30runtime requirements and without using a different ABI compared to
31applications and libraries written in C.
32
33valac, the Vala compiler, is a self-hosting compiler that translates
34Vala source code into C source and header files. It uses the GObject
35type system to create classes and interfaces declared in the Vala source
36code. It's also planned to generate GIDL files when gobject-
37introspection is ready.
38
39The syntax of Vala is similar to C#, modified to better fit the GObject
40type system.
41
42
43%package        devel
44Summary:        Development files for %{name}
45Summary(ja):    %{name} の開発用ファイル
46Group:          Development/Libraries
47Requires:       %{name} = %{version}-%{release}
48Requires:       pkgconfig
49
50%description    devel
51Vala is a new programming language that aims to bring modern programming
52language features to GNOME developers without imposing any additional
53runtime requirements and without using a different ABI compared to
54applications and libraries written in C.
55
56This package contains development files for %{name}. This is not necessary for
57using the %{name} compiler.
58
59
60%package        tools
61Summary:        Tools for creating projects and bindings for %{name}
62Summary(ja):    %{name} のプロジェクト作成やバインディングのためのツール集
63Group:          Development/Tools
64License:        LGPLv2+
65Requires:       %{name} = %{version}-%{release}
66Requires:       gnome-common intltool libtool
67Provides:       %{name}-vapigen = %{version}-%{release}
68Obsoletes:      %{name}-vapigen < %{version}-%{release}
69
70%description    tools
71Vala is a new programming language that aims to bring modern programming
72language features to GNOME developers without imposing any additional
73runtime requirements and without using a different ABI compared to
74applications and libraries written in C.
75
76This package contains tools to generate Vala projects, as well as API bindings
77from existing C libraries, allowing access from Vala programs.
78
79
80%package        doc
81Summary:        Documentation for %{name}
82Summary(ja):    %{name} のドキュメント
83Group:          Documentation
84License:        LGPLv2+
85
86BuildArch:      noarch
87Requires:       %{name} = %{version}-%{release}
88Requires:       devhelp
89Provides:       %{name}-docs = %{version}-%{release}
90Obsoletes:      %{name}-docs < %{version}-%{release}
91
92
93%description    doc
94Vala is a new programming language that aims to bring modern programming
95language features to GNOME developers without imposing any additional
96runtime requirements and without using a different ABI compared to
97applications and libraries written in C.
98
99This package contains documentation in a devhelp HTML book.
100
101
102%package -n     valadoc
103Summary:        Vala documentation generator
104Summary(ja):    Valaのドキュメントジェネレータ
105Group:          Development/Tools
106License:        LGPLv2+
107Requires:       vala = %{version}-%{release}
108
109%description -n valadoc
110Valadoc is a documentation generator for generating API documentation from Vala
111source code.
112
113
114%package -n     valadoc-devel
115Summary:        Development files for valadoc
116Summary(ja):    valadocを利用した開発のためのファイル群
117Group:          Development/Libraries
118License:        LGPLv2+
119
120Requires:       valadoc = %{version}-%{release}
121
122
123%description -n valadoc-devel
124Valadoc is a documentation generator for generating API documentation from Vala
125source code.
126
127The valadoc-devel package contains libraries and header files for
128developing applications that use valadoc.
129
130
131%prep
132%setup -q
133
134%build
135%configure --enable-vapigen
136# Don't use rpath!
137sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
138sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
139make %{?_smp_mflags}
140
141# checks currently utilize installed Vala, not the one being compiled
142#%check
143#make check
144
145%install
146rm -rf $RPM_BUILD_ROOT
147make install DESTDIR=$RPM_BUILD_ROOT
148find %{buildroot}%{_libdir} -type f -name 'lib*.la' | xargs rm -f
149
150
151%clean
152rm -rf $RPM_BUILD_ROOT
153
154%post -p /sbin/ldconfig
155
156%postun -p /sbin/ldconfig
157
158%files
159%defattr(-,root,root,-)
160%doc AUTHORS ChangeLog COPYING NEWS README THANKS
161%{_bindir}/vala
162%{_bindir}/valac
163%{_bindir}/vala-%{api_ver}
164%{_bindir}/valac-%{api_ver}
165%{_datadir}/vala-%{api_ver}
166%{_datadir}/vala
167%{_libdir}/libvala-%{api_ver}.so.*
168%{_mandir}/*/valac*
169
170%files devel
171%defattr(-,root,root,-)
172%{_includedir}/vala-%{api_ver}
173%{_libdir}/libvala-%{api_ver}.so
174%{_libdir}/pkgconfig/libvala-%{api_ver}.pc
175%{_datadir}/aclocal/vala.m4
176%{_datadir}/aclocal/vapigen.m4
177%{_libdir}/pkgconfig/vapigen.pc
178%{_libdir}/pkgconfig/vapigen-%{api_ver}.pc
179%{_datadir}/vala/Makefile.vapigen
180
181%files tools
182%defattr(-,root,root,-)
183%{_bindir}/vala-gen-introspect
184%{_bindir}/vapicheck
185%{_bindir}/vapigen
186%{_bindir}/vala-gen-introspect-%{api_ver}
187%{_bindir}/vapicheck-%{api_ver}
188%{_bindir}/vapigen-%{api_ver}
189%{_libdir}/vala-%{api_ver}
190%{_mandir}/*/*gen*
191
192%files doc
193%defattr(-,root,root,-)
194%{_datadir}/devhelp/books/vala-%{api_ver}
195
196%files -n valadoc
197%defattr(-,root,root,-)
198%{_bindir}/valadoc*
199%{_libdir}/libvaladoc-%{api_ver}.so.*
200%{_libdir}/valadoc
201%{_datadir}/valadoc
202%{_mandir}/*/valadoc*
203
204%files -n valadoc-devel
205
206%{_libdir}/libvaladoc-%{api_ver}.so
207%{_libdir}/pkgconfig/valadoc-%{api_ver}.pc
208%{_includedir}/valadoc-%{api_ver}
209
210%changelog
211* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.38.4-1
212- new upstream release.
213- added subpackages "valadoc" and "valadoc-devel".
214
215* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.32.1-1
216- new upstream release
217
218* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.30.0-1
219- new upstream release
220
221* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.1-1
222- new upstream release
223
224* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.0-1
225- new upstream release
226
227* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.26.2-1
228- new upstream release
229
230* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.26.1-1
231- new upstream release
232- moved tools subpackage to Development/Tools Group
233
234* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.0-1
235- new upstream release
236
237* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
238- new upstream release
239
240* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.0-1
241- new upstream release
242
243* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.20.1-1
244- new upstream release
245
246* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.1-1
247- new upstream release
248
249* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
250- new upstream release
251
252* Mon Jun 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
253- new upstream release
254
255* Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
256- new upstream release
257
258* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
259- new upstream release
260
261* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
262- new upstream release
263
264* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
265- new upstream release
266- remove BuildRequires: gtk2-devel, xulrunner-devel
267- add BuildRequires: glib2-devel, libxslt
268
269* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
270- new upstream release
271- remove BuildRequires: devhelp
272
273* Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
274- new upstream release
275
276* Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
277- new upstream release
278
279* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
280- new upstream release
281
282* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
283- rebuilt with rpm-4.8.1 for pkg-config
284
285* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
286- new upstream release
287- made -doc subpackage noarch
288
289* Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
290- new upstream release
291
292* Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
293- new upstream release
294
295* Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
296- new upstream release
297
298* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
299- new upstream release
300
301* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
302- new upstream release
303- change BuildRequires: gecko-libs -> xulrunner-devel
304
305* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
306- new upstream release
307
308* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
309- new upstream release
310
311* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
312- new upstream release
313
314* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
315- initial build for Vine Linux
316
317* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
318- Update to 0.7.5
319
320* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
321- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
322
323* Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
324- Patch broken ModuleInit attribute (upstream bug 587444)
325
326* Tue Jul  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
327- Update to 0.7.4
328
329* Wed Jun  3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
330- Update to 0.7.3
331
332* Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
333- Update to 0.6.1
334
335* Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
336- Update to 0.5.7
337
338* Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
339- Update to 0.5.6
340
341* Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
342- Update to 0.5.3
343
344* Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
345- Fix bug in Emacs version detection
346
347* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
348- Use buildsystem variables to determine available Emacs version
349- BR on gecko-devel >= 1.9, since older version is also in RHEL repo
350
351* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
352- Update to 0.5.2
353
354* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
355- Update to 0.5.1
356
357* Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
358- Update to 0.3.5
359
360* Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
361- Add vala-mode for editing Vala code in Emacs
362
363* Tue Jul  1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
364- Update to 0.3.4
365
366* Wed Jun  4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
367- Update to 0.3.3
368
369* Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
370- Update to 0.3.2
371
372* Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
373- Update to 0.2.0
374
375* Wed Mar  5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
376- Update to 0.1.7
377- -tool subpackage now requires gnome-common, intltool and libtoolize
378  for out-of-the-box vala-gen-project support
379
380* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
381- Autorebuild for GCC 4.3
382
383* Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
384- Update to 0.1.6
385- Revert vapi addition, needed declarations have been inlined (r846)
386- Rename -docs subpackage to -doc, to comply with guidelines
387
388* Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
389- Manually add Gee vapi file to package (bz #428692)
390
391* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
392- Backport patch to autodetect location of automake shared files
393
394* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
395- Add build dependency on gtk2-devel
396
397* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
398- Enable project generator tool
399
400* Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
401- Update to 0.1.5
402
403* Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
404- Add build dependency on devhelp
405
406* Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
407- Update to 0.1.4
408- Put newly-added documentation in its own subpackage (depends on devhelp)
409
410* Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
411- vapigen subpackage: add missing Require: on perl-XML-Twig
412
413* Sat Sep  8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
414- Split -vapigen subpackage. It is functionally self-contained and the license
415  is more restricted
416- Updated license declarations
417
418* Wed Sep  5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
419- Licensing and URL updates
420
421* Tue Sep  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
422- Enable binding generation tools
423
424* Sun Sep  2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
425- Update to 0.1.3
426
427* Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
428- Update to 0.0.8
429
430* Wed Mar  7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
431- Update to 0.0.7
432
433* Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
434- Update to 0.0.6
435
436* Mon Nov  6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
437- Initial package
Note: See TracBrowser for help on using the repository browser.