source: projects/specs/trunk/v/vala/vala-vl.spec @ 11983

Revision 11983, 13.4 KB checked in by tomop, 5 years ago (diff)

PackageKit?-1.1.12-1 and requirements

Line 
1%global api_ver 0.40
2%define _unpackaged_files_terminate_build 1
3
4Summary:        A modern programming language for GNOME
5Summary(ja):    GNOME 用のモダンなプログラミング言語
6
7Name:           vala
8Version:        0.40.11
9Release:        1%{?_dist_release}
10
11Group:          Development/Languages
12# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
13License:        LGPLv2+ and BSD
14
15Vendor:         Project Vine
16Distribution:   Vine Linux
17
18URL:            http://live.gnome.org/Vala
19Source0:        http://download.gnome.org/sources/vala/0.32/vala-%{version}.tar.xz
20BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
21
22BuildRequires:  glib2-devel
23BuildRequires:  gobject-introspection-devel
24BuildRequires:  flex
25BuildRequires:  bison
26BuildRequires:  libxslt
27BuildRequires:  graphviz-devel
28
29
30%description
31Vala is a new programming language that aims to bring modern programming
32language features to GNOME developers without imposing any additional
33runtime requirements and without using a different ABI compared to
34applications and libraries written in C.
35
36valac, the Vala compiler, is a self-hosting compiler that translates
37Vala source code into C source and header files. It uses the GObject
38type system to create classes and interfaces declared in the Vala source
39code. It's also planned to generate GIDL files when gobject-
40introspection is ready.
41
42The syntax of Vala is similar to C#, modified to better fit the GObject
43type system.
44
45
46%package        devel
47Summary:        Development files for %{name}
48Summary(ja):    %{name} の開発用ファイル
49Group:          Development/Libraries
50Requires:       %{name} = %{version}-%{release}
51Requires:       pkgconfig
52
53%description    devel
54Vala is a new programming language that aims to bring modern programming
55language features to GNOME developers without imposing any additional
56runtime requirements and without using a different ABI compared to
57applications and libraries written in C.
58
59This package contains development files for %{name}. This is not necessary for
60using the %{name} compiler.
61
62
63%package        tools
64Summary:        Tools for creating projects and bindings for %{name}
65Summary(ja):    %{name} のプロジェクト作成やバインディングのためのツール集
66Group:          Development/Tools
67License:        LGPLv2+
68Requires:       %{name} = %{version}-%{release}
69Requires:       gnome-common intltool libtool
70Provides:       %{name}-vapigen = %{version}-%{release}
71Obsoletes:      %{name}-vapigen < %{version}-%{release}
72
73%description    tools
74Vala is a new programming language that aims to bring modern programming
75language features to GNOME developers without imposing any additional
76runtime requirements and without using a different ABI compared to
77applications and libraries written in C.
78
79This package contains tools to generate Vala projects, as well as API bindings
80from existing C libraries, allowing access from Vala programs.
81
82
83%package        doc
84Summary:        Documentation for %{name}
85Summary(ja):    %{name} のドキュメント
86Group:          Documentation
87License:        LGPLv2+
88
89BuildArch:      noarch
90Requires:       %{name} = %{version}-%{release}
91Requires:       devhelp
92Provides:       %{name}-docs = %{version}-%{release}
93Obsoletes:      %{name}-docs < %{version}-%{release}
94
95
96%description    doc
97Vala is a new programming language that aims to bring modern programming
98language features to GNOME developers without imposing any additional
99runtime requirements and without using a different ABI compared to
100applications and libraries written in C.
101
102This package contains documentation in a devhelp HTML book.
103
104
105%package -n     valadoc
106Summary:        Vala documentation generator
107Summary(ja):    Valaのドキュメントジェネレータ
108Group:          Development/Tools
109License:        LGPLv2+
110Requires:       vala = %{version}-%{release}
111
112%description -n valadoc
113Valadoc is a documentation generator for generating API documentation from Vala
114source code.
115
116
117%package -n     valadoc-devel
118Summary:        Development files for valadoc
119Summary(ja):    valadocを利用した開発のためのファイル群
120Group:          Development/Libraries
121License:        LGPLv2+
122
123Requires:       valadoc = %{version}-%{release}
124
125
126%description -n valadoc-devel
127Valadoc is a documentation generator for generating API documentation from Vala
128source code.
129
130The valadoc-devel package contains libraries and header files for
131developing applications that use valadoc.
132
133
134%prep
135%setup -q
136
137%build
138%configure --enable-vapigen
139# Don't use rpath!
140sed -i 's|/lib /usr/lib|/lib /usr/lib /lib64 /usr/lib64|' libtool
141make %{?_smp_mflags}
142
143
144%install
145rm -rf $RPM_BUILD_ROOT
146make install DESTDIR=$RPM_BUILD_ROOT
147find %{buildroot}%{_libdir} -type f -name 'lib*.la' | xargs rm -f
148
149%check
150make check
151
152%clean
153rm -rf $RPM_BUILD_ROOT
154
155%post -p /sbin/ldconfig
156
157%postun -p /sbin/ldconfig
158
159%files
160%defattr(-,root,root,-)
161%doc AUTHORS ChangeLog COPYING NEWS README THANKS
162%{_bindir}/vala
163%{_bindir}/valac
164%{_bindir}/vala-%{api_ver}
165%{_bindir}/valac-%{api_ver}
166%{_datadir}/vala-%{api_ver}
167%{_datadir}/vala
168%{_libdir}/libvala-%{api_ver}.so.*
169%{_mandir}/*/valac*
170
171%files devel
172%defattr(-,root,root,-)
173%{_includedir}/vala-%{api_ver}
174%{_libdir}/libvala-%{api_ver}.so
175%{_libdir}/pkgconfig/libvala-%{api_ver}.pc
176%{_datadir}/aclocal/vala.m4
177%{_datadir}/aclocal/vapigen.m4
178%{_libdir}/pkgconfig/vapigen.pc
179%{_libdir}/pkgconfig/vapigen-%{api_ver}.pc
180%{_datadir}/vala/Makefile.vapigen
181
182%files tools
183%defattr(-,root,root,-)
184%{_bindir}/vala-gen-introspect
185%{_bindir}/vapigen
186%{_bindir}/vala-gen-introspect-%{api_ver}
187%{_bindir}/vapigen-%{api_ver}
188%{_libdir}/vala-%{api_ver}
189%{_mandir}/*/*gen*
190
191%files doc
192%defattr(-,root,root,-)
193%{_datadir}/devhelp/books/vala-%{api_ver}
194
195%files -n valadoc
196%defattr(-,root,root,-)
197%{_bindir}/valadoc*
198%{_libdir}/libvaladoc-%{api_ver}.so.*
199%{_libdir}/valadoc
200%{_datadir}/valadoc
201%{_mandir}/*/valadoc*
202
203%files -n valadoc-devel
204
205%{_libdir}/libvaladoc-%{api_ver}.so
206%{_libdir}/pkgconfig/valadoc-%{api_ver}.pc
207%{_includedir}/valadoc-%{api_ver}
208
209%changelog
210* Mon Dec 10 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40.11-1
211- new upstream release (LTS 0.40).
212
213* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.38.4-1
214- new upstream release.
215- added subpackages "valadoc" and "valadoc-devel".
216
217* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.32.1-1
218- new upstream release
219
220* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.30.0-1
221- new upstream release
222
223* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.1-1
224- new upstream release
225
226* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.0-1
227- new upstream release
228
229* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.26.2-1
230- new upstream release
231
232* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.26.1-1
233- new upstream release
234- moved tools subpackage to Development/Tools Group
235
236* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.0-1
237- new upstream release
238
239* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
240- new upstream release
241
242* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.0-1
243- new upstream release
244
245* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.20.1-1
246- new upstream release
247
248* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.1-1
249- new upstream release
250
251* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
252- new upstream release
253
254* Mon Jun 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
255- new upstream release
256
257* Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
258- new upstream release
259
260* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
261- new upstream release
262
263* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
264- new upstream release
265
266* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
267- new upstream release
268- remove BuildRequires: gtk2-devel, xulrunner-devel
269- add BuildRequires: glib2-devel, libxslt
270
271* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
272- new upstream release
273- remove BuildRequires: devhelp
274
275* Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
276- new upstream release
277
278* Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
279- new upstream release
280
281* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
282- new upstream release
283
284* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
285- rebuilt with rpm-4.8.1 for pkg-config
286
287* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
288- new upstream release
289- made -doc subpackage noarch
290
291* Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
292- new upstream release
293
294* Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
295- new upstream release
296
297* Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
298- new upstream release
299
300* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
301- new upstream release
302
303* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
304- new upstream release
305- change BuildRequires: gecko-libs -> xulrunner-devel
306
307* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
308- new upstream release
309
310* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
311- new upstream release
312
313* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
314- new upstream release
315
316* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
317- initial build for Vine Linux
318
319* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
320- Update to 0.7.5
321
322* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
323- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
324
325* Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
326- Patch broken ModuleInit attribute (upstream bug 587444)
327
328* Tue Jul  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
329- Update to 0.7.4
330
331* Wed Jun  3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
332- Update to 0.7.3
333
334* Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
335- Update to 0.6.1
336
337* Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
338- Update to 0.5.7
339
340* Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
341- Update to 0.5.6
342
343* Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
344- Update to 0.5.3
345
346* Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
347- Fix bug in Emacs version detection
348
349* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
350- Use buildsystem variables to determine available Emacs version
351- BR on gecko-devel >= 1.9, since older version is also in RHEL repo
352
353* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
354- Update to 0.5.2
355
356* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
357- Update to 0.5.1
358
359* Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
360- Update to 0.3.5
361
362* Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
363- Add vala-mode for editing Vala code in Emacs
364
365* Tue Jul  1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
366- Update to 0.3.4
367
368* Wed Jun  4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
369- Update to 0.3.3
370
371* Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
372- Update to 0.3.2
373
374* Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
375- Update to 0.2.0
376
377* Wed Mar  5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
378- Update to 0.1.7
379- -tool subpackage now requires gnome-common, intltool and libtoolize
380  for out-of-the-box vala-gen-project support
381
382* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
383- Autorebuild for GCC 4.3
384
385* Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
386- Update to 0.1.6
387- Revert vapi addition, needed declarations have been inlined (r846)
388- Rename -docs subpackage to -doc, to comply with guidelines
389
390* Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
391- Manually add Gee vapi file to package (bz #428692)
392
393* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
394- Backport patch to autodetect location of automake shared files
395
396* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
397- Add build dependency on gtk2-devel
398
399* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
400- Enable project generator tool
401
402* Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
403- Update to 0.1.5
404
405* Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
406- Add build dependency on devhelp
407
408* Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
409- Update to 0.1.4
410- Put newly-added documentation in its own subpackage (depends on devhelp)
411
412* Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
413- vapigen subpackage: add missing Require: on perl-XML-Twig
414
415* Sat Sep  8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
416- Split -vapigen subpackage. It is functionally self-contained and the license
417  is more restricted
418- Updated license declarations
419
420* Wed Sep  5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
421- Licensing and URL updates
422
423* Tue Sep  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
424- Enable binding generation tools
425
426* Sun Sep  2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
427- Update to 0.1.3
428
429* Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
430- Update to 0.0.8
431
432* Wed Mar  7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
433- Update to 0.0.7
434
435* Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
436- Update to 0.0.6
437
438* Mon Nov  6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
439- Initial package
Note: See TracBrowser for help on using the repository browser.