source: projects/specs/trunk/v/vala/vala-vl.spec @ 12165

Revision 12165, 13.6 KB checked in by tomop, 5 years ago (diff)

vala-0.44.7-1

RevLine 
[12165]1%global api_ver 0.44
[11332]2%define _unpackaged_files_terminate_build 1
[1545]3
[521]4Summary:        A modern programming language for GNOME
[10716]5Summary(ja):    GNOME 用のモダンなプログラミング言語
[521]6
7Name:           vala
[12165]8Version:        0.44.7
[2041]9Release:        1%{?_dist_release}
[521]10
11Group:          Development/Languages
12# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
13License:        LGPLv2+ and BSD
[11983]14
15Vendor:         Project Vine
16Distribution:   Vine Linux
17
[521]18URL:            http://live.gnome.org/Vala
[12165]19
20%define major_minor %(echo %{version} | sed -e 's/\.[0-9]*$//')
21Source0:        http://download.gnome.org/sources/vala/%{major_minor}/vala-%{version}.tar.xz
[521]22BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
23
[4812]24BuildRequires:  glib2-devel
[11983]25BuildRequires:  gobject-introspection-devel
[4616]26BuildRequires:  flex
27BuildRequires:  bison
[4812]28BuildRequires:  libxslt
[11332]29BuildRequires:  graphviz-devel
[521]30
[4616]31
[521]32%description
33Vala is a new programming language that aims to bring modern programming
34language features to GNOME developers without imposing any additional
35runtime requirements and without using a different ABI compared to
36applications and libraries written in C.
37
38valac, the Vala compiler, is a self-hosting compiler that translates
39Vala source code into C source and header files. It uses the GObject
40type system to create classes and interfaces declared in the Vala source
41code. It's also planned to generate GIDL files when gobject-
42introspection is ready.
43
44The syntax of Vala is similar to C#, modified to better fit the GObject
45type system.
46
47
48%package        devel
49Summary:        Development files for %{name}
[9069]50Summary(ja):    %{name} の開発用ファイル
[521]51Group:          Development/Libraries
52Requires:       %{name} = %{version}-%{release}
53Requires:       pkgconfig
54
55%description    devel
56Vala is a new programming language that aims to bring modern programming
57language features to GNOME developers without imposing any additional
58runtime requirements and without using a different ABI compared to
59applications and libraries written in C.
60
61This package contains development files for %{name}. This is not necessary for
62using the %{name} compiler.
63
64
65%package        tools
66Summary:        Tools for creating projects and bindings for %{name}
[9069]67Summary(ja):    %{name} のプロジェクト作成やバインディングのためのツール集
68Group:          Development/Tools
[521]69License:        LGPLv2+
70Requires:       %{name} = %{version}-%{release}
71Requires:       gnome-common intltool libtool
72Provides:       %{name}-vapigen = %{version}-%{release}
73Obsoletes:      %{name}-vapigen < %{version}-%{release}
74
75%description    tools
76Vala is a new programming language that aims to bring modern programming
77language features to GNOME developers without imposing any additional
78runtime requirements and without using a different ABI compared to
79applications and libraries written in C.
80
81This package contains tools to generate Vala projects, as well as API bindings
82from existing C libraries, allowing access from Vala programs.
83
84
85%package        doc
86Summary:        Documentation for %{name}
[9069]87Summary(ja):    %{name} のドキュメント
[521]88Group:          Documentation
89License:        LGPLv2+
[1803]90
91BuildArch:      noarch
[521]92Requires:       %{name} = %{version}-%{release}
93Requires:       devhelp
94Provides:       %{name}-docs = %{version}-%{release}
95Obsoletes:      %{name}-docs < %{version}-%{release}
96
97
98%description    doc
99Vala is a new programming language that aims to bring modern programming
100language features to GNOME developers without imposing any additional
101runtime requirements and without using a different ABI compared to
102applications and libraries written in C.
103
104This package contains documentation in a devhelp HTML book.
105
106
[11332]107%package -n     valadoc
108Summary:        Vala documentation generator
109Summary(ja):    Valaのドキュメントジェネレータ
110Group:          Development/Tools
111License:        LGPLv2+
112Requires:       vala = %{version}-%{release}
113
114%description -n valadoc
115Valadoc is a documentation generator for generating API documentation from Vala
116source code.
117
118
119%package -n     valadoc-devel
120Summary:        Development files for valadoc
121Summary(ja):    valadocを利用した開発のためのファイル群
122Group:          Development/Libraries
123License:        LGPLv2+
124
125Requires:       valadoc = %{version}-%{release}
126
127
128%description -n valadoc-devel
129Valadoc is a documentation generator for generating API documentation from Vala
130source code.
131
132The valadoc-devel package contains libraries and header files for
133developing applications that use valadoc.
134
135
[521]136%prep
137%setup -q
138
139%build
140%configure --enable-vapigen
141# Don't use rpath!
[11983]142sed -i 's|/lib /usr/lib|/lib /usr/lib /lib64 /usr/lib64|' libtool
[521]143make %{?_smp_mflags}
144
145
146%install
147rm -rf $RPM_BUILD_ROOT
148make install DESTDIR=$RPM_BUILD_ROOT
[11332]149find %{buildroot}%{_libdir} -type f -name 'lib*.la' | xargs rm -f
[521]150
[11983]151%check
152make check
[11332]153
[521]154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%post -p /sbin/ldconfig
158
159%postun -p /sbin/ldconfig
160
161%files
162%defattr(-,root,root,-)
[12165]163%license COPYING
164%doc AUTHORS ChangeLog NEWS README THANKS
[1516]165%{_bindir}/vala
[521]166%{_bindir}/valac
[1545]167%{_bindir}/vala-%{api_ver}
168%{_bindir}/valac-%{api_ver}
169%{_datadir}/vala-%{api_ver}
[11332]170%{_datadir}/vala
[1545]171%{_libdir}/libvala-%{api_ver}.so.*
[521]172%{_mandir}/*/valac*
173
174%files devel
175%defattr(-,root,root,-)
[1545]176%{_includedir}/vala-%{api_ver}
177%{_libdir}/libvala-%{api_ver}.so
[4616]178%{_libdir}/pkgconfig/libvala-%{api_ver}.pc
[1545]179%{_datadir}/aclocal/vala.m4
[6011]180%{_datadir}/aclocal/vapigen.m4
[11332]181%{_libdir}/pkgconfig/vapigen.pc
182%{_libdir}/pkgconfig/vapigen-%{api_ver}.pc
[6011]183%{_datadir}/vala/Makefile.vapigen
[521]184
185%files tools
186%defattr(-,root,root,-)
[1545]187%{_bindir}/vala-gen-introspect
188%{_bindir}/vapigen
189%{_bindir}/vala-gen-introspect-%{api_ver}
190%{_bindir}/vapigen-%{api_ver}
191%{_libdir}/vala-%{api_ver}
[521]192%{_mandir}/*/*gen*
193
194%files doc
195%defattr(-,root,root,-)
[1545]196%{_datadir}/devhelp/books/vala-%{api_ver}
[521]197
[11332]198%files -n valadoc
199%defattr(-,root,root,-)
200%{_bindir}/valadoc*
201%{_libdir}/libvaladoc-%{api_ver}.so.*
202%{_libdir}/valadoc
203%{_datadir}/valadoc
204%{_mandir}/*/valadoc*
[521]205
[11332]206%files -n valadoc-devel
207
208%{_libdir}/libvaladoc-%{api_ver}.so
209%{_libdir}/pkgconfig/valadoc-%{api_ver}.pc
210%{_includedir}/valadoc-%{api_ver}
211
[521]212%changelog
[12165]213* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.44.7-1
214- new upstream release.
215
[11983]216* Mon Dec 10 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40.11-1
217- new upstream release (LTS 0.40).
218
[11332]219* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.38.4-1
220- new upstream release.
221- added subpackages "valadoc" and "valadoc-devel".
222
[10716]223* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.32.1-1
224- new upstream release
225
[9791]226* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.30.0-1
227- new upstream release
228
[9724]229* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.1-1
230- new upstream release
231
[9475]232* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.0-1
233- new upstream release
234
[9313]235* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.26.2-1
236- new upstream release
237
[9069]238* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.26.1-1
[8353]239- new upstream release
[9069]240- moved tools subpackage to Development/Tools Group
[8353]241
[9069]242* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.0-1
243- new upstream release
244
[8011]245* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
246- new upstream release
247
[7938]248* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.0-1
249- new upstream release
250
[7633]251* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.20.1-1
252- new upstream release
253
[7119]254* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.1-1
255- new upstream release
256
[6890]257* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
258- new upstream release
259
[6428]260* Mon Jun 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
261- new upstream release
262
[6011]263* Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
264- new upstream release
265
[5651]266* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
267- new upstream release
268
[5311]269* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
270- new upstream release
271
[4812]272* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
273- new upstream release
274- remove BuildRequires: gtk2-devel, xulrunner-devel
275- add BuildRequires: glib2-devel, libxslt
276
[4616]277* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
[3263]278- new upstream release
[4616]279- remove BuildRequires: devhelp
[3263]280
[2437]281* Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
282- new upstream release
283
[2146]284* Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
285- new upstream release
286
[2041]287* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
288- new upstream release
289
[1934]290* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
291- rebuilt with rpm-4.8.1 for pkg-config
292
[1803]293* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
294- new upstream release
295- made -doc subpackage noarch
296
[1635]297* Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
298- new upstream release
299
[1545]300* Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
301- new upstream release
302
[1516]303* Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
304- new upstream release
305
[1007]306* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
307- new upstream release
308
[805]309* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
310- new upstream release
311- change BuildRequires: gecko-libs -> xulrunner-devel
312
[521]313* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
314- new upstream release
315
316* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
317- new upstream release
318
[7633]319* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
[521]320- new upstream release
321
322* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
323- initial build for Vine Linux
324
325* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
326- Update to 0.7.5
327
328* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
329- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
330
331* Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
332- Patch broken ModuleInit attribute (upstream bug 587444)
333
334* Tue Jul  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
335- Update to 0.7.4
336
337* Wed Jun  3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
338- Update to 0.7.3
339
340* Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
341- Update to 0.6.1
342
343* Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
344- Update to 0.5.7
345
346* Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
347- Update to 0.5.6
348
349* Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
350- Update to 0.5.3
351
352* Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
353- Fix bug in Emacs version detection
354
355* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
356- Use buildsystem variables to determine available Emacs version
357- BR on gecko-devel >= 1.9, since older version is also in RHEL repo
358
359* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
360- Update to 0.5.2
361
362* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
363- Update to 0.5.1
364
365* Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
366- Update to 0.3.5
367
368* Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
369- Add vala-mode for editing Vala code in Emacs
370
371* Tue Jul  1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
372- Update to 0.3.4
373
374* Wed Jun  4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
375- Update to 0.3.3
376
377* Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
378- Update to 0.3.2
379
380* Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
381- Update to 0.2.0
382
383* Wed Mar  5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
384- Update to 0.1.7
385- -tool subpackage now requires gnome-common, intltool and libtoolize
386  for out-of-the-box vala-gen-project support
387
388* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
389- Autorebuild for GCC 4.3
390
391* Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
392- Update to 0.1.6
393- Revert vapi addition, needed declarations have been inlined (r846)
394- Rename -docs subpackage to -doc, to comply with guidelines
395
396* Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
397- Manually add Gee vapi file to package (bz #428692)
398
399* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
400- Backport patch to autodetect location of automake shared files
401
402* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
403- Add build dependency on gtk2-devel
404
405* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
406- Enable project generator tool
407
408* Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
409- Update to 0.1.5
410
411* Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
412- Add build dependency on devhelp
413
414* Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
415- Update to 0.1.4
416- Put newly-added documentation in its own subpackage (depends on devhelp)
417
418* Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
419- vapigen subpackage: add missing Require: on perl-XML-Twig
420
421* Sat Sep  8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
422- Split -vapigen subpackage. It is functionally self-contained and the license
423  is more restricted
424- Updated license declarations
425
426* Wed Sep  5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
427- Licensing and URL updates
428
429* Tue Sep  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
430- Enable binding generation tools
431
432* Sun Sep  2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
433- Update to 0.1.3
434
435* Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
436- Update to 0.0.8
437
438* Wed Mar  7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
439- Update to 0.0.7
440
441* Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
442- Update to 0.0.6
443
444* Mon Nov  6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
445- Initial package
Note: See TracBrowser for help on using the repository browser.