source: projects/specs/trunk/u/upstart/upstart-vl.spec @ 7172

Revision 7172, 7.0 KB checked in by daisuke, 11 years ago (diff)

upstart: install upstart-{socket,udev}-bridge.conf

Line 
1Name:           upstart
2Version:        1.6
3Release:        2%{?_dist_release}
4Summary:        An event-driven init system
5Summary(ja):    イベントドリブン型 init システム
6
7Group:          System Environment/Base
8License:        GPLv2 and LGPLv2+
9URL:            http://launchpad.net/upstart
10
11Source0:        http://launchpad.net/upstart/1.x/%{version}/+download/upstart-%{version}.tar.gz
12Source1:        init-system-dbus.conf
13Patch1:         upstart-telinit.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16Obsoletes: SysVinit < 2.88
17Provides: SysVinit = 2.88
18BuildRequires:  gettext, audit-libs-devel, expat-devel
19BuildRequires:  dbus-devel >= 1.2.16
20BuildRequires:  libnih-devel >= 1.0.1
21BuildRequires:  json-c-devel >= 0.10
22BuildRequires:  libudev-devel
23Requires:      initscripts >= 8.90.4
24
25%description
26Upstart is an event-based replacement for the /sbin/init daemon which
27handles starting of tasks and services during boot, stopping them
28during shutdown and supervising them while the system is running.
29
30%description -l ja
31Upstart はイベントドリブン型の /sbin/init デーモンです。OSブート時の
32タスクやサービスの開始やシャットダウン時の終了およびそれらの管理を担
33当します。
34
35%prep
36%setup -q
37%patch1 -p1 -b .u
38
39%build
40%configure --sbindir=/sbin --libdir=/%{_lib}
41make %{?_smp_mflags}
42
43%install
44rm -rf %{buildroot}
45make install DESTDIR=%{buildroot}
46
47# don't ship default jobs
48rm -f %{buildroot}/%{_sysconfdir}/init/*
49install -m 644 %{SOURCE1} %{buildroot}/%{_sysconfdir}/init/
50
51# install upstart-{socket,udev}-bridge.conf
52install -m 644 extra/conf/*.conf %{buildroot}/%{_sysconfdir}/init/
53
54%find_lang %{name}
55
56%check
57#some tests fail in koji while pass in mock and local build
58#to run make check use "--with check"
59%if %{?_with_check:1}%{!?_with_check:0}
60  make check
61%endif
62
63%clean
64rm -rf %{buildroot}
65
66%files -f %{name}.lang
67%defattr(-,root,root,-)
68%doc AUTHORS
69%doc COPYING
70%doc NEWS
71%doc README
72%doc TODO
73%doc HACKING
74%{_sysconfdir}/init/
75%config(noreplace) %{_sysconfdir}/dbus-1/system.d/Upstart.conf
76/sbin/halt
77/sbin/init
78/sbin/initctl
79/sbin/poweroff
80/sbin/reboot
81/sbin/runlevel
82/sbin/shutdown
83/sbin/start
84/sbin/status
85/sbin/stop
86/sbin/restart
87/sbin/telinit
88/sbin/reload
89/sbin/upstart-socket-bridge
90/sbin/upstart-udev-bridge
91%{_bindir}/init-checkconf
92%{_bindir}/initctl2dot
93%{_mandir}/man5/init.5.gz
94%{_mandir}/man5/inittab.5.gz
95%{_mandir}/man7/*.7*
96%{_mandir}/man8/*.8*
97
98%changelog
99* Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-2
100- install upstart-{socket,udev}-bridge.conf
101
102* Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-1
103- update to 1.6
104- add BR: libudev-devel
105- add BR: json-c-devel >= 0.10
106
107* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
108- new upstream release
109
110* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.7-1
111- new upstream release
112
113* Wed May 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-2
114- add R: initscripts >= 8.90.4
115
116* Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-1
117- initial build for Vine Linux
118
119* Wed Feb 24 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.5-3
120- run "make check" only with --with check
121
122* Fri Feb 19 2010 Casey Dahlin <cdahlin@redhat.com> 0.6.5-2
123- be more specific about which libnih we need.
124
125* Wed Feb 17 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.5-1
126- upgrade to 0.6.5
127
128* Fri Jan 29 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.3-7
129- add SIGUSR1 handler and init-system-dbus.conf (#559660)
130
131* Sun Jan 17 2010 Dennis Gilmore <dennis@ausil.us> - 0.6.3-6
132- add patch from upstream fixing sparc alignment issues
133
134* Mon Jan 11 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.3-5
135- License changed to GPLv2 and LGPLv2+
136
137* Wed Dec 16 2009 Petr Lautrbach <plautrba@redhat.com> 0.6.3-4
138- audit events patch rebased for 0.6 (#470661)
139
140* Thu Dec  3 2009 Bill Nottingham <notting@redhat.com> 0.6.3-3
141- make 'telinit u' a no-op, temporarily
142
143* Fri Nov 27 2009 Petr Lautrbach <plautrba@redhat.com> 0.6.3-2
144- Removed tests which fail in koji
145
146* Fri Nov 20 2009 Casey Dahlin <cdahlin@redhat.com> - 0.6.3-1
147- Upgrade to 0.6.3
148
149* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.3.11-3
150- rebuilt with new audit
151
152* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.11-2
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
154
155* Mon Jun 22 2009 Petr Lautrbach <plautrba@redhat.com> - 0.3.11-1
156- Update to 0.3.11
157
158* Mon Apr 27 2009 Bill Nottingham <notting@redhat.com> - 0.3.9-24
159- Apply the audit patch correctly (#470661)
160
161* Fri Apr 3 2009 Casey Dahlin <cdahlin@redhat.com> - 0.3.9-23
162- Add audit events patch from Steve Grubb <sgrubb@redhat.com> (Bug #470661)
163
164* Fri Jan 23 2009 Casey Dahlin <cdahlin@redhat.com> - 0.3.9-22
165- Re-add 'telinit u' support along with patch to fix it (#450488). Patch due to
166  <pspencer@fields.utoronto.ca>
167
168* Mon Jan 12 2009 Bill Nottingham <notting@redhat.com> - 0.3.9-21
169- Remove 'telinit u' support as it is broken (#450488, <cjdahlin@ncsu.edu>)
170
171* Fri Apr 25 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-19
172- with the merge of event-compat-sysv, move the sysvinit obsoletes/provides here
173
174* Thu Apr 24 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-18
175- fix some man page typos (#444008, <archimerged@gmail.com>)
176
177* Wed Apr 09 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-17
178- Added list of stock events to events(5)
179
180* Tue Apr 08 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-16
181- Add telinit u support
182
183* Fri Apr 04 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-15
184- Add a events(5) manpage that describes event syntax
185
186* Thu Apr 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-14
187- Change bug report email address to fedora-devel-list@redhat.com
188
189* Thu Mar 14 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-13
190- Ignore rpm temporary files of the foo;<somehex> format
191- Make ignores of .rpm{new,orig,save} match only at the end of the name
192
193* Wed Mar 13 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-12
194- forgot about rpmorig too (ugh)
195
196* Wed Mar 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-11
197- Make logd a noreplace
198
199* Wed Mar 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-10
200- Add patch to ignore .rpm{new,save} files
201
202* Sun Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-9
203- Remove automake dependency, build Makefile.in changes into patch
204
205* Sun Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-8
206- Run automake after patching
207
208* Sun Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-7
209- Added BuildRequires: automake
210
211* Sun Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-6
212- Added patch to allow runtime tty changes
213
214* Fri Feb 15 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-5
215- Added patch to imply --force on runlevels 0 and 6
216
217* Wed Feb 06 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-4
218- Patched for GCC 4.3
219
220* Thu Jan 31 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-3
221- Added AUTHORS, COPYING, etc.
222- Made config --libdir option relative
223
224* Mon Jan 21 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-2
225- Remove libnih and libupstart
226
227* Sun Jan 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-1
228- Initial packaging
Note: See TracBrowser for help on using the repository browser.