source: projects/specs/trunk/u/upstart/upstart-vl.spec @ 12401

Revision 12401, 12.0 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

cryptsetup-2.3.2-1

device-mapper-multipath-0.8.2-2

gimp-2.10.18-1

json-c-0.14-1

libmypaint-1.6.1-1

strongswan-5.8.4-1

upstart-1.12.1-7

Line 
1%global prepare_systemd 1
2
3Name:           upstart
4Version:        1.12.1
5Release:        7%{?_dist_release}
6Summary:        An event-driven init system
7Summary(ja):    イベントドリブン型 init システム
8Group:          System Environment/Base
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        GPLv2 and LGPLv2+
13URL:            http://launchpad.net/upstart
14Source0:        http://launchpad.net/upstart/1.x/%{version}/+download/upstart-%{version}.tar.gz
15Source1:        init-system-dbus.conf
16#Patch1:         upstart-telinit.patch
17Patch0:         upstart-glibc-2.31.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20Obsoletes: SysVinit < 2.88
21Provides: SysVinit = 2.88
22BuildRequires:  gettext, audit-libs-devel, expat-devel
23BuildRequires:  dbus-devel >= 1.2.16
24BuildRequires:  libnih-devel >= 1.0.3-2
25BuildRequires:  json-c-devel >= 0.14
26BuildRequires:  eudev-libudev-devel
27BuildRequires:  dconf-devel
28Requires:       initscripts >= 8.90.4
29Requires(post,postun): bash
30
31Provides: /sbin/halt
32Provides: /sbin/init
33Provides: /sbin/poweroff
34Provides: /sbin/reboot
35Provides: /sbin/runlevel
36Provides: /sbin/shutdown
37Provides: /sbin/telinit
38
39%description
40Upstart is an event-based replacement for the /sbin/init daemon which
41handles starting of tasks and services during boot, stopping them
42during shutdown and supervising them while the system is running.
43
44%description -l ja
45Upstart はイベントドリブン型の /sbin/init デーモンです。OSブート時の
46タスクやサービスの開始やシャットダウン時の終了およびそれらの管理を担
47当します。
48
49%package devel
50Summary: Development files for upstart
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53
54%description devel
55Development files for upstart
56
57%package tools
58Summary: Misc tools for upstart
59Group: System Environment/Base
60Requires: %{name} = %{version}-%{release}
61Requires: python3
62Requires: dbus-python3
63
64%description tools
65Misc tools for upstart
66
67%prep
68%setup -q
69%patch0 -p1
70
71%build
72%configure --sbindir=/sbin --libdir=/%{_lib}
73make %{?_smp_mflags}
74
75%install
76rm -rf %{buildroot}
77make install DESTDIR=%{buildroot}
78
79# don't ship default jobs
80rm -f %{buildroot}/%{_sysconfdir}/init/*
81install -m 644 %{SOURCE1} %{buildroot}/%{_sysconfdir}/init/
82
83# install upstart-{socket,udev}-bridge.conf
84install -m 644 extra/conf/*.conf %{buildroot}/%{_sysconfdir}/init/
85
86# remove unneeded files
87rm %{buildroot}/%{_lib}/*.{a,la}
88
89%find_lang %{name}
90
91# for alternatives
92%if 0%{?prepare_systemd}
93mkdir -p %{buildroot}/%{_lib}/upstart
94for f in init halt poweroff reboot runlevel shutdown telinit; do
95  mv -f %{buildroot}/sbin/$f %{buildroot}/%{_lib}/upstart/
96done
97
98for f in halt poweroff reboot runlevel shutdown telinit; do
99  mv -f %{buildroot}/%{_mandir}/man8/$f.8 \
100        %{buildroot}/%{_mandir}/man8/upstart-$f.8
101done
102%endif
103
104%check
105#some tests fail in koji while pass in mock and local build
106#to run make check use "--with check"
107%if %{?_with_check:1}%{!?_with_check:0}
108  make check
109%endif
110
111%if 0%{?prepare_systemd}
112%post
113/sbin/alternatives \
114  --install /sbin/init     init     /%{_lib}/upstart/init 200 \
115    --slave /sbin/halt     halt     /%{_lib}/upstart/halt \
116    --slave /sbin/poweroff poweroff /%{_lib}/upstart/poweroff \
117    --slave /sbin/reboot   reboot   /%{_lib}/upstart/reboot \
118    --slave /sbin/runlevel runlevel /%{_lib}/upstart/runlevel \
119    --slave /sbin/shutdown shutdown /%{_lib}/upstart/shutdown \
120    --slave /sbin/telinit  telinit  /%{_lib}/upstart/telinit \
121    --slave %{_mandir}/man8/halt.8.gz halt.8 %{_mandir}/man8/upstart-halt.8.gz \
122    --slave %{_mandir}/man8/poweroff.8.gz poweroff.8 %{_mandir}/man8/upstart-poweroff.8.gz \
123    --slave %{_mandir}/man8/reboot.8.gz reboot.8 %{_mandir}/man8/upstart-reboot.8.gz \
124    --slave %{_mandir}/man8/runlevel.8.gz runlevel.8 %{_mandir}/man8/upstart-runlevel.8.gz \
125    --slave %{_mandir}/man8/shutdown.8.gz shutdown.8 %{_mandir}/man8/upstart-shutdown.8.gz \
126    --slave %{_mandir}/man8/telinit.8.gz telinit.8 %{_mandir}/man8/upstart-telinit.8.gz
127
128%postun
129if [ "$1" = "0" ]; then
130  /sbin/alternatives --remove init /%{_lib}/upstart/init
131fi
132
133%triggerpostun -- upstart <= 1.12.1-5vl7
134/sbin/alternatives \
135  --install /sbin/init     init     /%{_lib}/upstart/init 200 \
136    --slave /sbin/halt     halt     /%{_lib}/upstart/halt \
137    --slave /sbin/poweroff poweroff /%{_lib}/upstart/poweroff \
138    --slave /sbin/reboot   reboot   /%{_lib}/upstart/reboot \
139    --slave /sbin/runlevel runlevel /%{_lib}/upstart/runlevel \
140    --slave /sbin/shutdown shutdown /%{_lib}/upstart/shutdown \
141    --slave /sbin/telinit  telinit  /%{_lib}/upstart/telinit \
142    --slave %{_mandir}/man8/halt.8.gz halt.8 %{_mandir}/man8/upstart-halt.8.gz \
143    --slave %{_mandir}/man8/poweroff.8.gz poweroff.8 %{_mandir}/man8/upstart-poweroff.8.gz \
144    --slave %{_mandir}/man8/reboot.8.gz reboot.8 %{_mandir}/man8/upstart-reboot.8.gz \
145    --slave %{_mandir}/man8/runlevel.8.gz runlevel.8 %{_mandir}/man8/upstart-runlevel.8.gz \
146    --slave %{_mandir}/man8/shutdown.8.gz shutdown.8 %{_mandir}/man8/upstart-shutdown.8.gz \
147    --slave %{_mandir}/man8/telinit.8.gz telinit.8 %{_mandir}/man8/upstart-telinit.8.gz
148
149%endif
150
151%clean
152rm -rf %{buildroot}
153
154%files -f %{name}.lang
155%defattr(-,root,root,-)
156%license COPYING
157%doc AUTHORS
158%doc NEWS
159%doc README
160%doc TODO
161%doc HACKING
162%{_sysconfdir}/init/
163%config(noreplace) %{_sysconfdir}/dbus-1/system.d/Upstart.conf
164/%{_lib}/libupstart.so.*
165%if 0%{?prepare_systemd}
166/%{_lib}/upstart
167%else
168/sbin/halt
169/sbin/init
170/sbin/poweroff
171/sbin/reboot
172/sbin/runlevel
173/sbin/shutdown
174/sbin/telinit
175%endif
176/sbin/initctl
177/sbin/start
178/sbin/status
179/sbin/stop
180/sbin/restart
181/sbin/reload
182/sbin/upstart-socket-bridge
183/sbin/upstart-udev-bridge
184/sbin/upstart-dbus-bridge
185/sbin/upstart-dconf-bridge
186/sbin/upstart-event-bridge
187/sbin/upstart-file-bridge
188/sbin/upstart-local-bridge
189%{_bindir}/init-checkconf
190%dir %{_datadir}/upstart
191%dir %{_datadir}/upstart/sessions
192%{_datadir}/upstart/sessions/*
193%{_mandir}/man5/init.5.gz
194%{_mandir}/man5/inittab.5.gz
195%{_mandir}/man7/*.7*
196%{_mandir}/man8/*.8*
197%exclude %{_mandir}/man8/initctl2dot.8*
198%exclude %{_mandir}/man8/upstart-monitor.8*
199
200%files devel
201%defattr(-,root,root,-)
202/%{_lib}/libupstart.so
203%{_includedir}/upstart*
204%{_prefix}/lib/pkgconfig/*.pc
205
206%files tools
207%defattr(-,root,root,-)
208%{_bindir}/upstart-monitor
209%{_bindir}/initctl2dot
210%{_datadir}/applications/*.desktop
211%{_datadir}/icons/hicolor/scalable/apps/*.svg
212%{_datadir}/upstart/icons/*.svg
213%{_mandir}/man8/initctl2dot.8*
214%{_mandir}/man8/upstart-monitor.8*
215
216%changelog
217* Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.1-7
218- rebuilt with json-c-0.14.
219
220* Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.1-6
221- manuals for {halt,poweroff,reboot,runlevel,shutdown,telinit} are alternatives ready.
222
223* Tue Jan 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.1-5
224- rebuilt with json-c-0.13.
225- /sbin/{init,halt,poweroff,reboot,runlevel,shutdown,telinit} are alternatives ready.
226
227* Tue Jun 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-4
228- change BuildRequires: eudev-libudev-devel instead of libudev-devel
229
230* Sun Jun 22 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-3
231- rebuild with libnih-1.0.3-2
232
233* Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-2
234- add -tools subpackage
235- split initctl2dot and upstart-monitor to -tools subpackage
236- add R: dbus-python3 to upstart-tools
237
238* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-1
239- update to 1.12.1
240- add BR: dconf-devel
241- add -devel subpackage
242
243* Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-2
244- install upstart-{socket,udev}-bridge.conf
245
246* Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-1
247- update to 1.6
248- add BR: libudev-devel
249- add BR: json-c-devel >= 0.10
250
251* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
252- new upstream release
253
254* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.7-1
255- new upstream release
256
257* Wed May 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-2
258- add R: initscripts >= 8.90.4
259
260* Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-1
261- initial build for Vine Linux
262
263* Wed Feb 24 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.5-3
264- run "make check" only with --with check
265
266* Fri Feb 19 2010 Casey Dahlin <cdahlin@redhat.com> 0.6.5-2
267- be more specific about which libnih we need.
268
269* Wed Feb 17 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.5-1
270- upgrade to 0.6.5
271
272* Fri Jan 29 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.3-7
273- add SIGUSR1 handler and init-system-dbus.conf (#559660)
274
275* Sun Jan 17 2010 Dennis Gilmore <dennis@ausil.us> - 0.6.3-6
276- add patch from upstream fixing sparc alignment issues
277
278* Mon Jan 11 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.3-5
279- License changed to GPLv2 and LGPLv2+
280
281* Wed Dec 16 2009 Petr Lautrbach <plautrba@redhat.com> 0.6.3-4
282- audit events patch rebased for 0.6 (#470661)
283
284* Thu Dec  3 2009 Bill Nottingham <notting@redhat.com> 0.6.3-3
285- make 'telinit u' a no-op, temporarily
286
287* Fri Nov 27 2009 Petr Lautrbach <plautrba@redhat.com> 0.6.3-2
288- Removed tests which fail in koji
289
290* Fri Nov 20 2009 Casey Dahlin <cdahlin@redhat.com> - 0.6.3-1
291- Upgrade to 0.6.3
292
293* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.3.11-3
294- rebuilt with new audit
295
296* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.11-2
297- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
298
299* Mon Jun 22 2009 Petr Lautrbach <plautrba@redhat.com> - 0.3.11-1
300- Update to 0.3.11
301
302* Mon Apr 27 2009 Bill Nottingham <notting@redhat.com> - 0.3.9-24
303- Apply the audit patch correctly (#470661)
304
305* Fri Apr 3 2009 Casey Dahlin <cdahlin@redhat.com> - 0.3.9-23
306- Add audit events patch from Steve Grubb <sgrubb@redhat.com> (Bug #470661)
307
308* Fri Jan 23 2009 Casey Dahlin <cdahlin@redhat.com> - 0.3.9-22
309- Re-add 'telinit u' support along with patch to fix it (#450488). Patch due to
310  <pspencer@fields.utoronto.ca>
311
312* Mon Jan 12 2009 Bill Nottingham <notting@redhat.com> - 0.3.9-21
313- Remove 'telinit u' support as it is broken (#450488, <cjdahlin@ncsu.edu>)
314
315* Fri Apr 25 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-19
316- with the merge of event-compat-sysv, move the sysvinit obsoletes/provides here
317
318* Thu Apr 24 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-18
319- fix some man page typos (#444008, <archimerged@gmail.com>)
320
321* Wed Apr 09 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-17
322- Added list of stock events to events(5)
323
324* Tue Apr 08 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-16
325- Add telinit u support
326
327* Fri Apr 04 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-15
328- Add a events(5) manpage that describes event syntax
329
330* Thu Apr 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-14
331- Change bug report email address to fedora-devel-list@redhat.com
332
333* Fri Mar 14 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-13
334- Ignore rpm temporary files of the foo;<somehex> format
335- Make ignores of .rpm{new,orig,save} match only at the end of the name
336
337* Thu Mar 13 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-12
338- forgot about rpmorig too (ugh)
339
340* Thu Mar 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-11
341- Make logd a noreplace
342
343* Thu Mar 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-10
344- Add patch to ignore .rpm{new,save} files
345
346* Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-9
347- Remove automake dependency, build Makefile.in changes into patch
348
349* Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-8
350- Run automake after patching
351
352* Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-7
353- Added BuildRequires: automake
354
355* Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-6
356- Added patch to allow runtime tty changes
357
358* Fri Feb 15 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-5
359- Added patch to imply --force on runlevels 0 and 6
360
361* Wed Feb 06 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-4
362- Patched for GCC 4.3
363
364* Thu Jan 31 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-3
365- Added AUTHORS, COPYING, etc.
366- Made config --libdir option relative
367
368* Mon Jan 21 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-2
369- Remove libnih and libupstart
370
371* Sun Jan 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-1
372- Initial packaging
Note: See TracBrowser for help on using the repository browser.