source: projects/specs/trunk/u/unixODBC/unixODBC-vl.spec @ 521

Revision 521, 9.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define __libtoolize true
2%define vine26 0
3
4%define kde 1
5# disable -kde subpackage on Vine Linux 2.5,2.6/alpha
6%if %{vine26}
7%ifarch alpha
8%define kde 0
9%endif
10%endif
11
12Summary: A complete ODBC Driver Manager for Linux
13Name: unixODBC
14Version: 2.2.12
15Release: 1%{?_dist_release}
16License: LGPL
17Group: System Environment/Libraries
18Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
19Source1: odbcinst.ini
20Source2: ODBCConfig.desktop
21Source3: DataManager.desktop
22
23Patch1: unixODBC-2.2.11-symbols.patch
24Patch2: nortldglobal.patch
25Patch100: unixODBC-2.2.5-backslash-typo.patch
26URL: http://www.unixODBC.org/
27Conflicts: iodbc
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30%if %{vine26}
31BuildRequires: autoconf253 automake15
32%else
33BuildRequires: autoconf >= 2.53
34BuildRequires: automake >= 1.5
35%endif
36%if %{kde}
37BuildRequires: kdelibs-devel
38BuildRequires: qt-devel
39BuildRequires: libmng-devel
40%endif
41
42%description
43The unixODBC Project goals are to develop and promote unixODBC to
44be the definitive standard for ODBC on the Linux platform. This is to
45include GUI support for KDE.
46
47Install unixODBC if you'd like to access databases through ODBC. This
48package include drivers for PostgreSQL and local files.
49
50If you want to develop programs that will access data through ODBC,
51you'll also need to have the unixODBC package installed.
52
53%package devel
54Summary: Development files for programs which will use the unixODBC library.
55Group: Development/Libraries
56Requires: unixODBC = %{version}
57
58%description devel
59Install unixODBC if you'd like to access databases through ODBC drivers.
60
61If you want to develop programs that will access data through ODBC,
62you'll also need to install the unixODBC-devel (this) package.
63
64%package kde
65Summary: KDE DriverManager components for ODBC
66Group: System Environment/Libraries
67Requires: unixODBC = %{version}
68#Requires: XFree86-libs qt freetype2 libjpeg libmng libpng zlib
69
70%description kde
71Components for the ODBCConfig and DataManager (KDE) Components of unixODBC.
72
73%prep
74%setup -q
75
76%patch1 -p1
77
78# 2.2.8 includes a libtool that is too old for some of our architectures.
79# Blow it away and replace with build system's libtool.  (We intend to use
80# the installed libtool anyway, but this makes sure they match.)
81rm -rf config.guess config.sub ltmain.sh libltdl
82cp -r /usr/share/libtool/* .
83
84# Use newer install-sh and mkinstalldirs, too
85if [ -f libltdl/install-sh ]; then
86  cp -f libltdl/install-sh .
87fi
88if [ -f libltdl/mkinstalldirs ]; then
89  cp -f libltdl/mkinstalldirs .
90fi
91
92# libltdl patch has to be applied after the above
93%patch2 -p1
94
95%build
96%if %{vine26}
97[ -x /usr/bin/autoconf-2.5? ] && ln -s /usr/bin/autoconf-2.5? autoconf
98[ -x /usr/bin/autoheader-2.5? ] && ln -s /usr/bin/autoheader-2.5? autoheader
99[ -x /usr/bin/aclocal-1.5 ] && ln -s /usr/bin/aclocal-1.5 aclocal
100[ -x /usr/bin/automake-1.5 ] && ln -s /usr/bin/automake-1.5 automake
101export PATH=`pwd`:$PATH
102%endif
103
104%if %{kde}
105# pick up qt path
106export QTDIR=
107. /etc/profile.d/qt.sh
108%endif
109
110aclocal
111automake --add-missing
112autoconf
113pushd libltdl
114aclocal
115automake
116autoconf
117popd
118
119%configure --with-gnu-ld=yes --enable-threads=yes --enable-gui=yes --enable-static=yes --enable-drivers
120make all
121
122%install
123%if %{kde}
124# pick up qt path
125unset QTDIR || : ; . /etc/profile.d/qt.sh
126%endif
127
128rm -rf $RPM_BUILD_ROOT
129mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/applnk/System
130mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons
131
132%makeinstall
133cp %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
134#cp DataManager/LinuxODBC.xpm $RPM_BUILD_ROOT%{_datadir}/icons
135#cp odbcinstQ/smallLinuxODBC.xpm $RPM_BUILD_ROOT%{_datadir}/icons
136
137#install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/X11/applnk/System
138#install -m755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/X11/applnk/System
139
140rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%post -p /sbin/ldconfig
146
147%postun -p /sbin/ldconfig
148
149%if %{kde}
150%post kde -p /sbin/ldconfig
151
152%postun kde -p /sbin/ldconfig
153%endif
154
155%files
156%defattr(-,root,root)
157%doc README COPYING AUTHORS ChangeLog NEWS INSTALL doc
158%config(noreplace) %{_sysconfdir}/odbc*
159%{_bindir}/dltest
160%{_bindir}/isql
161%{_bindir}/iusql
162%{_bindir}/odbcinst
163%{_libdir}/libboundparam.so.*
164%{_libdir}/libesoobS.so.*
165%{_libdir}/libgtrtst.so.*
166%{_libdir}/libmimerS.so.*
167%{_libdir}/libnn.so.*
168%{_libdir}/libodbc.so.*
169%{_libdir}/libodbccr.so.*
170%{_libdir}/libodbcdrvcfg1S.so.*
171%{_libdir}/libodbcdrvcfg2S.so.*
172#%{_libdir}/libodbcextras.so.*
173%{_libdir}/libodbcinst.so.*
174%{_libdir}/libodbcminiS.so.*
175%{_libdir}/libodbcmyS.so.*
176%{_libdir}/libodbcnnS.so.*
177%{_libdir}/libodbcpsql.so.*
178%{_libdir}/libodbcpsqlS.so.*
179%{_libdir}/libodbctxt.so.*
180%{_libdir}/libodbctxtS.so.*
181%{_libdir}/liboplodbcS.so.*
182%{_libdir}/liboraodbcS.so.*
183%{_libdir}/libsapdbS.so.*
184%{_libdir}/libtdsS.so.*
185%{_libdir}/libtemplate.so.*
186
187%files devel
188%defattr(-,root,root)
189%{_bindir}/odbc_config
190%{_includedir}/*
191%{_libdir}/libboundparam.so
192%{_libdir}/libesoobS.so
193%{_libdir}/libgtrtst.so
194%{_libdir}/libmimerS.so
195%{_libdir}/libnn.so
196%{_libdir}/libodbc.so
197%{_libdir}/libodbccr.so
198%{_libdir}/libodbcdrvcfg1S.so
199%{_libdir}/libodbcdrvcfg2S.so
200#%{_libdir}/libodbcextras.so
201%{_libdir}/libodbcinst.so
202%{_libdir}/libodbcminiS.so
203%{_libdir}/libodbcmyS.so
204%{_libdir}/libodbcnnS.so
205%{_libdir}/libodbcpsql.so
206%{_libdir}/libodbcpsqlS.so
207%{_libdir}/libodbctxt.so
208%{_libdir}/libodbctxtS.so
209%{_libdir}/liboplodbcS.so
210%{_libdir}/liboraodbcS.so
211%{_libdir}/libsapdbS.so
212%{_libdir}/libtdsS.so
213%{_libdir}/libtemplate.so
214%{_libdir}/*.a
215#{_libdir}/*.la
216
217%if %{kde}
218%files kde
219%defattr(-,root,root)
220%{_bindir}/DataManager
221%{_bindir}/DataManagerII
222%{_bindir}/ODBCConfig
223%{_bindir}/odbctest
224%{_libdir}/libodbcinstQ.so*
225#%{_sysconfdir}/X11/applnk/System/*
226%endif
227
228%changelog
229* Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
230- applied new versioning policy
231- removed *.la files from devel package
232
233* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
234- updated to 2.2.12
235- rebuilt with new toolchain
236
237* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
238- use installed libltdl
239- added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
240
241* Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
242- rebuilt with readline 5.1
243
244* Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
245- updated to 2.2.11
246- not libtoolize
247
248* Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
249- added Patch100 to fix typo in doc/Makefile.am from failure on compiling
250
251* Fri Jun  6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
252- source upgrade
253- remove patch (no need)
254- run libtoolize etc for VineSeed
255
256* Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
257- enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
258
259* Sun Feb  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
260- source upgrade
261- change spec to build both VineSeed and Vine2.5/2.6
262- add patch from rawhide 2.2.3-6
263
264* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
265- Requires: libjpeg (not libjpeg-6b)
266
267* Sun Oct  6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
268- source upgrade
269- add BuildPrereq: autoconf253 automake15
270- add PreReq: ldconfig
271- fix %files section and clean up spec
272- for unixODBC-kde package
273  - add Requires: unixODBC = %{version}
274  - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
275  - delete .desktop files
276
277* Thu Apr  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
278- rebuild with KDE3
279
280* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
281- updated unixODBC-2.2.0
282- fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
283
284* Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
285- remove -kde package on alpha
286
287* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
288- Rebuild for Vine.
289
290* Sun Jun 24 2001 Than Ngo <than@redhat.com>
291- rebuild against qt-2.3.1, kde-2.1.x
292
293* Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
294- Better default odbcinst.ini
295- Minor cleanups
296
297* Wed Jun  6 2001 Trond Eivind Glomsrød <teg@redhat.com>
298- 2.0.7
299
300* Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
301- Fix for isql segfault on EOF/ctrl-d exit
302
303* Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
304- 2.0.6
305- add patch for 64 bit archs (dword shouldn't be "long int")
306
307* Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
308- rebuild
309
310* Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
311- 1.8.13
312
313* Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
314- enable GUI now that we have KDE compiled with the standard
315  compiler
316- move the applnk entries to the KDE package
317
318* Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
319- add the missing shared libs to the non-devel package
320
321* Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
322- 1.8.12 fixes problems with the postgresql driver
323
324* Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
325- disable KDE subpackage to avoid the mess that is C++ binary
326  compatibility
327
328* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
329- automatic rebuild
330
331* Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
332- improved QTDIR detection
333
334* Thu Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
335- 1.8.10
336- use %%{_tmppath}
337- update URL
338- including two missing libraries
339
340* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
341- 1.8.9
342
343* Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
344- adopted for Winston, changed to Red Hat packaging standards
345
346* Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
347- added a unixODBC-devel RPM to the group, added KDE links and icons to system
348- all of which came from recommendations from Fredrick Meunier
349- <Fredrick.Meunier@computershare.com.au>
350
351* Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
352- unixODBC-1.8.7
353- moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.
354
355
Note: See TracBrowser for help on using the repository browser.