source: projects/specs/trunk/u/unixODBC/unixODBC-vl.spec @ 3408

Revision 3408, 10.9 KB checked in by inagaki, 13 years ago (diff)

updated: apr-util, gambas2, gambas3, openldap, php5, qt, qt4, unixODBC

Line 
1%define __libtoolize true
2
3%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
4%define _qt4_bindir %(pkg-config --variable bindir --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{_qt4_version}/bin)
5
6Name: unixODBC
7Summary: A complete ODBC Driver Manager for Linux
8Version: 2.2.14
9Release: 1%{?_dist_release}
10
11Group: System Environment/Libraries
12# Programs are GPL, libraries are LGPL, except News Server library is GPL.
13License: GPLv2+ and LGPLv2+
14URL: http://www.unixODBC.org/
15
16Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
17Source1: odbcinst.ini
18Source2: ODBCConfig.desktop
19Source3: DataManager.desktop
20Source4: conffile.h
21
22Patch1: depcomp.patch
23Patch2: multilib-config.patch
24Patch3: warning-cleanup.patch
25Patch6: export-symbols.patch
26Patch7: libtool-config.patch
27Patch8: so-version-bump.patch
28Patch9: keep-typedefs.patch
29Patch10: odbcint64-config.patch
30Patch11: enable-items.patch
31Patch12: isql-fixes.patch
32Conflicts: iodbc
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35BuildRequires: libX11-devel libXt-devel libXext-devel
36BuildRequires: qt4-devel qt-assistant-adp-devel readline-devel
37BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
38BuildRequires: desktop-file-utils
39
40%description
41The unixODBC Project goals are to develop and promote unixODBC to
42be the definitive standard for ODBC on the Linux platform. This is to
43include GUI support for KDE.
44
45Install unixODBC if you'd like to access databases through ODBC. This
46package include drivers for PostgreSQL and local files.
47
48If you want to develop programs that will access data through ODBC,
49you'll also need to have the unixODBC package installed.
50
51%package devel
52Summary: Development files for programs which will use the unixODBC library.
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
55
56%description devel
57Install unixODBC if you'd like to access databases through ODBC drivers.
58
59If you want to develop programs that will access data through ODBC,
60you'll also need to install the unixODBC-devel (this) package.
61
62%package kde
63Summary: KDE DriverManager components for ODBC
64Group: System Environment/Libraries
65Requires: %{name} = %{version}-%{release}
66
67%description kde
68Components for the ODBCConfig and DataManager (KDE) Components of unixODBC.
69
70%prep
71%setup -q
72%patch1 -p1
73%patch2 -p1
74%patch3 -p1
75%patch6 -p1
76%patch7 -p1
77%patch8 -p1
78%patch9 -p1
79%patch10 -p1
80%patch11 -p1
81%patch12 -p1
82
83chmod 0644 Drivers/MiniSQL/*.c
84chmod 0644 Drivers/nn/*.c
85chmod 0644 Drivers/template/*.c
86chmod 0644 doc/ProgrammerManual/Tutorial/*.html
87chmod 0644 doc/lst/*
88chmod 0644 include/odbcinst.h
89
90# Blow away the embedded libtool and replace with build system's libtool.
91# (We will use the installed libtool anyway, but this makes sure they match.)
92rm -rf config.guess config.sub install-sh ltmain.sh libltdl
93# this hack is so we can build with either libtool 2.2 or 1.5
94libtoolize --install || libtoolize
95
96%build
97# pick up qt path
98export PATH="%{_qt4_bindir}:$PATH"
99# clean up old moc files
100(cd odbcinstQ4 && rm -f mC*.cpp)
101
102aclocal
103automake --add-missing
104autoconf
105
106# unixODBC 2.2.14 is not aliasing-safe
107CFLAGS="%{optflags} -fno-strict-aliasing"
108CXXFLAGS="$CFLAGS"
109export CFLAGS CXXFLAGS
110
111%configure --with-gnu-ld=yes --enable-threads=yes --enable-gui=yes --enable-drivers --enable-ltdllib --with-qt-programs="%{_qt4_bindir}" --with-qt-libraries="%{_qt4_libdir}"
112make all
113
114%install
115# pick up qt path
116export PATH="%{_qt4_bindir}:$PATH"
117
118rm -rf $RPM_BUILD_ROOT
119mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
120mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps
121
122make DESTDIR=$RPM_BUILD_ROOT install
123cp %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
124
125# install *.desktop files
126desktop-file-install --dir=$RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE2}
127
128# package doesn't supply an icon for ODBCConfig, so use the one for DataManager
129cp DataManager/LinuxODBC.xpm $RPM_BUILD_ROOT%{_datadir}/pixmaps
130
131# multilib header hacks
132# we only apply this to known Red Hat multilib arches, per bug #181335
133case `uname -i` in
134  i386 | x86_64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
135    mv $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf_`uname -i`.h
136    rm -f unixodbc_conf.h
137    sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
138    install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}
139    ;;
140  *)
141    ;;
142esac
143
144# remove obsolete Postgres drivers from the package (but not the setup code)
145rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
146
147# copy text driver documentation into main doc directory
148# currently disabled because upstream no longer includes text driver
149# mkdir -p doc/Drivers/txt
150# cp -pr Drivers/txt/doc/* doc/Drivers/txt
151
152# don't want to install doc Makefiles as docs
153#find doc -name 'Makefile*' | xargs rm
154
155# we do not want to ship static libraries
156rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
157
158# remove unpackaged files from the buildroot
159rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
160rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
161rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
162
163%clean
164rm -rf $RPM_BUILD_ROOT
165
166%post -p /sbin/ldconfig
167
168%postun -p /sbin/ldconfig
169
170%post kde -p /sbin/ldconfig
171
172%postun kde -p /sbin/ldconfig
173
174%files
175%defattr(-,root,root)
176%doc README COPYING AUTHORS ChangeLog NEWS INSTALL doc
177%config(noreplace) %{_sysconfdir}/odbc*
178%{_bindir}/dltest
179%{_bindir}/isql
180%{_bindir}/iusql
181%{_bindir}/odbcinst
182%{_libdir}/libboundparam.so.*
183%{_libdir}/libesoobS.so.*
184%{_libdir}/libgtrtst.so.*
185%{_libdir}/libmimerS.so.*
186%{_libdir}/libnn.so.*
187%{_libdir}/libodbc.so.*
188%{_libdir}/libodbccr.so.*
189%{_libdir}/libodbcdrvcfg1S.so.*
190%{_libdir}/libodbcdrvcfg2S.so.*
191#%{_libdir}/libodbcextras.so.*
192%{_libdir}/libodbcinst.so.*
193%{_libdir}/libodbcminiS.so.*
194%{_libdir}/libodbcmyS.so.*
195%{_libdir}/libodbcnnS.so.*
196#%{_libdir}/libodbcpsql.so.*
197%{_libdir}/libodbcpsqlS.so.*
198#%{_libdir}/libodbctxt.so.*
199%{_libdir}/libodbctxtS.so.*
200%{_libdir}/liboplodbcS.so.*
201%{_libdir}/liboraodbcS.so.*
202%{_libdir}/libsapdbS.so.*
203%{_libdir}/libtdsS.so.*
204%{_libdir}/libtemplate.so.*
205
206%files devel
207%defattr(-,root,root)
208%{_bindir}/odbc_config
209%{_includedir}/*
210%{_libdir}/libboundparam.so
211%{_libdir}/libesoobS.so
212%{_libdir}/libgtrtst.so
213%{_libdir}/libmimerS.so
214%{_libdir}/libnn.so
215%{_libdir}/libodbc.so
216%{_libdir}/libodbccr.so
217%{_libdir}/libodbcdrvcfg1S.so
218%{_libdir}/libodbcdrvcfg2S.so
219#%{_libdir}/libodbcextras.so
220%{_libdir}/libodbcinst.so
221%{_libdir}/libodbcminiS.so
222%{_libdir}/libodbcmyS.so
223%{_libdir}/libodbcnnS.so
224#%{_libdir}/libodbcpsql.so
225%{_libdir}/libodbcpsqlS.so
226#%{_libdir}/libodbctxt.so
227%{_libdir}/libodbctxtS.so
228%{_libdir}/liboplodbcS.so
229%{_libdir}/liboraodbcS.so
230%{_libdir}/libsapdbS.so
231%{_libdir}/libtdsS.so
232%{_libdir}/libtemplate.so
233#{_libdir}/*.a
234#{_libdir}/*.la
235
236%files kde
237%defattr(-,root,root)
238%{_bindir}/ODBCConfig
239%{_datadir}/applications/ODBCConfig.desktop
240%{_datadir}/pixmaps/LinuxODBC.xpm
241%{_libdir}/libodbcinstQ*so
242%{_libdir}/libodbcinstQ*so.*
243
244%changelog
245* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
246- updated to 2.2.14
247
248* Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
249- applied new versioning policy
250- removed *.la files from devel package
251
252* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
253- updated to 2.2.12
254- rebuilt with new toolchain
255
256* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
257- use installed libltdl
258- added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
259
260* Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
261- rebuilt with readline 5.1
262
263* Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
264- updated to 2.2.11
265- not libtoolize
266
267* Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
268- added Patch100 to fix typo in doc/Makefile.am from failure on compiling
269
270* Fri Jun  6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
271- source upgrade
272- remove patch (no need)
273- run libtoolize etc for VineSeed
274
275* Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
276- enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
277
278* Sun Feb  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
279- source upgrade
280- change spec to build both VineSeed and Vine2.5/2.6
281- add patch from rawhide 2.2.3-6
282
283* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
284- Requires: libjpeg (not libjpeg-6b)
285
286* Sun Oct  6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
287- source upgrade
288- add BuildPrereq: autoconf253 automake15
289- add PreReq: ldconfig
290- fix %files section and clean up spec
291- for unixODBC-kde package
292  - add Requires: unixODBC = %{version}
293  - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
294  - delete .desktop files
295
296* Thu Apr  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
297- rebuild with KDE3
298
299* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
300- updated unixODBC-2.2.0
301- fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
302
303* Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
304- remove -kde package on alpha
305
306* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
307- Rebuild for Vine.
308
309* Sun Jun 24 2001 Than Ngo <than@redhat.com>
310- rebuild against qt-2.3.1, kde-2.1.x
311
312* Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
313- Better default odbcinst.ini
314- Minor cleanups
315
316* Wed Jun  6 2001 Trond Eivind Glomsrød <teg@redhat.com>
317- 2.0.7
318
319* Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
320- Fix for isql segfault on EOF/ctrl-d exit
321
322* Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
323- 2.0.6
324- add patch for 64 bit archs (dword shouldn't be "long int")
325
326* Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
327- rebuild
328
329* Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
330- 1.8.13
331
332* Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
333- enable GUI now that we have KDE compiled with the standard
334  compiler
335- move the applnk entries to the KDE package
336
337* Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
338- add the missing shared libs to the non-devel package
339
340* Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
341- 1.8.12 fixes problems with the postgresql driver
342
343* Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
344- disable KDE subpackage to avoid the mess that is C++ binary
345  compatibility
346
347* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
348- automatic rebuild
349
350* Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
351- improved QTDIR detection
352
353* Thu Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
354- 1.8.10
355- use %%{_tmppath}
356- update URL
357- including two missing libraries
358
359* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
360- 1.8.9
361
362* Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
363- adopted for Winston, changed to Red Hat packaging standards
364
365* Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
366- added a unixODBC-devel RPM to the group, added KDE links and icons to system
367- all of which came from recommendations from Fredrick Meunier
368- <Fredrick.Meunier@computershare.com.au>
369
370* Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
371- unixODBC-1.8.7
372- moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.
373
374
Note: See TracBrowser for help on using the repository browser.