source: projects/specs/trunk/u/unixODBC/unixODBC-vl.spec @ 11985

Revision 11985, 9.1 KB checked in by tomop, 6 years ago (diff)

updated 3 packages, add 2 packages

vine-themes-7.0.11-1
llvm-7.0.1-1
unixODBC-2.3.7-1
new: autoconf-archive-2018.03.13-3
new: mozjs52-52.9.0-2

RevLine 
[3408]1Name: unixODBC
[11985]2Version: 2.3.7
[9933]3Release: 1%{?_dist_release}
[9467]4Summary: A complete ODBC Driver Manager for Linux
5Summary(ja): Linux 用 ODBC ドライバマネージャー
[3408]6
[521]7Group: System Environment/Libraries
[3408]8# Programs are GPL, libraries are LGPL, except News Server library is GPL.
9License: GPLv2+ and LGPLv2+
10URL: http://www.unixODBC.org/
11
[521]12Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
13Source1: odbcinst.ini
[3408]14Source4: conffile.h
[8757]15Source5: README.dist
[521]16
[3408]17Patch8: so-version-bump.patch
18Patch9: keep-typedefs.patch
[8757]19
[521]20Conflicts: iodbc
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
[3408]23BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
[9467]24BuildRequires: readline-devel
[521]25
[8067]26Vendor: Project Vine
27Distribution: Vine Linux
28
[521]29%description
[9467]30Install unixODBC if you want to access databases through ODBC.
31You will also need the mysql-connector-odbc package if you want to access
32a MySQL database, and/or the postgresql-odbc package for PostgreSQL.
[521]33
34%package devel
35Summary: Development files for programs which will use the unixODBC library.
[9467]36Summary(ja): unixODBC ライブラリを用いるプログラムのための開発用ファイル
[521]37Group: Development/Libraries
[3408]38Requires: %{name} = %{version}-%{release}
[521]39
40%description devel
[9467]41The unixODBC package can be used to access databases through ODBC
42drivers. If you want to develop programs that will access data through
43ODBC, you need to install this package.
[521]44
45%prep
46%setup -q
[3408]47%patch8 -p1
48%patch9 -p1
[521]49
[3408]50chmod 0644 Drivers/MiniSQL/*.c
51chmod 0644 Drivers/nn/*.c
52chmod 0644 Drivers/template/*.c
53chmod 0644 doc/ProgrammerManual/Tutorial/*.html
54chmod 0644 doc/lst/*
55chmod 0644 include/odbcinst.h
[521]56
57%build
[11440]58autoreconf -ivf
[521]59
[3408]60# unixODBC 2.2.14 is not aliasing-safe
61CFLAGS="%{optflags} -fno-strict-aliasing"
62CXXFLAGS="$CFLAGS"
63export CFLAGS CXXFLAGS
64
[8757]65%configure --with-gnu-ld=yes --enable-threads=yes \
66        --enable-drivers=yes --enable-driverc=yes --enable-ltdllib
[9933]67
68# Get rid of the rpaths
69sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
70sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
71
[521]72make all
73
74%install
[9467]75rm -rf $RPM_BUILD_ROOT
[3408]76make DESTDIR=$RPM_BUILD_ROOT install
[8757]77install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
[521]78
[3408]79# multilib header hacks
80# we only apply this to known Red Hat multilib arches, per bug #181335
81case `uname -i` in
[8757]82  i386 | x86_64 | ia64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
[3408]83    mv $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf_`uname -i`.h
84    rm -f unixodbc_conf.h
85    sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
86    install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}
87    ;;
88  *)
89    ;;
90esac
91
[8757]92# add some explanatory documentation
93cp %{SOURCE5} README.dist
94
[3408]95# remove obsolete Postgres drivers from the package (but not the setup code)
96rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
97
98# copy text driver documentation into main doc directory
99# currently disabled because upstream no longer includes text driver
100# mkdir -p doc/Drivers/txt
101# cp -pr Drivers/txt/doc/* doc/Drivers/txt
102
103# don't want to install doc Makefiles as docs
[8757]104find doc -name 'Makefile*' | xargs rm
[3408]105
106# we do not want to ship static libraries
107rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
108
109# remove unpackaged files from the buildroot
110rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
111rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
112rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
113
[8757]114# initialize lists of .so files
115find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
116find $RPM_BUILD_ROOT%{_libdir} -name "*.so"   | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
117
118# move these to main package, they're often dlopened...
119for lib in libodbc.so libodbcinst.so libodbcpsqlS.so libodbcmyS.so
120do
121    echo "%{_libdir}/$lib" >> base-so-list
122    grep -v "/$lib$" devel-so-list > devel-so-list.x
123    mv -f devel-so-list.x devel-so-list
124done
125
[521]126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -p /sbin/ldconfig
130
131%postun -p /sbin/ldconfig
132
[8757]133%files -f base-so-list
134%doc README COPYING AUTHORS ChangeLog NEWS doc
135%doc README.dist
[521]136%config(noreplace) %{_sysconfdir}/odbc*
[8757]137%{_bindir}/odbcinst
[521]138%{_bindir}/isql
[8757]139%{_bindir}/dltest
[521]140%{_bindir}/iusql
141%{_bindir}/odbc_config
[8757]142%{_bindir}/slencheck
143%{_mandir}/man*/*
144
145%files devel -f devel-so-list
[521]146%{_includedir}/*
[11985]147%{_libdir}/pkgconfig/*.pc
[521]148
149%changelog
[11985]150* Wed Dec 12 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.7-1
151- new upstream release.
152- dropped Patch6: fixed in upstream.
153
[11440]154* Sat Jan 20 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.5-1
155- new upstream release.
156
[9933]157* Tue Jan  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
158- new upstream release.
159
[9467]160* Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
161- rebuilt with readline 6.3
162- removed kde-subpackage-related BuildRequires
163- added Japanese summary
164
[8757]165* Tue Jul  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
166- new upstream release.
167- gui was discontinued in upstream.
168
[8067]169* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-3
170- rebuild with VineSeed environment
171
[3409]172* Tue Apr 12 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.14-2
173- add --with-qt-includes option for configure
174
[3408]175* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
176- updated to 2.2.14
177
[521]178* Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
179- applied new versioning policy
180- removed *.la files from devel package
181
182* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
183- updated to 2.2.12
184- rebuilt with new toolchain
185
186* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
187- use installed libltdl
188- added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
189
190* Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
191- rebuilt with readline 5.1
192
193* Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
194- updated to 2.2.11
195- not libtoolize
196
197* Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
198- added Patch100 to fix typo in doc/Makefile.am from failure on compiling
199
200* Fri Jun  6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
201- source upgrade
202- remove patch (no need)
203- run libtoolize etc for VineSeed
204
205* Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
206- enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
207
208* Sun Feb  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
209- source upgrade
210- change spec to build both VineSeed and Vine2.5/2.6
211- add patch from rawhide 2.2.3-6
212
213* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
214- Requires: libjpeg (not libjpeg-6b)
215
216* Sun Oct  6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
217- source upgrade
218- add BuildPrereq: autoconf253 automake15
219- add PreReq: ldconfig
220- fix %files section and clean up spec
221- for unixODBC-kde package
222  - add Requires: unixODBC = %{version}
223  - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
224  - delete .desktop files
225
226* Thu Apr  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
227- rebuild with KDE3
228
229* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
230- updated unixODBC-2.2.0
231- fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
232
233* Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
234- remove -kde package on alpha
235
236* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
237- Rebuild for Vine.
238
239* Sun Jun 24 2001 Than Ngo <than@redhat.com>
240- rebuild against qt-2.3.1, kde-2.1.x
241
242* Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
243- Better default odbcinst.ini
244- Minor cleanups
245
246* Wed Jun  6 2001 Trond Eivind Glomsrød <teg@redhat.com>
247- 2.0.7
248
249* Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
250- Fix for isql segfault on EOF/ctrl-d exit
251
252* Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
253- 2.0.6
254- add patch for 64 bit archs (dword shouldn't be "long int")
255
256* Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
257- rebuild
258
259* Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
260- 1.8.13
261
262* Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
263- enable GUI now that we have KDE compiled with the standard
264  compiler
265- move the applnk entries to the KDE package
266
267* Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
268- add the missing shared libs to the non-devel package
269
270* Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
271- 1.8.12 fixes problems with the postgresql driver
272
273* Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
274- disable KDE subpackage to avoid the mess that is C++ binary
275  compatibility
276
277* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
278- automatic rebuild
279
280* Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
281- improved QTDIR detection
282
[8067]283* Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]284- 1.8.10
285- use %%{_tmppath}
286- update URL
287- including two missing libraries
288
289* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
290- 1.8.9
291
292* Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
293- adopted for Winston, changed to Red Hat packaging standards
294
295* Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
296- added a unixODBC-devel RPM to the group, added KDE links and icons to system
297- all of which came from recommendations from Fredrick Meunier
298- <Fredrick.Meunier@computershare.com.au>
299
300* Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
301- unixODBC-1.8.7
302- moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.
303
304
Note: See TracBrowser for help on using the repository browser.