source: projects/specs/trunk/u/unbound/unbound-vl.spec @ 12374

Revision 12374, 22.4 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

libevent-2.1.11-1

memcached-1.6.5-1

netatalk-3.1.12-2

nfs-utils-2.4.3-1

nsd-4.3.0-3

perl-Event-Lib-1.03-5

tmux-3.0a-1

unbound-1.10.0-2

zabbix-4.0.19-2

Line 
1%bcond_with systemd
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4%global with_munin 0
5%{?!enable_gost:      %global enable_gost      1}
6
7# not ready yet
8%{?!with_python:      %global with_python      0}
9
10%define _sharedstatedir /var/lib
11
12Summary: Validating, recursive, and caching DNS(SEC) resolver
13Name: unbound
14Version: 1.10.0
15Release: 2%{?_dist_release}%{?with_systemd:.systemd}
16Group: System Environment/Daemons
17Distribution: Vine Linux
18Vendor: Project Vine
19Packager: iwaim, daisuke
20
21License: BSD
22Url: http://www.unbound.net/
23Source: https://nlnetlabs.nl/downloads/unbound/%{name}-%{version}.tar.gz
24Source1: unbound.init
25Source3: unbound.munin
26Source4: dlv.isc.org.key
27Source5: root.key
28Source6: root.anchor
29Source7: icannbundle.pem
30Source8: unbound.cron
31Source9: example.com.key
32Source10: example.com.conf
33Source11: block-example.com.conf
34
35Source100: unbound.service
36Source101: unbound-keygen.service
37Source102: unbound-anchor.service
38Source103: unbound-anchor.timer
39Source104: tmpfiles-unbound.conf
40Source105: unbound.sysconfig
41
42BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
43BuildRequires: flex
44BuildRequires: libevent-devel
45BuildRequires: expat-devel
46%if %{with_python}
47BuildRequires:  python-devel python-rpm-macros swig
48%endif
49%if %{enable_gost}
50BuildRequires: openssl-devel >= 1.0.0
51%else
52BuildRequires: openssl-devel
53%endif
54# Required for SVN versions
55#BuildRequires: bison
56
57%if %{with systemd}
58%global piddir /run/%{name}
59BuildRequires: systemd
60%{?systemd_requires}
61%else
62%global piddir %{_localstatedir}/run/%{name}
63Requires(post): chkconfig
64Requires(preun): chkconfig
65Requires(preun): initscripts
66Requires(postun): initscripts
67%endif
68Requires(pre): shadow-utils
69
70
71%description
72Unbound is a validating, recursive, and caching DNS(SEC) resolver.
73
74The C implementation of Unbound is developed and maintained by NLnet
75Labs. It is based on ideas and algorithms taken from a java prototype
76developed by Verisign labs, Nominet, Kirei and ep.net.
77
78Unbound is designed as a set of modular components, so that also
79DNSSEC (secure DNS) validation and stub-resolvers (that do not run
80as a server, but are linked into an application) are easily possible.
81
82%if %{with_munin}
83%package munin
84Summary: Plugin for the munin / munin-node monitoring package
85Summary(ja): munin/munin-node モニタリングパッケージ用のプラグイン
86Group:     System Environment/Daemons
87Requires: munin-node
88Requires: %{name} = %{version}-%{release}, bc
89
90%description munin
91Plugin for the munin / munin-node monitoring package
92%endif
93
94%package devel
95Summary: Development package that includes the unbound header files
96Group: Development/Libraries
97Requires: %{name}-libs = %{version}-%{release}, openssl-devel
98
99%description devel
100The devel package contains the unbound library and the include files
101
102%package libs
103Summary: Libraries used by the unbound server and client applications
104Group: Applications/System
105Requires(post): /sbin/ldconfig
106Requires(postun): /sbin/ldconfig
107Requires: openssl >= 0.9.8g-12
108
109%description libs
110Contains libraries used by the unbound server and client applications
111
112%if %{with_python}
113%package python
114Summary: Python modules and extensions for unbound
115Group: Applications/System
116Requires: %{name}-libs = %{version}-%{release}
117
118%description python
119Python modules and extensions for unbound
120%endif
121
122%package -n compat32-%{name}-libs
123Summary: Libraries used by the unbound server and client applications
124Group: Applications/System
125Requires: %{name}-libs = %{version}-%{release}
126Requires(post): /sbin/ldconfig
127Requires(postun): /sbin/ldconfig
128Requires: openssl >= 0.9.8g-12
129
130%description -n compat32-%{name}-libs
131Contains libraries used by the unbound server and client applications
132
133
134%prep
135%setup -q
136
137
138%build
139%configure  --with-libevent --with-pthreads --with-ssl \
140            --disable-rpath --enable-debug --disable-static \
141            --enable-relro-now --enable-pie \
142            --enable-subnet --enable-ipsecmod \
143            --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
144            --with-pidfile=%{piddir}/%{name}.pid \
145%if %{with_python}
146            --with-pythonmodule --with-pyunbound \
147%endif
148%if !%{enable_gost}
149            --disable-gost \
150%endif
151            --enable-sha2 \
152            --disable-sha1 \
153            --with-rootkey-file=%{_sharedstatedir}/unbound/root.key
154
155%{__make} %{?_smp_mflags}
156
157
158%install
159rm -rf %{buildroot}
160%{__make} DESTDIR=%{buildroot} install
161install -d 0755 %{buildroot}%{_initrddir}
162
163%if %{with systemd}
164install -d -m 0755 %{buildroot}%{_unitdir} %{buildroot}%{_sysconfdir}/sysconfig
165install -p -m 0644 %{SOURCE100} %{buildroot}%{_unitdir}/unbound.service
166install -p -m 0644 %{SOURCE101} %{buildroot}%{_unitdir}/unbound-keygen.service
167install -p -m 0644 %{SOURCE103} %{buildroot}%{_unitdir}/unbound-anchor.timer
168install -p -m 0644 %{SOURCE102} %{buildroot}%{_unitdir}/unbound-anchor.service
169install -p -m 0644 %{SOURCE105} %{buildroot}%{_sysconfdir}/sysconfig/unbound
170# Install tmpfiles.d config
171install -d -m 0755 %{buildroot}%{_tmpfilesdir} %{buildroot}%{_sharedstatedir}/unbound
172install -m 0644 %{SOURCE104} %{buildroot}%{_tmpfilesdir}/unbound.conf
173%else
174install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
175install -d 0755 %{buildroot}%{_sysconfdir}/cron.d
176install -p -m 0644 %{SOURCE8} %{buildroot}%{_sysconfdir}/cron.d/unbound-anchor
177%endif
178
179install -m 0644 %{SOURCE7} %{buildroot}%{_sysconfdir}/unbound
180
181echo "include: %{_sysconfdir}/unbound/conf.d/*.conf" >> %{buildroot}%{_sysconfdir}/unbound/unbound.conf
182
183%if %{with_munin}
184# Install munin plugin and its softlinks
185install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
186install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
187install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
188install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
189for plugin in unbound_munin_hits unbound_munin_queue \
190              unbound_munin_memory unbound_munin_by_type \
191              unbound_munin_by_class unbound_munin_by_opcode \
192              unbound_munin_by_rcode unbound_munin_by_flags \
193              unbound_munin_histogram; do
194    ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
195done
196%endif
197
198# install root and DLV key
199install -m 0644 %{SOURCE4} %{SOURCE5} %{buildroot}%{_sysconfdir}/unbound/
200install -d -m 0755 %{buildroot}%{_sharedstatedir}/unbound
201install -m 0644 %{SOURCE6} %{buildroot}%{_sharedstatedir}/unbound/root.key
202
203# remove static library from install (fedora packaging guidelines)
204rm -rf %{buildroot}%{_libdir}/*.la
205%if %{with_python}
206rm -rf %{buildroot}%{python_sitelib}/*/*.la
207%endif
208
209mkdir -p %{buildroot}%{_localstatedir}/run/unbound
210
211# Install directories for easier config file drop in
212install -d -m 0755 %{buildroot}%{_sysconfdir}/unbound/{keys.d,local.d,conf.d}
213install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/unbound/keys.d/
214install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/unbound/conf.d/
215install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/unbound/local.d/
216
217
218%clean
219rm -rf ${RPM_BUILD_ROOT}
220
221
222%files
223%defattr(-,root,root,-)
224%license doc/LICENSE
225%doc doc/README doc/CREDITS doc/FEATURES
226%if %{with systemd}
227%attr(0644,root,root) %{_tmpfilesdir}/unbound.conf
228%{_unitdir}/%{name}.service
229%{_unitdir}/%{name}-keygen.service
230%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
231%else
232%attr(0755,root,root) %{_initrddir}/%{name}
233%endif
234%attr(0755,root,root) %dir %{_sysconfdir}/%{name}
235%attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
236%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
237%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/keys.d
238%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/keys.d/*.key
239%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/conf.d
240%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/conf.d/*.conf
241%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/local.d
242%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/local.d/*.conf
243%{_sbindir}/*
244%exclude %{_sbindir}/unbound-anchor
245%{_mandir}/*/*
246
247%if %{with_python}
248%files python
249%{python_sitelib}/*
250%endif
251
252%if %{with_munin}
253%files munin
254%defattr(-,root,root,-)
255%config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
256%{_datadir}/munin/plugins/unbound*
257%endif
258
259%files devel
260%defattr(-,root,root,-)
261%{_libdir}/libunbound.so
262%{_includedir}/unbound.h
263%{_libdir}/pkgconfig/libunbound.pc
264%doc README
265
266%files libs
267%defattr(-,root,root,-)
268%license doc/LICENSE
269%doc doc/README
270%{_sbindir}/unbound-anchor
271%{_libdir}/libunbound.so.*
272%{_sysconfdir}/%{name}/icannbundle.pem
273%dir %attr(0755,unbound,unbound) %{_sharedstatedir}/%{name}
274%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
275%attr(0644,unbound,unbound) %config(noreplace) %{_sharedstatedir}/%{name}/root.key
276%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/root.key
277%if %{with systemd}
278%{_unitdir}/unbound-anchor.timer
279%{_unitdir}/unbound-anchor.service
280%else
281%attr(0644,root,root) %{_sysconfdir}/cron.d/unbound-anchor
282%endif
283
284%if %{build_compat32}
285%files -n compat32-%{name}-libs
286%defattr(-,root,root,-)
287%{_libdir}/libunbound.so.*
288%endif
289
290
291%pre libs
292getent group unbound >/dev/null || groupadd -r unbound
293getent passwd unbound >/dev/null || \
294useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
295-c "Unbound DNS resolver" unbound
296exit 0
297
298%post libs
299/sbin/ldconfig
300/sbin/runuser  --command="%{_sbindir}/unbound-anchor -a %{_sharedstatedir}/unbound/root.key -c %{_sysconfdir}/unbound/icannbundle.pem"  --shell /bin/sh unbound ||:
301%if %{with systemd}
302%systemd_post unbound-anchor.timer
303# start the timer only if installing the package to prevent starting it, if it was stopped on purpose
304if [ "$1" -eq 1 ]; then
305    # the Unit is in presets, but would be started after reboot
306    /bin/systemctl start unbound-anchor.timer >/dev/null 2>&1 || :
307fi
308%endif
309
310%if %{with systemd}
311%preun libs
312%systemd_preun unbound-anchor.timer
313%endif
314
315%postun libs
316/sbin/ldconfig
317%if %{with systemd}
318%systemd_postun_with_restart unbound-anchor.timer
319%endif
320
321%post
322%if %{with systemd}
323%systemd_post unbound.service
324%systemd_post unbound-keygen.service
325%else
326/sbin/chkconfig --add %{name}
327%endif
328# dnssec-conf used to contain our DLV key, but now we include it via unbound
329# If unbound had previously been configured with dnssec-configure, we need
330# to migrate the location of the DLV key file (to keep DLV enabled, and because
331# unbound won't start with a bad location for a DLV key file.
332sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
333
334%preun
335%if %{with systemd}
336%systemd_preun unbound.service
337%systemd_preun unbound-keygen.service
338%else
339if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
340  /sbin/service %{name} stop >/dev/null 2>&1
341  /sbin/chkconfig --del %{name}
342fi
343%endif
344
345%postun
346%if %{with systemd}
347%systemd_postun_with_restart unbound.service
348%systemd_postun unbound-keygen.service
349%else
350if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
351  /sbin/service %{name} condrestart >/dev/null 2>&1 || :
352fi
353%endif
354
355%post -n compat32-%{name}-libs
356/sbin/ldconfig
357
358%postun -n compat32-%{name}-libs
359/sbin/ldconfig
360
361%changelog
362* Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-2
363- rebuilt with libevent-2.1.11.
364
365* Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-1
366- updated to 1.10.0.
367- added systemd support (disabled as default).
368- disabled munin.
369
370* Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.6-1
371- updated to 1.9.6.
372
373* Fri Oct 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.4-1
374- updated to 1.9.4.
375
376* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.3-1
377- updated to 1.9.3.
378
379* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-1
380- updated to 1.9.2.
381
382* Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-2
383- added a subpackage 'compat32-unbound-libs'.
384
385* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-1
386- updated to 1.8.1.
387- rebuilt with openssl-1.1.1 and libevent-2.1.8.
388- updated root.key and root.anchor.
389
390* Thu Oct  4 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.0-1
391- update to 1.8.0
392- drop mesh patch (Patch0): upstream fixed
393
394* Thu May 24 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-3
395- Fix mesh state assertion failure due to callback removal. (Patch0)
396
397* Sun May  6 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-2
398- enable ECDSA support
399- enable GOST support
400
401* Sat May  5 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-1
402- update to 1.7.1
403- add pkgconfig file in devel sub package
404
405* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.7-1
406- updated to 1.6.7.
407
408* Mon Jul 31 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.4-1
409- update to 1.6.4
410
411* Sat Jun 24 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.3-1
412- update to 1.6.3
413
414* Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.2-1
415- update to 1.6.2
416- disables SHA1 support
417
418* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.1-1
419- update to 1.6.1
420
421* Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-2
422- fix Requires and BuildRequres
423 - drop ldns
424
425* Thu Dec 29 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-1
426- update to 1.6.0
427
428* Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.9-1
429- new upstream release.
430
431* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.8-1
432- new upstream release.
433
434* Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.7-1
435- new upstream release.
436
437* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-1
438- new upstream release.
439
440* Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.5.3-1
441- update to 1.5.3
442
443* Tue Dec 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.1-1
444- update to 1.5.1
445
446* Tue Jun 17 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-3
447- move create user script to libs subpackage
448
449* Wed Jun 11 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-2
450- add {B,C}.ROOT-SERVERS.NET. IPv6 address
451
452* Wed Apr 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
453- update to 1.4.22
454- move root.key to /var/lib/unbound
455- add icannbundle.pem from http://data.iana.org/root-anchors/icannbundle.pem
456- add unbound.cron
457- move keys and unbound-anchor to libs subpackage
458
459* Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.21-1
460- new upstream release
461
462* Tue Mar 26 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.20-1
463- new upstream release
464
465* Thu Dec 13 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.19-1
466- new upstream release
467- drop glob patch (Patch1): upstream merged
468
469* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.18-1
470- new upstream release
471
472* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.17-1
473- update to 1.4.17
474- add root.key for DNSSEC
475- enable munin subpackage by default
476- buildrequire ldns-devel >= 1.6.13
477
478* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
479- rebuild with python-2.7.2
480
481* Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
482- new upstream release
483
484* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
485- new upstream release
486
487* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
488- new upstream releas
489
490* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
491- new upstream release
492
493* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
494- new upstream release
495
496* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
497- rebuilt with libevent-2.0.10
498
499* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
500- new upstream release
501- add enable_gost flag: default disable
502- add BuildRequires: expat-devel
503
504* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
505- new upstream release
506
507* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
508- new upstream release
509
510* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
511- initial build for Vine Linux: based Fedora 1.4.3-1.fc14
512 - update to 1.4.4
513 - build without munin
514
515* Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
516- Update to 1.4.3 that fixes 64bit crasher
517
518* Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
519- Updated to 1.4.2
520- Updated unbound.conf with new options
521- Enabled pre-fetching DNSKEY records (DNSSEC speedup)
522- Enabled re-fetching popular records before they expire
523- Enabled logging of DNSSEC validation errors
524
525* Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
526- Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
527  with pthreads
528
529* Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
530- Change make/configure lines to attempt to fix -lphtread linking issue
531
532* Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
533- Removed dependancy for dnssec-conf
534- Added ISC DLV key (formerly in dnssec-conf)
535- Fixup old DLV locations in unbound.conf file via %%post
536- Fix parent child disagreement handling and no-ipv6 present [svn r1953]
537
538* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
539- Updated to 1.4.1
540- Changed %%define to %%global
541
542* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
543- Bump version
544
545* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
546- Upgraded to 1.3.4. Security fix with validating NSEC3 records
547
548* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
549- rebuilt with new openssl
550
551* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
552- Updated to 1.3.3
553
554* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
555- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
556
557* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
558- Added missing glob patch to cvs
559- Place python macros within the %%with_python check
560
561* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
562- Updated to 1.3.0
563- Added unbound-python sub package. disabled for now
564- Patch from svn to fix DLV lookups
565- Patches from svn to detect wrong truncated response from BIND 9.6.1 with
566  minimal-responses)
567- Added Default-Start and Default-Stop to unbound.init
568- Re-enabled --enable-sha2
569- Re-enabled glob.patch
570
571* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
572- unbound-iterator.patch was not commited
573
574* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
575- Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
576
577* Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
578- Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
579
580* Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
581- enable DNSSEC only if it is enabled in sysconfig/dnssec
582
583* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
584- add DNSSEC support to initscript and enabled it per default
585- add requires dnssec-conf
586
587* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
588- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
589
590* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
591- updated to 1.2.1
592
593* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
594- rebuild with new openssl
595
596* Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
597- Updated to 1.2.0
598- Added dependancy on minimum SSL for CVE-2008-5077
599- Added dependancy on bc for unbound-munin
600- Added minimum requirement of libevent 1.4.5. Crashes with older versions
601  (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
602- Removed dependancy on selinux-policy (will get used when available)
603- Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
604- Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
605- Enable val-clean-additional to drop addition unsigned data from signed
606  response.
607- Removed patches (got merged into upstream)
608
609* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
610- Modified scandir patch to silently fail when wildcard matches nothing
611- Patch to allow unbound-checkconf to find empty wildcard matches
612
613* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
614- Added scandir patch for trusted-keys-file: option, which
615  is used to load multiple dnssec keys in bind file format
616
617* Mon Dec  8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
618- Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
619
620* Mon Dec  1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
621- We did not own the /etc/unbound directory (#474020)
622- Fixed cvs anomalies
623
624* Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
625- removed all obsolete chroot related stuff
626- label control certs after generation correctly
627
628* Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
629- Updated to unbound 1.1.1 which fixes a crasher and
630  addresses nlnetlabs bug #219
631
632* Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
633- Remove the chroot, obsoleted by SElinux
634- Add additional munin plugin links supported by unbound plugin
635- Move configuration directory from /var/lib/unbound to /etc/unbound
636- Modified unbound.init and unbound.conf to account for chroot changes
637- Updated unbound.conf with new available options
638- Enabled dns-0x20 protection per default
639
640* Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
641- unbound-1.1.0-log_open.patch
642  - make sure log is opened before chroot call
643  - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
644- removed /dev/log and /var/run/unbound and /etc/resolv.conf from
645  chroot, not needed
646- don't mount files in chroot, it causes problems during updates
647- fixed typo in default config file
648
649* Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
650- Updated to version 1.1.0
651- Updated unbound.conf's statistics options and remote-control
652  to work properly for munin
653- Added unbound-munin package
654- Generate unbound remote-control  key/certs on first startup
655- Required ldns is now 1.4.0
656
657* Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
658- Only call ldconfig in -libs package
659- Move configure into build section
660- devel subpackage should only depend on libs subpackage
661
662* Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
663- Fix CFLAGS getting lost in build
664- Don't enable interface-automatic:yes because that
665  causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
666
667* Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
668- Split off unbound-libs, make build verbose
669
670* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
671- FSB compliance, chroot fixes, initscript fixes
672
673* Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
674- Upgraded to 1.0.2
675
676* Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
677- upgraded to new release
678
679* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
680- Build against ldns-1.3.0
681
682* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
683- Split of -devel package, fixed dependancies, make rpmlint happy
684
685* Fri Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
686- Using parts from ports collection entry by Jaap Akkerhuis.
687- Using Fedoraproject wiki guidelines.
688
689* Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
690- Initial version.
Note: See TracBrowser for help on using the repository browser.