source: projects/specs/trunk/u/unbound/unbound-vl.spec @ 12316

Revision 12316, 19.9 KB checked in by tomop, 4 years ago (diff)

updated 22 packages

actdiag-0.5.4-1

blockdiag-1.5.4-1

clamav-0.102.1-1

ghostscript-9.27-3

git-2.24.1-1

incron-0.5.12-4

iputils-20190709-2

libsass-3.6.3-1

libxslt-1.1.34-1

nginx-1.16.1-4

nsd-4.2.4-1

nwdiag-1.0.4-1

oniguruma-6.9.4-1

php73-7.3.12-1

python-funcparserlib-0.3.6-1

python-webcolors-1.10-1

samba-4.10.10-1

seqdiag-0.9.6-1

strongswan-5.8.1-1

trousers-0.3.14-1

unbound-1.9.6-1

unrar-free-0.0.1.20140707-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%global with_munin 1
4%{?!enable_gost:      %global enable_gost      1}
5
6# not ready yet
7%{?!with_python:      %global with_python      0}
8
9%define _sharedstatedir /var/lib
10
11Summary: Validating, recursive, and caching DNS(SEC) resolver
12Name: unbound
13Version: 1.9.6
14Release: 1%{?_dist_release}
15License: BSD
16Url: http://www.unbound.net/
17Source: https://nlnetlabs.nl/downloads/unbound/%{name}-%{version}.tar.gz
18Source1: unbound.init
19Source3: unbound.munin
20Source4: dlv.isc.org.key
21Source5: root.key
22Source6: root.anchor
23Source7: icannbundle.pem
24Source8: unbound.cron
25Source9: example.com.key
26Source10: example.com.conf
27Source11: block-example.com.conf
28
29
30Group: System Environment/Daemons
31BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
32BuildRequires: flex
33BuildRequires: libevent-devel
34BuildRequires: expat-devel
35%if %{with_python}
36BuildRequires:  python-devel python-rpm-macros swig
37%endif
38%if %{enable_gost}
39BuildRequires: openssl-devel >= 1.0.0
40%else
41BuildRequires: openssl-devel
42%endif
43# Required for SVN versions
44#BuildRequires: bison
45
46
47Requires(post): chkconfig
48Requires(preun): chkconfig
49Requires(preun): initscripts
50Requires(postun): initscripts
51Requires(pre): shadow-utils
52
53Distribution: Vine Linux
54Vendor: Project Vine
55Packager: iwaim, daisuke
56
57%description
58Unbound is a validating, recursive, and caching DNS(SEC) resolver.
59
60The C implementation of Unbound is developed and maintained by NLnet
61Labs. It is based on ideas and algorithms taken from a java prototype
62developed by Verisign labs, Nominet, Kirei and ep.net.
63
64Unbound is designed as a set of modular components, so that also
65DNSSEC (secure DNS) validation and stub-resolvers (that do not run
66as a server, but are linked into an application) are easily possible.
67
68%if %{with_munin}
69%package munin
70Summary: Plugin for the munin / munin-node monitoring package
71Summary(ja): munin/munin-node モニタリングパッケージ用のプラグイン
72Group:     System Environment/Daemons
73Requires: munin-node
74Requires: %{name} = %{version}-%{release}, bc
75
76%description munin
77Plugin for the munin / munin-node monitoring package
78%endif
79
80%package devel
81Summary: Development package that includes the unbound header files
82Group: Development/Libraries
83Requires: %{name}-libs = %{version}-%{release}, openssl-devel
84
85%description devel
86The devel package contains the unbound library and the include files
87
88%package libs
89Summary: Libraries used by the unbound server and client applications
90Group: Applications/System
91Requires(post): /sbin/ldconfig
92Requires(postun): /sbin/ldconfig
93Requires: openssl >= 0.9.8g-12
94
95%description libs
96Contains libraries used by the unbound server and client applications
97
98%if %{with_python}
99%package python
100Summary: Python modules and extensions for unbound
101Group: Applications/System
102Requires: %{name}-libs = %{version}-%{release}
103
104%description python
105Python modules and extensions for unbound
106%endif
107
108%package -n compat32-%{name}-libs
109Summary: Libraries used by the unbound server and client applications
110Group: Applications/System
111Requires: %{name}-libs = %{version}-%{release}
112Requires(post): /sbin/ldconfig
113Requires(postun): /sbin/ldconfig
114Requires: openssl >= 0.9.8g-12
115
116%description -n compat32-%{name}-libs
117Contains libraries used by the unbound server and client applications
118
119%prep
120%setup -q
121
122%build
123%configure  --with-libevent --with-pthreads --with-ssl \
124            --disable-rpath --enable-debug --disable-static \
125            --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
126            --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
127%if %{with_python}
128            --with-pythonmodule --with-pyunbound \
129%endif
130%if !%{enable_gost}
131            --disable-gost \
132%endif
133            --enable-sha2 \
134            --disable-sha1 \
135            --with-rootkey-file=%{_sharedstatedir}/unbound/root.key
136
137%{__make} %{?_smp_mflags}
138
139%install
140rm -rf %{buildroot}
141%{__make} DESTDIR=%{buildroot} install
142install -d 0755 %{buildroot}%{_initrddir}
143install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
144install -m 0644 %{SOURCE7} %{buildroot}%{_sysconfdir}/unbound
145install -d 0755 %{buildroot}%{_sysconfdir}/cron.d
146install -p -m 0644 %{SOURCE8} %{buildroot}%{_sysconfdir}/cron.d/unbound-anchor
147
148echo "include: %{_sysconfdir}/unbound/conf.d/*.conf" >> %{buildroot}%{_sysconfdir}/unbound/unbound.conf
149
150%if %{with_munin}
151# Install munin plugin and its softlinks
152install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
153install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
154install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
155install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
156for plugin in unbound_munin_hits unbound_munin_queue \
157              unbound_munin_memory unbound_munin_by_type \
158              unbound_munin_by_class unbound_munin_by_opcode \
159              unbound_munin_by_rcode unbound_munin_by_flags \
160              unbound_munin_histogram; do
161    ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
162done
163%endif
164
165# install root and DLV key
166install -m 0644 %{SOURCE4} %{SOURCE5} %{buildroot}%{_sysconfdir}/unbound/
167install -d -m 0755 %{buildroot}%{_sharedstatedir}/unbound
168install -m 0644 %{SOURCE6} %{buildroot}%{_sharedstatedir}/unbound/root.key
169
170# remove static library from install (fedora packaging guidelines)
171rm -rf %{buildroot}%{_libdir}/*.la
172%if %{with_python}
173rm -rf %{buildroot}%{python_sitelib}/*/*.la
174%endif
175
176mkdir -p %{buildroot}%{_localstatedir}/run/unbound
177
178# Install directories for easier config file drop in
179install -d -m 0755 %{buildroot}%{_sysconfdir}/unbound/{keys.d,local.d,conf.d}
180install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/unbound/keys.d/
181install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/unbound/conf.d/
182install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/unbound/local.d/
183
184
185%clean
186rm -rf ${RPM_BUILD_ROOT}
187
188%files
189%defattr(-,root,root,-)
190%license doc/LICENSE
191%doc doc/README doc/CREDITS doc/FEATURES
192%attr(0755,root,root) %{_initrddir}/%{name}
193%attr(0755,root,root) %dir %{_sysconfdir}/%{name}
194%attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
195%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
196%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/keys.d
197%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/keys.d/*.key
198%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/conf.d
199%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/conf.d/*.conf
200%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/local.d
201%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/local.d/*.conf
202%{_sbindir}/*
203%exclude %{_sbindir}/unbound-anchor
204%{_mandir}/*/*
205
206%if %{with_python}
207%files python
208%{python_sitelib}/*
209%endif
210
211%if %{with_munin}
212%files munin
213%defattr(-,root,root,-)
214%config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
215%{_datadir}/munin/plugins/unbound*
216%endif
217
218%files devel
219%defattr(-,root,root,-)
220%{_libdir}/libunbound.so
221%{_includedir}/unbound.h
222%{_libdir}/pkgconfig/libunbound.pc
223%doc README
224
225%files libs
226%defattr(-,root,root,-)
227%license doc/LICENSE
228%doc doc/README
229%{_sbindir}/unbound-anchor
230%{_libdir}/libunbound.so.*
231%{_sysconfdir}/%{name}/icannbundle.pem
232%attr(0644,root,root) %{_sysconfdir}/cron.d/unbound-anchor
233%dir %attr(0755,unbound,unbound) %{_sharedstatedir}/%{name}
234%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
235%attr(0644,unbound,unbound) %config(noreplace) %{_sharedstatedir}/%{name}/root.key
236%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/root.key
237
238%if %{build_compat32}
239%files -n compat32-%{name}-libs
240%defattr(-,root,root,-)
241%{_libdir}/libunbound.so.*
242%endif
243
244%pre libs
245getent group unbound >/dev/null || groupadd -r unbound
246getent passwd unbound >/dev/null || \
247useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
248-c "Unbound DNS resolver" unbound
249exit 0
250
251%post
252/sbin/chkconfig --add %{name}
253# dnssec-conf used to contain our DLV key, but now we include it via unbound
254# If unbound had previously been configured with dnssec-configure, we need
255# to migrate the location of the DLV key file (to keep DLV enabled, and because
256# unbound won't start with a bad location for a DLV key file.
257sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
258
259%post libs
260/sbin/ldconfig
261/sbin/runuser  --command="%{_sbindir}/unbound-anchor -a %{_sharedstatedir}/unbound/root.key -c %{_sysconfdir}/unbound/icannbundle.pem"  --shell /bin/sh unbound ||:
262
263%preun
264if [ "$1" -eq 0 ]; then
265        /sbin/service %{name} stop >/dev/null 2>&1
266        /sbin/chkconfig --del %{name}
267fi
268
269%postun
270if [ "$1" -ge "1" ]; then
271  /sbin/service %{name} condrestart >/dev/null 2>&1 || :
272fi
273
274%postun libs
275/sbin/ldconfig
276
277%post -n compat32-%{name}-libs
278/sbin/ldconfig
279
280%postun -n compat32-%{name}-libs
281/sbin/ldconfig
282
283%changelog
284* Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.6-1
285- updated to 1.9.6.
286
287* Fri Oct 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.4-1
288- updated to 1.9.4.
289
290* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.3-1
291- updated to 1.9.3.
292
293* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-1
294- updated to 1.9.2.
295
296* Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-2
297- added a subpackage 'compat32-unbound-libs'.
298
299* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-1
300- updated to 1.8.1.
301- rebuilt with openssl-1.1.1 and libevent-2.1.8.
302- updated root.key and root.anchor.
303
304* Thu Oct  4 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.0-1
305- update to 1.8.0
306- drop mesh patch (Patch0): upstream fixed
307
308* Thu May 24 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-3
309- Fix mesh state assertion failure due to callback removal. (Patch0)
310
311* Sun May  6 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-2
312- enable ECDSA support
313- enable GOST support
314
315* Sat May  5 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-1
316- update to 1.7.1
317- add pkgconfig file in devel sub package
318
319* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.7-1
320- updated to 1.6.7.
321
322* Mon Jul 31 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.4-1
323- update to 1.6.4
324
325* Sat Jun 24 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.3-1
326- update to 1.6.3
327
328* Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.2-1
329- update to 1.6.2
330- disables SHA1 support
331
332* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.1-1
333- update to 1.6.1
334
335* Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-2
336- fix Requires and BuildRequres
337 - drop ldns
338
339* Thu Dec 29 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-1
340- update to 1.6.0
341
342* Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.9-1
343- new upstream release.
344
345* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.8-1
346- new upstream release.
347
348* Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.7-1
349- new upstream release.
350
351* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-1
352- new upstream release.
353
354* Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.5.3-1
355- update to 1.5.3
356
357* Tue Dec 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.1-1
358- update to 1.5.1
359
360* Tue Jun 17 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-3
361- move create user script to libs subpackage
362
363* Wed Jun 11 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-2
364- add {B,C}.ROOT-SERVERS.NET. IPv6 address
365
366* Wed Apr 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
367- update to 1.4.22
368- move root.key to /var/lib/unbound
369- add icannbundle.pem from http://data.iana.org/root-anchors/icannbundle.pem
370- add unbound.cron
371- move keys and unbound-anchor to libs subpackage
372
373* Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.21-1
374- new upstream release
375
376* Tue Mar 26 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.20-1
377- new upstream release
378
379* Thu Dec 13 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.19-1
380- new upstream release
381- drop glob patch (Patch1): upstream merged
382
383* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.18-1
384- new upstream release
385
386* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.17-1
387- update to 1.4.17
388- add root.key for DNSSEC
389- enable munin subpackage by default
390- buildrequire ldns-devel >= 1.6.13
391
392* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
393- rebuild with python-2.7.2
394
395* Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
396- new upstream release
397
398* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
399- new upstream release
400
401* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
402- new upstream releas
403
404* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
405- new upstream release
406
407* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
408- new upstream release
409
410* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
411- rebuilt with libevent-2.0.10
412
413* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
414- new upstream release
415- add enable_gost flag: default disable
416- add BuildRequires: expat-devel
417
418* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
419- new upstream release
420
421* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
422- new upstream release
423
424* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
425- initial build for Vine Linux: based Fedora 1.4.3-1.fc14
426 - update to 1.4.4
427 - build without munin
428
429* Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
430- Update to 1.4.3 that fixes 64bit crasher
431
432* Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
433- Updated to 1.4.2
434- Updated unbound.conf with new options
435- Enabled pre-fetching DNSKEY records (DNSSEC speedup)
436- Enabled re-fetching popular records before they expire
437- Enabled logging of DNSSEC validation errors
438
439* Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
440- Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
441  with pthreads
442
443* Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
444- Change make/configure lines to attempt to fix -lphtread linking issue
445
446* Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
447- Removed dependancy for dnssec-conf
448- Added ISC DLV key (formerly in dnssec-conf)
449- Fixup old DLV locations in unbound.conf file via %%post
450- Fix parent child disagreement handling and no-ipv6 present [svn r1953]
451
452* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
453- Updated to 1.4.1
454- Changed %%define to %%global
455
456* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
457- Bump version
458
459* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
460- Upgraded to 1.3.4. Security fix with validating NSEC3 records
461
462* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
463- rebuilt with new openssl
464
465* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
466- Updated to 1.3.3
467
468* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
469- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
470
471* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
472- Added missing glob patch to cvs
473- Place python macros within the %%with_python check
474
475* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
476- Updated to 1.3.0
477- Added unbound-python sub package. disabled for now
478- Patch from svn to fix DLV lookups
479- Patches from svn to detect wrong truncated response from BIND 9.6.1 with
480  minimal-responses)
481- Added Default-Start and Default-Stop to unbound.init
482- Re-enabled --enable-sha2
483- Re-enabled glob.patch
484
485* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
486- unbound-iterator.patch was not commited
487
488* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
489- Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
490
491* Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
492- Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
493
494* Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
495- enable DNSSEC only if it is enabled in sysconfig/dnssec
496
497* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
498- add DNSSEC support to initscript and enabled it per default
499- add requires dnssec-conf
500
501* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
502- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
503
504* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
505- updated to 1.2.1
506
507* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
508- rebuild with new openssl
509
510* Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
511- Updated to 1.2.0
512- Added dependancy on minimum SSL for CVE-2008-5077
513- Added dependancy on bc for unbound-munin
514- Added minimum requirement of libevent 1.4.5. Crashes with older versions
515  (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
516- Removed dependancy on selinux-policy (will get used when available)
517- Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
518- Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
519- Enable val-clean-additional to drop addition unsigned data from signed
520  response.
521- Removed patches (got merged into upstream)
522
523* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
524- Modified scandir patch to silently fail when wildcard matches nothing
525- Patch to allow unbound-checkconf to find empty wildcard matches
526
527* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
528- Added scandir patch for trusted-keys-file: option, which
529  is used to load multiple dnssec keys in bind file format
530
531* Mon Dec  8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
532- Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
533
534* Mon Dec  1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
535- We did not own the /etc/unbound directory (#474020)
536- Fixed cvs anomalies
537
538* Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
539- removed all obsolete chroot related stuff
540- label control certs after generation correctly
541
542* Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
543- Updated to unbound 1.1.1 which fixes a crasher and
544  addresses nlnetlabs bug #219
545
546* Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
547- Remove the chroot, obsoleted by SElinux
548- Add additional munin plugin links supported by unbound plugin
549- Move configuration directory from /var/lib/unbound to /etc/unbound
550- Modified unbound.init and unbound.conf to account for chroot changes
551- Updated unbound.conf with new available options
552- Enabled dns-0x20 protection per default
553
554* Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
555- unbound-1.1.0-log_open.patch
556  - make sure log is opened before chroot call
557  - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
558- removed /dev/log and /var/run/unbound and /etc/resolv.conf from
559  chroot, not needed
560- don't mount files in chroot, it causes problems during updates
561- fixed typo in default config file
562
563* Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
564- Updated to version 1.1.0
565- Updated unbound.conf's statistics options and remote-control
566  to work properly for munin
567- Added unbound-munin package
568- Generate unbound remote-control  key/certs on first startup
569- Required ldns is now 1.4.0
570
571* Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
572- Only call ldconfig in -libs package
573- Move configure into build section
574- devel subpackage should only depend on libs subpackage
575
576* Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
577- Fix CFLAGS getting lost in build
578- Don't enable interface-automatic:yes because that
579  causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
580
581* Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
582- Split off unbound-libs, make build verbose
583
584* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
585- FSB compliance, chroot fixes, initscript fixes
586
587* Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
588- Upgraded to 1.0.2
589
590* Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
591- upgraded to new release
592
593* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
594- Build against ldns-1.3.0
595
596* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
597- Split of -devel package, fixed dependancies, make rpmlint happy
598
599* Fri Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
600- Using parts from ports collection entry by Jaap Akkerhuis.
601- Using Fedoraproject wiki guidelines.
602
603* Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
604- Initial version.
Note: See TracBrowser for help on using the repository browser.