source: projects/specs/trunk/u/unbound/unbound-vl.spec @ 12121

Revision 12121, 20.0 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%global with_munin 1
4%{?!enable_gost:      %global enable_gost      1}
5
6# not ready yet
7%{?!with_python:      %global with_python      0}
8
9%if %{with_python}
10%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
11%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
12%endif
13
14%define _sharedstatedir /var/lib
15
16Summary: Validating, recursive, and caching DNS(SEC) resolver
17Name: unbound
18Version: 1.9.3
19Release: 1%{?_dist_release}
20License: BSD
21Url: http://www.unbound.net/
22Source: https://nlnetlabs.nl/downloads/unbound/%{name}-%{version}.tar.gz
23Source1: unbound.init
24Source2: unbound.conf
25Source3: unbound.munin
26Source4: dlv.isc.org.key
27Source5: root.key
28Source6: root.anchor
29Source7: icannbundle.pem
30Source8: unbound.cron
31Source9: example.com.key
32Source10: example.com.conf
33Source11: block-example.com.conf
34
35
36Group: System Environment/Daemons
37BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
38BuildRequires: flex
39BuildRequires: libevent-devel
40BuildRequires: expat-devel
41%if %{with_python}
42BuildRequires:  python-devel swig
43%endif
44%if %{enable_gost}
45BuildRequires: openssl-devel >= 1.0.0
46%else
47BuildRequires: openssl-devel
48%endif
49# Required for SVN versions
50#BuildRequires: bison
51
52
53Requires(post): chkconfig
54Requires(preun): chkconfig
55Requires(preun): initscripts
56Requires(postun): initscripts
57Requires(pre): shadow-utils
58
59Distribution: Vine Linux
60Vendor: Project Vine
61Packager: iwaim, daisuke
62
63%description
64Unbound is a validating, recursive, and caching DNS(SEC) resolver.
65
66The C implementation of Unbound is developed and maintained by NLnet
67Labs. It is based on ideas and algorithms taken from a java prototype
68developed by Verisign labs, Nominet, Kirei and ep.net.
69
70Unbound is designed as a set of modular components, so that also
71DNSSEC (secure DNS) validation and stub-resolvers (that do not run
72as a server, but are linked into an application) are easily possible.
73
74%if %{with_munin}
75%package munin
76Summary: Plugin for the munin / munin-node monitoring package
77Summary(ja): munin/munin-node モニタリングパッケージ用のプラグイン
78Group:     System Environment/Daemons
79Requires: munin-node
80Requires: %{name} = %{version}-%{release}, bc
81
82%description munin
83Plugin for the munin / munin-node monitoring package
84%endif
85
86%package devel
87Summary: Development package that includes the unbound header files
88Group: Development/Libraries
89Requires: %{name}-libs = %{version}-%{release}, openssl-devel
90
91%description devel
92The devel package contains the unbound library and the include files
93
94%package libs
95Summary: Libraries used by the unbound server and client applications
96Group: Applications/System
97Requires(post): /sbin/ldconfig
98Requires(postun): /sbin/ldconfig
99Requires: openssl >= 0.9.8g-12
100
101%description libs
102Contains libraries used by the unbound server and client applications
103
104%if %{with_python}
105%package python
106Summary: Python modules and extensions for unbound
107Group: Applications/System
108Requires: %{name}-libs = %{version}-%{release}
109
110%description python
111Python modules and extensions for unbound
112%endif
113
114%package -n compat32-%{name}-libs
115Summary: Libraries used by the unbound server and client applications
116Group: Applications/System
117Requires: %{name}-libs = %{version}-%{release}
118Requires(post): /sbin/ldconfig
119Requires(postun): /sbin/ldconfig
120Requires: openssl >= 0.9.8g-12
121
122%description -n compat32-%{name}-libs
123Contains libraries used by the unbound server and client applications
124
125%prep
126%setup -q
127
128%build
129%configure  --with-libevent --with-pthreads --with-ssl \
130            --disable-rpath --enable-debug --disable-static \
131            --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
132            --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
133%if %{with_python}
134            --with-pythonmodule --with-pyunbound \
135%endif
136%if !%{enable_gost}
137            --disable-gost \
138%endif
139            --enable-sha2 \
140            --disable-sha1 \
141            --with-rootkey-file=%{_sharedstatedir}/unbound/root.key
142
143%{__make} %{?_smp_mflags}
144
145%install
146rm -rf %{buildroot}
147%{__make} DESTDIR=%{buildroot} install
148install -d 0755 %{buildroot}%{_initrddir}
149install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
150install -m 0755 %{SOURCE2} %{buildroot}%{_sysconfdir}/unbound
151install -m 0755 %{SOURCE7} %{buildroot}%{_sysconfdir}/unbound
152install -d 0755 %{buildroot}%{_sysconfdir}/cron.d
153install -p -m 0644 %{SOURCE8} %{buildroot}%{_sysconfdir}/cron.d/unbound-anchor
154
155%if %{with_munin}
156# Install munin plugin and its softlinks
157install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
158install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
159install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
160install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
161for plugin in unbound_munin_hits unbound_munin_queue \
162              unbound_munin_memory unbound_munin_by_type \
163              unbound_munin_by_class unbound_munin_by_opcode \
164              unbound_munin_by_rcode unbound_munin_by_flags \
165              unbound_munin_histogram; do
166    ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
167done
168%endif
169
170# install root and DLV key
171install -m 0644 %{SOURCE4} %{SOURCE5} %{buildroot}%{_sysconfdir}/unbound/
172install -d -m 0755 %{buildroot}%{_sharedstatedir}/unbound
173install -m 0644 %{SOURCE6} %{buildroot}%{_sharedstatedir}/unbound/root.key
174
175# remove static library from install (fedora packaging guidelines)
176rm -rf %{buildroot}%{_libdir}/*.la
177%if %{with_python}
178rm -rf %{buildroot}%{python_sitelib}/*/*.la
179%endif
180
181mkdir -p %{buildroot}%{_localstatedir}/run/unbound
182
183# Install directories for easier config file drop in
184install -d -m 0755 %{buildroot}%{_sysconfdir}/unbound/{keys.d,local.d,conf.d}
185install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/unbound/keys.d/
186install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/unbound/conf.d/
187install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/unbound/local.d/
188
189
190%clean
191rm -rf ${RPM_BUILD_ROOT}
192
193%files
194%defattr(-,root,root,-)
195%license doc/LICENSE
196%doc doc/README doc/CREDITS doc/FEATURES
197%attr(0755,root,root) %{_initrddir}/%{name}
198%attr(0755,root,root) %dir %{_sysconfdir}/%{name}
199%attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
200%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
201%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/keys.d
202%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/keys.d/*.key
203%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/conf.d
204%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/conf.d/*.conf
205%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/local.d
206%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/local.d/*.conf
207%{_sbindir}/*
208%exclude %{_sbindir}/unbound-anchor
209%{_mandir}/*/*
210
211%if %{with_python}
212%files python
213%{python_sitelib}/*
214%endif
215
216%if %{with_munin}
217%files munin
218%defattr(-,root,root,-)
219%config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
220%{_datadir}/munin/plugins/unbound*
221%endif
222
223%files devel
224%defattr(-,root,root,-)
225%{_libdir}/libunbound.so
226%{_includedir}/unbound.h
227%{_libdir}/pkgconfig/libunbound.pc
228%doc README
229
230%files libs
231%defattr(-,root,root,-)
232%license doc/LICENSE
233%doc doc/README
234%{_sbindir}/unbound-anchor
235%{_libdir}/libunbound.so.*
236%{_sysconfdir}/%{name}/icannbundle.pem
237%attr(0644,root,root) %{_sysconfdir}/cron.d/unbound-anchor
238%dir %attr(0755,unbound,unbound) %{_sharedstatedir}/%{name}
239%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
240%attr(0644,unbound,unbound) %config(noreplace) %{_sharedstatedir}/%{name}/root.key
241%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/root.key
242
243%if %{build_compat32}
244%files -n compat32-%{name}-libs
245%defattr(-,root,root,-)
246%{_libdir}/libunbound.so.*
247%endif
248
249%pre libs
250getent group unbound >/dev/null || groupadd -r unbound
251getent passwd unbound >/dev/null || \
252useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
253-c "Unbound DNS resolver" unbound
254exit 0
255
256%post
257/sbin/chkconfig --add %{name}
258# dnssec-conf used to contain our DLV key, but now we include it via unbound
259# If unbound had previously been configured with dnssec-configure, we need
260# to migrate the location of the DLV key file (to keep DLV enabled, and because
261# unbound won't start with a bad location for a DLV key file.
262sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
263
264%post libs
265/sbin/ldconfig
266/sbin/runuser  --command="%{_sbindir}/unbound-anchor -a %{_sharedstatedir}/unbound/root.key -c %{_sysconfdir}/unbound/icannbundle.pem"  --shell /bin/sh unbound ||:
267
268%preun
269if [ "$1" -eq 0 ]; then
270        /sbin/service %{name} stop >/dev/null 2>&1
271        /sbin/chkconfig --del %{name}
272fi
273
274%postun
275if [ "$1" -ge "1" ]; then
276  /sbin/service %{name} condrestart >/dev/null 2>&1 || :
277fi
278
279%postun libs
280/sbin/ldconfig
281
282%post -n compat32-%{name}-libs
283/sbin/ldconfig
284
285%postun -n compat32-%{name}-libs
286/sbin/ldconfig
287
288%changelog
289* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.3-1
290- updated to 1.9.3.
291
292* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-1
293- updated to 1.9.2.
294
295* Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-2
296- added a subpackage 'compat32-unbound-libs'.
297
298* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-1
299- updated to 1.8.1.
300- rebuilt with openssl-1.1.1 and libevent-2.1.8.
301- updated root.key and root.anchor.
302
303* Thu Oct  4 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.0-1
304- update to 1.8.0
305- drop mesh patch (Patch0): upstream fixed
306
307* Thu May 24 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-3
308- Fix mesh state assertion failure due to callback removal. (Patch0)
309
310* Sun May  6 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-2
311- enable ECDSA support
312- enable GOST support
313
314* Sat May  5 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-1
315- update to 1.7.1
316- add pkgconfig file in devel sub package
317
318* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.7-1
319- updated to 1.6.7.
320
321* Mon Jul 31 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.4-1
322- update to 1.6.4
323
324* Sat Jun 24 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.3-1
325- update to 1.6.3
326
327* Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.2-1
328- update to 1.6.2
329- disables SHA1 support
330
331* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.1-1
332- update to 1.6.1
333
334* Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-2
335- fix Requires and BuildRequres
336 - drop ldns
337
338* Thu Dec 29 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-1
339- update to 1.6.0
340
341* Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.9-1
342- new upstream release.
343
344* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.8-1
345- new upstream release.
346
347* Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.7-1
348- new upstream release.
349
350* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-1
351- new upstream release.
352
353* Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.5.3-1
354- update to 1.5.3
355
356* Tue Dec 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.1-1
357- update to 1.5.1
358
359* Tue Jun 17 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-3
360- move create user script to libs subpackage
361
362* Wed Jun 11 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-2
363- add {B,C}.ROOT-SERVERS.NET. IPv6 address
364
365* Wed Apr 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
366- update to 1.4.22
367- move root.key to /var/lib/unbound
368- add icannbundle.pem from http://data.iana.org/root-anchors/icannbundle.pem
369- add unbound.cron
370- move keys and unbound-anchor to libs subpackage
371
372* Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.21-1
373- new upstream release
374
375* Tue Mar 26 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.20-1
376- new upstream release
377
378* Thu Dec 13 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.19-1
379- new upstream release
380- drop glob patch (Patch1): upstream merged
381
382* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.18-1
383- new upstream release
384
385* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.17-1
386- update to 1.4.17
387- add root.key for DNSSEC
388- enable munin subpackage by default
389- buildrequire ldns-devel >= 1.6.13
390
391* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
392- rebuild with python-2.7.2
393
394* Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
395- new upstream release
396
397* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
398- new upstream release
399
400* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
401- new upstream releas
402
403* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
404- new upstream release
405
406* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
407- new upstream release
408
409* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
410- rebuilt with libevent-2.0.10
411
412* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
413- new upstream release
414- add enable_gost flag: default disable
415- add BuildRequires: expat-devel
416
417* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
418- new upstream release
419
420* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
421- new upstream release
422
423* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
424- initial build for Vine Linux: based Fedora 1.4.3-1.fc14
425 - update to 1.4.4
426 - build without munin
427
428* Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
429- Update to 1.4.3 that fixes 64bit crasher
430
431* Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
432- Updated to 1.4.2
433- Updated unbound.conf with new options
434- Enabled pre-fetching DNSKEY records (DNSSEC speedup)
435- Enabled re-fetching popular records before they expire
436- Enabled logging of DNSSEC validation errors
437
438* Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
439- Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
440  with pthreads
441
442* Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
443- Change make/configure lines to attempt to fix -lphtread linking issue
444
445* Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
446- Removed dependancy for dnssec-conf
447- Added ISC DLV key (formerly in dnssec-conf)
448- Fixup old DLV locations in unbound.conf file via %%post
449- Fix parent child disagreement handling and no-ipv6 present [svn r1953]
450
451* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
452- Updated to 1.4.1
453- Changed %%define to %%global
454
455* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
456- Bump version
457
458* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
459- Upgraded to 1.3.4. Security fix with validating NSEC3 records
460
461* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
462- rebuilt with new openssl
463
464* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
465- Updated to 1.3.3
466
467* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
468- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
469
470* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
471- Added missing glob patch to cvs
472- Place python macros within the %%with_python check
473
474* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
475- Updated to 1.3.0
476- Added unbound-python sub package. disabled for now
477- Patch from svn to fix DLV lookups
478- Patches from svn to detect wrong truncated response from BIND 9.6.1 with
479  minimal-responses)
480- Added Default-Start and Default-Stop to unbound.init
481- Re-enabled --enable-sha2
482- Re-enabled glob.patch
483
484* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
485- unbound-iterator.patch was not commited
486
487* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
488- Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
489
490* Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
491- Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
492
493* Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
494- enable DNSSEC only if it is enabled in sysconfig/dnssec
495
496* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
497- add DNSSEC support to initscript and enabled it per default
498- add requires dnssec-conf
499
500* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
501- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
502
503* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
504- updated to 1.2.1
505
506* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
507- rebuild with new openssl
508
509* Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
510- Updated to 1.2.0
511- Added dependancy on minimum SSL for CVE-2008-5077
512- Added dependancy on bc for unbound-munin
513- Added minimum requirement of libevent 1.4.5. Crashes with older versions
514  (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
515- Removed dependancy on selinux-policy (will get used when available)
516- Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
517- Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
518- Enable val-clean-additional to drop addition unsigned data from signed
519  response.
520- Removed patches (got merged into upstream)
521
522* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
523- Modified scandir patch to silently fail when wildcard matches nothing
524- Patch to allow unbound-checkconf to find empty wildcard matches
525
526* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
527- Added scandir patch for trusted-keys-file: option, which
528  is used to load multiple dnssec keys in bind file format
529
530* Mon Dec  8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
531- Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
532
533* Mon Dec  1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
534- We did not own the /etc/unbound directory (#474020)
535- Fixed cvs anomalies
536
537* Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
538- removed all obsolete chroot related stuff
539- label control certs after generation correctly
540
541* Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
542- Updated to unbound 1.1.1 which fixes a crasher and
543  addresses nlnetlabs bug #219
544
545* Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
546- Remove the chroot, obsoleted by SElinux
547- Add additional munin plugin links supported by unbound plugin
548- Move configuration directory from /var/lib/unbound to /etc/unbound
549- Modified unbound.init and unbound.conf to account for chroot changes
550- Updated unbound.conf with new available options
551- Enabled dns-0x20 protection per default
552
553* Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
554- unbound-1.1.0-log_open.patch
555  - make sure log is opened before chroot call
556  - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
557- removed /dev/log and /var/run/unbound and /etc/resolv.conf from
558  chroot, not needed
559- don't mount files in chroot, it causes problems during updates
560- fixed typo in default config file
561
562* Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
563- Updated to version 1.1.0
564- Updated unbound.conf's statistics options and remote-control
565  to work properly for munin
566- Added unbound-munin package
567- Generate unbound remote-control  key/certs on first startup
568- Required ldns is now 1.4.0
569
570* Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
571- Only call ldconfig in -libs package
572- Move configure into build section
573- devel subpackage should only depend on libs subpackage
574
575* Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
576- Fix CFLAGS getting lost in build
577- Don't enable interface-automatic:yes because that
578  causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
579
580* Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
581- Split off unbound-libs, make build verbose
582
583* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
584- FSB compliance, chroot fixes, initscript fixes
585
586* Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
587- Upgraded to 1.0.2
588
589* Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
590- upgraded to new release
591
592* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
593- Build against ldns-1.3.0
594
595* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
596- Split of -devel package, fixed dependancies, make rpmlint happy
597
598* Fri Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
599- Using parts from ports collection entry by Jaap Akkerhuis.
600- Using Fedoraproject wiki guidelines.
601
602* Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
603- Initial version.
Note: See TracBrowser for help on using the repository browser.