source: projects/specs/trunk/u/unbound/unbound-vl.spec @ 11896

Revision 11896, 19.8 KB checked in by tomop, 5 years ago (diff)

unbound-1.8.1-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%global with_munin 1
4%{?!enable_gost:      %global enable_gost      1}
5
6# not ready yet
7%{?!with_python:      %global with_python      0}
8
9%if %{with_python}
10%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
11%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
12%endif
13
14%define _sharedstatedir /var/lib
15
16Summary: Validating, recursive, and caching DNS(SEC) resolver
17Name: unbound
18Version: 1.8.1
19Release: 2%{?_dist_release}
20License: BSD
21Url: http://www.unbound.net/
22Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
23Source1: unbound.init
24Source2: unbound.conf
25Source3: unbound.munin
26Source4: dlv.isc.org.key
27Source5: root.key
28Source6: root.anchor
29Source7: icannbundle.pem
30Source8: unbound.cron
31Source9: example.com.key
32Source10: example.com.conf
33Source11: block-example.com.conf
34
35
36Group: System Environment/Daemons
37BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
38BuildRequires: flex
39BuildRequires: libevent-devel
40BuildRequires: expat-devel
41%if %{with_python}
42BuildRequires:  python-devel swig
43%endif
44%if %{enable_gost}
45BuildRequires: openssl-devel >= 1.0.0
46%else
47BuildRequires: openssl-devel
48%endif
49# Required for SVN versions
50#BuildRequires: bison
51
52
53Requires(post): chkconfig
54Requires(preun): chkconfig
55Requires(preun): initscripts
56Requires(postun): initscripts
57Requires(pre): shadow-utils
58
59Distribution: Vine Linux
60Vendor: Project Vine
61Packager: iwaim, daisuke
62
63%description
64Unbound is a validating, recursive, and caching DNS(SEC) resolver.
65
66The C implementation of Unbound is developed and maintained by NLnet
67Labs. It is based on ideas and algorithms taken from a java prototype
68developed by Verisign labs, Nominet, Kirei and ep.net.
69
70Unbound is designed as a set of modular components, so that also
71DNSSEC (secure DNS) validation and stub-resolvers (that do not run
72as a server, but are linked into an application) are easily possible.
73
74%if %{with_munin}
75%package munin
76Summary: Plugin for the munin / munin-node monitoring package
77Summary(ja): munin/munin-node モニタリングパッケージ用のプラグイン
78Group:     System Environment/Daemons
79Requires: munin-node
80Requires: %{name} = %{version}-%{release}, bc
81
82%description munin
83Plugin for the munin / munin-node monitoring package
84%endif
85
86%package devel
87Summary: Development package that includes the unbound header files
88Group: Development/Libraries
89Requires: %{name}-libs = %{version}-%{release}, openssl-devel
90
91%description devel
92The devel package contains the unbound library and the include files
93
94%package libs
95Summary: Libraries used by the unbound server and client applications
96Group: Applications/System
97Requires(post): /sbin/ldconfig
98Requires(postun): /sbin/ldconfig
99Requires: openssl >= 0.9.8g-12
100
101%description libs
102Contains libraries used by the unbound server and client applications
103
104%if %{with_python}
105%package python
106Summary: Python modules and extensions for unbound
107Group: Applications/System
108Requires: %{name}-libs = %{version}-%{release}
109
110%description python
111Python modules and extensions for unbound
112%endif
113
114%package -n compat32-%{name}-libs
115Summary: Libraries used by the unbound server and client applications
116Group: Applications/System
117Requires: %{name}-libs = %{version}-%{release}
118Requires(post): /sbin/ldconfig
119Requires(postun): /sbin/ldconfig
120Requires: openssl >= 0.9.8g-12
121
122%description -n compat32-%{name}-libs
123Contains libraries used by the unbound server and client applications
124
125%prep
126%setup -q
127
128%build
129%configure  --with-libevent --with-pthreads --with-ssl \
130            --disable-rpath --enable-debug --disable-static \
131            --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
132            --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
133%if %{with_python}
134            --with-pythonmodule --with-pyunbound \
135%endif
136%if !%{enable_gost}
137            --disable-gost \
138%endif
139            --enable-sha2 \
140            --disable-sha1 \
141            --with-rootkey-file=%{_sharedstatedir}/unbound/root.key
142
143%{__make} %{?_smp_mflags}
144
145%install
146rm -rf %{buildroot}
147%{__make} DESTDIR=%{buildroot} install
148install -d 0755 %{buildroot}%{_initrddir}
149install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
150install -m 0755 %{SOURCE2} %{buildroot}%{_sysconfdir}/unbound
151install -m 0755 %{SOURCE7} %{buildroot}%{_sysconfdir}/unbound
152install -d 0755 %{buildroot}%{_sysconfdir}/cron.d
153install -p -m 0644 %{SOURCE8} %{buildroot}%{_sysconfdir}/cron.d/unbound-anchor
154
155%if %{with_munin}
156# Install munin plugin and its softlinks
157install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
158install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
159install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
160install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
161for plugin in unbound_munin_hits unbound_munin_queue \
162              unbound_munin_memory unbound_munin_by_type \
163              unbound_munin_by_class unbound_munin_by_opcode \
164              unbound_munin_by_rcode unbound_munin_by_flags \
165              unbound_munin_histogram; do
166    ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
167done
168%endif
169
170# install root and DLV key
171install -m 0644 %{SOURCE4} %{SOURCE5} %{buildroot}%{_sysconfdir}/unbound/
172install -d -m 0755 %{buildroot}%{_sharedstatedir}/unbound
173install -m 0644 %{SOURCE6} %{buildroot}%{_sharedstatedir}/unbound/root.key
174
175# remove static library from install (fedora packaging guidelines)
176rm -rf %{buildroot}%{_libdir}/*.la
177%if %{with_python}
178rm -rf %{buildroot}%{python_sitelib}/*/*.la
179%endif
180
181mkdir -p %{buildroot}%{_localstatedir}/run/unbound
182
183# Install directories for easier config file drop in
184install -d -m 0755 %{buildroot}%{_sysconfdir}/unbound/{keys.d,local.d,conf.d}
185install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/unbound/keys.d/
186install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/unbound/conf.d/
187install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/unbound/local.d/
188
189
190%clean
191rm -rf ${RPM_BUILD_ROOT}
192
193%files
194%defattr(-,root,root,-)
195%doc doc/README doc/CREDITS doc/LICENSE doc/FEATURES
196%attr(0755,root,root) %{_initrddir}/%{name}
197%attr(0755,root,root) %dir %{_sysconfdir}/%{name}
198%attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
199%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
200%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/keys.d
201%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/keys.d/*.key
202%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/conf.d
203%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/conf.d/*.conf
204%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/local.d
205%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/local.d/*.conf
206%{_sbindir}/*
207%exclude %{_sbindir}/unbound-anchor
208%{_mandir}/*/*
209
210%if %{with_python}
211%files python
212%{python_sitelib}/*
213%endif
214
215%if %{with_munin}
216%files munin
217%defattr(-,root,root,-)
218%config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
219%{_datadir}/munin/plugins/unbound*
220%endif
221
222%files devel
223%defattr(-,root,root,-)
224%{_libdir}/libunbound.so
225%{_includedir}/unbound.h
226%{_libdir}/pkgconfig/libunbound.pc
227%doc README
228
229%files libs
230%defattr(-,root,root,-)
231%doc doc/README doc/LICENSE
232%{_sbindir}/unbound-anchor
233%{_libdir}/libunbound.so.*
234%{_sysconfdir}/%{name}/icannbundle.pem
235%attr(0644,root,root) %{_sysconfdir}/cron.d/unbound-anchor
236%dir %attr(0755,unbound,unbound) %{_sharedstatedir}/%{name}
237%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
238%attr(0644,unbound,unbound) %config(noreplace) %{_sharedstatedir}/%{name}/root.key
239%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/root.key
240
241%if %{build_compat32}
242%files -n compat32-%{name}-libs
243%defattr(-,root,root,-)
244%{_libdir}/libunbound.so.*
245%endif
246
247%pre libs
248getent group unbound >/dev/null || groupadd -r unbound
249getent passwd unbound >/dev/null || \
250useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
251-c "Unbound DNS resolver" unbound
252exit 0
253
254%post
255/sbin/chkconfig --add %{name}
256# dnssec-conf used to contain our DLV key, but now we include it via unbound
257# If unbound had previously been configured with dnssec-configure, we need
258# to migrate the location of the DLV key file (to keep DLV enabled, and because
259# unbound won't start with a bad location for a DLV key file.
260sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
261
262%post libs
263/sbin/ldconfig
264/sbin/runuser  --command="%{_sbindir}/unbound-anchor -a %{_sharedstatedir}/unbound/root.key -c %{_sysconfdir}/unbound/icannbundle.pem"  --shell /bin/sh unbound ||:
265
266%preun
267if [ "$1" -eq 0 ]; then
268        /sbin/service %{name} stop >/dev/null 2>&1
269        /sbin/chkconfig --del %{name}
270fi
271
272%postun
273if [ "$1" -ge "1" ]; then
274  /sbin/service %{name} condrestart >/dev/null 2>&1 || :
275fi
276
277%postun libs
278/sbin/ldconfig
279
280%post -n compat32-%{name}-libs
281/sbin/ldconfig
282
283%postun -n compat32-%{name}-libs
284/sbin/ldconfig
285
286%changelog
287* Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-2
288- added a subpackage 'compat32-unbound-libs'.
289
290* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-1
291- updated to 1.8.1.
292- rebuilt with openssl-1.1.1 and libevent-2.1.8.
293- updated root.key and root.anchor.
294
295* Thu Oct  4 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.0-1
296- update to 1.8.0
297- drop mesh patch (Patch0): upstream fixed
298
299* Thu May 24 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-3
300- Fix mesh state assertion failure due to callback removal. (Patch0)
301
302* Sun May  6 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-2
303- enable ECDSA support
304- enable GOST support
305
306* Sat May  5 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-1
307- update to 1.7.1
308- add pkgconfig file in devel sub package
309
310* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.7-1
311- updated to 1.6.7.
312
313* Mon Jul 31 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.4-1
314- update to 1.6.4
315
316* Sat Jun 24 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.3-1
317- update to 1.6.3
318
319* Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.2-1
320- update to 1.6.2
321- disables SHA1 support
322
323* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.1-1
324- update to 1.6.1
325
326* Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-2
327- fix Requires and BuildRequres
328 - drop ldns
329
330* Thu Dec 29 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-1
331- update to 1.6.0
332
333* Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.9-1
334- new upstream release.
335
336* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.8-1
337- new upstream release.
338
339* Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.7-1
340- new upstream release.
341
342* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-1
343- new upstream release.
344
345* Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.5.3-1
346- update to 1.5.3
347
348* Tue Dec 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.1-1
349- update to 1.5.1
350
351* Tue Jun 17 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-3
352- move create user script to libs subpackage
353
354* Wed Jun 11 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-2
355- add {B,C}.ROOT-SERVERS.NET. IPv6 address
356
357* Wed Apr 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
358- update to 1.4.22
359- move root.key to /var/lib/unbound
360- add icannbundle.pem from http://data.iana.org/root-anchors/icannbundle.pem
361- add unbound.cron
362- move keys and unbound-anchor to libs subpackage
363
364* Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.21-1
365- new upstream release
366
367* Tue Mar 26 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.20-1
368- new upstream release
369
370* Thu Dec 13 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.19-1
371- new upstream release
372- drop glob patch (Patch1): upstream merged
373
374* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.18-1
375- new upstream release
376
377* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.17-1
378- update to 1.4.17
379- add root.key for DNSSEC
380- enable munin subpackage by default
381- buildrequire ldns-devel >= 1.6.13
382
383* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
384- rebuild with python-2.7.2
385
386* Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
387- new upstream release
388
389* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
390- new upstream release
391
392* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
393- new upstream releas
394
395* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
396- new upstream release
397
398* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
399- new upstream release
400
401* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
402- rebuilt with libevent-2.0.10
403
404* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
405- new upstream release
406- add enable_gost flag: default disable
407- add BuildRequires: expat-devel
408
409* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
410- new upstream release
411
412* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
413- new upstream release
414
415* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
416- initial build for Vine Linux: based Fedora 1.4.3-1.fc14
417 - update to 1.4.4
418 - build without munin
419
420* Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
421- Update to 1.4.3 that fixes 64bit crasher
422
423* Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
424- Updated to 1.4.2
425- Updated unbound.conf with new options
426- Enabled pre-fetching DNSKEY records (DNSSEC speedup)
427- Enabled re-fetching popular records before they expire
428- Enabled logging of DNSSEC validation errors
429
430* Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
431- Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
432  with pthreads
433
434* Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
435- Change make/configure lines to attempt to fix -lphtread linking issue
436
437* Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
438- Removed dependancy for dnssec-conf
439- Added ISC DLV key (formerly in dnssec-conf)
440- Fixup old DLV locations in unbound.conf file via %%post
441- Fix parent child disagreement handling and no-ipv6 present [svn r1953]
442
443* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
444- Updated to 1.4.1
445- Changed %%define to %%global
446
447* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
448- Bump version
449
450* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
451- Upgraded to 1.3.4. Security fix with validating NSEC3 records
452
453* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
454- rebuilt with new openssl
455
456* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
457- Updated to 1.3.3
458
459* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
460- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
461
462* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
463- Added missing glob patch to cvs
464- Place python macros within the %%with_python check
465
466* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
467- Updated to 1.3.0
468- Added unbound-python sub package. disabled for now
469- Patch from svn to fix DLV lookups
470- Patches from svn to detect wrong truncated response from BIND 9.6.1 with
471  minimal-responses)
472- Added Default-Start and Default-Stop to unbound.init
473- Re-enabled --enable-sha2
474- Re-enabled glob.patch
475
476* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
477- unbound-iterator.patch was not commited
478
479* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
480- Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
481
482* Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
483- Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
484
485* Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
486- enable DNSSEC only if it is enabled in sysconfig/dnssec
487
488* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
489- add DNSSEC support to initscript and enabled it per default
490- add requires dnssec-conf
491
492* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
493- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
494
495* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
496- updated to 1.2.1
497
498* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
499- rebuild with new openssl
500
501* Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
502- Updated to 1.2.0
503- Added dependancy on minimum SSL for CVE-2008-5077
504- Added dependancy on bc for unbound-munin
505- Added minimum requirement of libevent 1.4.5. Crashes with older versions
506  (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
507- Removed dependancy on selinux-policy (will get used when available)
508- Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
509- Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
510- Enable val-clean-additional to drop addition unsigned data from signed
511  response.
512- Removed patches (got merged into upstream)
513
514* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
515- Modified scandir patch to silently fail when wildcard matches nothing
516- Patch to allow unbound-checkconf to find empty wildcard matches
517
518* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
519- Added scandir patch for trusted-keys-file: option, which
520  is used to load multiple dnssec keys in bind file format
521
522* Mon Dec  8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
523- Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
524
525* Mon Dec  1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
526- We did not own the /etc/unbound directory (#474020)
527- Fixed cvs anomalies
528
529* Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
530- removed all obsolete chroot related stuff
531- label control certs after generation correctly
532
533* Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
534- Updated to unbound 1.1.1 which fixes a crasher and
535  addresses nlnetlabs bug #219
536
537* Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
538- Remove the chroot, obsoleted by SElinux
539- Add additional munin plugin links supported by unbound plugin
540- Move configuration directory from /var/lib/unbound to /etc/unbound
541- Modified unbound.init and unbound.conf to account for chroot changes
542- Updated unbound.conf with new available options
543- Enabled dns-0x20 protection per default
544
545* Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
546- unbound-1.1.0-log_open.patch
547  - make sure log is opened before chroot call
548  - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
549- removed /dev/log and /var/run/unbound and /etc/resolv.conf from
550  chroot, not needed
551- don't mount files in chroot, it causes problems during updates
552- fixed typo in default config file
553
554* Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
555- Updated to version 1.1.0
556- Updated unbound.conf's statistics options and remote-control
557  to work properly for munin
558- Added unbound-munin package
559- Generate unbound remote-control  key/certs on first startup
560- Required ldns is now 1.4.0
561
562* Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
563- Only call ldconfig in -libs package
564- Move configure into build section
565- devel subpackage should only depend on libs subpackage
566
567* Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
568- Fix CFLAGS getting lost in build
569- Don't enable interface-automatic:yes because that
570  causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
571
572* Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
573- Split off unbound-libs, make build verbose
574
575* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
576- FSB compliance, chroot fixes, initscript fixes
577
578* Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
579- Upgraded to 1.0.2
580
581* Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
582- upgraded to new release
583
584* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
585- Build against ldns-1.3.0
586
587* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
588- Split of -devel package, fixed dependancies, make rpmlint happy
589
590* Fri Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
591- Using parts from ports collection entry by Jaap Akkerhuis.
592- Using Fedoraproject wiki guidelines.
593
594* Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
595- Initial version.
Note: See TracBrowser for help on using the repository browser.