source: projects/specs/trunk/u/unbound/unbound-vl.spec @ 11858

Revision 11858, 19.0 KB checked in by tomop, 6 years ago (diff)

unbound-1.8.1-1

Line 
1%global with_munin 1
2%{?!enable_gost:      %global enable_gost      1}
3
4# not ready yet
5%{?!with_python:      %global with_python      0}
6
7%if %{with_python}
8%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
9%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
10%endif
11
12%define _sharedstatedir /var/lib
13
14Summary: Validating, recursive, and caching DNS(SEC) resolver
15Name: unbound
16Version: 1.8.1
17Release: 1%{?_dist_release}
18License: BSD
19Url: http://www.unbound.net/
20Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
21Source1: unbound.init
22Source2: unbound.conf
23Source3: unbound.munin
24Source4: dlv.isc.org.key
25Source5: root.key
26Source6: root.anchor
27Source7: icannbundle.pem
28Source8: unbound.cron
29Source9: example.com.key
30Source10: example.com.conf
31Source11: block-example.com.conf
32
33
34Group: System Environment/Daemons
35BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
36BuildRequires: flex
37BuildRequires: libevent-devel
38BuildRequires: expat-devel
39%if %{with_python}
40BuildRequires:  python-devel swig
41%endif
42%if %{enable_gost}
43BuildRequires: openssl-devel >= 1.0.0
44%else
45BuildRequires: openssl-devel
46%endif
47# Required for SVN versions
48#BuildRequires: bison
49
50
51Requires(post): chkconfig
52Requires(preun): chkconfig
53Requires(preun): initscripts
54Requires(postun): initscripts
55Requires(pre): shadow-utils
56
57Distribution: Vine Linux
58Vendor: Project Vine
59Packager: iwaim, daisuke
60
61%description
62Unbound is a validating, recursive, and caching DNS(SEC) resolver.
63
64The C implementation of Unbound is developed and maintained by NLnet
65Labs. It is based on ideas and algorithms taken from a java prototype
66developed by Verisign labs, Nominet, Kirei and ep.net.
67
68Unbound is designed as a set of modular components, so that also
69DNSSEC (secure DNS) validation and stub-resolvers (that do not run
70as a server, but are linked into an application) are easily possible.
71
72%if %{with_munin}
73%package munin
74Summary: Plugin for the munin / munin-node monitoring package
75Summary(ja): munin/munin-node モニタリングパッケージ用のプラグイン
76Group:     System Environment/Daemons
77Requires: munin-node
78Requires: %{name} = %{version}-%{release}, bc
79
80%description munin
81Plugin for the munin / munin-node monitoring package
82%endif
83
84%package devel
85Summary: Development package that includes the unbound header files
86Group: Development/Libraries
87Requires: %{name}-libs = %{version}-%{release}, openssl-devel
88
89%description devel
90The devel package contains the unbound library and the include files
91
92%package libs
93Summary: Libraries used by the unbound server and client applications
94Group: Applications/System
95Requires(post): /sbin/ldconfig
96Requires(postun): /sbin/ldconfig
97Requires: openssl >= 0.9.8g-12
98
99%description libs
100Contains libraries used by the unbound server and client applications
101
102%if %{with_python}
103%package python
104Summary: Python modules and extensions for unbound
105Group: Applications/System
106Requires: %{name}-libs = %{version}-%{release}
107
108%description python
109Python modules and extensions for unbound
110%endif
111
112%prep
113%setup -q
114
115%build
116%configure  --with-libevent --with-pthreads --with-ssl \
117            --disable-rpath --enable-debug --disable-static \
118            --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
119            --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
120%if %{with_python}
121            --with-pythonmodule --with-pyunbound \
122%endif
123%if !%{enable_gost}
124            --disable-gost \
125%endif
126            --enable-sha2 \
127            --disable-sha1 \
128            --with-rootkey-file=%{_sharedstatedir}/unbound/root.key
129
130%{__make} %{?_smp_mflags}
131
132%install
133rm -rf %{buildroot}
134%{__make} DESTDIR=%{buildroot} install
135install -d 0755 %{buildroot}%{_initrddir}
136install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
137install -m 0755 %{SOURCE2} %{buildroot}%{_sysconfdir}/unbound
138install -m 0755 %{SOURCE7} %{buildroot}%{_sysconfdir}/unbound
139install -d 0755 %{buildroot}%{_sysconfdir}/cron.d
140install -p -m 0644 %{SOURCE8} %{buildroot}%{_sysconfdir}/cron.d/unbound-anchor
141
142%if %{with_munin}
143# Install munin plugin and its softlinks
144install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
145install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
146install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
147install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
148for plugin in unbound_munin_hits unbound_munin_queue \
149              unbound_munin_memory unbound_munin_by_type \
150              unbound_munin_by_class unbound_munin_by_opcode \
151              unbound_munin_by_rcode unbound_munin_by_flags \
152              unbound_munin_histogram; do
153    ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
154done
155%endif
156
157# install root and DLV key
158install -m 0644 %{SOURCE4} %{SOURCE5} %{buildroot}%{_sysconfdir}/unbound/
159install -d -m 0755 %{buildroot}%{_sharedstatedir}/unbound
160install -m 0644 %{SOURCE6} %{buildroot}%{_sharedstatedir}/unbound/root.key
161
162# remove static library from install (fedora packaging guidelines)
163rm -rf %{buildroot}%{_libdir}/*.la
164%if %{with_python}
165rm -rf %{buildroot}%{python_sitelib}/*/*.la
166%endif
167
168mkdir -p %{buildroot}%{_localstatedir}/run/unbound
169
170# Install directories for easier config file drop in
171install -d -m 0755 %{buildroot}%{_sysconfdir}/unbound/{keys.d,local.d,conf.d}
172install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/unbound/keys.d/
173install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/unbound/conf.d/
174install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/unbound/local.d/
175
176
177%clean
178rm -rf ${RPM_BUILD_ROOT}
179
180%files
181%defattr(-,root,root,-)
182%doc doc/README doc/CREDITS doc/LICENSE doc/FEATURES
183%attr(0755,root,root) %{_initrddir}/%{name}
184%attr(0755,root,root) %dir %{_sysconfdir}/%{name}
185%attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
186%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
187%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/keys.d
188%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/keys.d/*.key
189%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/conf.d
190%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/conf.d/*.conf
191%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/local.d
192%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/local.d/*.conf
193%{_sbindir}/*
194%exclude %{_sbindir}/unbound-anchor
195%{_mandir}/*/*
196
197%if %{with_python}
198%files python
199%{python_sitelib}/*
200%endif
201
202%if %{with_munin}
203%files munin
204%defattr(-,root,root,-)
205%config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
206%{_datadir}/munin/plugins/unbound*
207%endif
208
209%files devel
210%defattr(-,root,root,-)
211%{_libdir}/libunbound.so
212%{_includedir}/unbound.h
213%{_libdir}/pkgconfig/libunbound.pc
214%doc README
215
216%files libs
217%defattr(-,root,root,-)
218%doc doc/README doc/LICENSE
219%{_sbindir}/unbound-anchor
220%{_libdir}/libunbound.so.*
221%{_sysconfdir}/%{name}/icannbundle.pem
222%attr(0644,root,root) %{_sysconfdir}/cron.d/unbound-anchor
223%dir %attr(0755,unbound,unbound) %{_sharedstatedir}/%{name}
224%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
225%attr(0644,unbound,unbound) %config(noreplace) %{_sharedstatedir}/%{name}/root.key
226%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/root.key
227
228%pre libs
229getent group unbound >/dev/null || groupadd -r unbound
230getent passwd unbound >/dev/null || \
231useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
232-c "Unbound DNS resolver" unbound
233exit 0
234
235%post
236/sbin/chkconfig --add %{name}
237# dnssec-conf used to contain our DLV key, but now we include it via unbound
238# If unbound had previously been configured with dnssec-configure, we need
239# to migrate the location of the DLV key file (to keep DLV enabled, and because
240# unbound won't start with a bad location for a DLV key file.
241sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
242
243%post libs
244/sbin/ldconfig
245/sbin/runuser  --command="%{_sbindir}/unbound-anchor -a %{_sharedstatedir}/unbound/root.key -c %{_sysconfdir}/unbound/icannbundle.pem"  --shell /bin/sh unbound ||:
246
247%preun
248if [ "$1" -eq 0 ]; then
249        /sbin/service %{name} stop >/dev/null 2>&1
250        /sbin/chkconfig --del %{name}
251fi
252
253%postun
254if [ "$1" -ge "1" ]; then
255  /sbin/service %{name} condrestart >/dev/null 2>&1 || :
256fi
257
258%postun libs
259/sbin/ldconfig
260
261%changelog
262* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-1
263- updated to 1.8.1.
264- rebuilt with openssl-1.1.1 and libevent-2.1.8.
265- updated root.key and root.anchor.
266
267* Thu Oct  4 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.0-1
268- update to 1.8.0
269- drop mesh patch (Patch0): upstream fixed
270
271* Thu May 24 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-3
272- Fix mesh state assertion failure due to callback removal. (Patch0)
273
274* Sun May  6 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-2
275- enable ECDSA support
276- enable GOST support
277
278* Sat May  5 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-1
279- update to 1.7.1
280- add pkgconfig file in devel sub package
281
282* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.7-1
283- updated to 1.6.7.
284
285* Mon Jul 31 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.4-1
286- update to 1.6.4
287
288* Sat Jun 24 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.3-1
289- update to 1.6.3
290
291* Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.2-1
292- update to 1.6.2
293- disables SHA1 support
294
295* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.1-1
296- update to 1.6.1
297
298* Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-2
299- fix Requires and BuildRequres
300 - drop ldns
301
302* Thu Dec 29 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-1
303- update to 1.6.0
304
305* Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.9-1
306- new upstream release.
307
308* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.8-1
309- new upstream release.
310
311* Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.7-1
312- new upstream release.
313
314* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-1
315- new upstream release.
316
317* Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.5.3-1
318- update to 1.5.3
319
320* Tue Dec 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.1-1
321- update to 1.5.1
322
323* Tue Jun 17 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-3
324- move create user script to libs subpackage
325
326* Wed Jun 11 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-2
327- add {B,C}.ROOT-SERVERS.NET. IPv6 address
328
329* Wed Apr 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
330- update to 1.4.22
331- move root.key to /var/lib/unbound
332- add icannbundle.pem from http://data.iana.org/root-anchors/icannbundle.pem
333- add unbound.cron
334- move keys and unbound-anchor to libs subpackage
335
336* Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.21-1
337- new upstream release
338
339* Tue Mar 26 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.20-1
340- new upstream release
341
342* Thu Dec 13 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.19-1
343- new upstream release
344- drop glob patch (Patch1): upstream merged
345
346* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.18-1
347- new upstream release
348
349* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.17-1
350- update to 1.4.17
351- add root.key for DNSSEC
352- enable munin subpackage by default
353- buildrequire ldns-devel >= 1.6.13
354
355* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
356- rebuild with python-2.7.2
357
358* Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
359- new upstream release
360
361* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
362- new upstream release
363
364* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
365- new upstream releas
366
367* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
368- new upstream release
369
370* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
371- new upstream release
372
373* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
374- rebuilt with libevent-2.0.10
375
376* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
377- new upstream release
378- add enable_gost flag: default disable
379- add BuildRequires: expat-devel
380
381* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
382- new upstream release
383
384* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
385- new upstream release
386
387* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
388- initial build for Vine Linux: based Fedora 1.4.3-1.fc14
389 - update to 1.4.4
390 - build without munin
391
392* Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
393- Update to 1.4.3 that fixes 64bit crasher
394
395* Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
396- Updated to 1.4.2
397- Updated unbound.conf with new options
398- Enabled pre-fetching DNSKEY records (DNSSEC speedup)
399- Enabled re-fetching popular records before they expire
400- Enabled logging of DNSSEC validation errors
401
402* Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
403- Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
404  with pthreads
405
406* Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
407- Change make/configure lines to attempt to fix -lphtread linking issue
408
409* Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
410- Removed dependancy for dnssec-conf
411- Added ISC DLV key (formerly in dnssec-conf)
412- Fixup old DLV locations in unbound.conf file via %%post
413- Fix parent child disagreement handling and no-ipv6 present [svn r1953]
414
415* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
416- Updated to 1.4.1
417- Changed %%define to %%global
418
419* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
420- Bump version
421
422* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
423- Upgraded to 1.3.4. Security fix with validating NSEC3 records
424
425* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
426- rebuilt with new openssl
427
428* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
429- Updated to 1.3.3
430
431* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
432- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
433
434* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
435- Added missing glob patch to cvs
436- Place python macros within the %%with_python check
437
438* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
439- Updated to 1.3.0
440- Added unbound-python sub package. disabled for now
441- Patch from svn to fix DLV lookups
442- Patches from svn to detect wrong truncated response from BIND 9.6.1 with
443  minimal-responses)
444- Added Default-Start and Default-Stop to unbound.init
445- Re-enabled --enable-sha2
446- Re-enabled glob.patch
447
448* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
449- unbound-iterator.patch was not commited
450
451* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
452- Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
453
454* Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
455- Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
456
457* Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
458- enable DNSSEC only if it is enabled in sysconfig/dnssec
459
460* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
461- add DNSSEC support to initscript and enabled it per default
462- add requires dnssec-conf
463
464* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
465- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
466
467* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
468- updated to 1.2.1
469
470* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
471- rebuild with new openssl
472
473* Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
474- Updated to 1.2.0
475- Added dependancy on minimum SSL for CVE-2008-5077
476- Added dependancy on bc for unbound-munin
477- Added minimum requirement of libevent 1.4.5. Crashes with older versions
478  (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
479- Removed dependancy on selinux-policy (will get used when available)
480- Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
481- Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
482- Enable val-clean-additional to drop addition unsigned data from signed
483  response.
484- Removed patches (got merged into upstream)
485
486* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
487- Modified scandir patch to silently fail when wildcard matches nothing
488- Patch to allow unbound-checkconf to find empty wildcard matches
489
490* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
491- Added scandir patch for trusted-keys-file: option, which
492  is used to load multiple dnssec keys in bind file format
493
494* Mon Dec  8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
495- Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
496
497* Mon Dec  1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
498- We did not own the /etc/unbound directory (#474020)
499- Fixed cvs anomalies
500
501* Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
502- removed all obsolete chroot related stuff
503- label control certs after generation correctly
504
505* Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
506- Updated to unbound 1.1.1 which fixes a crasher and
507  addresses nlnetlabs bug #219
508
509* Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
510- Remove the chroot, obsoleted by SElinux
511- Add additional munin plugin links supported by unbound plugin
512- Move configuration directory from /var/lib/unbound to /etc/unbound
513- Modified unbound.init and unbound.conf to account for chroot changes
514- Updated unbound.conf with new available options
515- Enabled dns-0x20 protection per default
516
517* Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
518- unbound-1.1.0-log_open.patch
519  - make sure log is opened before chroot call
520  - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
521- removed /dev/log and /var/run/unbound and /etc/resolv.conf from
522  chroot, not needed
523- don't mount files in chroot, it causes problems during updates
524- fixed typo in default config file
525
526* Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
527- Updated to version 1.1.0
528- Updated unbound.conf's statistics options and remote-control
529  to work properly for munin
530- Added unbound-munin package
531- Generate unbound remote-control  key/certs on first startup
532- Required ldns is now 1.4.0
533
534* Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
535- Only call ldconfig in -libs package
536- Move configure into build section
537- devel subpackage should only depend on libs subpackage
538
539* Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
540- Fix CFLAGS getting lost in build
541- Don't enable interface-automatic:yes because that
542  causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
543
544* Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
545- Split off unbound-libs, make build verbose
546
547* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
548- FSB compliance, chroot fixes, initscript fixes
549
550* Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
551- Upgraded to 1.0.2
552
553* Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
554- upgraded to new release
555
556* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
557- Build against ldns-1.3.0
558
559* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
560- Split of -devel package, fixed dependancies, make rpmlint happy
561
562* Fri Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
563- Using parts from ports collection entry by Jaap Akkerhuis.
564- Using Fedoraproject wiki guidelines.
565
566* Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
567- Initial version.
Note: See TracBrowser for help on using the repository browser.