source: projects/specs/trunk/t/tzdata/tzdata-vl.spec @ 8850

Revision 8850, 11.7 KB checked in by daisuke, 10 years ago (diff)

tzdata: update to 2014e

Line 
1Summary: Timezone data
2Summary(ja): タイムゾーンのデータ
3Name: tzdata
4Version: 2014e
5%define tzdata_version 2014e
6%define tzcode_version 2014e
7Release: 1%{?_dist_release}
8
9License: Public Domain
10Group: System Environment/Base
11URL: ftp://elsie.nci.nih.gov/pub/
12
13# The tzdata-base-0.tar.bz2 is a simple building infrastructure and
14# a test suite.  It is occasionally updated from glibc sources, and as
15# such is under LGPLv2+, but none of this ever gets to be part of
16# final zoneinfo files.
17Source0: tzdata-base-0.tar.bz2
18# These are official upstream.
19Source1: ftp://munnari.oz.au/pub/tzdata%{tzdata_version}.tar.gz
20Source2: ftp://munnari.oz.au/pub/tzcode%{tzcode_version}.tar.gz
21Source3: javazic.tar.gz
22
23Patch100: javazic-fixup.patch
24Patch101: javazic-exclusion-fix.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildArch: noarch
28BuildRequires: gawk, glibc, perl
29BuildRequires: java-devel
30BuildRequires: glibc-common >= 2.5.90-7
31Conflicts: glibc-common <= 2.3.2-63
32
33
34%description
35This package contains data files with rules for various timezones around
36the world.
37
38%description -l ja
39このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
40
41%package java
42Summary: Timezone data for Java
43Group: System Environment/Base
44
45%description java
46This package contains timezone information for use by Java runtimes.
47
48
49%prep
50%setup -n tzdata
51mkdir tzdata%{tzdata_version}
52tar xzf %{SOURCE1} -C tzdata%{tzdata_version}
53mkdir tzcode%{tzcode_version}
54tar xzf %{SOURCE2} -C tzcode%{tzcode_version}
55sed -e 's|@objpfx@|'`pwd`'/obj/|' \
56    -e 's|@datadir@|%{_datadir}|' \
57  Makeconfig.in > Makeconfig
58
59pushd src
60for i in ../tzcode%{tzcode_version}/*.{c,h,ksh,[1-9]}
61do
62  ln -sf $i .
63done
64popd
65
66mkdir javazic
67tar zxf %{SOURCE3} -C javazic
68pushd javazic
69%patch100
70%patch101
71
72# Hack alert! sun.tools may be defined and installed in the
73# VM. In order to guarantee that we are using IcedTea/OpenJDK
74# for creating the zoneinfo files, rebase all the packages
75# from "sun." to "rht.". Unfortunately, gcj does not support
76# any of the -Xclasspath options, so we must go this route
77# to ensure the greatest compatibility.
78mv sun rht
79find . -type f -name '*.java' -print0 \
80    | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
81                         -e 's:sun\.util\.:rht.util.:g'
82popd
83
84
85%build
86make
87grep -v tz-art.htm tzcode%{tzcode_version}/tz-link.htm > tzcode%{tzcode_version}/tz-link.html
88
89pushd javazic
90javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
91popd
92pushd tzdata%{tzdata_version}
93java -classpath ../javazic/ rht.tools.javazic.Main -V %{version} \
94  -d ../zoneinfo/java \
95  africa antarctica asia australasia europe northamerica pacificnew \
96  southamerica backward etcetera \
97  ../javazic/tzdata_jdk/gmt ../javazic/tzdata_jdk/jdk11_backward
98popd
99
100
101%install
102rm -fr $RPM_BUILD_ROOT
103sed -i 's|@install_root@|%{buildroot}|' Makeconfig
104make install \
105  TOPDIR=%{buildroot}%{_prefix} \
106  TZDIR=%{buildroot}%{_datadir}/zoneinfo
107
108cp -pr zoneinfo/java $RPM_BUILD_ROOT%{_datadir}/javazi
109
110rm -f %{buildroot}%{_datadir}/zoneinfo-posix
111mkdir %{buildroot}%{_datadir}/zoneinfo-posix
112cp -af %{buildroot}%{_datadir}/zoneinfo/* %{buildroot}%{_datadir}/zoneinfo-posix
113mkdir %{buildroot}%{_datadir}/zoneinfo/posix
114cp -af %{buildroot}%{_datadir}/zoneinfo-posix/* %{buildroot}%{_datadir}/zoneinfo/posix
115mkdir -p %{buildroot}%{_datadir}/zoneinfo/right
116cp -a %{buildroot}%{_datadir}/zoneinfo-leaps/* %{buildroot}%{_datadir}/zoneinfo/right
117
118rm -rf %{buildroot}%{_datadir}/zoneinfo-{posix,leaps}
119rm -rf %{buildroot}%{_prefix}/etc
120rm -rf %{buildroot}%{_prefix}/lib
121rm -rf %{buildroot}%{_prefix}/man
122
123%clean
124rm -fr $RPM_BUILD_ROOT
125
126%files
127%defattr(-,root,root)
128%{_datadir}/zoneinfo
129%doc tzcode%{tzcode_version}/README
130%doc tzcode%{tzcode_version}/Theory
131%doc tzcode%{tzcode_version}/tz-link.html
132
133%files java
134%defattr(-,root,root)
135%{_datadir}/javazi
136
137%changelog
138* Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
139- update to tzdata-2012c, tzcode-2012b
140
141* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
142- rebuilt with rpm-4.8.1-3
143
144* Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
145- update to tzdata-2010l, tzcode-2010l
146- added java subpackage
147
148* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
149- update to tzdata-2009d, tzcode-2009d
150- spec in utf-8
151
152* Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
153- update to tzdata-2008b, tzcode-2008a
154
155* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
156- initial build for VineSeed
157
158* Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
159- Upstream 2007d
160  - Mongolia has abolished DST.
161  - Turkey will use EU rules this year, changing at 01:00 UTC rather
162    than 01:00 standard time.
163  - Cuba observed DST starting Sunday.
164  - Resolute, Nunavut switched from Central to Eastern time last
165    November.
166
167* Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
168- Upstream 2007c
169  - Pulaski County, Indiana, switched back to eastern time.
170  - Turkey switches at 01:00 standard time, not at 01:00 UTC.
171- Upstream 2007b
172  - Changes to the commentary in "leapseconds".
173- Upstream 2007a
174  - Updates to Bahamas, they will be in sync with 2007 US DST change
175  - New zone Australia/Eucla
176  - Africa/Asmera renamed to Africa/Asmara, link created
177  - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
178
179* Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
180- Upstream 2006p
181  - Covers changes from 2006m-2 and 2006m-3
182  - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
183
184* Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
185- Patch for Western Australia DST trial
186
187* Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
188- Proposed upstream patch (#210058)
189  - Jordan will switch to winter time on October 27, not September 29
190  - Brazil's DST this year is the first Sunday in November to the last
191    Sunday in February.  (Thanks to Frederico A. C. Neves.)
192  - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
193  - Commentary and past timestamps changes
194
195* Tue Oct  3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
196- Upstream 2006m:
197  - Adjustments for Egypt, Palestine, Uruguay
198  - Better description of `until' field in zic (8) manpage
199
200* Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
201- Upstream 2006k, 2006l:
202  - Adjustments for Egypt, Palestine, Cuba, Honduras
203  - Documentation changes
204
205* Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
206- Upstream 2006j
207  - Honduras stopped observing DST on Monday at 00:00
208  - America/Bermuda will follow the US's lead next year
209  - America/Moncton will use US-style rules next year
210  - New Zone America/Blanc-Sablon, for Canadians who observe AST all
211    year
212  - New zone: America/Atikokan instead of America/Coral_Harbour
213  - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
214  - Historical changes
215  - Commentary updates
216- Upstream 2006i
217  - localtime.c fixes
218- Upstream 2006h
219  - zic leapsecond fix
220
221* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
222- rebuild
223
224* Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
225- Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
226- Nicaragua updates
227
228* Tue May  2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
229- Upstream 2006f
230  - America/Guatemala observes DST between Apr/30 and Oct/1
231  - Historical changes for Nicaragua
232  - Update of America/Indiana/Vincennes in zone table
233
234* Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
235- Upstream 2006d
236  - Haiti observes DST
237  - Sri Lanka change actually took effect Apr/15
238  - All Canada is now scheduled for 2007 US DST rules
239  - Some historical fixes
240
241* Thu Apr  6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
242- Upstream 2006c
243  - Time-related changes:
244    - dozens of historical and commentary changes
245    - Iran stopped observing DST
246    - Sri Lanka switches from UTC+6 to UTC+5:30
247    - America/Thule and America/Edmonton will adopt new US rules,
248      starting 2007
249    - Tunisia is adopting regular DST
250  - Code:
251    - asctime.c: Chages in format strings to silent gcc warnings
252    - removing K&R notation from function signatures
253    - few fixes across the code
254
255* Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
256- Patch for Sri Lanka time zone change (#184514)
257
258* Thu Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
259- Upstream 2006b:
260  - using tz64code version, as 32 is legacy according to tzdata ML
261  - new manual pages for ctime, strftime, tzset
262  - some source code reorganizations
263  - no timezone/dst rule updates
264
265* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
266- Small changes in tst-timezone.c
267
268* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
269- Upstream 2006a:
270  - private.h(scheck): changing char* to char const*
271  - Rule changes for Palestine, zone changes for Indiana/US, both
272    changes for Canada.
273  - Many related doc changes.
274- Naming scheme in spec file doesn't use %%{name}, but tzdata.
275
276* Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
277- 2005r-3
278  - Meta changes.  Renaming tzdata.tar.bz2 file to tzdata$ver-base,
279    so that it won't clash across updates.
280
281* Thu Jan  5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
282- 2005r
283  - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
284    northamerica to guard against old files with obsolete information
285    being left in the time zone binary directory.
286  - Changes for countries that are supposed to join 2007 US DST
287    change.  This includes most of Canada, however entries already in
288    the database (Alberta, British Columbia, Newfoundland, Northwest
289    Territories, and Yukon) were left alone for the time being.
290  - Fixes in zdump.c (abbrok): conditions are chained, and the string
291    is checked for emptiness.
292
293* Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
294- 2005q
295  - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
296  - SystemV timezone changes
297
298* Wed Nov  2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
299- 2005n
300  - changes for Kyrgyzstan and Uruguay
301- fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
302  make check), update tst-timezone.c from glibc CVS (#172102)
303
304* Tue Sep  6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
305- 2005m
306  - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
307    Australia, Kazakhstan
308  - historical timezone data changes for Japan, Poland, Northern Ireland and
309    Mali
310  - timezone name change for East Timor
311
312* Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
313- 2005k
314  - leap seconds update
315
316* Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
317- 2005i
318  - updates for Iran, Haiti and Nicaragua
319
320* Mon Apr  4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
321- 2005h
322  - fixes for Kazakhstan
323
324* Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
325- 2005g
326  - fixes for Uruguay
327- include README and Theory from tzcode tarball in %{_docdir};
328  Theory includes a good summary of how the timezone data files
329  are supposed to be named
330
331* Tue Mar  1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
332- 2005f
333  - more updates for Israel, updates for Azerbaijan
334
335* Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
336- 2005c
337  - updates for Israel and Paraguay
338
339* Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
340- 2004g (#141107)
341  - updates for Cuba
342
343* Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
344- 2004e (#135194)
345  - updates for Brazil, Uruguay and Argentina
346
347* Wed Aug  4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
348- 2004b
349
350* Mon Oct  6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
351- 2003d
352
353* Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
354- 2003c
355- updates for Brazil (#104840)
356
357* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
358- rebuilt
359
360* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
361- initial package
Note: See TracBrowser for help on using the repository browser.